LDAP exception occurred getting attributes for the class <Object Class name> from LDAP server when testing connection to identity source configured with the RSA SecurID Access Cloud Authentication Service
Originally Published: 2019-11-14
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Cloud Authentication Service
Issue
- Unable to connect to Active Directory server. Review the configuration details (if the identity source is Active Directory),
- Unable to connect to LDAP server. Review the configuration details (if the identity source is LDAP).
Service failure [response: ServiceError [code=REMOTE_ERROR, platform=CONTROLLER, reason=LDAP
exception occurred getting attributes for the class 'exampleClassName' from LDAP server 'ldap://<IP address of directory server>:<port>'.,
exceptionClass=com.symplified.adapter.api.userstore.ldap.LdapUserStoreException,
stackTrace=com.symplified.adapter.api.userstore.ldap.LdapUserStoreException: LDAP exception occurred
getting attributes for the class 'exampleClassName' from LDAP server 'ldap://<IP address of directory server>:<port>'. at
com.symplified.adapter.userstores.ldap.LdapUserStoreConnectionImpl.getClassAttributes(LdapUserStoreConnectionImpl.java:1382)Cause
Resolution
- Active Directory: user
- LDAP: inetOrgPerson
Related Articles
Access Fulfillment Express (AFX) Connector import fails to import enabled capabilities if no mappings are defined in RSA I… 36Number of Views FileCloud-SecurID-Access-SAML-Integration 11Number of Views An unexpected JavaScript error ('remoteCAs[...].catype' is null or not an object) has occurred in RSA Registration Manager 59Number of Views Cloud Authentication Service Integration 13Number of Views Users 6Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?