"ORA-00020: maximum number of processes (500) exceeded" when attempting to connect to the Oracle Database on IGL
Originally Published: 2018-02-06
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Appliance
RSA Version/Condition: 7.x
Issue
ORA-00020: maximum number of processes (500) exceeded
Cause
Resolution
select resource_name, current_utilization, max_utilization, limit_value from v$resource_limit where resource_name in ('sessions', 'processes');
Once you know what the current limit is set to, you can increase it using the following replacing X with a value higher than the process limit from the previous query:
alter system set processes=X scope=spfile;
Workaround
You also have the option to kill any zombie process you have identified. In this situation you may not be able to get a free process to establish a connection to Oracle. This would prevent you from identifying which process belongs with which user or query. This makes killing individual processes carry some risk of killing a process you do not wish to.
Notes
Related Articles
Howto: Change the Master Encryption Key Storage Directory in RSA Identity Governance and Lifecycle (IGL) 108Number of Views RSA G&L Community Exchange Overview and FAQs 155Number of Views CSV Account Data Collectors of Data Source Type Database joining multiple CSV files reject Account Mappings of Accounts wi… 40Number of Views AFX Connectors remain in a Not Deployed state and templates show (Migration Required) in RSA Identity Governance & Lifecycle 583Number of Views Error "Reference resolution: Invalid user type attribute information. Specified user references couldn't be resolved." is … 80Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Unable to login to RSA Authentication Manager Security Console as super admin RSA MFA Agent 2.3.6 for Microsoft Windows Installation and Administration Guide Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory
Don't see what you're looking for?