ORA-00054: resource busy and acquire with NOWAIT specified or timeout expired
Originally Published: 2019-05-01
Last Modified: 2023-09-22
Article Number
Applies To
RSA Product/Service Type: Enterprise Software
RSA Version/Condition: 7.1.0
Platform: null
Platform (Other): null
O/S Version: null
Product Name: null
Product Description: null
Issue
04/08/2019 02:05:16.251 WARN (EmailSenderServiceProvider) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] SQL Error: 54, SQLState: 61000 04/08/2019 02:05:16.251 ERROR (EmailSenderServiceProvider) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] ORA-00054: resource busy and acquire with NOWAIT specified or timeout expired
Cause
I had opened this separate case to investigate below errors as observed from aveksaServer.log:
04/08/2019 02:05:12.620 WARN (EmailSenderServiceProvider) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] SQL Error: 54, SQLState: 61000
04/08/2019 02:05:12.620 ERROR (EmailSenderServiceProvider) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] ORA-00054: resource busy and acquire with NOWAIT specified or timeout expired
Error ORA-00054 is a commonly seen error by Oracle users and occurs when a user tries to execute a LOCK TABLE or SELECT FOR UPDATE command with the NOWAIT keyword when the resource is unavailable. DDL or DML operations are being run concurrently without proper commits.
In most cases, Error ORA-00054? occurs from a session. Any session that has referenced the table and any structural change attempt, such as adding a column, requires an “exclusive” lock.
Workaround
select a.sid, a.serial#
from v$session a, v$locked_object b, dba_objects c
where b.object_id = c.object_id
and a.sid = b.session_id
and OBJECT_NAME=’EMP’;
To kill the session and unlock the tables, write the following statement:
SQL>alter system kill session ‘sid, serial#’;
Related Articles
Authentication Manager Primary Replication Service Fails to Start with "Could Not Acquire Lock" 1.36KNumber of Views Windows Password Integration (WPI) fails for the RSA MFA Agent for Microsoft Windows with error "JWT token has expired" 628Number of Views RSA Governance & Lifecycle 8.0.0 Database Setup and Management Guide 300Number of Views On database startup for RSA Identity Governance and Lifecycle the following error is seen: CRS-2501: Resource 'ora.avdb.d… 530Number of Views Invalid tokencode failures and expired QR code alerts in RSA SecurID Authenticate app 258Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA SecurID software token .sdtid file fails to import into RSA SecurID Software Token 5.0 for Windows RSA MFA Agent 2.3.6 for Microsoft Windows Installation and Administration Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide How to Verify TLS 1.2 Connectivity on RSA Authentication Manager 8.x Using OpenSSL
Don't see what you're looking for?