On RSA Via Lifecycle and Governance the aveksa_server start returns message: Cannot connect to the database, but the DB is up
4 years ago
Originally Published: 2016-05-24
Article Number
000050433
Applies To
RSA Product Set: Identity Management and Governance
RSA Product/Service Type: Enterprise Software
RSA Version/Condition: 7.0 and higher
Issue
When starting the aveksa_server service, the following message is returned:
$ service aveksa_server start
Cannot connect to the database. The watchdog will start the server when it can connect to the database.
However, the database can be successfully connected to from SQL*Plus and is showing as up with the aveksa_server statusdb option:
$ service aveksa_server statusdb
15817
Database is running.
Cause
This scenario can occur when the sys database password is changed without following the procedure for changing database user passwords starting on page 156 of the RSA Via Lifecycle and Governance 7.0 Installation Guide.
Resolution
Update the sys password in both the database and in the Aveksa_System.cfg file, as described in Appendix C of the the RSA Via Lifecycle and Governance 7.0 Installation Guide.