Password Available External email incorrectly defaults to localhost for hostname in RSA Identity Governance & Lifecycle
Originally Published: 2017-03-16
Article Number
Applies To
RSA Product/Service Type: Email Templates, User Interface
RSA Version/Condition: 7.0.0, 7.0.1, 7.0.2, 7.1.0
Issue
The body of the email has a message similar to "One or more of your passwords has changed. To view your new password, click here" with a hyperlink for the user to click.
The default value for the embedded URL in incorrectly uses the hostname localhost and port 8080 which directs the user to an invalid page. For example,
Depending on the browser, this will result in one of the following messages:
- Page not Found
- Unable to connect
Cause
When this value is not set it defaults to http://localhost:8080, which is not a valid hostname.
Resolution
- RSA Identity Governance and Lifecycle 7.0.2 P06
- RSA Identify Governance and Lifecycle 7.1.0 P01
Select the Settings tab from the Requests/Password Management menu and enter the URL in the View Password URL field.
Workaround
- Create a text file on the local system named customerstrings.properties.
- Edit this file in a local text editor and set a name value pair with the text VIEW_PASSWORD_EXTERNAL_URL= and the hostname and port (optional) of your system and the base URL /aveksa/viewpassword, as shown:
VIEW_PASSWORD_EXTERNAL_URL= http://{hostname}:{port(optional)}/aveksa/viewpassword
- Save this file to the local system.
- Launch the Admin UI.
- Select User Interface under the Admin menu.
- Select the Files tab.
- Select Customer Strings from the drop down menu.
- Select Upload.
- Navigate to the customerstrings.properties file saved earlier and select this file for upload.
Notes
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