- RSA Governance & Lifecycle 8.0.0
- SecurID Governance & Lifecycle 7.5.2
- When installing RSA Governance & Lifecycle with local RSA-provided Oracle 19c database.
- When installing a remote RSA-provided Oracle19c database from the RSA database-only tar file.
The installation fails and the following message is logged in the aveksa-install.log:
2023/11/23 17:21:18 CLSRSC-318: Failed to start Oracle OHASD service ... Problem running roothas.pl
Note that this article covers failures during installation of the product. There are potentially unknown failures that might occur if SELinux is enabled (in Enforcing mode) after installation but these are not covered here.
This is a known limitation of the installers in these versions of RSA Governance & Lifecycle.
Full support for installing RSA-provided Oracle database on RHEL with SELinux mode set to Enforcing, is being considered for a future release of the product.
At this time RSA recommends that the RHEL hosts intended for use with RSA-provided Oracle Database (local or remote) be configured to set SELinux mode to Permissive, for a successful installation of RSA-provided Oracle Database. (See Notes)
This limitation is only with an RSA-provided Oracle 19c database. Customers may elect to choose a deployment type that leverages their own Oracle instance or other types of Oracle deployment for Customer-supplied Oracle Database.
Customers who elect to change the SELinux mode from the default Enforcing to Permissive (or setting SELinux to Disable) should fully review the Red Hat Linux documentation and guidance regarding enabling or disabling of this setting as there are potential security implications regarding changes to this setting after the operating system has been installed which are beyond the scope of this article.
Customers installing AFX on RHEL should also be aware of additional RHEL security requirements for FIPS mode discussed in the following article:
AFX fails to start on RHEL 8.4 and greater in RSA Governance & Lifecycle
Related Articles
How to troubleshoot Oracle database ORA-04030 errors in RSA Identity Governance & Lifecycle 232Number of Views Oracle Database Memory Sizing for RSA Identity Governance & Lifecycle 472Number of Views OPatch failure when individually applying Oracle patch 19509982 in RSA Identity Governance & Lifecycle 122Number of Views Script to update "REMOTE_ORACLE_JDBC_URL" and database connection configuration in RSA Governance & Lifecycle 95Number of Views Unable to create connection to the database using Oracle 12 pluggable database as remote database on RSA Via Lifecycle & G… 19Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide