RSA Authentication Agent 7.4.x for Windows 2016 running on Citrix XenApp hangs before credentials when accessed
Originally Published: 2019-03-21
Article Number
Applies To
RSA Product/Service Type: Authentication Agent for Windows
RSA Version/Condition: 7.4, 7.4.2
O/S Version: Citrix VDI, Microsoft Windows 2016 server
Issue
From Citrix StoreFront, when launching a VDI when the target is a Microsoft Windows 2016 server that has the RSA Authentication Agent 7.4.x for Windows installed, a screen displays to view credentials. It keeps loading and spinning but never asks for user name and SecurID passcode.
Cause
A hot fix is being announced by Citrix and Microsoft that requires editing the registry keys on the server VDA.
Resolution
- Launch the registry key editor
- Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Citrix Virtual Desktop Agent.
- Create the following registry value with value type = REG_DWORD DisableLogonUISuppression value set to 1.
- Reboot the Server VDA
Notes
Related Articles
How to enable verbose logging for an RSA Authentication Agent 7.x for Windows through the registry 203Number of Views Increase the maximum length of a reserve password hash for the RSA Authentication Agent 7.x for Windows 213Number of Views SetPin has garbled characters when ID contains 7Ch value in RSA ACE/Server 3Number of Views How to disable smart card credential provider on Windows 2012? 260Number of Views IDR SSO - Step 9: Protect a Resource 38Number of Views
Trending Articles
Passwordless Authentication in Windows MFA Agent for Active Directory – Quick Setup Guide RSA Authentication Manager 8.9 Release Notes (January 2026) RSA Authentication Manager Upgrade Process RSA Authentication Manager 8.7 SP2 Setup and Configuration Guide An example of SSO using SAML and ADFS with RSA Identity Management and Governance 6.9.x
Don't see what you're looking for?