RSA Authentication Agent 7.4.x for Windows 2016 running on Citrix XenApp hangs before credentials when accessed
Originally Published: 2019-03-21
Article Number
Applies To
RSA Product/Service Type: Authentication Agent for Windows
RSA Version/Condition: 7.4, 7.4.2
O/S Version: Citrix VDI, Microsoft Windows 2016 server
Issue
From Citrix StoreFront, when launching a VDI when the target is a Microsoft Windows 2016 server that has the RSA Authentication Agent 7.4.x for Windows installed, a screen displays to view credentials. It keeps loading and spinning but never asks for user name and SecurID passcode.
Cause
A hot fix is being announced by Citrix and Microsoft that requires editing the registry keys on the server VDA.
Resolution
- Launch the registry key editor
- Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Citrix Virtual Desktop Agent.
- Create the following registry value with value type = REG_DWORD DisableLogonUISuppression value set to 1.
- Reboot the Server VDA
Notes
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