RSA Authentication Agent 7.4.x for Windows 2016 running on Citrix XenApp hangs before credentials when accessed
Originally Published: 2019-03-21
Article Number
Applies To
RSA Product/Service Type: Authentication Agent for Windows
RSA Version/Condition: 7.4, 7.4.2
O/S Version: Citrix VDI, Microsoft Windows 2016 server
Issue
From Citrix StoreFront, when launching a VDI when the target is a Microsoft Windows 2016 server that has the RSA Authentication Agent 7.4.x for Windows installed, a screen displays to view credentials. It keeps loading and spinning but never asks for user name and SecurID passcode.
Cause
A hot fix is being announced by Citrix and Microsoft that requires editing the registry keys on the server VDA.
Resolution
- Launch the registry key editor
- Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Citrix Virtual Desktop Agent.
- Create the following registry value with value type = REG_DWORD DisableLogonUISuppression value set to 1.
- Reboot the Server VDA
Notes
Related Articles
Run as a different user prompts for a passcode not password with RSA Authentication Agent 7.4 for Windows 256Number of Views RSA Authentication Agent API 8.6 for C Developer's Guide 110Number of Views Agent Auto-Registration 95Number of Views Errors in SAML debug regarding inability for Relying Party to create a token 12Number of Views Increase the maximum length of a reserve password hash for the RSA Authentication Agent 7.x for Windows 224Number of Views
Trending Articles
RSA Authentication Manager 8.9 Release Notes (January 2026) RSA MFA Agent 2.3.6 for Microsoft Windows Installation and Administration Guide RSA-2026-07: RSA Authentication Manager Security Update for Third-Party Component Vulnerabilities Downloading RSA Authentication Manager license files or RSA Software token seed records RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?