RSA Authentication Manager 8.1 SP 1 patch 1 backups to a Windows Shared Folder are failing after software upgrade
4 years ago
Originally Published: 2015-09-08
Article Number
000063142
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.1 SP1 P1 and later
Issue
  • Windows backup is failing after RSA Authentication Manager 8.1 is upgraded to SP1 patch 1 or later
  • The backup is failing from the Operations Console
  • Mounting the Windows share from the command line will also fail using the sec=ntlmssp and sec=ntlmsspi options as shown below.
Make sure you replace the values of <Windows_Share_Server>, <Windows_Share_Folder> and <Windows_Share_User> attributes with your actual Windows share information.
am81p:~ # /sbin/mount.cifs //<Windows_Share_Server>/<Windows_Share_Folder>/ /opt/rsa/am/backup/test -o user=<Windows_Share_User>,sec=ntlmsspi,uid=1000
Password: <enter password for Windows_Share_User>
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
am81p:~ # /sbin/mount.cifs //<Windows_Share_Server>/<Windows_Share_Folder>/ /opt/rsa/am/backup/test 
-o user=<Windows_Share_User>,sec=ntlmssp,uid=1000
Password: <enter password for Windows_Share_User>
mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
  • Mounting the Windows share from the command line succeeds when removing the sec=xxxxx option as shown below:
am81p:~ # /sbin/mount.cifs //<Windows_Share_Server>/<Windows_Share_Folder>/ /opt/rsa/am/backup/test -o user=<Windows_Share_User>,uid=1000 
Password: <enter password for Windows_Share_User> 
am81p:~ #
 
  • Backups to the Local Authentication Manager Server or NFS are working.
Cause

The changes made as part of supporting the NTLMv2 in SP1 Patch 1 enforced Authentication Manager to use the security options ntlmssp or ntlmsspi. If your Windows Shared Folder does not support these security modes, then Authentication Manager will fail to mount the share and fail to perform the backup.

Resolution
Apply Authentication Manager 8.1 SP1 P8 or later to solve the problem as per defect AM-29331.
Workaround
As workarounds, try the following:
  • Use NFS backup,
  • Use internal backup, or
  • Change the security mode to NTLMv2 on the Windows machine.