RSA Authentication Manager 8.x trusted realms not working (java.net.UnknownHostException)
Originally Published: 2015-05-26
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
Issue
Enabled the verbose for trace log on local Authentication Manager instance and see the following error message in imsTrace.log.
2015-05-25 15:04:00,453, [[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'], (EJBRemoteTarget.java:316), trace.com.rsa.command.EJBRemoteTargetBase, ERROR, am81pri.dc.rsa.shanghai.com,,,, Unable to connect to downgraded EJB/2.1 command server.null 2015-05-25 15:04:00,453, [[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'], (EJBRemoteTarget.java:317), trace.com.rsa.command.EJBRemoteTargetBase, DEBUG, am81pri.dc.rsa.shanghai.com,,,, Unable to connect to downgraded EJB/2.1 command server. javax.naming.ServiceUnavailableException [Root exception is java.net.UnknownHostException: marge.csau.ap.rsa.net] at weblogic.jndi.internal.ExceptionTranslator.toNamingException(ExceptionTranslator.java:34) at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(WLInitialContextFactoryDelegate.java:767) at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:368)
Cause
Resolution
- If the remote trusted realm no longer exists, delete the trusted realm.
- If the hostname/ip of remote trusted realm has been changed, update the trusted realm package.
- If the remote trusted realm server is offline, bring that server online and this issue should be automatically fixed.
Related Articles
Password change fails for users in an external identity source via Self-Service Console in RSA Authentication Manager 8.x 345Number of Views RSA Authentication Manager 8.2 Troubleshooting Guide 265Number of Views Authentication Manager Log Messages (26111-26150) 39Number of Views RSA Authentication Manager 7.1 to 8.1 - Migrating to a New Hardware or Virtual Appliance 289Number of Views AM8 web tier shows as offline or pending connection 898Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?