RSA Federated Identity Manager: Session Plugin does not clean up temporary user created by the transient nameID plugin
Originally Published: 2015-05-14
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product/Service Type: Federated Identity Management Module
RSA Version/Condition: 4.2
Platform: Windows
Issue
The following messages should occur in the FIM system.log file when the CTSession Cleanup thread runs.
2015-05-14 14:21:41,141, (CTSessionCleanupThread.java:61), WIN-505ATCFECED, , , , Cleaning up ct temporary users created by the CT session plug-in. 2015-05-14 14:21:41,402, (CTPluginHelper.java:453), WIN-505ATCFECED, , , , Started Deleting users 2015-05-14 14:21:41,437, (CTPluginHelper.java:459), WIN-505ATCFECED, , , , Time taken for deleting 1users:35ms 2015-05-14 14:21:41,438, (CTPluginHelper.java:460), WIN-505ATCFECED, , , , Time taken for deleting 1users:0sec 2015-05-14 14:21:41,442, (CTPluginHelper.java:453), WIN-505ATCFECED, , , , Started Deleting users 2015-05-14 14:21:41,442, (CTPluginHelper.java:459), WIN-505ATCFECED, , , , Time taken for deleting 0users:0ms 2015-05-14 14:21:41,442, (CTPluginHelper.java:460), WIN-505ATCFECED, , , , Time taken for deleting 0users:0sec 2015-05-14 14:21:41,442, (CTSessionCleanupThread.java:59), WIN-505ATCFECED, , , , Sleeping for 86400000 ms.
If these events are not logged then the cleanup thread may not have run.
Cause
In addition, even if the CTSession plugin is reloaded, if an existing CTSessionCleanupThread is currently sleeping, the new cleanup interval will not take effect until the existing thread sleep interval has expired.
Also note that if any error occurs that prevents the CTSession plugin from being loaded, the cleanup thread will not be started.
Workaround
Related Articles
Error: '%1 is not a valid win32 application' when starting RSA RADIUS Server 6.1 12Number of Views How to view a certificate fingerprint as SHA-256, SHA-1 or MD5 using OpenSSL for RSA Authentication Manager 81Number of Views Using PowerShell to Update Registry Keys for the MFA Agent for Microsoft Windows 56Number of Views RSA Authentication Manager 8.X server fails to start the RSA Services after a Reboot 242Number of Views RSA MFA Agent for Windows logs a warning that "System cannot access location data for this computer" 35Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?