RSA Identity Governance & Lifecycle scheduled report generation with attachments in email fails when having a slash (/) in Report Name
Originally Published: 2018-06-05
Last Modified: 2023-12-01
Article Number
Applies To
RSA Version/Condition: 7.0.0, 7.0.1, 7.0.2, 7.1.0
Issue
Below is the error we see in aveksaServer.log:
ERROR (ThreadPool-1) [com.aveksa.server.report.ReportRunnerTask] Failed to generate the report. Report Details: Report[id="148" name="Test/report"], ReportResult[id="306", report-id="148", save-date="Tue Jun 05 01:06:01 EDT 2018", fill-start-date="Tue Jun 05 01:04:35 EDT 2018", status="Completed", type="S", created-by-user="0", type-string="Scheduled Report", description="Scheduled Report", filter="null"], run-status="FAILED"]
java.io.FileNotFoundException: /home/oracle/wildfly/standalone/tmp/vfs/deployment/deploymenta01ddddae3cfb04c/aveksa.war-4cca8bb149afacf8/WEB-INF/../report_images/Test/report.CSV (No such file or directory)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:221)
at java.io.FileOutputStream.<init>(FileOutputStream.java:110)
at com.aveksa.server.report.Report.saveForEmail(Report.java:1376)
at com.aveksa.server.report.ReportRunnerTask.process(ReportRunnerTask.java:115)
at com.aveksa.server.scheduler.ScheduledTask$Executor.execute(ScheduledTask.java:159)
at com.aveksa.common.ThreadPool$Executor.run(ThreadPool.java:141)
at java.lang.Thread.run(Thread.java:745)
java.io.FileNotFoundException: /home/oracle/wildfly/standalone/tmp/vfs/deployment/deploymenta01ddddae3cfb04c/aveksa.war-4cca8bb149afacf8/WEB-INF/../report_images/Test/report.CSV (No such file or directory)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:221)
at java.io.FileOutputStream.<init>(FileOutputStream.java:110)
at com.aveksa.server.report.Report.saveForEmail(Report.java:1376)
at com.aveksa.server.report.ReportRunnerTask.process(ReportRunnerTask.java:115)
at com.aveksa.server.scheduler.ScheduledTask$Executor.execute(ScheduledTask.java:159)
at com.aveksa.common.ThreadPool$Executor.run(ThreadPool.java:141)
at java.lang.Thread.run(Thread.java:745)
Steps to reproduce
- On the General tab, create a custom report with the name Test/report.
- On the Query tab, put any simple query: for example, select 1 from dual.
- From the Schedule and E-Mail tab, schedule the report and select Attach the report result to the email (sent when scheduled).
Cause
It throws the error No such file or directory.
Resolution
Related Articles
View a Scheduled Report Job 7Number of Views Log Artifacts generation fails due to ORA-31061 error in ASR report generation in RSA Identity Governance & Lifecycle 119Number of Views Duplicate a Scheduled Report Job 5Number of Views User Access Reviews defined with the Default Reviewer Interface Style in 7.1.x have a 5000 review item export limit in RSA… 38Number of Views Scheduled custom reports are intermittently failing and generating blank reports in RSA Identity Governance & Lifecycle 174Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?