RSA Identity Governance and Lifecycle error "The selected file does not match the required CSV format" when importing Local Entitlement Definitions
Originally Published: 2017-03-03
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 6.9.1, 7.0.0, 7.0.1
Issue
RSA Identity Governance and Lifecycle generates the following error message when importing Local Entitlement Definitions:
The selected file does not match the required CSV format
This happens when the following steps are followed:
- From the Applications menu, select an application and then select the Import button.
- For CSV file to import, select the Browse button to import your CSV file:
- The following warning message is displayed and entitlements are not imported.
- The following errors are logged in the aveksaServer.log file (in 7.0.x located in /home/oracle/wildfly-8.2.0.Final/standalone/log/aveksaServer.log or in 6.9.1 located in /home/oracle/jboss-4.2.2.GA/server/default/deploy/aveksa.ear/aveksa.war/log/aveksaServer.log )
03/03/2017 17:38:31.864 ERROR (default task-6) [com.aveksa.server.core.ManualEntitlementImporter]
com.aveksa.server.core.ManualEntitlementImporter$AbortProcessing: Resource entry is not found or is null
03/03/2017 17:38:31.865 ERROR (default task-6) [com.aveksa.gui.pages.admin.rawEntitlement.edit.ImportApplicationEntitlementsDialogData]
com.aveksa.server.core.AdminServiceException: Bad data encountered:MyLocalEntitlementA :
MyActon,MyLocalEntitlementCollector,MyActon,"Long Description Line1 ::Resource entry is not found or is null
Cause
This issue may occur if the imported data contains embedded line feed and carriage return characters that are not handled by the CSV export format. This may cause the column data to miss-align.
This may occur for example if the database import is created from a database export of the Entitlements view from another instance of RSA Identity Governance and Lifecycle and that export contains the multi-line field Long Description.
Resolution
Workaround
- Avoid using multiple lines in the Long Description field.
- If the database import is created from a database export of the Entitlements view from another instance of RSA Identity Governance and Lifecycle ensure you do not export the Long Description field.
- Edit the CSV file in Excel or a text editor before importing and remove the Long Description column, or edit the contents so the description does not contain line feeds.
Related Articles
Unable to import CRL in Firefox 6Number of Views SA: UI fails to load due to wrong version of Java being installed 6Number of Views Authentication Manager 8.x Wildcard Certificate Fails with 'Subject Name Does Not Match Hostname' 556Number of Views Anti-virus agent best practices for enVision 67Number of Views How to Delete Pending Certificate Signing Requests (CSRs) from RSA Authentication Manager 8.x Operations Console 4Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?