Report preview and/or generation fails with 'java.lang.NoClassDefFoundError: Could not initialize class net.sf.jasperreports.engine.util.JRStyledTextParser' error in RSA Identity Governance & Lifecycle (font dependencies)
Originally Published: 2016-12-07
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 7.0.1, 7.0.2, 7.1.0, 7.1.1
O/S Version: Red Hat Enterprise Linux
Issue
Generating or previewing reports in RSA Identity Governance & Lifecycle fails and the following errors are seen in the aveksaServer.log:
When entering the following command, no results appear :
com.aveksa.server.runtime.ServerException: java.lang.NoClassDefFoundError:
Could not initialize class net.sf.jasperreports.engine.util.JRStyledTextParser
at com.aveksa.server.report.Report.fillReport(Report.java:2019)
at com.aveksa.server.report.Report.fillReport(Report.java:1665)
at com.aveksa.server.report.Report.fillReport(Report.java:1654)
at com.aveksa.gui.objects.report.GuiReport.getPreview(GuiReport.java:930)
at com.aveksa.gui.pages.report.report_definition.edit.tabular.BaseEditTabularReportWizard.updatePreview(BaseEditTabularReportWizard.java:200)
at com.aveksa.gui.pages.report.report_definition.edit.tabular.BaseEditTabularReportWizard.handlePreview(BaseEditTabularReportWizard.java:143)
at com.aveksa.gui.pages.report.report_definition.edit.tabular.BaseEditTabularReportWizard.handleRequest(BaseEditTabularReportWizard.java:101)
at com.aveksa.gui.pages.PageManager.forwardRequest(PageManager.java:577)
at com.aveksa.gui.pages.PageManager.handleRequest(PageManager.java:341)
at com.aveksa.gui.pages.PageManager.handleRequest(PageManager.java:272)
at com.aveksa.gui.core.MainManager.handleRequest(MainManager.java:179)
at com.aveksa.gui.core.MainManager.doGet(MainManager.java:128)
at com.aveksa.gui.core.MainManager.doPost(MainManager.java:414)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
at io.undertow.servlet.handlers.ServletHandler.handleRequest(ServletHandler.java:85)
at io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter(FilterHandler.java:130)
When entering the following command, no results appear :
# rpm -qa | grep deja
Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the aveksaServer.log for your specific deployment.
Cause
Resolution
- Login as the root user.
- Execute the following command:
# yum install dejav*
- When prompted, enter y to install all the packages.
- Switch to the oracle user and restart the application server:
# su - oracle # acm restart
Notes
- 000038324 -- Report preview and/or generation fails with 'java.lang.NoClassDefFoundError: Could not initialize class net.sf.jasperreports.engine.util.JRStyledTextParser' error in RSA Identity Governance & Lifecycle (fontconfig)
- 000033818 -- Report preview and/or generation fails with 'java.lang.NoClassDefFoundError: Could not initialize class sun.awt.X11GraphicsEnvironment' error in 6.9.1 and earlier versions of RSA Identity Governance & Lifecycle
Related Articles
Report preview and/or generation fails with 'java.lang.NoClassDefFoundError: Could not initialize class net.sf.jasperrepor… 260Number of Views RSA Error "Offline Authentication is not enabled or not available" in MFA agent 678Number of Views AFX Server stuck in 'Not running' State, with error 'timed out waiting for AFX applications to start' 3.67KNumber of Views Duplicate User ID error when running All Users report in RSA Authentication Manager 8.x 1.79KNumber of Views Error: Principal does not possess one or more authenticators when using RSA SecurID Access Authenticate app tokencode with… 591Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?