- RSA Governance & Lifecycle 8.0 Patch 02 - Patch 10 (Software Bundle only)
- SecurID Governance & Lifecycle 7.5.2 (Software Bundle only)
Updating database connection configuration in a Wildfly-based software-bundle deployment of RSA Governance & Lifecycle requires performing changes in multiple files:
- domain.xml
- setDeployEnv.sh
- Aveksa_System.cfg
Contact RSA Technical Support, referencing this article, to obtain a script changeJDBCUrl.sh for updating database connection configuration in a Wildfly-based software-bundle deployment of RSA Governance & Lifecycle. Please review the Note below for limitations on the use of this script.
Using the script changeJDBCUrl.sh, you can change database connection configuration with the below steps instead of manually updating each of the above mentioned files:
1. Copy the script changeJDBCUrl.sh to the Wildfly Domain Controller Node (usually also System Operations Node (SON) in multi-node cluster configuration)
2. Change file Permissions and Ownership using the below commands:
chmod a+x changeJDBCUrl.sh chown oracle:oinstall changeJDBCUrl.sh
3. Execute the script using the below command:
sh changeJDBCUrl.sh
Note: You will be prompted to enter the below details:
Provide Valid DB IP address or hostname (*mandatory): Provide port number [1555]: Provide Oracle Service Name [AVDB]:
4. Restart the server to bring the changes into effect
IMPORTANT:
- This script can be used only for software bundle installation of RSA Governance & Lifecycle (G&L) which is based on Wildfly as the application server.
- Other deployment types (for example: Virtual Application (OVA), Docker container, or EAR file deployed in WebSphere/WebLogic) require different methods to change the database configuration and thus are not addressed by the script provided here.
- The script is not meant to be used with G&L 8.0 Patch 11 HotFix 01 (G&L 8.0P11HF01) and later where the database has been migrated to Oracle multi-tenant architecture (PDB/CDB).
Note that the script copies the original files to a backup folder: /tmp/aveksa/backupConfig
oracle@acm-vapp:/tmp/aveksa/backupConfig> ll total 168 -rwxr-xr-x 1 oracle oinstall 11182 Apr 23 21:37 Aveksa_System_20240423_213713.cfg -rw-r--r-- 1 oracle oinstall 150546 Apr 23 21:37 domain_20240423_213713.xml -rwxr-x--- 1 oracle oinstall 1449 Apr 23 21:37 setDeployEnv_20240423_213713.sh
Related Articles
How to troubleshoot Oracle database ORA-04030 errors in RSA Identity Governance & Lifecycle 232Number of Views Unable to delete Object while connected to the HOST node in a cluster setup in RSA Governance & Lifecycle 7Number of Views Unable to create connection to the database using Oracle 12 pluggable database as remote database on RSA Via Lifecycle & G… 19Number of Views RHEL SELinux mode causes failure to install Oracle Database in RSA Governance & Lifecycle 205Number of Views Data Purging fails with ORA-02292: integrity constraint (AVUSER.FK_AFX_REQUEST_CHANGE_ITEM_ID) violated - child record fou… 339Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle RSA Authentication Manager 8.9 Setup and Configuration Guide Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle