Startup fails with 'Job for aveksa_server.service failed because the control process exited with error code' when starting RSA Identity Governance & Lifecycle
Originally Published: 2019-08-01
Last Modified: 2023-11-30
Article Number
Applies To
RSA Version/Condition: 7.1.x, 7.2.x
Issue
acm start
Job for aveksa_server.service failed because the control process exited with error code.
See "systemctl status aveksa_server.service" and "journalctl -xe" for details.
The output from systemctl status aveksa_server.service is:
systemctl status aveksa_server.service
aveksa_server.service - Aveksa Server
Loaded: loaded {/etc/systemd/system/aveksa_server.service; enabled; vendor preset: disabled)
Active: failed (Result:exit-code) since Fri 2020-03-13 07:53:52 EDT; 4min 3s ago
Process: 24078 ExecStop=/etc/init.d/aveksa_server.service stop (code=exited, status=0/SUCCESS)
Process: 24922 ExecStart=/etc/init.d/aveksa_server.service start (code=exited, status=1/FAILURE)
Main PID: 24922 (code=exited, status=1/FAILURE)
The output from journalctl -xe is (login as the root user to execute the statement):
-- Unit aveksa_server.service has begun starting up. Mar 13 07:53:49 acm-720 su[24946]: (to oracle) root on none Mar 13 07:53:49 acm-720 su[24946]: pam_unix(su-l:session): session opened for user oracle by (uid=0) Mar 13 07:53:49 acm-720 system[1]: Started Session c190 of user oracle. -- Subject: Unit session-c190.scope has finished start-up -- Defined-By: systemd -- Support: http://lists.freedeskstop.org/mailman/listinfo/systemd-devel -- -- Unit session-c190.scope has finished starting up. -- -- The start-up result is done. Mar 13 07:53:52 acm-720 aveksa_server[24922]: - Checking if DB is running for user: sys, failed with error:ORA-01034: ORACLE not available Mar 13 07:53:52 acm-720 aveksa_server[24922]: ORA-27101: shared memory realm does not exist Mar 13 07:53:52 acm-720 aveksa_server[24922]: Linux-x86_64 Error: 2: No such file or directory Mar 13 07:53:52 acm-720 aveksa_server[24922]: Additional information: 3640 Mar 13 07:53:52 acm-720 aveksa_server[24922]: Additional information: -2048436317 Mar 13 07:53:52 acm-720 su[24946]: pam_unix(su-l:session): session closed for user oracle Mar 13 07:53:52 acm-720 aveksa_server[24922]: Cannot connect to the database. The watchdog will start the server when it can connect to the database. Mar 13 07:53:52 acm-720 systemd[1]: aveksa_server.service: Main process exited, code=exited, status=1/FAILURE Mar 13 07:53:52 acm-720 systemd[1]: Failed to start Aveksa Server. -- Subject: Unit aveksa_server.service has failed -- Defined-By: systemd -- Support: http://lists.freedeskstop.org/mailman/listinfo/systemd-devel -- -- Unit aveksa_server.service has failed.
Cause
- The RSA Identity Governance & Lifecycle database is not running, and
- The RSA Identity Governance & Lifecycle application is on version 7.1.0 or above.
Prior to 7.1.x, the message was:
acm start
Cannot connect to the database. The watchdog will start the server when it can connect to the database
Starting with versions 7.1.x and 7.2.x the message is:
acm start
Job for aveksa_server.service failed because the control process exited with error code.
See "systemctl status aveksa_server.service" and "journalctl -xe" for details.
Note that the output from journalcts -xe shows:
Cannot connect to the database. The watchdog will start the server when it can connect to the database.
Resolution
- Login as the oracle user
- Execute the below SQL statements:
acm startdb acm start
Related Articles
Running out of disk space when using RMAN in RSA Identity Governance & Lifecycle 220Number of Views RSA Authentication Agent for Web: IIS Authentication Test Fails Due to Node Secret Mismatch with RSA Authentication Manager 556Number of Views Connection fails to Cloud Authentication Service when connecting through a proxy server from RSA Authentication Manager to… 1.37KNumber of Views How to create and configure certificates for HTTPS access when using intermediate CA certs in RSA Identity Governance & Li… 1.09KNumber of Views RSA SecurID software token is distributed in a disabled state when requested with modified software token profiles via the… 554Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle How to Download and Reinstall the AFX Server Archive in RSA Governance & Lifecycle
Don't see what you're looking for?