The WildFly server.log file is not updated on RSA Identity Governance & Lifecycle 7.1.0 and above
Originally Published: 2018-11-05
Article Number
Applies To
RSA Version/Condition: 7.1.x
Platform (Other): WildFly
Issue
Cause
This issue has been reported in engineering ticket ACM-92729.
Resolution
Workaround
- Login as the oracle user
- This procedure will modify the $AVEKSA_HOME/wildfly/standalone/configuration/aveksa-standalone-full.xml. Backup this file before proceeding.
cp $AVEKSA_HOME/wildfly/standalone/configuration/aveksa-standalone-full.xml $AVEKSA_HOME/wildfly/standalone/configuration/aveksa-standalone-full.xml_backup_<MM-DD-YYYY>
- Run the following command at the system prompt:
$AVEKSA_HOME/wildfly/bin/jboss-cli.sh --connect "/subsystem=logging/root-logger=ROOT:add-handler(name=FILE)"
- The output should look similar to:
{"outcome" => "success"}
- This command modifies the $AVEKSA_HOME/wildfly/standalone/configuration/aveksa-standalone-full.xml file as shown below. The parameter <handler name="FILE"/> is added to the root-logger section so that WildFly server information will now be logged to server.log.
FROM:
<root-logger>
<level name="INFO"/>
<handlers>
<handler name="CONSOLE"/>
</handlers>
</root-logger>
TO:
<root-logger>
<level name="INFO"/>
<handlers>
<handler name="FILE"/>
<handler name="CONSOLE"/>
</handlers>
</root-logger>
Note: This modification takes effect immediately and does not require a restart of RSA Identity Governance & Lifecycle.
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