The WildFly server.log file is not updated on RSA Identity Governance & Lifecycle 7.1.0 and above
Originally Published: 2018-11-05
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 7.1.x
Platform (Other): WildFly
Issue
Cause
This issue has been reported in engineering ticket ACM-92729.
Resolution
Workaround
- Login as the oracle user
- This procedure will modify the $AVEKSA_HOME/wildfly/standalone/configuration/aveksa-standalone-full.xml. Backup this file before proceeding.
cp $AVEKSA_HOME/wildfly/standalone/configuration/aveksa-standalone-full.xml $AVEKSA_HOME/wildfly/standalone/configuration/aveksa-standalone-full.xml_backup_<MM-DD-YYYY>
- Run the following command at the system prompt:
$AVEKSA_HOME/wildfly/bin/jboss-cli.sh --connect "/subsystem=logging/root-logger=ROOT:add-handler(name=FILE)"
- The output should look similar to:
{"outcome" => "success"}
- This command modifies the $AVEKSA_HOME/wildfly/standalone/configuration/aveksa-standalone-full.xml file as shown below. The parameter <handler name="FILE"/> is added to the root-logger section so that WildFly server information will now be logged to server.log.
FROM:
<root-logger>
<level name="INFO"/>
<handlers>
<handler name="CONSOLE"/>
</handlers>
</root-logger>
TO:
<root-logger>
<level name="INFO"/>
<handlers>
<handler name="FILE"/>
<handler name="CONSOLE"/>
</handlers>
</root-logger>
Note: This modification takes effect immediately and does not require a restart of RSA Identity Governance & Lifecycle.
Related Articles
Review overall status bar is not updated when a review is completed in RSA Identity Governance & Lifecycle 123Number of Views enVision does not discover any new devices 21Number of Views Adding an additional Operations Console administrator fails with the error message Encrypted data could not be updated in … 111Number of Views Authentication Manager Console Access using CNAME or DNS alias fails with Redirect Logon Loop - ERR_TOO_MANY_REDIRECTS 11Number of Views Ensuring the hostname of an RSA Authentication Manager 8.1 instance is used in the local syslog 655Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?