The aveksa.ear file fails to deploy on a WildFly cluster with an access denied error message in RSA Identity Governance & Lifecycle
Originally Published: 2019-06-12
Last Modified: 2023-11-30
Article Number
Applies To
RSA Platform: WildFly cluster
RSA Version/Condition: 7.1.1
Issue
[Server:bd-1] 05:36:42,961 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool – 80) WFLYCTL0013: Operation ("deploy") failed - address: ([("deployment" => "aveksa.ear")]) - failure description: \{
[Server:bd-1] "WFLYCTL0080: Failed services" => \{"jboss.undertow.deployment.default-server.default-host./aveksa" => "org.jboss.msc.service.StartException in service jboss.undertow.deployment.default-server.default-host./aveksa: java.lang.ExceptionInInitializerError
[Server:bd-1] Caused by: java.lang.ExceptionInInitializerError
[Server:bd-1] Caused by: java.lang.SecurityException: PBOX00016: Access denied: authentication failed"},
[Server:bd-1] "WFLYCTL0412: Required services that are not installed:" => ["jboss.undertow.deployment.default-server.default-host./aveksa"],
[Server:bd-1] "WFLYCTL0180: Services with missing/unavailable dependencies" => undefined
[Server:bd-1] }
[Server:bd-1] 05:36:42,965 ERROR [org.jboss.as.server] (ServerService Thread Pool – 80) WFLYSRV0021: Deploy of deployment "aveksa.ear" was rolled back with the following failure message:
[Server:bd-1] \{
[Server:bd-1] "WFLYCTL0080: Failed services" => \
Steps used to deploy the ear were:
- Configure the domain node by modifying domain.xml and host.xml.
- Configure and run configureWildfly.sh.
- Deploy the aveksa.ear by running the following commands as user 'oracle':
# /home/oracle/wildfly/bin/jboss-cli.sh -c --controller=<ip address>
[domain@localhost:9990]: deploy /tmp/repackaged_ear_dir/aveksa.ear --server-groups-img-server-groupCause
Resolution
Complete steps to deploy the ear are:
- Configure the domain node by modifying domain.xml and host.xml.
- Reboot the domain node. As the root user run the linux 'shutdown -r [time]' command where [time] is the amount of time before the system shuts down. To shutdown immediately use 'now' as in the following:
shutdown -r now
- Configure and run configureWildfly.sh.
- Deploy the aveksa.ear by running the following commands as user 'oracle':
# /home/oracle/wildfly/bin/jboss-cli.sh -c --controller=<ip address>
[domain@localhost:9990]: deploy /tmp/repackaged_ear_dir/aveksa.ear --server-groups-img-server-group
Related Articles
How to manually deploy an aveksa ear file in RSA Identity Governance & Lifecycle 1KNumber of Views Adding an additional Operations Console administrator fails with the error message Encrypted data could not be updated in … 111Number of Views Error message "GC overhead limit exceeded" in RSA IMG 6.8.1 97Number of Views WSDL Error when trying to deploy RSA Identity Governance and Lifecycle 7.0.x on a WebSphere application server 34Number of Views RSA Authentication Manager 8.2 SP1 system log shows error message: Message Key manager limit reached when using the RSA … 116Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?