When adding User Attributes in RSA Identity Governance and Lifecycle 7.1.0 the following error appear: The number of parameters exceeded the maximum of 1000
Originally Published: 2018-10-08
Last Modified: 2023-09-22
Article Number
Applies To
RSA Version/Condition: 7.1.0
Application Server: WildFly
Issue
ERROR (default task-16) [com.aveksa.gui.core.filters.LoginFilter]
java.lang.IllegalStateException: UT000047: The number of parameters exceeded the maximum of 1000
at io.undertow.server.handlers.form.FormData.add(FormData.java:78)
at io.undertow.server.handlers.form.FormData.add(FormData.java:68)
at io.undertow.server.handlers.form.FormEncodedDataDefinition$FormEncodedDataParser.doParse(FormEncodedDataDefinition.java:173)
at io.undertow.server.handlers.form.FormEncodedDataDefinition$FormEncodedDataParser.parseBlocking(FormEncodedDataDefinition.java:252)
at io.undertow.servlet.spec.HttpServletRequestImpl.parseFormData(HttpServletRequestImpl.java:761)
at io.undertow.servlet.spec.HttpServletRequestImpl.getParameter(HttpServletRequestImpl.java:636)
at javax.servlet.ServletRequestWrapper.getParameter(ServletRequestWrapper.java:194)
at com.aveksa.gui.util.security.XSSRequestWrapper.getParameter(XSSRequestWrapper.java:80)Cause
Workaround
In the example below the limit is increased from 1000 (default) to 3000 by adding the max-parameters value and setting it to 3000.
acm-710:/home/oracle/wildfly/standalone/configuration # cat aveksa-standalone-full.xml | grep listener
<http-acceptor name="http-acceptor" http-listener="default"/>
<http-acceptor name="http-acceptor-throughput" http-listener="default">
<http-listener name="default" socket-binding="http" max-post-size="2147483647" redirect-socket="https" enable-http2="true" max-parameters="3000"/>
<https-listener name="https" socket-binding="https" max-post-size="2147483647" security-realm="AveksaRealm" enabled-protocols="TLSv1,TLSv1.1,TLSv1.2" max-parameters="3000"/>
<https-listener name="agent-ssl" socket-binding="agent-ssl" max-post-size="2147483647" security-realm="AveksaAgentRealm" verify-client="REQUIRED" enabled-protocols="TLSv1.2" max-parameters="3000"/>
Related Articles
Updating the Violation Manager attribute for a large number of RSA Identity Governance and Lifecycle applications 17Number of Views What happens when you exceed the maximum number of email recipients limits on email provider 3Number of Views 'UT000047: The number of parameters exceeded the maximum of 1000' error when scheduling collectors in RSA Identity Governa… 106Number of Views Resend E-mail to Users 3Number of Views 'UT000047: The number of parameters exceeded the maximum of 1000' error when adding User Attributes in RSA Identity Govern… 187Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle How to Download and Reinstall the AFX Server Archive in RSA Governance & Lifecycle
Don't see what you're looking for?