Errors encountered when running ./sdconnect start for the first time in RSA ACE/Server 5.2
Originally Published: 2003-12-17
Last Modified: 2023-09-25
Article Number
Applies To
UNIX
Issue
Error: "2380:error:0D0A0007:asn1 encoding routines:D2I_X509_ALGOR:expecting an asn1 sequence:x_algor.c:47:address=1047697 offset=0"
Error: "2380:error:0D09F004:asn1 encoding routines:D2I_X509:nested asn1 error:x_x509.c:66:address=1047336 offset=361"
Error: "2380:error:140AC80D:SSL routines:SSL_CTX_USE_CERTIFICATE_ASN1:ASN1 lib:ssl_rsa.c:1020:"
Error: "Unable to load certificate"
Error: "Dec 17 10:03:23 scrapdogg ACESERVER: [ID 505037 user.info] (1) AUTHENTICATION : Admin Server SSL server side initialization failed in admin_server initialization failed, check certificates with (Error 20020)."
The output of sdconnect start is as follows:
Copyright 1994 - 2003 by RSA Security Inc.
RSA ACE/Server 5.2
---ALL RIGHTS RESERVED---
Message: Starting server database broker and page writers.
10:03:20 BROKER 0: Multi-user session begin. (333)
10:03:20 BROKER 0: This server accepts secure clients only
10:03:20 BROKER 0: Started for sdserv using TCP, pid 2346. (5644)
10:03:20 APW 1: Started. (2518)
10:03:20 BIW 2: Started. (2518)
Message: Starting log database broker and page writers.
10:03:20 BROKER 0: Multi-user session begin. (333)
10:03:20 BROKER 0: This server accepts secure clients only
10:03:20 BROKER 0: Started for sdlog using TCP, pid 2354. (5644)
10:03:20 APW 1: Started. (2518)
10:03:20 BIW 2: Started. (2518)
Message: Starting Automated Audit Log Maintenance.
Message: Starting Administration Daemon.
Message: Error Starting the sdadmind server
Message: Starting Job Executor Daemon.
Message: Starting Web Admin Daemon.
Unable to load certificate
2380:error:0D0A0007:asn1 encoding routines:D2I_X509_ALGOR:expecting an asn1 sequence:x_algor.c:47:address=1047697 offset=0
2380:error:0D09F004:asn1 encoding routines:D2I_X509:nested asn1 error:x_x509.c:66:address=1047336 offset=361
2380:error:140AC80D:SSL routines:SSL_CTX_USE_CERTIFICATE_ASN1:ASN1 lib:ssl_rsa.c:1020:
Message: Starting Replication.
Message: Database broker start operation completed
The system log shows the following errors when running ./sdconnect start:
Dec 17 10:03:23 scrapdogg ACESERVER: [ID 505037 user.info] (1) AUTHENTICATION : Admin Server SSL server side initialization failed in admin_server initialization failed, check certificates with (Error 20020).
Dec 17 10:03:25 scrapdogg JSED: [ID 477914 user.info] (2) MESSAGE : Job executor STARTED.
Dec 17 10:03:29 scrapdogg ACESERVER: [ID 978520 user.info] (5) ACESYNCHD : Replica successfully bound to port 5505 (172.168.1.102) CrossRealm ACM_OK 0. [acesyncd.c.1115.1]
Dec 17 10:03:29 scrapdogg ACESERVER: [ID 821012 user.info] (5) ACESYNCHD : RSA ACE/Server syncsrvc service started.
Dec 17 10:03:29 scrapdogg ACESERVER: [ID 622954 user.info] (5) ACESYNCHD : Acesyncd Primary Started (172.168.1.102) CrossRealm ACM_OK 0. [acesyncd.c.1213.2]
Dec 17 10:03:56 scrapdogg named[167]: [ID 295310 daemon.notice] check_root: 1 root servers after query to root server < min
Cause
Resolution
If you do not have a copy of the license diskette, contact RSA Security Customer Support at 1-800-995-5095 and request that a new set of license files be sent to you.
Related Articles
Unable to create RADIUS profiles via the RSA Authentication Manager Security Console 397Number of Views RSA response to Fox-IT report and Best Practices for RSA SecurID 48Number of Views Invalid tokencode failures and expired QR code alerts in RSA SecurID Authenticate app 257Number of Views Connection to Cloud Authentication service via Security Console fails with an error; ""Failed to register to the Cloud Aut… 485Number of Views RSA RADIUS Server service failed to start in the RSA Authentication Manager 8.1 Operations Console 1.54KNumber of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA Authentication Manager Patch Updates RSA MFA Agent 2.3.6 for Microsoft Windows Installation and Administration Guide Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle Authentication Manager Security Console and Operations Console Inaccessible After Certificate Update
Don't see what you're looking for?