How to change message seen by end user's mobile phone in RSA Mobile Authentication Server 1.5
2 years ago
Originally Published: 2004-05-20
Article Number
000060362
Applies To
RSA Mobile 1.5 Authentication Server
Microsoft Windows 2000 Advanced Server SP4
Issue
How to change message seen by end user's mobile phone in RSA Mobile Authentication Server 1.5
Some parts of the SMS message cannot be altered
Cause
A default RSA mobile message sent to a mobile phone has a standard format, for example:

     Tokencode::
     12345678
     (Message#: AD200123)
     RSA Mobile
     Authentication

Some parts of this message may be customized by the administrator (see How to update RSA Mobile SMS Configuration) however two key parts of the message may not be altered.

    The 8-digit tokencode, which in the above example the value is "12345678"
    The message ID to compare with a prompt on an authentication page, which above reads "(Message#: AD200123)"

These 2 components are considered to be the bare minimum of an SMS message. During an standard authentication, the user will see a message along the lines of "use the tokencode associated with message # AD200123", at this point they would type in "12345678". This allows for users who may have inadvertently left old messages on their phone, and can scroll through to find the correct (up to date) tokencode value. All other parts may be changed or removed.
Resolution
If non-standard customization of the remaining text is required, this would take the part of RSA Security Professional Services producing a custom, site-specific change to the existing system. In some instances, the further customization may not even be possible after an initial investigation.