Error: 'It doesn't appear that the BlackBerry software is installed on this machine. Exiting...'
3 years ago
Originally Published: 2004-07-23
Article Number
000057808
Applies To
BlackBerry API updater
RSA SecurID Software Token for BlackBerry Handhelds
Issue
Error: "It doesn't appear that the BlackBerry software is installed on this machine. Exiting..."
Cause
Running a newer version of BlackBerry handheld / desktop device
Resolution
Contact your wireless Carrier Support for the proper "System Software" and install into the BlackBerry Desktop Software.

The API updater provided with RSA SecurID Software Token for BlackBerry can update BlackBerry versions 3.6.0, 3.6.1. 3.7.0. RSA Security has specifically qualified the devices 6710, 6750, 6510, 6210, and 5810 which use the 3.6.0 API updater. You can check if your Desktop Software has your DEVICE SYSTEM SOFTWARE as follows:

1. Open Desktop Manager

2. Click on Help from the menu

3. Select About Desktop Manager

4. Click the Handheld Software Tab. You should see version information displayed. If not, contact your wireless carrier.

See http://www.blackberry.com/support/downloads/aws/ for newer devices and the version they run.