When trying to connect with the Event Explorer, the application returns the following error:
Invalid Server Configuration: <hostname> org.xml.sax.SAWParseException: Invalid byte 1 of 1-byte UTF-8 sequence
This error is generated when an Envision device contains invalid characters.
If you do not believe you have a device with an invalid character, you can do the following to confirm:
1. Make a note of the URL you use to log into the Envision UI.
2. Open your browser and point it at:
<Your normal Envision URL>/event_explorer/ee-metadata.jsp
So, for example, if you normally log into:
In your browser URL line, you would enter:
http://1.2.3.4:8080/event_explorer/ee-metadata.jsp
3. When challenged by the authentication page, authenticate as normal.
4. When the XML page comes up, save this page as type *.xml
5. Open the saved page in a standard ASCII editor (notepad or wordpad, for example).
6. Search for "<device>" and you will come across one that has invalid characters. Here's an example of a device with invalid characters:
<device>
<id><![CDATA[dba6006c-fcc2-4641-bc3e-a98c5031e771]]></id>
<type><![CDATA[Unknown]]></type>
<ip><![CDATA[null,true,null,null,????]]></ip>
<site><![CDATA[NCCI-LOG]]></site>
<domain><![CDATA[NIC]]></domain>
<category><![CDATA[Unknown]]></category>
</device>
This normally occurs when you have removed a device and then readded it. If you have recently removed a device and then readded it please try removing the device and logging into Event Explorer. After logging into Event Explorer you should be able to readd the device again and log into Event Explorer again.
Related Articles
How to process PKCS#10 Certificate Signing Request (CSR) from WebSphere 39Number of Views What format is the time stored in the SC_TOUCH_TIME and SC_CREATION_TIME variables of the token within the CTSESSION cookie? 16Number of Views Interoperability between RSA Authentication Agent 7.x for Microsoft Windows and RSA Authentication Agent for Web for IIS 186Number of Views Missing sdconf.rec file causes SecurID to fail on Raptor Firewall 77Number of Views RSA Authentication Manager no longer connects to the RSA Cloud Access Service 46Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide