Impersonation error when creating a token using runtimeAPI.createToken
Originally Published: 2013-06-06
Last Modified: 2023-10-06
Article Number
Applies To
RSA Access Manager 6.1
RSA Access Manager version 6.2
Issue
The following error is logged in the eserver standard output file in DEBUG mode:
15:29:33:115 [*] [MuxWorker-10] - result: {EXCEPTION_TYPE=TokenException, EXCEPTION_MESSAGE=Impersonation is allowed only for administrative user}
Cause
Resolution
values.remove(TokenKeys. SC_IMPERSONATED_ID);
This error should not occur when cleartrust.aserver.impersonation.enable=false. This will be fixed in a future service pack.
Workaround
Related Articles
The workpoint log has daily occurrences of ORA-02049: timeout: distributed transaction waiting for lock errors in RSA Id… 321Number of Views Creating a Trust Relationship 12Number of Views WebSphere clustered server node causes system outages due to 'ORA-02049: timeout: distributed transaction waiting f… 374Number of Views Creating a custom attribute and reporting on it in RSA Authentication Manager 8.2 SP1 or later 20Number of Views Questions on creating an AFX connector to PostgreSQL using a generic ODBC driver in RSA Identity Governance & Lifecycle 140Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?