Issue
When using On-Demand Authentication (ODA) as the step-up authentication method for your RSA Community and/or myRSA account, the text message (SMS) with the tokencode is never delivered if you reside in Singapore after entering your ODA PIN.
Cause
This issue occurs because there are new regulations in place within Singapore that make it extremely difficult for text messages (SMS) to be sent from automated systems, including the system utilized by the RSA Community and myRSA authentication.
Workaround
Unfortunately the only workaround for this issue is to
set up security questions as an alternative form of step-up authentication for your RSA Community and/or myRSA account. This will allow you to successfully log in to the platforms.