Article Number
000014101
Applies To
RSA ClearTrust Server 5.5.3
RSA Access Manager Servers 6.0
Issue
AXM & Cleartrust Memory leak in eserver over a period of several weeks.
The eserver standard output shows the following message. This message does not occur in the regular log files.
Starting Admin API server on port 5601: done.
Starting Runtime subsystem: Failed to connect to runtime subsystem: unable to contact any servers
Retry in 10 seconds
AdminAPI program reports the following error message: (Actually, this error occurs on the client, but indicates a problem on the eserver itself):
sirrus.api.client.TransportException: java.lang.OutOfMemoryError
Cause
The eserver must be able to establish connections to the aservers to perform cache flush updates. If the eserver cannot make this connection, cache flush events will begin to queue on the eserver. If this queue cannot be cleared, it may result in a gradual loss of available memory on the eserver.
Resolution
Ensure that the cleartrust.eserver.dispatcher_list= parameter in the eserver.conf file is correct. Ensure that the eserver is able to connect to the dispatcher and aservers.