SecurID® Discussions

Browse the SecurID discussion board to get product help and collaborate with other SecurID users.
New Contributor
New Contributor

How to force user to logon only with RSA passcode

Hello im presently configuring Windows RSA Authentication Agent on Windows 10 

What i was trying to figure out is how do i force user to only use RSA passcode authentication method and not the Windows normal authentication method for only certain user.

So to be clear for exemple i would like that every user in the AD group "RSA Authentication" need to authenticated with RSA method and that if they tried to authenticate with windows method it don't work. 


Is this something we can do ? 


I was able to only put the RSA authentication method folowing these steps


1.    Start --- > Run --- > gpedit.msc

2.    Expand Administrative templates

3.    Expand Classic Administrative templates

4.    RSA Desktop --- > Credential provider Filter Settings:

The following 4 changes have been made:

        Exclude the Microsoft Password Credential Provider =Enabled

        Exclude the RSA Credential Provider for disconnect auth =Disabled

        Exclude the RSA Smart Card Credential Provider =Disabled

                Exclude the Third-party Credential Providers = Enabled

5.    Command line prompt: gpupdate /force

6.    Log off and log back.


But the problem with this is that we cannot logon with Windows Authentication method for exemple if we want to logon with local administrator account

Thanks for your help !

0 Replies