Announcements

SecurID® Discussions

Browse the SecurID discussion board to get product help and collaborate with other SecurID users.
PatrickPeneder
Beginner
Beginner

unable to connect via ssh to rsa server

I have reset the password of the rsaadmin user (local unix user), because we didn’t know that anymore. On the server I can login now, but when I tried to make a ssh connection to the server it always says that it’s denied.

 

Also when I want to change the operating system password in the OC --> Administration --> Operating System Access --> Change Operating System Passwort, it’s always the wrong one.

There comes the message: There was a problem processing your request. Original password provided was invalid. I don’t know the where there could be the problem? This is not the problem!

Labels (1)
0 Likes
2 Replies
JayGuillette
Apprised Contributor Apprised Contributor
Apprised Contributor

If the rsaadmin password does not work, then it was reset incorrectly.  If the original password also does not work, then you need access to the real console (not SSH), either hardware appliance with Keyboard and VGA monitor or VMWare console, so that you can interrupt the Linux boot process and edit the /etc/passwd file to delete the unknown rsaadmin password.

 

There is an Internal KB 37050 called "Reset the rsaadmin command line password for RSA Authentication Manager 8.4 and up" which explains how to do this. You would need to open a Support case to see it or learn about it, but this is basic Linux Security - that's why Server rooms are locked.

 

Older versions of AM used a different Boot Manager, and had a variation on this approach where you booted Linux from a CD, mounted the system disk, then edited the /etc/passwd file to delete the unknown rsaadmin password.

0 Likes
KeithBradley
New Contributor
New Contributor

Make sure to turn on the SSH Connation on the local page under Diagnostics -> Troubleshooting -> SSH Configuration

0 Likes