SecurID® Governance & Lifecycle 7.2 Enablement

EdBertsch
Occasional Contributor
Occasional Contributor

IG&L: about Oracle 19c and 18c support for IGL DB and also for collection

Jump to solution

Please discuss the current and planned future support for Oracle databases running 18c and also 19c.

 

#1 is as the RSA database itself (remote Oracle database)

 

#2 is as an endpoint for collection using the standard RSA such as with connection strings like the following

 

jdbc:oracle:thin:@//<server>:<port>/whatever.whatever.whatever

 

These are discussed briefly in the product overview for 7.2 but please discuss in more detail when possible.

 

Will there be any such support in any patch or hotfix prior to 7.2 going GA ?

1 Solution

Accepted Solutions
SeanMiller1
Moderator Moderator
Moderator
  1. We do not ship Oracle 18c/19c yet as the RSA database.  We will support a remote installation where the customer provides an Oracle 18c/19c server
  2. Not sure if anyone is using version 18.  There was an issue with collectors against that version that is now fixed.  With 19 we might also require that there are some db configuration changes primarily the ones that we required for 12.2.  We have not done any certification efforts against 18/19 against collectors.  It should work but we were focusing our support statement on the AVDB the system uses.
  3. We are officially supporting Oracle 18/19 in 7.2.  We are not backporting the changes to allow support against those versions from an install.  It is possible to upgrade your Oracle version after installing the product and in those cases we will work against Oracle 18/19.  We have not certified this however and we will not be officially reflecting it in the platform matrix.  Customers wanting to use Oracle 18/19 should migrate to 7.2 to ensure any issues related that are found can be addressed.

View solution in original post

1 Reply
SeanMiller1
Moderator Moderator
Moderator
  1. We do not ship Oracle 18c/19c yet as the RSA database.  We will support a remote installation where the customer provides an Oracle 18c/19c server
  2. Not sure if anyone is using version 18.  There was an issue with collectors against that version that is now fixed.  With 19 we might also require that there are some db configuration changes primarily the ones that we required for 12.2.  We have not done any certification efforts against 18/19 against collectors.  It should work but we were focusing our support statement on the AVDB the system uses.
  3. We are officially supporting Oracle 18/19 in 7.2.  We are not backporting the changes to allow support against those versions from an install.  It is possible to upgrade your Oracle version after installing the product and in those cases we will work against Oracle 18/19.  We have not certified this however and we will not be officially reflecting it in the platform matrix.  Customers wanting to use Oracle 18/19 should migrate to 7.2 to ensure any issues related that are found can be addressed.