Article Number
000034794
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 6.8.1, 6.9.1, 7.0.x
Platform (DB): Oracle 11.2.0.3 to 12.1.0.2
Issue
An Aveksa Statistics Report (ASR) cannot be generated (
Admin >
System >
Diagnostics tab >
Create Report) in RSA Identity Governance & Lifecycle..
The
aveksaServer.log file
($AVEKSA_HOME/wildfly/standalone/log/aveksaServer.log) has the following errors:
01/12/2017 16:17:21.735 ERROR (GuiSystemReportObjectStore) [com.aveksa.server.db.persistence.PersistenceServiceProvider] Executing Procedure: java.sql.SQLException: ORA-00603: ORACLE server session terminated by fatal error
ORA-27102: out of memory
Linux-x86_64 Error: 12: Cannot allocate memory
Additional information: 108
Additional information: 1835008
ORA-04030: out of process memory when trying to allocate 1032 bytes (qmxlu subheap,qmemNextBuf:alloc)
...
FAILED method=runStoredProcedure System_Report.Run, [ProcedureParameter[direction = IN name = null value = <SECTION REFERENCE='101'>
The Oracle alert log (/u01/app/oracle/diag/rdbms/avdb/AVDB/trace/alert_AVDB.log) has the same error:
Thu Dec 08 13:15:21 2016 Errors in file /u01/app/oracle/diag/rdbms/avdb/AVDB/trace/AVDB_ora_7081.trc (incident=180976): ORA-04030: out of process memory when trying to allocate 1032 bytes (qmxlu subheap,qmemNextBuf:alloc)
Incident details in: /u01/app/oracle/diag/rdbms/avdb/AVDB/incident/incdir_180976/AVDB_ora_7081_i180976.trc
Please refer to RSA Knowledge Base Article
000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the log files for your specific deployment if you are on a WildFly cluster or a non-WildFly platform. The
aveksaServer.log may also be downloaded from the RSA Identity Governance & Lifecycle user interface (
Admin >
System >
Server Nodes tab > under
Logs.)
Cause
The ORA-04030 error is a known issue caused by Oracle Database Bug 19678658 which is a memory leak when using XML data.
Resolution
For customers using the RSA-supplied Oracle database software
The Oracle database Patch 19678658 is included in the Appliance Updater, starting with the December 2017 version. Please check for the latest
RSA Identity Governance and Lifecycle Updater, for your platform. Always install the latest Appliance Updater available for your platform.
For customers using their own Oracle database software
Download and apply Oracle Database Patch 19678658 from the
Oracle Support portal, for your specific Operating System and version of Oracle database software.
How to check if Oracle database patch 19678658 has been applied
To check if the patch has been applied, perform the following steps.
- Login as user oracle.
- Navigate to $ORACLE_HOME/OPatch and run the opatch command as follows:
cd $ORACLE_HOME/OPatch
./opatch lsinventory
In a typical RSA Identity Governance & Lifecycle installation where the patch is installed, the results would look similar to the following:
--------------------------------------------------------------------------------
Installed Top-level Products (1):
Oracle Database 12c 12.1.0.2.0
There are 1 products installed in this Oracle Home.
Interim patches (2) :
Patch 19678658 : applied on Mon Mar 20 22:13:50 EDT 2017
Unique Patch ID: 19261499
Created on 20 Aug 2015, 14:51:46 hrs PST8PDT
Bugs fixed:
19678658
Patch 19509982 : applied on Mon Oct 03 12:49:01 EDT 2016
Unique Patch ID: 18265206
Created on 11 Feb 2015, 14:07:42 hrs PST8PDT
Bugs fixed:
19509982
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