Article Number
000038734
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Product/Service Type: Appliance
RSA Version/Condition: 7.0.0, 7.0.1, 7.0.2
Issue
When scheduling database backups from the RSA Identity Governance & Lifecycle user interface (
Admin >
System >
Backup tab),sometimes a backup gets stuck
In Progress and never finishes. No more backups can run until the stuck backup completes.
Image description
From the command line, the
ps command shows a backup job still running:
ps
oracle 29676 36554 0 Mar05 ? 00:00:00 /bin/bash /home/oracle/database/DBA/AVDB/scripts/AVDB_Export_AVUSER.sh -t 2020-03-5
Cause
This is a known issue reported in engineering ticket ACM-58925.
Resolution
This issue is resolved in the following RSA Identity Governance & Lifecycle versions and patch levels:
- RSA Identity Governance & Lifecycle 7.0.2 P04
- RSA Identity Governance & Lifecycle 7.1.0
Workaround
To stop the failed backup, restart the application and database server. Login as the
oracle user and execute the following commands:
acm stop
acm stopdb
acm startdb
acm start
To clear the
In Progress status in the user interface, a good backup should be completed from the command line. For more information on backing up the RSA Identity Governance & Lifecycle database, see RSA Knowledge Base Article
000038174 -- How to perform a database backup (export) and a database restore (import) in RSA Identity Governance & Lifecycle.
Execute the following backup commands as the oracle user.
acm stop
cd /home/oracle/database/DBA/AVDB/scripts
./AVDB_Export_AVUSER.sh -t <optional tag on the filename>
or
acm stop
avdbexport -t <optional tag on the filename>
For example, the following commands will create a backup file called Export_AVDB_avuser_040120.dmp in the $AVEKSA_HOME/AveksaExportImportDir directory
acm stop
avdbexport -t _040120