Article Number
000027952
Applies To
RSA Product Set: Identity Governance & Lifecycle
RSA Version/Condition: 6.x
Issue
Users are unable to login to RSA Identity Governance & Lifecycle after the system was rebooted.
The symptom for this problem is the inability to log in. There may be a migration required error in the User Interface (UI) and the following error may be seen in the home/oracle/jboss/server/default/log/server.log:
WARN [arjLoggerI18N] [com.arjuna.ats.arjuna.recovery.RecoverAtomicAction_4] -
RecoverAtomicAction: transaction not activated, unable to replay phase 2 commit
Cause
There were numerous files in /home/oracle/jboss/server/default/data/tx-object-store/HashedActionStore/defaultStore/StateManager/BasicAction/TwoPhaseCoordinator/AtomicAction that were 0 bytes in size amd this was preventing the startup from being successful.
The WARNING message from the log file appears when the writes of a transactional object state to the persistent store have failed. This will create corrupt records in the persistent store, probably zero length files. The recovery process tries to retrieve the transactional object state so that it can recreate the relevant object in memory. This transactional object may be a transaction, a participant record or some other type of object. Since the records are corrupt this is going to keep failing and the recovery manager will keep retrying and failing.
The most common cause for this problem is the disk is full.
Resolution
There are two parts to this solution:
- Free up disk space.
- Clear the transaction store.
- Stop the application server:
$> sudo service aveksa_server stop
- Execute the following commands in the /home/oracle/jboss/server/default/data DIRECTORY to list the zero-length files:
$> cd /home/oracle/jboss/server/default/data
$> find . -size 0 -type f -ls
- Execute the following to delete the zero-length files (Note: This only deletes files in this directory that have a zero-length (0 bytes) file size):
find . -size 0 -type f -delete
After these commands are run, the errors in the server log will stop once the application server is re-started.
- Restart the application server
sudo service aveksa_server start
Notes