AnsweredAssumed Answered

AFX Exchange Integration

Question asked by Nico van der Westhuizen on Jan 17, 2016

Hi All We are experiencing issues when trying to initiate a exchange management shell cmdlet via AFX. We have executed: Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010 before the enable-mailbox cmdlet We are receiving an error message relating to that it cannot load Windows PowerShell snap-in Microsoft.Exchange.Management.PowerShell.E2010 because of the following error: The type initializer for ’Microsoft.Exchange.Data.Directory.Globals’ threw an exception. Research around this ( https://connect.microsoft.com/VisualStudio/feedback/details/770748/powershell-exception-after-4-5-upgrade ) indicates that the .NET framework version 4.5 is the source of the issue. My team found a solution around this if you ever come across the this error "Microsoft.Exchange.Data.Directory.Globals" Workaround In the Service Manager you have the option to change you .NET framework Version. Go to Service Manager -> Roles -> Web Services -> Internet Information Services (IIS) Manager Under your connections click on your server which you want to change the .NET framework. Once selected under actions on the right you would see the option Change .NET Framework Version. Click on it and it will provide you with option which version do you want to use. Select version 4 and try again :) Regards Nico

Outcomes