AnsweredAssumed Answered

Install AFX server

Question asked by Dj4bIamQPv7HFSpC1lG08vP2ANE8fvnDUNK3hVdVlsQ= on Aug 5, 2016
Latest reply on Aug 8, 2016 by Dj4bIamQPv7HFSpC1lG08vP2ANE8fvnDUNK3hVdVlsQ=

Hi,

I installed an aveksa 7.0.0 without AFX then  i applied a P03 patch. But When i  tried to install AFX server using the /home/oracle/deploy/installAFX.sh script i had this error:

 

in the log file:

 

*****************************************************

*****************************************************

Installation started on Fri Aug  5 11:17:48 CEST 2016

*****************************************************

QUIET mode specified. User prompts will be disabled.

Install Summary:

----------------

Install Mode: New Install

AFX_STAGING_DIR             /tmp/AFX

AFX_HOME                    /home/oracle/AFX

MULE_HOME                   /home/oracle/AFX/mule

ACTIVEMQ_HOME               /home/oracle/AFX/activemq

MMC_HOME                /home/oracle/AFX/mmc-console

JAVA_HOME                   /etc/alternatives/java_sdk_1.7.0

JAVA_CMD_DIR                /etc/alternatives/java_sdk_1.7.0/bin

AFX_OWNER                   oracle

AFX_GROUP                   oinstall

----------------

Cleaning up existing AFX staging directory /tmp/AFX...

Expanding AFX server archive to /tmp/AFX...

Configuring AFX environment script...

Configuring SSL Certificates for AFX Server...

FATAL ERROR!! Failed to create SSL certificate for AFX server using Aveksa CA

FAILURE!! AFX installation FAILED due to FATAL ERRORS on Fri Aug 5 11:18:53 CEST 2016

*****************************************************

 

I saw a similar error here so i tried to change a certificate and generate a new server.keystore and a new client.keystore

 

 

 

Regards.

Outcomes