AnsweredAssumed Answered

[Duplicate Error] The unification process don't do its job

Question asked by Dj4bIamQPv7HFSpC1lG08vP2ANE8fvnDUNK3hVdVlsQ= on Aug 22, 2016
Latest reply on Aug 25, 2016 by Mostafa Helmy

Hi All,

 

I had a lot of unification duplicate error:

[ORA-00001][ORA-30926] Identity Data Unification Error, [Unification][Error ORA-30926] Unification issue:"Resolve User Type References Failed", [Unification] Collect identities from two collectors without duplicata

After a long investigation and your help, i detect that unification don't do its job, i explain my case:

I have 3 collector:

The first and the second collector collect identities, i have 36 duplicate identities, for that i create a join rule and i set the first collector as an authoritative source.

And the third collector collect just a dn for all my identities, so i have a duplicate userid for all my identities, then i create two join rules between the the two identities collectors and the dn collector.

 

When i run each collector alone:

First collector+unification, second collector+unification, third collector+unification that works

But when i run the third collectors in the same time then i run the unification process, i had duplicate error:

First collector+ second collector+ third collector then unification that not works

 

Have you any idea how can i resolve that cause for this moment i run each collector alone to by pass this error?

 

Best regards.

Outcomes