AnsweredAssumed Answered

Identity collection connection to MS SQL fails

Question asked by Gregory Taft on Apr 26, 2017
Latest reply on Apr 26, 2017 by Gregory Taft

I am attempting to change my identity collection to go against a MS SQL server directly rather than having the HR team create a CSV file and creating a File Transfer Job to send the file to RSA L&G. 

I am running RSA L&G 6.9.1 P18. 

I created the identity collector I have tried the SQL Server driver and the SQL Server 3 driver. 

I have tried several connection strings, the last supplied by the SQL DBA.


jdbc:sqlserver://<Server DNS Name>:<port>;databaseName=<database name>


When I click the "Test" button for the collector, I am getting the following error message which appears to indicate there is a "to_char" call being attempted and it is not accepted.  Not sure what is happening behind the scenes but the failure is pretty consistent no matter which connection string format I us and no matter which driver I use.


Collector test failed: com.aveksa.server.runtime.ServerException: Test request failed with response: com.aveksa.server.runtime.ServerException: com.aveksa.common.DataReadException: Could not create user data iterator!. Caused by 'to_char' is not a recognized built-in function name. Caused By Stack com.aveksa.common.DataReadException: Could not create user data iterator! at com.aveksa.collector.userdata.DBUserIterator.( at com.aveksa.collector.userdata.DBGenericReader.constructUserIterator( at com.aveksa.collector.userdata.DBGenericReader.getUserIteratorForTestData( at com.aveksa.client.datacollector.collectors.identitydatacollectors.IdentityDataCollector.writeData( at com.aveksa.client.datacollector.collectors.identitydatacollectors.IdentityDataCollector.collectData( at com.aveksa.client.datacollector.collectors.identitydatacollectors.IdentityDataCollector.collect( at com.aveksa.client.datacollector.collectors.identitydatacollectors.IdentityDataCollector.collectTestData( at com.aveksa.client.datacollector.framework.DataCollectorManager.collect( at com.aveksa.client.component.collector.DefaultCollectorManager.actUpon( at com.aveksa.client.component.collector.DefaultCollectorManager.handle( at com.aveksa.client.component.event.DefaultEventManager.handle( at com.aveksa.client.datacollector.framework.SimpleEventSource.notifyListeners( at com.aveksa.client.component.communication.DefaultCommunicationManager.notifyEvent( at com.aveksa.client.component.communication.ChangeListHandler.applyChanges( at com.aveksa.client.component.communication.ChangeListHandler.access$300( at com.aveksa.client.component.communication.ChangeListHandler$ at Caused by: 'to_char' is not a recognized built-in function name. at at at at$StmtExecCmd.doExecute( at at at at at at com.aveksa.collector.userdata.DBUserIterator.( ... 16 more End Stack

Anyone have any thoughts?