AnsweredAssumed Answered

IDC query fails with ORA-00942

Question asked by Aaron Stromas Employee on Apr 27, 2017

Hi,

 

I have the following issue. We are staging user data in the Aveksa database in different schema (dsouser) from where the IDC reads it. The data can be accessed in SQLDeveloper. The IDC is configured to use the dsouser user ID to connect to the database and the connection test is successful, yet the quey fails with "ORA-00942: table or view does not exist". I suspect that the reason is that the schema is not readable, as suggested by (Not Authorized) in the Shamas field.

 

IDC query

 

I had also tried to configure the IDC using the avuser and got the same result

IDC query

 

Note that the schemas are still not accessible.

The database on this GnL database was dropped and reloaded. Perhaps, something went amiss there.

Any suggestions on how to get this fixed? TIA.

 

-aaron

 

 

Update: I was able to resolve the collection issue by granting SELECT privilege to AVUSER and collect by collecting as AVUSER, however, I'm still concerned by AVUSEr not being able to read schemas.

Outcomes