AnsweredAssumed Answered

Schema Migration Fails after upgrade 7.0.2

Question asked by Ashish Ahluwalia on Oct 10, 2017
Latest reply on Oct 12, 2017 by Rakhee Tarar

At the very end of the upgrade process from Aveksa RSA via L and G 7.0 to 7.0.2

Lakhwinder SinghBoris Polikarpov  the DB Schema migration fails:

1) Tried re-running the migrate.sh  (/home/oracle/deploy/migrate.sh)

java.sql.SQLException: ORA-24344: success with compilation error
ORA-06512: at "AVUSER.SIEM_INTEGRATION", line 134
ORA-06512: at "AVUSER.PUBLIC_SCHEMA", line 69

If I look at the database, through SQLPLUS Client, I can see that under CHANGED_USER_TYPE, it created a duplicate for SUPERVISOR_NAME, which I can remove manually abd when I re-run script it recreates and fails..

 

Other Option I tried :

 

2) The Upgrade and Migrate Guide says, that

"

If you chose not to migrate the database, when you start RSA Identity Governance and

Lifecycle for the first time after upgrading, the Initialization Status indicates that the database

schema is out-of-date. At the prompt, enter the following password: AuthorizeMigration. The

startup process performs a migration of the database, which updates the schema.

"

 

So I Open up the Admin UI, and its says that Schema Must be Migrated and I give the password as AuthorizeMigration, which it accepts and invokes nothing but migrate.sh, (/home/oracle/deploy/migrate.sh) , which again fails as explained above...

 

Basically the upgrade is impacted due to migrate DB is not working as expected.

 

Does Anyone  know how to fix it please?

 

regards,

Ashish Ahluwalia

Outcomes