Stefano Elia

Local repository moved and sym-linked, leads to puppet agent failure: missing repomd.xml

Discussion created by Stefano Elia on Feb 5, 2018
Latest reply on Feb 5, 2018 by John Snider

Hi all,
I have already browsed the browsable about the "missing repomd.xml" issue, but I already know the reason I'm getting this error.

Briefly, RSA support moved my local repository from /var/netwitness/srv/www/rsa/updates/{version} to another location in filesystem, in order to free some precious disk space. Then they made a symlink to the new location.

When I run puppet agent -t, I encounter the said error "cannot find repomd.xml for RSASoftware".
Later I discovered that if I run "curl http://puppetmaster.local/rsa/updates/{version}" , I get 403 (forbidden).

My question is: is there a way to allow puppet to follow that symlink? Or should I set some permission in order to make that file available via http?

Or am I forced to move back the local repo, in order to make things work again?

Any helpful consideration is appreciated.
Thank you.

Stefano

Outcomes