AnsweredAssumed Answered

CryptoAPI passwords with SecurID not working

Question asked by Neil Frick on Mar 1, 2018
Latest reply on May 1, 2018 by Erica Chalfin

We're using RSA Authentication Agent 7.3.3.99 on Windows 10 Build 1703. We have a number of users who have document signing certificates issued by external trusted Certificate Authorities (IdenTrust, for example). These certificates were imported with a CryptoAPI security level of "High," meaning users type in a password to unlock the private key on the certificate when using them to sign documents (Adobe Acrobat).

 

After deploying the 7.3.3.99 agent, they are no longer able to enter their password to access the private key and sign documents. They receive this message - "To allow the app to access your private key, enter the password:" however there is no password field present. There was a password field before the RSA agent was installed. The image of the message is attached. The only dialog option is "Don't allow" so the user isn't able to enter any password or sign the doucment.

 

I can't find any existing information about this issue. Any ideas?

Attachments

Outcomes