AnsweredAssumed Answered

checkOracleRPMsPreReqs

Question asked by Razvan Dumitriu on Mar 8, 2019
Latest reply on Mar 11, 2019 by Razvan Dumitriu

Hello,

 

As part of the installation process, the install script checks some packages/libraries on the OS. In my case, having some of these failed, I would like to enquire additional details:

 

1) why are X.org libraries needed for in RSA IGL?

Needed package "xorg-x11-driver-video-7.6_1-14.30.x86_64" (or higher) is not installed on system

Needed package "xorg-x11-server-7.6_1.15.2-36.21.x86_64" (or higher) is not installed on system

Needed package "xorg-x11-essentials-7.6_1-14.17.noarch" (or higher) is not installed on system

Needed package "xorg-x11-Xvnc-1.4.3-7.2.x86_64" (or higher) is not installed on system

Needed package "xorg-x11-fonts-core-7.6-29.45.noarch" (or higher) is not installed on system

Needed package "xorg-x11-7.6_1-14.17.noarch" (or higher) is not installed on system

Needed package "xorg-x11-server-extra-7.6_1.15.2-36.21.x86_64" (or higher) is not installed on system

Needed package "xorg-x11-libs-7.6-45.14.noarch" (or higher) is not installed on system

Needed package "xorg-x11-fonts-7.6-29.45.noarch" (or higher) is not installed on system

 

 

2) trying to get them installed, additional errors are encountered:

/tmp/aveksa/staging # zypper in xorg-x11-Xvnc
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

 

Problem: xorg-x11-Xvnc-1.6.0-18.20.1.x86_64 requires icewm-lite, but this requirement cannot be provided
  uninstallable providers: icewm-lite-1.3.12-9.3.x86_64[spacewalk:sles12-sp2-pool-x86_64]
                   icewm-lite-1.3.12-11.81.x86_64[spacewalk:sles12-sp2-updates-x86_64]
 Solution 1: remove lock to allow installation of libasound2-1.0.27.2-15.1.x86_64[spacewalk:sles12-sp2-updates-x86_64]
 Solution 2: remove lock to allow installation of libasound2-1.0.27.2-11.10.x86_64[spacewalk:sles12-sp2-pool-x86_64]
 Solution 3: do not install xorg-x11-Xvnc-1.6.0-18.20.1.x86_64
 Solution 4: break xorg-x11-Xvnc-1.6.0-18.20.1.x86_64 by ignoring some of its dependencies

 

Choose from above solutions by number or cancel [1/2/3/4/c] (c):

 

Any feedback for the above questions is appreciated.

 

Thank you for your time and assistance.

 

Razvan

Attachments

Outcomes