AnsweredAssumed Answered

RSA IGL - 7.2 AFX

Question asked by Mekala Subramanian on Mar 22, 2020
Latest reply on Mar 23, 2020 by Mekala Subramanian

AFX started and running, but Connectors not being deployed - Check mule log file error...

 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ Started app '10_AFX-INIT' +
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
INFO 2020-03-20 14:30:07,375 [WrapperListener_start_runner] org.mule.module.lau ncher.DefaultArchiveDeployer: ================== New Exploded Artifact: 15_AFX-M AIN
INFO 2020-03-20 14:30:07,376 [WrapperListener_start_runner] org.mule.module.lau ncher.application.DefaultMuleApplication:
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ New app '15_AFX-MAIN' +
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
INFO 2020-03-20 14:30:07,377 [WrapperListener_start_runner] org.mule.module.lau ncher.log4j.ArtifactAwareRepositorySelector: Found logging config for applicatio n '15_AFX-MAIN' at 'file:/home/oracle/AFX/esb/apps/15_AFX-MAIN/classes/log4j.xml '
log4j:WARN No appenders could be found for logger (org.mule.DefaultMuleContext).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more in fo.
ERROR 2020-03-20 14:30:43,858 [WrapperListener_start_runner] org.mule.module.lau ncher.DefaultArchiveDeployer:
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ Failed to deploy artifact '15_AFX-MAIN', see below +
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
org.mule.module.launcher.DeploymentStartException: BindException: Address alread y in use (Bind failed)
at org.mule.module.launcher.application.DefaultMuleApplication.start(Def aultMuleApplication.java:155)
at org.mule.module.launcher.artifact.ArtifactWrapper$4.execute(ArtifactW rapper.java:98)
at org.mule.module.launcher.artifact.ArtifactWrapper.executeWithinArtifa ctClassLoader(ArtifactWrapper.java:129)
at org.mule.module.launcher.artifact.ArtifactWrapper.start(ArtifactWrapp er.java:93)
at org.mule.module.launcher.DefaultArtifactDeployer.deploy(DefaultArtifa ctDeployer.java:26)
at org.mule.module.launcher.DefaultArchiveDeployer.guardedDeploy(Default ArchiveDeployer.java:310)
at org.mule.module.launcher.DefaultArchiveDeployer.deployArtifact(Defaul tArchiveDeployer.java:330)
at org.mule.module.launcher.DefaultArchiveDeployer.deployExplodedApp(Def aultArchiveDeployer.java:297)
at org.mule.module.launcher.DefaultArchiveDeployer.deployExplodedArtifac t(DefaultArchiveDeployer.java:108)
at org.mule.module.launcher.DeploymentDirectoryWatcher.deployExplodedApp s(DeploymentDirectoryWatcher.java:289)
at org.mule.module.launcher.DeploymentDirectoryWatcher.start(DeploymentD irectoryWatcher.java:146)
at org.mule.module.launcher.MuleDeploymentService.start(MuleDeploymentSe rvice.java:99)
at org.mule.module.launcher.MuleContainer.start(MuleContainer.java:152)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl. java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces sorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.mule.module.reboot.MuleContainerWrapper.start(MuleContainerWrappe r.java:52)
at org.tanukisoftware.wrapper.WrapperManager$11.run(WrapperManager.java: 4048)
Caused by: org.mule.api.lifecycle.LifecycleException: Failed to start inbound en dpoint "endpoint.http.localhost.8089.callback"
at org.mule.endpoint.DefaultInboundEndpoint.start(DefaultInboundEndpoint .java:118)
at org.mule.construct.AbstractFlowConstruct.startIfStartable(AbstractFlo wConstruct.java:322)
at org.mule.construct.AbstractPipeline.doStart(AbstractPipeline.java:315 )
at org.mule.construct.AbstractFlowConstruct$2.onTransition(AbstractFlowC onstruct.java:141)
at org.mule.construct.AbstractFlowConstruct$2.onTransition(AbstractFlowC onstruct.java:137)
at org.mule.lifecycle.AbstractLifecycleManager.invokePhase(AbstractLifec ycleManager.java:138)
at org.mule.construct.FlowConstructLifecycleManager.fireStartPhase(FlowC onstructLifecycleManager.java:92)
at org.mule.construct.AbstractFlowConstruct.start(AbstractFlowConstruct. java:136)
at sun.reflect.GeneratedMethodAccessor22.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces sorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.mule.lifecycle.phases.DefaultLifecyclePhase.applyLifecycle(Defaul tLifecyclePhase.java:237)
at org.mule.lifecycle.RegistryLifecycleManager$RegistryLifecycleCallback .onTransition(RegistryLifecycleManager.java:273)
at org.mule.lifecycle.RegistryLifecycleManager.invokePhase(RegistryLifec ycleManager.java:152)
at org.mule.lifecycle.RegistryLifecycleManager.fireLifecycle(RegistryLif ecycleManager.java:123)
at org.mule.registry.AbstractRegistryBroker.fireLifecycle(AbstractRegist ryBroker.java:76)
at org.mule.registry.MuleRegistryHelper.fireLifecycle(MuleRegistryHelper .java:136)
at org.mule.lifecycle.MuleContextLifecycleManager$MuleContextLifecycleCa llback.onTransition(MuleContextLifecycleManager.java:91)
at org.mule.lifecycle.MuleContextLifecycleManager$MuleContextLifecycleCa llback.onTransition(MuleContextLifecycleManager.java:87)
at org.mule.lifecycle.MuleContextLifecycleManager.invokePhase(MuleContex tLifecycleManager.java:69)
at org.mule.lifecycle.MuleContextLifecycleManager.fireLifecycle(MuleCont extLifecycleManager.java:61)
at org.mule.DefaultMuleContext.start(DefaultMuleContext.java:278)
at org.mule.module.launcher.application.DefaultMuleApplication.start(Def aultMuleApplication.java:133)
... 18 more
Caused by: org.mule.api.MuleRuntimeException: java.net.BindException: Address al ready in use (Bind failed)
at org.mule.transport.http.HttpConnectionManager.addConnection(HttpConne ctionManager.java:70)
at org.mule.transport.http.HttpConnector.connect(HttpConnector.java:566)
at org.mule.transport.http.HttpMessageReceiver.doConnect(HttpMessageRece iver.java:42)
at org.mule.transport.AbstractMessageReceiver.connectHandler(AbstractMes sageReceiver.java:447)
at org.mule.transport.AbstractTransportMessageHandler.connect(AbstractTr ansportMessageHandler.java:214)
at org.mule.transport.AbstractConnector.registerListener(AbstractConnect or.java:1251)
at org.mule.transport.http.HttpConnector.registerListener(HttpConnector. java:355)
at org.mule.endpoint.DefaultInboundEndpoint.start(DefaultInboundEndpoint .java:104)
... 40 more
Caused by: java.net.BindException: Address already in use (Bind failed)
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.AbstractPlainSocketImpl.bind(AbstractPlainSocketImpl.java:38 7)
at java.net.ServerSocket.bind(ServerSocket.java:375)
at org.mule.transport.tcp.TcpServerSocketFactory.configure(TcpServerSock etFactory.java:59)
at org.mule.transport.tcp.TcpServerSocketFactory.createServerSocket(TcpS erverSocketFactory.java:43)
at org.mule.transport.tcp.TcpServerSocketFactory.createServerSocket(TcpS erverSocketFactory.java:37)
at org.mule.transport.tcp.TcpConnector.getServerSocket(TcpConnector.java :488)
at org.mule.transport.http.HttpConnector.getServerSocket(HttpConnector.j ava:676)
at org.mule.transport.http.HttpConnectionManager.addConnection(HttpConne ctionManager.java:61)
... 47 more
INFO 2020-03-20 14:30:43,860 [WrapperListener_start_runner] org.mule.module.lau ncher.DefaultArchiveDeployer: ================== New Exploded Artifact: AFX-TEST
INFO 2020-03-20 14:30:43,861 [WrapperListener_start_runner] org.mule.module.lau ncher.application.DefaultMuleApplication:
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ New app 'AFX-TEST' +
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
INFO 2020-03-20 14:30:43,861 [WrapperListener_start_runner] org.mule.module.lau ncher.MuleApplicationClassLoader: [AFX-TEST] Loading the following jars:
=============================
file:/home/oracle/AFX/esb/apps/AFX-TEST/lib/Verify_FIPS_Enable.jar
file:/home/oracle/AFX/esb/apps/AFX-TEST/lib/ojdbc6.jar
=============================

INFO 2020-03-20 14:30:43,861 [WrapperListener_start_runner] org.mule.module.lau ncher.log4j.ArtifactAwareRepositorySelector: Found logging config for applicatio n 'AFX-TEST' at 'file:/home/oracle/AFX/esb/apps/AFX-TEST/classes/log4j.propertie s'
INFO 2020-03-20 14:30:47,231 [WrapperListener_start_runner] org.mule.module.lau ncher.MuleDeploymentService:
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ Started app 'AFX-TEST' +
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
INFO 2020-03-20 14:30:47,240 [WrapperListener_start_runner] org.mule.module.lau ncher.DeploymentDirectoryWatcher:
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ ESB is up and kicking (every 5000ms) +
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
INFO 2020-03-20 14:30:47,278 [WrapperListener_start_runner] org.mule.module.lau ncher.StartupSummaryDeploymentListener:
**********************************************************************
* - - + DOMAIN + - - * - - + STATUS + - - *
**********************************************************************
* default * DEPLOYED *
**********************************************************************

******************************************************************************** ***********************
* - - + APPLICATION + - - * - - + DOMAIN + - - * - - + STATUS + - - *
******************************************************************************** ***********************
* AFX-TEST * default * DEPLOYED *
* 10_AFX-INIT * default * DEPLOYED *
* 15_AFX-MAIN * default * FAILED *
* 05_AFX-PREINIT * default * DEPLOYED *
********************************************************************************

Outcomes