AnsweredAssumed Answered

Multiple Remote Desktop Session Hosts token import problem

Question asked by Ralph Smith on Apr 6, 2020
Latest reply on Apr 7, 2020 by Erica Chalfin

I could use some help if anyone has a solution.

I am IT at a non-profit in which employees are using the RSA Soft Token in order to access some NY State web sites.

 

Now with everyone working from home I am having a problem with the soft tokens on our Windows Remote Desktop Session Hosts.

 

We have multiple session hosts that users access through a Remote Desktop Gateway, and the RD Connection Broker load balances so users don't always get the same session host.

We use a user profile disk in our RD setup, so user profiles on the session hosts are redirected to the user's specific profile disk.

 

The problem I am having is importing the token file on one host works OK, but when a user tries to import a token while connected to a different session host, they get a blank screen  asking them to select a device where the token will be stored, but the list is blank.

 

I've found some seemingly relevant articles in the knowledge base

000011874 - RSA SecurID Software Token for Microsoft Windows shows blank screen when asked to select a device where the token will be stored

000032390 - Installing the same RSA SecurID Software Token 5.0 for Windows on different machines without reimporting

 

Multiple Users Sharing desktop

 

None of these are specifically addressing remote desktop sessions the way we are set up, and although I tried them, nothing has resolved this.

 

The last thing I did was install the RSA software version 5.0.2 on the session hosts with the following command:

 

msiexec /i RSASecurIDToken502x64.msi /qn /l*v install.log SETROAMING=TRUE SETSINGLEDATABASE=TRUE SETCOPYPROTECTION=FALSE SETDATABASEDIR=%AppData%\RSA

 

Still no success.

 

If anyone has the answer I'd sure appreciate it.

Outcomes