AnsweredAssumed Answered

Webtier 8.5 services not starting on boot

Question asked by David Pala on Sep 2, 2020

Hi Folks !

 

Has someone already experienced that issue with the brand new Webtier 8.5 installation ?

 

Here is the server stat AFTER booting :

[CT-KIP DEV] root@webtier: ~  # uptime
 10:08:27 up 8 min,  1 user,  load average: 0.16, 0.39, 0.34

 

[CT-KIP DEV] root@webtier: ~  # /etc/init.d/rsaservmgr status
RSA Webtier Server                                         [SHUTDOWN]

 

[CT-KIP DEV] root@webtier: ~  # /etc/init.d/rsabootstrapperservmgr status
RSA Webtier Bootstrapper Server                            [SHUTDOWN]

 

[CT-KIP DEV] root@webtier: ~  # chkconfig --list | grep rsa

 

Note: This output shows SysV services only and does not include native
      systemd services. SysV configuration data might be overridden by native
      systemd configuration.

 

      If you want to list systemd services use 'systemctl list-unit-files'.
      To see services enabled on particular target use
      'systemctl list-dependencies [target]'.

 

rsabootstrapperservmgr  0:off   1:off   2:on    3:on    4:on    5:on    6:off
rsaservmgr              0:off   1:off   2:on    3:on    4:on    5:on    6:off

 

[CT-KIP DEV] root@webtier: ~  # cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.8 (Maipo)

 

And the Webtier server goes in "Offline" state to the Operations Console :

 

Below the only clue I found in the logs right after the server booted :

[CT-KIP DEV] root@webtier: ~  # tail -100 /apps/rsa/RSAAuthenticationManagerWebtier/server/logs/rsaserv.log.0
02-Sep-2020 10:20:45 CEST Attempting to perform start against target all
02-Sep-2020 10:20:45 CEST Deployment type is set to Webtier
02-Sep-2020 10:20:45 CEST Service dependency set to dep
02-Sep-2020 10:20:45 CEST Starting RSA Webtier Server
02-Sep-2020 10:20:46 CEST start of service RSA Webtier Server completed in 0.40 seconds.
02-Sep-2020 10:20:46 CEST Failed to start RSA Webtier Server
02-Sep-2020 10:20:46 CEST Service start for RSA Webtier Server got return code 67
02-Sep-2020 10:20:46 CEST Action start against target all complete

 

Now, if I start the services manually, they do start :

 

[CT-KIP DEV] root@webtier: ~  # /etc/init.d/rsaservmgr start
Starting RSA Webtier Server: ******************************
RSA Webtier Server                                 [RUNNING]


[CT-KIP DEV] root@webtier: ~  # /etc/init.d/rsabootstrapperservmgr start
Starting RSA Webtier Bootstrapper Server: **
RSA Webtier Bootstrapper Server                    [RUNNING]


[CT-KIP DEV] root@webtier: ~  # /etc/init.d/rsaservmgr status && /etc/init.d/rsabootstrapperservmgr status
RSA Webtier Server                                 [RUNNING]

RSA Webtier Bootstrapper Server                    [RUNNING]

 

And the Webtier gets back "Online" in the Operations Console :

 

 

Kind Regards,

David

Outcomes