AnsweredAssumed Answered

Approval Workflow 7.2.1

Question asked by Johan Arvidsson on Nov 30, 2020
Latest reply on Nov 30, 2020 by Ian Staines

Hi!

I recently had a customer who wanted to migrate from 7.1.1 -> 7.2.1. After this migration, in a testt environment, we noticed that some bugs started to appear in the Approval workflows.

I reinstalled my own environment with 7.2.1 to have a fresh install to see if this was a general bug with 7.2.1 or if it was only in their environment and I got the same result. I patched the environment to 7.2.1 P01 and still had the same issues.

 

The bug seems to appear when I modify the name on a button transition(the workflow).

workflow

 

After the name is modified the button name in the approval form is in all uppercase and the option to partial reject disappear.

The standard supplied workflows works as expected but as soon as you modify the name on a transition the bug appears.

I have tried using the standard CR approval template and tried using the Role Owners Approval workflow.

I haven't touched the approval forms I only modified the name in the button transition.

 

Approval using the Standard role owner approval workflow:

Standard Approval

 

Approval using the Modified role owner approval workflow (appended an a the end of each name):

Modified workflow

 

Sometimes, on the modified workflow, partial rejected is apparent(modifyPic_1) but after I click on rejected(modifyPic_2) and then back again to accept(modifyPic_1) the partial rejected option has disappeared.

 

(modifyPic_1)

modifyPic_1

 

(modifyPic_2)

modifyPic_2

(modifyPic_3)

modifyPic_3

 

I'm wondering if anyone has experienced the same or could try this case to see if this is an general problem? (Mostafa Helmy (?), Ian Staines (?))

 

(The data used in this example is just test data and fictional data)

 

//Johan

Outcomes