AnsweredAssumed Answered

Disabling automatic parser reload for REST file upload in 9.8

Question asked by RSA Admin Employee on Oct 29, 2013
Latest reply on Nov 3, 2013 by RSA Admin



I'm in the process of automating the deployment of some of our custom parsers and feeds.  I see that the REST API apparently allows for the automatic reload to be disabled, but I cannot make that work.  Even if using the NW-built web form at <decoder>:50104/decoder/parsers/upload and leaving the "reload" checkbox turned off, the device still logs "Issuing automatic parser reload" and reloads all parsers.


I've tried to find a real REST API document, but haven't found anything that details the things I need.  I first thought that I could use /decoder/parsers?msg=upload&op=start, sending the file in the POST body... but that didn't work.  I *can* successfully send the file to /decoder/parsers/upload but then all attempts to disable the auto reload have failed.


Can someone please point me to a real API document, or perhaps an example of how to disable this automatic reload?