I am trying to upgrade my RSA SA AIO for logs appliance from 10.3.2 to 10.4, but due to some dependency issues I am not able to do it. Kindly refer to the below mentioned error messages which I am getting while upgrading. I had simply follow the whole steps which is being mentioned in the available docs from RSA on RSA SA upgrade from 10.3.2 to 10.4.
As a part of troubleshooting I had also gone through the notes available on RSA SCOL regarding the upgrade issue in RSA SA in 10.4.
Topic name is :
Security Analytics 10.4.0.2 Upgrade Issue
Updated December 29, 2014
RSA has identified an issue that may impact upgrade and operation from previous versions of Security Analytics.
When upgrading an appliance to Security Analytics version 10.4.0.2 in certain situations, a dependency issue can occur.
This issue can be avoided by applying the Q3 Security Patch and using the updated 10.4.0.2 download. If you have previously downloaded 10.4.0.2 and successfully installed it, no action is required. If you have previously downloaded 10.4.0.2 and have not yet installed it, apply the Q3 Security Patch and subsequent Security Patches, and download the updated version of 10.4.0.2.
The below mentioned are error message which I am getting during the up-gradation process.
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Setting up Install Process
No package libgcc.x866_64 available.
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package libgcc.i686 0:4.4.7-3.el6 will be updated
---> Package libgcc.i686 0:4.4.7-4.el6 will be an update
--> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:
1. You have an upgrade for libgcc which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of libgcc of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude libgcc.otherarch ... this should give you an error
message showing the root cause of the problem.
2. You have multiple architectures of libgcc installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
3. You have duplicate versions of libgcc installed already.
You can use "yum check" to get yum show these errors.
...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).
Protected multilib versions: libgcc-4.4.7-4.el6.i686 != libgcc-4.4.7-3.el6.x86_64
You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
cjkuni-fonts-common-0.2.20080216.1-36.el6.noarch is a duplicate with cjkuni-fonts-common-0.2.20080216.1-35.el6.noarch
cjkuni-uming-fonts-0.2.20080216.1-36.el6.noarch is a duplicate with cjkuni-uming-fonts-0.2.20080216.1-35.el6.noarch
libgcc-4.4.7-4.el6.x86_64 is a duplicate with libgcc-4.4.7-3.el6.x86_64
If any one have the knowledge to get this issue resolved, kindly suggest.
Thanks to all in advance.