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Preface

About This Guide

This guide contains information that helps RSA® Archer™ GRC Suite users understand the business
need and use of the RSA Archer PCI Management solution. It is designed to be used with the RSA
Archer GRC Platform documentation set.

RSA Archer GRC Documentation

You can access the RSA Archer GRC documentation for Platform, Solutions, Applications, and
Content from the RSA Archer GRC Community on RSA Link.

https://community.rsa.com/community/products/ArcherGRC

Document Description

Release Notes Overview of the new and updated features in the release. A list of issues fixed in
the release and a list of issues known at the time of the release are also provided.
Available in PDF format.

Installation
Guide

Instructions for installing RSA Archer GRC 5.x.

Online
Documentation

All of the information for using RSA Archer GRC Platform.

Archer Control
Panel (ACP)
Online Help

Information for managing the internal settings of the Platform, such as license
keys, global paths and settings. Available from within the ACP module.

Web Services
API Reference
Help

List of the available web services for programmatically interfacing with RSA
Archer GRC, in a searchable online system. Available in a Zip format for local
installation.

REST API
Reference
Help

List of the available resources for programmatically interfacing with the product
through RESTful API calls to RSA Archer GRC, in a searchable online system.
Provides formatting guidelines for field results, field inputs, and search inputs;
provides sample code for searching, adding and updating users, and updating
assets. Available in a Zip format for local installation.
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Document Description

Security and
Configuration
Guide

Overview of the security configuration settings available in the RSA Archer GRC
Platform and the security best practices for using those setting to help ensure
secure operation of the Platform. Available in PDF format.

RSA continues to assess and improve the documentation. Check the RSA Archer GRC Community
on RSA Link for the latest documentation.

Support and Service

Customer Support Information www.emc.com/support/rsa/index.htm

Customer Support E-mail archersupport@rsa.com

Other Resources

RSA Archer GRC Community on RSA Link: Our public forum, on the new RSA Link Community
platform, brings together customers, prospects, consultants, RSA Archer GRC thought leaders,
partners and analysts to talk about GRC as a practice, and includes product demos, GRC videos,
white papers, blogs and more. https://community.rsa.com/community/products/grc/overview

RSA Archer Community on RSA Link: Our private community, is a powerful governance, risk and
compliance online network that promotes collaboration among Archer customers, partners, industry
analysts, and product experts. Engaging with the RSA Archer Community on RSA Link enables you
to collaborate to solve problems, build best practices, establish peer connections and engage with
RSA Archer GRC Thought Leaders. https://community.rsa.com/community/products/grc/overview

RSA Ready: RSA's Technology Partner Program is where 3rd parties gain access to RSA Software
in order to develop an interoperability and have it documented and certified. RSA Ready
certifications are posted to an online Community and supported by RSA Support.
https://community.rsa.com/community/products/rsa-ready
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Payment Card Idustry
The Payment Card Industry Data Security Standard (PCI DSS) was developed to encourage and
enhance cardholder data security and facilitate the broad adoption of consistent data security
measures globally. PCI DSS provides a baseline of technical and operational requirements designed
to protect account data. PCI DSS applies to all entities involved in payment card processing—
including merchants, processors, acquirers, issuers, and service providers. PCI DSS also applies to
all other entities that store, process or transmit cardholder data and/or sensitive authentication data.
The PCI DSS is organized by the following categories:

• Build and maintain a security network and systems

• Protect cardholder data

• Maintain a vulnerability management program

• Implement strong access control measures

• Regularly monitor and test networks

• Maintain an information security policy

PCI DSS comprises a minimum set of requirements for protecting account data, and may be
enhanced by additional controls and practices to further mitigate risks, as well as local, regional and
sector laws and regulations. Additionally, legislation or regulatory requirements may require specific
protection of personal information or other data elements (for example, cardholder name). PCI DSS
does not supersede local or regional laws, government regulations, or other legal requirements.

RSA Archer PCI Management 3.1

The RSA Archer PCI Management solution enables organizations to streamline the compliance
process, simplify stakeholder participation, and reduce overall compliance effort and cost. It allows
organizations to jumpstart a PCI compliance program by conducting continuous assessments and
gaining visibility to manage and mitigate risk. The solution also guides merchants through the
completion of relevant Self Assessment Questionnaires (SAQs), as well as packaging and exporting
compliance program results and attestation articles into a properly formatted PCI Report on
Compliance (ROC) for easy submission and review.

RSA Archer PCI Management Architecture Diagram

The following diagram shows the relationships between the applications and solutions that make up
the RSA Archer PCI Management 3.1 solution.
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Installing RSA Archer PCI Management

Step 1: Prepare for the Installation

1. Ensure that your RSA Archer GRC system meets the following requirements:

Requirement Details

RSA Archer GRC Platform
versions 5.5.3.1 or later.

This solution is designed to run on specific versions of the
platform.

A valid license for the current
solution.

RSA Archer PCI Management 3.1

The specified applications are
installed and configured.

Applications

Authoritative Sources

Business Processes

Contacts

Control Procedures

Control Standards

Devices

Exception Requests

Facilities

Findings

Information Assets

Remediation Plans

Vendor Profile (optional)

A user account on the platform
with access rights to specific
platform features.

Data Feed Manager

Package Installer

Application Builder

A user account on RSA Link. The solution package files are stored on RSA Link.

Installing RSA Archer PCI Management 8
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Requirement Details

PCI Import Content Pack. Contact your sales representative to obtain the PCI
Authoritative Sources content pack.

2. Download the solution package.

The following files are included in the RSA_Archer_PCI_Management_3.1.zip file:

l Solution install package, RSA_Archer_PCI_Management_3.1_Install_Package.zip.

l Data feed file, PCI_Management_3.1_Data_Feeds.zip

l Autoscope_Card_Data_Environment_From Business_Processes_PATH_1.dfx5

l Autoscope_Card_Data_Environment_From Business_Processes_PATH_2.dfx5

l Autoscope_Card_Data_Environment_From Business_Processes_PATH_3.dfx5

l Autoscope_Card_Data_Environment_From Business_Processes_PATH_4.dfx5

l Generate_PCI_Controls.dfx5

l Auto-Link_Findings_To_PCI_Controls.dfx5

l Auto-Generate_Findings_For_PCI_Controls.dfx5

l Mail merge template file, Report_On_Compliance_Mail_Merge.doc

l Images zip file, PCI_Management_3.1_iView_Images.zip

3. Review the RSA Archer PCI Management 3.1 Release Notes to understand what has changed
before installing and configuring the solution.

Step 2: Add new Content Source field to Control Procedures

Important: You must complete this procedure only if you are running RSA Archer Compliance
Management 4 or earlier.

Installing RSA Archer PCI Management 9
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1. Go to Search Records: Control Procedures.

Navigation

a. Click the Compliance Management workspace.

b. Click Navigation Menu > Compliance Management > Control Procedures > Search Records.

2. In the Fields to Display section, do the following:

a. Remove the fields that are populated by default.

b. Select the following search criteria:

l Procedure Tracking ID

l Content Source

c. Click Search.

d. Click Export.

e. In Export Options, click CSV.

f. Save your file.

3. Delete Content Source field from the Control Procedures application.

a. Click Administration > Application Builder > Manage Applications.

b. Click Control Procedures.

c. Click the Fields tab.

d. In the Content Source row, click .

e. Click OK.

4. Create a new field.

a. Click Add New.

b. In Creation Method, select Create a New Field from scratch.

c. In Field Types, select Values List, and click OK.

d. On the General Information tab, do the following: 

i. In the Name field, enter Content Source.

ii. Beside Values Field, select .
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iii. Select Policy: Content Source.

iv. Click OK.

e. Click Save.

f. Click the Layout tab.

a. Click the Archer Reference Content tab.

b. Move the Content Source field to the right of Archer Procedure ID.

c. Click Save.

5. Import Content Source CSV from Step 2.

a. Click Administration > Navigation Menu > Integration > Manage Data Imports.

b. Select Control Procedures.

c. Click Browse.

d. Click Add New.

e. Select the file created in Step 2, and click OK.

f. Click Next.

g. In Import Type, select Update Existing Records.

h. In Application Field(s), select Procedure Tracking ID.

i. Map Procedure Tracking ID and Content Source.

j. Click Next.

k. Click Import.

Step 3: Modify the Findings Application System ID

Modify the Findings ID field options to enable the tracking ID to be generated based on the number
of records within the system.

1. Go to the Fields tab of the Findings application.

Installing RSA Archer PCI Management 11
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Navigation

a. Click the Compliance Management workspace.

b. Click Navigation Menu > Administration > Application Builder > Manage Applications.

c. Click the Findings application.

d. Click the Fields tab.

2. In the Fields column, select the Finding ID field.

3. Click the Options tab.

4. In the Options Section, select System ID.

5. Click Save.

Step 4: Import the Package

1. Click Navigation Menu > Administration > Application Builder > Install Packages.

2. In the Available Packages section, click Import to open the Select Import File dialog box.

3. Click Add New.

4. Locate and select the package file that you want to import.

5. Click OK.

Step 5: Perform Advanced Package Mapping

To perform this task, you must be a user with an access role that has rights to install a package.
When you install the latest solution package, you must perform Advanced Package Mapping to avoid
creating duplicate objects.

Important: Advanced Package Mapping does not update data feeds and Web APIs. If you modify
the system ID of an object used by a data feed or Web API, the data feed or Web Service API will
not function properly. You must update the data feed and Web Service API to reference the new
system ID of the object. Changing the system ID of a field can adversely affect data feeds or
calculations that use the field. Before you execute the mapping process, RSA recommends that you
back up your database.
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As part of Advanced Package Mapping, you can do the following:

l Map objects

l Review the Package Mapping Log

l Export Mapping Settings

l Import Mapping Settings

l Undo Package Mapping Changes

Advanced Package Mapping requires a considerable amount of memory, which can result in loss of
data input and IE errors when working with large applications. System performance may vary based
on the size of a package file.

Note: To optimize your system for packaging, RSA recommends using Silverlight 5.1.3 or later.

Procedure

For information about advanced package mapping and its components, see "Mapping Objects" in the
RSA Archer Online Help.

Step 6: Install the Package

1. In the Available Packages section, locate the package file that you want to install, and click
Install.

2. Modify the components of the installation package.

a. In the Configuration section, select the components of the package that you want to install.

Important: By default, RSA Archer GRC only selects new applications, so you must select
all other applications and questionnaires as needed. For steps b and c, you should select the
recommended option. Otherwise the solution may not work properly.
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b. In the Translation Option column, for each component, select one of the following options.

Option Description

Full Install Translates all text into the specified language.

Translations Only Translates only selected text into the specified language.

c. In the Install Method column, for each component, select one of the following options.

Option Description

Create New Only Only creates new objects that do not currently exist in the
instance. Does not update existing objects.

Important: You must manually update any existing items that
you want to change. See the Data Dictionary for field
information.

Create New and Update
(recommended)

Creates new objects and updates existing objects that match
objects in the package.

Important: If you are installing the solution for the first time,
ensure that you select Create New and Update.

d. In the Install Option column, for each component, select one of the following options.

Option Description

Override Layout
(recommended)

Replaces the existing layout with the layout in the package.
Moves fields that were previously on the layout that are not on
the package layout to the Available Fields list.

Important: If you are installing the solution for the first time,
ensure that you select Override Layout.

Do Not Override Layout No changes are made to the existing layout, but you may have
to modify the layout after installing the new package.

3. Click Install, and click OK.
For sample installation log messages, see Package Installation Log Message Examples.

Note:When you install a package that updates a sub-form, the updates affect all applications,
questionnaires, workspaces, and dashboards that use the sub-form.
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Step 7: Update Link to Control Procedures field

1. Go to the Manage Applications page.

Navigation

a. Click the PCI Management workspace.

b. Click Navigation Menu > Administration > Application Builder > Manage Applications.

2. Click Compliance Project.

3. Click the Fields tab.

4. Select the Link to Control Procedures field.

5. Click the Options tab.

6. In the Configuration section, do the following: 

a. Select the Relate content by field checkbox.

b. Select Content Source from the Application Field dropdown.

c. Select Content Source from the Related Field dropdown.

7. Click Save.

Step 8: Import Data Feeds

Important: The data feeds for RSA Archer PCI Management must be imported in the following
order: 

1. Autoscope_Card_Data_Environment_From_Business_Processes_PATH_1.dfx5

2. Autoscope_Card_Data_Environment_From_Business_Processes_PATH_2.dfx5

3. Autoscope_Card_Data_Environment_From_Business_Processes_PATH_3.dfx5

4. Autoscope_Card_Data_Environment_From_Business_Processes_PATH_4.dfx5

5. Generate_PCI_Controls.dfx5

6. Auto-Link_Findings_To_PCI_Controls.dfx5

Installing RSA Archer PCI Management 15
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7. Auto-Generate_Findings_For_PCI_Controls.dfx5

Important: Ensure that the Project ID field is mapped.

Procedure

1. Click Navigation Menu > Administration > Integration > Manage Data Feeds.

2. In the Manage Data Feeds section, click Import.

3. Locate and select the .dfx5 file for the data feed.

4. From the General tab in the General Information section, in the Status field, select Active.

5. Click the Transport tab. Complete the fields in the Transport Configuration section as follows:

a. In the URL field, type: YourServerName/VirtualDirectoryName/ws/search.asmx

b. In the User Name and Password fields, type the username and password of a Platform user
that has API access and access to all of the records on the Platform instance (from which the
data feed is coming). For instructions on creating a user account, see Create a User Account
for the RSA Archer Web Service Client.

c. In the Instance field, type the name of the Platform instance from which the data feed is
coming (this is the instance name as you enter it on the Login window).

6. Verify that key field values are not missing from the data feed setup window.

7. Click Save.

Step 9: Schedule Data Feeds

Important: A data feed must be active and valid to successfully run.

As you schedule your data feed, the Data Feed Manager validates the information. If any
information is invalid, an error message is displayed. You can save the data feed and correct the
errors later, but the data feed does not process until you make corrections.

1. Click Navigation Menu > Administration > Integration > Manage Data Feeds.

2. In the Name column, click the data feed that you want to edit.

3. Click the Schedule tab.

Note: The Schedule tab is available for both Standard and Transport-Only data feed types.
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4. In the Frequency drop-down list, set the frequency for the data feed. For example, if you select
Minutely and specify 3 in the Every field, the data feed runs every 3 minutes.

5. (Optional) To configure a data feed to run immediately after another data feed, follow these
steps:

a. In the Frequency drop-down list, select Reference.

b. In the Reference Feed drop-down list, select the first data feed. Your current data feed
would run after this selected one.

6. (Optional) To override the data feed schedule and immediately run your data feed, in the Run
Data Feed Now section, click Start.

7. Click Save.

Step 10: Add images to quick link iViews

Complete the following steps for each of the iViews listed below: 

1. Go to the Manage Global iViews page.

Navigation

a. Click the PCI Management tab.

b. Click Navigation Menu > Administration > Workspaces and Dashboards > Manage Global
iViews.

2. Click My PCI Quick Links.

3. In the Configuration section, click Edit.

4. Click Add Primary Graphic.

5. Select the image from the PCI_Management_3.1_iView_Images.zip that has the name of the link
that you are editing.

6. Click OK.

7. Repeat steps 1a - 5 until all links have an image.

8. Repeat step 1 for iView:Internal Stakeholder Quick Links.
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Step 11: Configure Record Permissions

Users can only scope records and complete findings for issues to which they have access. Update
the record permissions fields for the applications listed in the following table to ensure that users
have the required levels of access.

Solution Application

Enterprise Management Applications

Business Processes

Business Units

Information Assets

Devices

Facilities

Vendor Management Vendor Profile

Issues Management Findings

Exception Requests

Policy Change Requests

Remediation Plans

Procedure

For information about record permissions in RSA Archer, see "Permissions for a Record
Permissions Field" in the RSA Archer Online Help.

Step 12: Import PCI 3.1 Content Pack

Contact RSA Archer Customer Support to obtain the PCI content import pack if it has not already
been imported into your library. The PCI import pack contains content for the following applications:

l Authoritative Sources

l Control Procedures

l Question Library
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Important: A separate content import tip sheet is available with instructions for how to properly
upload content updates on the RSA Archer GRC Platform.

Step 13: Test the Solution

Test the RSA Archer PCI Management solution according to your company standards and
procedures, to ensure that the solution works with your existing processes. Some of the items that
you might want to include in your testing are:

l Customized objects and fields

l Calculations - ensure that calculations are functioning

Installing RSA Archer PCI Management 19
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Create a User Account for the RSA Archer Web

Service Client
You must create a user account with System Administrator rights that uses the web service client to
transfer data into the RSA Archer Platform.

Procedure

1. Click Administration > Access Control > Manage Users > New.

2. In the Manage Users section, click Add New.

3. Click the General Information tab, and in the General Information section, enter a first name,
last name, and user name.

4. Click the Roles tab, and follow these steps:

a. In the Roles section, click Lookup.

b. In the Available Roles window, expand Roles.

c. Scroll down and select one of the access roles.

d. Click OK.

5. Click Save, then click Apply.
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Appendix A: Package Installation Log Message

Examples
For more information on the Package Installation Log messages, see "Reviewing the Package
Installation Log" in the RSA Archer GRC Online Documentation.

For information on the dependencies for each solution, see the Data Dictionary.

Warning
Message Explanation Remediation

<Object Name>
Alias was
changed from
<Original
Alias> to <New
Alias>

This message is an
informational warning
indicating that the Alias was
updated on the object. There
are two reasons for an alias
in the Target Instance to have
been updated:

l Update was in the Source
Package.

l Alias has to be unique in
the Target Instance. If the
alias already exists in
Target, packaging adds a
unique identifier to the
end.

This message is only potentially an issue if the
change occurs on a field that is utilized in a
Mail Merge Template or Data Publication
Service. In that scenario, update the DPS or the
mail merge template with the new alias.

<Field Name>
in the
application
<Application
Name> cannot
be changed from
a private field to
a public field.

This message is an
informational warning
notifying you that packaging
does not change a private
field in the target instance to
a public field.

Change the field to public manually (optional).
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Warning
Message Explanation Remediation

Field <Field
Name> could
not be saved due
to inability to
identify the
related module.

This message is seen when a
cross-reference or related
record field could not be
created because the related
application does not exist in
the target instance. This
message usually occurs
because the field is part of a
related core solution that has
not been updated in the target
instance.

1. Install the package for the solution
containing the related application. You must
have a license for the related application.

2. Reapply the original package to resolve the
warning.

See the Data Dictionary.

The calculated
field <Field
Name> in the
application
<Application
Name> cannot
be verified.

The formula in the calculated
field is incorrect. Most often,
this message occurs when the
formula references a field in
a related application and
either the field or the
application does not exist in
the target instance. This may
be because the application is
in a related core solution that
has not been updated.

1. Install the package for the solution
containing the related application. You must
have a license for the related application.

2. Reapply the original package to resolve the
warning.

See the Data Dictionary.

Field <Field
Name> was not
found and
removed from a
collection.

This warning may be seen on
Inherited Record Permission
fields, cross-
reference/related record
fields (record lookup and grid
display), or as a display field
in a report. The warning
means that the field could not
be found in the target
instance and was not
included in the package. This
is usually because the field is
part of an application in a
related core solution that has
not been updated in the target
instance.

1. Install the package for the solution
containing the related application (to obtain
the missing field). You must have a license
for the related application.

2. Reapply the original package to resolve the
warning.

See the Data Dictionary.

If you do not have a license for the related
application, you may ignore this message, and
the field remains omitted from the object.
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Warning
Message Explanation Remediation

The advanced
workflow was
installed, but is
inactive. Please
review and
activate.

All advanced workflows are
installed as inactive. You
must review and activate the
workflow.

Go to the Advanced Workflow tab in the
application or questionnaire, review the
workflow, then click Activate.

Minor failure:
Advanced
workflow HTTP
request error:
404 not found.

This failure message may
appear if certain services
were not running when you
installed the package.

1. Verify that the Advanced Workflow Service
and the Job Service are running.

2. Reapply the package.
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