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Preface

About This Guide
This guide is for RSA® Archer™ GRC administrators who need to install the RSA
Archer Security Operations Management 1 solution. It is designed to be used with
the RSA Archer GRC Platform Administrator Guide portfolio.

This guide assumes that the reader is knowledgeable about the GRC industry and
RSA Archer GRC.

RSA Archer Documentation
You can access the RSA Archer documentation from the RSA Archer Exchange
and RSA Archer Community.

Documentation Location

Platform On the RSA Archer Community at:
https://community.emc.com/community/connect/grc_
ecosystem/rsa_archer

Solutions, Applications,
and Content

On Content tab on the RSA Archer Exchange at:
https://community.emc.com/community/connect/grc_
ecosystem/rsa_archer_exchange

RSA continues to assess and improve the documentation. Check the RSA Archer
Community and RSA Archer Exchange for the latest documentation.

RSA Security Analytics Documentation
For information about RSA Security Analytics, see the following documentation:

Guide Description

RSA Security Analytics Help The RSA Security Analytics Help provides
information needed to understand and use RSA
Security Analytics features. It contains topics and
tutorials to help you learn the basics of the user
interface, system configuration, and analysis
concepts. In addition, troubleshooting information
for common situations is added on a continuous
basis.
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You can access this reference material from the RSA Security Analytics Unified
Dashboard.

RSA Archer Security Operations Management Data Dictionary
The RSA Archer Security Operations Management Data Dictionary contains
configuration information for the solution, including the user groups and access
roles that must be created.

You can obtain the Data Dictionary for the solution by contacting your RSA Archer
Account Representative or calling 1-888-539-EGRC.

Support and Service

Customer Support
Information

www.emc.com/support/rsa/index.htm

Customer Support
E-mail

archersupport@rsa.com

RSA Archer
Community

https://community.emc.com/community/connect/grc_
ecosystem/rsa_archer

RSA Archer
Exchange

https://community.emc.com/community/connect/grc_
ecosystem/rsa_archer_exchange

RSA Solution
Gallery

https://gallery.emc.com/community/marketplace/

RSA SecurCare
Online

https://knowledge.rsasecurity.com/cleartrust/ct_
logon.asp?CTAuthMode=BASIC&amp;language=en&amp
;CT_ORIG_
URL=https%3A%2F%2Fknowledge.rsasecurity.com%3
A443%2F&amp;ct_orig_uri=%2F

The Community enables collaboration among GRC clients, partners, and product
experts. Members actively share ideas, vote for product enhancements, and discuss
trends that help guide the RSA Archer product roadmap.

The Exchange is an online marketplace dedicated to supporting GRC initiatives.
The Exchange brings together on-demand applications along with service, content,
and integration providers to fuel the success of RSA Archer clients.
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Chapter 1: RSA Archer
Security Operations Management

RSA Archer Security Operations Management
The RSA Archer Security Operations Management solution enables you to
aggregate all actionable security alerts, allowing you to become more effective,
proactive, and targeted in your incident response and SOC management.

RSA Archer Security Operations Management helps you do the following:

l Prioritize and respond faster to security incidents by leveraging business context
and actionable threat intelligence.

l Engage key business and IT stakeholders in the incident management process

l Simplify incident investigation and breach response procedures through industry
best practice methodologies and response procedures.

l Optimize SOC investments through SOC KPI (key performance indicators)
monitoring and staff time management tracking.

RSA Archer Security Operations Management Components
RSA Archer Security Operations Management is composed of the following:

l RSA Archer Security Operations Management solution
o Incident Response subsolution
o Data Breach Response subsolution
o SOC Program Management subsolution
o Issue Management subsolution

l Two-way integration with RSA Security Analytics, using the RSA Connector
Framework (RCF)
o The SecOps plug-in takes alerts from Security Analytics and aggregates them

into incidents in the RSA Archer Security Operations Management solution.
o The Enterprise Management plug-in pulls business context information out of

your RSA Archer Enterprise Management solution and feeds it into RSA
Security Analytics as meta data.

Note: The RSA Archer Enterprise Management solution is also required for RSA
Archer Security Operations Management to be fully functional.

Chapter 1: RSA Archer Security Operations Management 9
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RSA Archer Security Operations Management Requirements
You must meet the following requirements before installing the RSA Archer
Security Operations Management 1 solution:

l RSA Archer GRC Platform 5.4 SP1 P1.

l Valid license for RSA Archer Security Operations Management and for RSA
Archer Enterprise Management 4.

l User account on the RSA Archer GRC Platform with access rights to the Data
Feed Manager.

l User account on the Archer GRC Exchange to download the solution files.

l An independent system running Microsoft Windows 2008 R2 Server 64-bit that
can reach both your RSA Security Analytics system and your RSA Archer
Platform and on which you can install the RCF.

Note: RSA also recommends that this system has 4 GB RAM with a dual core
processor and 40 GB of available hard drive space.

l RSA Security Analytics 10.2 SP2, 10.3, or 10.3 SP1 is installed , running, and
has the Reporting Engine configured.

RSA Archer Security Operations Management Files
The RSA Archer Security Operations Management file RSA_Archer_Security_
Operations_Management_1.zip includes the following files:

l Solution install package, RSA_Archer_Security_Operations_Management_1_
Install_Package.zip

l RSA_Archer_Security_Operations_Management_1_Data_Feeds.zip

l Generate_Breach_Tasks_1.dfx5

l Generate_Incident_Tasks_1.dfx5
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To set up the two-way integration between your RSA Archer and RSA Security
Analytics systems, you also need RSA_Connector_Framework_2.6.zip, which
contains:

l RSA_Connector_Framework_2.6.0bnnn.exe
This file is the RCF installer

l RSA_Connector_Framework_Plugin_2.6.0bnnn.exe
This file is the RCF plug-in installer

l secops_plugin_1.0bnn.zip
This file contains the SecOps plug-in

l em_plugin_1.0bnn.zip
This file contains the Enterprise Management plug-in

l thirdpartylicenses_rcf_2.6.pdf
This file contains the third-party licenses for the RCF

RSA Archer Security Operations Management Architecture
The following figure is a simplified view of the architecture of the two-way
integration between RSA Archer Security Operations Management and RSA
Security Analytics and how data flows back and forth through the RCF.

Chapter 1: RSA Archer Security Operations Management 11
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Prepare to Install RSA Archer Security Operations Management 1

Procedure

1. Download the following documentation from the Documents page on the
RSA Archer Community at
https://community.emc.com/community/connect/grc_ecosystem/rsa_archer

l RSA Archer GRC Platform Administrator Guide portfolio

l RSA Archer GRC Platform Control Panel Guide

2. Read and understand the Packaging section of the RSA Archer GRC Platform
Administrator Guide portfolio.

3. Obtain the Data Dictionary for the solution by contacting your RSA Archer
Account Representative or calling 1-888-539-EGRC. The Data Dictionary
contains the configuration information for the solution.
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Chapter 2: Installing the RSA Archer
Security Operations Management Solution

Upgrading from RSA Advanced Incident Management for Security 1.1
If you are upgrading from RSA Advanced Incident Management for Security 1.1,
follow the process to install the RSA Archer Security Operations Management
solution in this chapter. A couple extra steps that you must perform are noted in the
individual sections. RSA also recommends that prior to upgrading you ensure that
all your existing security incidents are closed (have a status of Resolved or Invalid).
If you upgrade open incidents, some fields that are not required become set to
required and users are prompted to fill them out when they edit the record. If you
want to upgrade but have open incidents that are not ready to be closed, contact
RSA Archer Professional Services for additional assistance.

Install and Configure RSA Archer Security Operations Management

Procedure

1. Download the Solution File from the RSA Archer Exchange

2. Import the Solution Install Package

3. Back Up the Database

4. Update the License Key

5. Perform Advanced Package Mapping

6. Install the Solution Install Package

7. Review the Package Installation Log

8. Create the Security Operations Management Group

9. Install RSA Archer Enterprise Management 4

10. Create a New Crisis Event Status

11. Create a User Account for the RSA Archer Web Service Client

12. RSA Archer Security Operations Data Feeds

13. Perform Post-Install Activities

14. Test the Solution

Chapter 2: Installing the RSA Archer Security Operations Management Solution 13
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Download the Solution File from the RSA Archer Exchange

Procedure

Download the RSA Archer Security Operations Management 1 file, RSA_Archer_
Security_Operations_Management_1.zip, from the Applications Exchange page on
the RSA Archer Exchange at
https://community.emc.com/community/connect/grc_ecosystem/rsa_archer_
exchange.

Import the Install Package

Procedure

1. Click Administration > Application Builder > Install Packages.

2. In the Available Packages section, click Import to open the Select Import File
dialog box.

3. Click Add New, then locate and select the package file that you want to import,
RSA_Archer_Security_Operations_Management_1_Install_Package.zip.

4. Click OK.

Back Up the Database
After a solution package has been installed, the installation cannot be rolled back
(reversed). RSA recommends that you create a backup of your database before
installing the new package in case you need to return to a pre-install state.

Important: You must be a database administrator to perform this task.

Procedure

Back up the database according to your company's standards and procedures.

Update the License Key

Note: You must update the license key if you are updating existing or installing
new applications or questionnaires. If you are installing a new application or
questionnaire immediately after installing the RSA Archer GRC Platform, you do
not need to update the license key.
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The administrator (a web or database administrator) on the server on which the
Archer Control Panel resides must update the license key in the Archer Control
Panel before the application package is imported in order for the new applications
and questionnaires to be available for use.

Procedure

Update the license key. For instructions, see "Update a License Key" in the RSA
Archer GRC Platform Control Panel Help.

Important: If you do not update the license key prior to installing the solution
package, you may receive package failures.

Performing Advanced Package Mapping
To perform this task, you must be a user with an access role that has rights to install
a package. When you install the latest solution package, you must perform
Advanced Package Mapping to avoid creating duplicate objects.

Important: Advanced Package Mapping does not update data feeds and Web
APIs. If you modify the system ID of an object used by a data feed or Web API, the
data feed or Web Service API will not function properly. You must update the data
feed and Web Service API to reference the new system ID of the object.

Important: Changing the system ID of a field can adversely affect data feeds or
calculations that use the field. Before you execute the mapping process,
RSA recommends that you back up your database.

As part of Advanced Package Mapping, you can do the following:

l Map objects

l Review the Package Mapping Log

l Export Mapping Settings

l Import Mapping Settings

l Undo Package Mapping Changes

Advanced Package Mapping requires a considerable amount of memory, which can
result in loss of data input and IE errors when working with large applications.
System performance may vary based on the size of a package file.

Note: To optimize your system for packaging, RSA recommends using Silverlight
5.06 or later.

For information about advanced package mapping and its components, see
"Advanced Package Mapping" in the Packaging section of the RSA Archer GRC
Administrator Guide.

Chapter 2: Installing the RSA Archer Security Operations Management Solution 15
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Install the Solution Package

Important:When you install a package that updates a subform, the updates affect
all applications, questionnaires, workspaces, and dashboards that use the subform.

Procedure

1. Click Administration > Application Builder > Install Packages.

2. In the Available Packages section, locate the package file that you want to
install, and click Install.

3. To modify the components of the installation package, follow these steps:

a. In the Configuration section, select the components of the package that you
want to install.

Note: By default, RSA Archer only selects new applications, so you must
select all other applications and questionnaires as needed.

b. In the Install Method section, for each component, select one of the
following options.

Option Description

Create New Only Only creates new objects that do not currently exist in
the instance. Does not update existing objects.

Important: You must manually update any existing
items that you want to change. See the Data
Dictionary for field information.

Create New and
Update

Creates new objects and updates existing objects that
match objects in the package.

c. In the Layout section, for each component, select one of the following
options.

Option Description

Override Layout Replaces the existing layout with the layout in the
package. Moves fields that were previously on the
layout that are not on the package layout to the
Available Fields list.

16 Chapter 2: Installing the RSA Archer Security Operations Management Solution
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Option Description

Do Not Override
Layout

No changes are made to the existing layout, but you
may have to modify the layout after installing the new
package.

4. Click Install, and click OK.

5. For sample installation log messages, see Package Installation Log Message
Examples.

Review the Package Installation Log

Procedure

Review the Package Installation Log to determine if you need to take specific
action to resolve issues. For more information on the log messages, see "Package
Installation Log Messages" in the Packaging section of the RSA Archer
GRC Platform Administrator Guide portfolio.

For example, you may need to install specific dependent solutions or applications.
For information on the dependencies for each solution, see the Data Dictionary.

For additional examples and remediation information for common Package
Installation Log messages, see Package Installation Log Message Examples.

Create the Security Operations Management Group
Once you have installed the RSA Archer Security Operations Management
package, you must create a Security Operations Management group to make it the
parent group of all the other SOC subgroups that were added during installation.

Procedure

1. Click Navigation > Administration > Access Control > Manage Groups.

2. Click Add New.

3. In the Name field, enter Security Operations Management.

4. In the Members section, locate and select the following groups from the
Available list:

l SOC : Business Manager

l SOC : CISO/CSO

l SOC : Compliance/Privacy Officer

l SOC : HR

l SOC : Incident Coordinator

Chapter 2: Installing the RSA Archer Security Operations Management Solution 17
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l SOC : IT Helpdesk

l SOC : L1 Incident Handler

l SOC : L2 Incident Handler

l SOC : Legal

l SOC : SOC Manager

l SOC : Solution Administrator

5. Click Save.

Install RSA Archer Enterprise Management 4
The RSA Archer Enterprise Management 4 solution is used by the RSA Archer
Security Operations Management solution, however it is packaged separately. The
RSA Archer Enterprise Management 4 solution is available for download from the
Applications Exchange page on the RSA Archer Exchange at
https://community.emc.com/community/connect/grc_ecosystem/rsa_archer_
exchange.

Procedure

Install the RSA Archer Enterprise Management 4 solution, RSA_Archer_
Enterprise_Management_4.zip. For instructions, see the RSA Archer Enterprise
Management 4 Installation Guide.

Create a New Crisis Event Status
This procedure is only required if you have licensed the RSA Archer Business
Continuity Management solution.

The RSA Archer Security Operations Management solution allows users to create a
new Crisis Event record from either an incident, investigation, or a data breach
record. You must create a new Status field value named Under Review for new
Crisis Events created from RSA Archer Security Operations Management, so that
when a RSA Archer Security Operations Management user creates a new crisis
event, the crisis response team can determine whether to approve or reject the
record.

Procedure

1. Click Administration > Application Builder > Manage Applications.

2. Click Crisis Events.

3. Click the Fields tab.

4. Click the Status field.

5. Click the Values tab.
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6. Click Add New.

7. In the Text Value field, enter Under Review.

8. Save the field and the application.

Create a User Account for the RSA Archer Web Service Client
You must create a user account for the web service client to use to transfer data
into the RSA Archer Platform.

Note: If you are upgrading from RSA Advanced Incident Management for Security
1.1, you can use the same user account that you already created.

Procedure

1. Click Administration > Access Control > Manage Users > New.

2. In the Manage Users section, click Add New.

3. Click the General Information tab, and in the General Information section, enter
a first name, last name, and user name.

4. Click the Roles tab, and follow these steps:

a. In the Roles section, click Lookup.

b. In the Available Roles window, expand Roles.

c. Scroll down and select SOC: Solution Administrator and EM: Read Only.

d. Click OK.

5. Click Save, then click Apply.

RSA Archer Security Operations Management Data Feeds
RSA Archer Security Operations Management includes the following data feed
files:

l Generate_Breach_Tasks_1.dfx5

l Generate_Incident_Tasks_1.dfx5

Each data feed automatically create tasks based on the response templates
associated with a record. For example, when an Incident Handler selects a category
for an incident, the Generate Incident Tasks data feed copies all incident response
procedures that match that category and associates them with the incident. You
must import each data feed and schedule it to run as frequently as you need. By
default, the feeds are scheduled to run every minute. If you encounter any
performance impacts, please contact RSA Archer Professional Services for
assistance.

Chapter 2: Installing the RSA Archer Security Operations Management Solution 19
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Import a Data Feed

Procedure

1. Click Administration > Integration > Manage Data Feeds.

2. In the Manage Data Feeds section, click Import.

3. Locate and select the .dfx5 file for the data feed.

4. From the General tab in the General Information section, in the Status field,
select Active.

5. Click the Transport tab. Complete the fields in the Transport Configuration
section as follows:

a. In the URL field, type:
YourServerName/VirtualDirectoryName/ws/search.asmx

b. In the User Name and Password fields, type the username and password of
a Platform user that has API access and access to all of the records on the
Platform instance (from which the data feed is coming). For instructions on
creating a user account, see Create a User Account for the RSA Archer
Web Service Client.

c. In the Instance field, type the name of the Platform instance from which the
data feed is coming (this is the instance name as you enter it on the Login
window).

6. Verify that key field values are not missing from the data feed setup window.

7. Click Save.

Schedule a Data Feed

Important: A data feed must be active and valid to successfully run.

As you schedule your data feed, the Data Feed Manager validates the information.
If any information is invalid, an error message is displayed. You can save the data
feed and correct the errors later; but the data feed does not process until you make
corrections. To schedule a data feed, follow these steps:

Procedure

1. Click Administration > Integration > Manage Data Feeds.

2. In the Name column, click the data feed that you want to edit.

3. Click the Schedule tab.

Note: The Schedule tab is available for both Standard and Transport-Only data
feed types.
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4. In the Frequency drop-down list, set the frequency for the data feed. For
example, if you select Minutely and specify 3 in the Every field, the data feed
runs every 3 minutes.

5. (Optional) To configure a data feed to run immediately after another data feed,
follow these steps:

a. In the Frequency drop-down list, select Reference.

b. In the Reference Feed drop-down list, select the first data feed. Your
current data feed would run after this selected one.

6. (Optional) To override the data feed schedule and immediately run your data
feed, in the Run Data Feed Now section, click Start.

7. Click Save.

Post-Install Activities
The package installation does not update some attributes of objects, or delete
obsolete objects that are not included in the current solution. RSA recommends that
you compare the objects in your database with the information in the Data
Dictionary to determine which objects are obsolete or have been updated.

Deleting Obsolete Objects
Packaging does not delete obsolete objects. RSA recommends that you delete these
objects because they may affect how the applications function. Follow these
guidelines on deleting obsolete objects:

l If you select Override Layout when you install the solution install package, the
Packager does not remove old fields from the layout. You must delete the old
fields.

l Evaluate your need for certain data driven events (DDE), pre-existing rules, and
actions that were not updated through Packaging. Delete any obsolete rules and
actions.

l Verify the DDE order and update it if necessary.

l Evaluate pre-existing notifications and reports that Packaging did not update.
Delete obsolete notifications and reports.

For more information about objects, see the Packaging section of the RSA Archer
GRC Platform Administrator Guide portfolio.

Validating Formulas and Calculation Orders
Follow these guidelines on validating formulas and calculation orders:

l The packaging process logs an error if a formula does not validate. This error
may be caused by a formula that references applications or fields that do not
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exist in the instance and were not part of the package (for example, fields in
applications that are part of a different core solution). Review those fields to
determine if they are needed.
o If a field is needed, modify the formula to remove references to applications

or fields that do not existing in your instance. Fields that do not exist in your
instance are identified with an exclamation mark.

o If a field is not needed, delete the field or remove it from the layout. If the
field is not deleted, removing the formula prevents errors from being written
in the log files when records are saved.

l Verify the order of calculations for each application and sub-form in the solution.
See the Data Dictionary for calculation orders for each individual application or
sub-form.

l Update the order of calculations as needed for each application and subform in
the solution.

For more information about deleting objects, see the Calculations section of the RSA
Archer GRC Platform Administrator Guide portfolio.

Verifying Key Fields
Packaging does not change key fields. To verify the key fields in each application,
see the RSA Archer Security Operations Management Data Dictionary.

Updating Record Permissions Fields to Allow Access to Other Solution
Records

The access roles in the RSA Archer Security Operations Management package
provide read-access rights to records in the Crisis Events application (in the RSA
Archer Business Continuity Management solution) and the Risk Register
application (in the RSA Archer Risk Management solution), if you have licensed
these solutions.

However, the package does not update any Record Permissions fields in those
applications, so users must still be selected in a Record Permissions field in a
record in order to view that record.

RSA recommends that you work with your Business Continuity Management and
Risk Management solution administrators to determine which RSA Archer
Security Operations Managementusers require access to Crisis Events or Risk
Register records and to update any Record Permissions fields necessary to provide
default access.

Verifying the Upgrade from RSA Advanced Incident Management for Security
1.1

If you have upgraded from RSA Advanced Incident Management for Security 1.1,
you should see the following changes:
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l In the Security Incidents application, you have two new tabs: Forensic Analysis
and Remediation. The Results tab also has new sections and the Overview tab
has a couple new fields.

l In the Incident Response subsolution, you have two new applications: Forensic
Analysis and Incident Investigations.

l You have three new subsolutions: Data Breach Response, SOC Program
Management, and Issue Management.

l You have six new dashboards for each primary solution user role.

l The Incident Coordinator dashboard provides a Bing maps iView.

Note: You must have a Bing maps license installed for this iView to work.

l Incident Response Tasks can now be created from the SOC Procedure Library
records that match the selected category.

Test the Solution

Procedure

Test the RSA Archer Security Operations Management 1 solution according to your
company standards and procedures, to ensure that the solution works with your
existing processes. Some of the items that you may want to include in your testing
are:

l Customized objects and fields

l Notifications - ensure that notifications are firing

l Calculations - ensure that calculations are functioning

l Workflows - ensure that workflows are correct
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Chapter 3: Setting Up the RSA Connector
Framework

RSA Connector Framework (RCF)
The RCF is a plug-and-play structure that runs as a Windows system service and
integrates your RSA Archer system with RSA Security Analytics.

Set Up the RCF

Procedure

1. If you are upgrading from the RCF 2.5, Prepare for Upgrade.

2. Install the RCF

3. Set Up TLS/SSL Communication between the RSA Archer Platform and
the RCF

4. Set Up TLS/SSL Communication between RSA Security Analytics and the
RCF

Prepare for Upgrade
If you are currently using the RCF 2.5, you must uninstall it and install the RCF 2.6
for the RSA Archer Security Operations Management solution. This process does
not preserve any of your existing configuration information, so before you begin,
RSA recommends that you create copies of necessary files. You can then reference
these files for configuration values when you run the configuration wizards for the
SecOps and Enterprise Management plug-ins.

Procedure

1. Copy the following files and save them in a separate location:

l For the SecOps plugin:
o felix.properties, located in the Install_Dir\EMC\RSA Connector

Framework\config folder
This file contains your syslog server configuration details.

o endpoint.properties, located in the Install_Dir\EMC\RSA Connector
Framework\plugins\plugin_name folder
This file contains your Archer instance configuration details.
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l For the Enterprise Management plug-in:
o plugin.properties, located in Install_Dir\EMC\RSA Connector

Framework\plugins\plugin_name folder
This file contains your business context feed configuration details.

o endpoint.properties, located in the Install_Dir\EMC\RSA Connector
Framework\plugins\plugin_name folder
This file contains your Archer instance configuration details.

2. Uninstall the RCF 2.5:

a. Click Start > Programs > EMC > RSA Connector Framework > Uninstall.

b. When prompted to uninstall, click Yes.

c. Click Finish.

Install the RCF

Before You Begin

l Review the Solution Requirements.

Note: You must install the RCF on a Microsoft Windows 2008 R2 Server 64-bit
system that can reach both your RSA Security Analytics system and your RSA
Archer Platform

l Ensure that the secops_plugin_1.0bnn.zip and em_plugin_1.0bnn.zip files are
located in the same folder as the RCF executable, depending on which you plan
to configure.

Procedure

1. Double-click RSA_Connector_Framework_2.6bnnn.exe.

2. Click Next.

3. Read and accept the license agreement, and click Next.

4. (Optional) If you want to change the destination path:

a. Click Change.

b. Select your destination, and click OK.

5. Click Next.

6. On the Select Plug-ins page, select the plug-ins that you want to install, and
click Next.

7. On the Create User Credentials page, complete the following fields, and click
Next.
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Field Description

User Name User name for the RSA
Connector Shell. This user
name is used exclusively for
the RCF.

Enter Password Password for the user name.

Confirm Password Confirmation of the
password.

Connector Shell Port Port used by the RSA
Connector Shell (default
8001, which is an SSH port).

RCF user names:

l Must be at least 8 characters in length

l Must be at most 32 characters in length

l Are not case sensitive

l Cannot include the following special characters: " / \ [ ] : ; | = , + * ? < >
RCF passwords:

l Must be between 8 and 32 characters in length

l Must contain at least one upper case letter

l Must contain at least one numeral

l Must contain at least one special character

l Cannot include the following special characters: " \

8. On the Ready to Install the Program page, click Install.

9. On the InstallShield Wizard Complete page, click Finish.
The RSA Connector Framework Service starts automatically, without requiring
a restart of your system.

TLS/SSL Communication Between the RCF and the RSA Archer GRC
Platform

Transport Layer Security (TLS) and its predecessor, Secure Sockets Layer (SSL),
are cryptographic protocols that provide communications security over the Internet.
The RCF can communicate with the RSA Archer GRC Platform through TLS or
SSL.
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Set Up TLS/SSL Communication Between the RCF and the RSA Archer GRC
Platform

This procedure is optional.

Before You Begin

Ensure that the following requirements have been met:

l The RSA Archer Platform has been installed and is running.

l The RSA Archer Platform is configured to support (or require) TLS or SSL
communication.

l The RCF has been installed.

Procedure

1. On the system on which you installed the RC Framework, open a DOS
command prompt.

2. Change directories to Install_Dir\EMC\RSA\RSA Connector Framework\tools

3. Type:
install_cert_admin.bat Archer Host URL:Port

where:

l Archer Host URL is the hostname or IP address of your RSA Archer system.
Your hostname or IP address must match the value that you specified in the
RSA Archer Platform TLS or SSL certificate. If you have specified a
hostname, you must use that hostname for importing certificates and
configuring the RSA Archer Platform endpoint properties. The Port argument
is optional if you are using the standard SSL port 443.

l Port is the TLS or SSL port used.

TLS/SSL Communication Between the RCF and RSA Security
Analytics

The RCF can communicate with your RSA Security Analytics system using
TLS/SSL communication.

The SecOps plug-in communicates with the RSA Security Analytics Reporting
Engine Service, which supports mutual authentication. If you are setting up both
plug-ins, follow all of the procedures below. If you are only setting up the
SecOps plug-in, follow all of the procedures below, but skip steps 3 to 6 in
Create SSL Certificates.
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The Enterprise Management plug-in communicates with the Live Module of
Security Analytics. Live does not support mutual authentication. If you are only
setting up the Enterprise Management plug-in, follow the procedures below, but
skip step 2 in Create SSL Certificates.

Set Up TLS/SSL Communication Between the RCF and RSA Security
Analytics

These procedures are required only if you want to configure the RCF to
communicate with your RSA Security Analytics system using TLS/SSL. If you do
not want to use TLS/SSL, you can skip to the next chapter, Configuring the
SecOps Plug-in.

Procedure

1. Create a Self-Signed Root Certificate

2. Export the Root Certificate Public Key to a Trust Store

3. Create SSL Certificates for RSA Security Analytics and the RCF

Create a Self-Signed Root Certificate
You must create a self-signed root certificate, used to sign the client certificates for
your RSA Security Analytics and RCF systems.

Procedure

1. On your RSA Security Analytics system, using OpenSSL, type:
openssl req –x509 –newkey rsa:nbits –days n –out ca.pem
–keyout ca_pvt.pem

where:

l nbits is number of bits to generate for an RSA key.

l n is the number of days for which to certify the certificate.
ca.pem is the public key and ca_pvt.pem is the private key. You can use
other names for these files.

2. When prompted, enter a password for the private key for this certificate.

3. When prompted, enter RSA for the Common Name value, and for the rest of the
prompted information, enter information as desired.

Export the Root Certificate Public Key to Trust Stores
After you have created a root certificate, you must export the public key to a trust
store on both your RSA Security Analytics and RCF systems.
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Procedure

1. On your RSA Security Analytics system, using the JDK keytool utility, type:
keytool -importcert -alias alias_name -file ca.pem -trustcacerts -storetype jks -
keystore ssltruststore.jks

where

l alias_name is the name that you want to use to distinguish this certificate if
multiple certificates are present in a key store.
ssltruststore.jks is the trust store file that you want to create. You can use
other names for this file.

ca.pem is the public key that you created in Create a Self-Signed Root
Certificate. If you named the file something different, use that name here.

2. When prompted, enter Yes to trust this certificate.

3. Move a copy of ssltruststore.jks to your RCF system.

4. On your Security Analytics system, in the /home/rsasoc/rsa/soc/reporting-
engine/keystores/ directory, determine whether a file named re-truststore.jks
exists.

5. Do one of the following:

l If the file does not exist, rename ssl-truststore.jks to re-truststore.jks and
copy the file to the /home/rsasoc/rsa/soc/reporting-engine/keystores/
directory. Using the JDK keytool utility, type:

keytool -importcert -alias alias_name -file ca.pem trustcacerts -storetype jks
-keystore re-truststore.jks

l If the file does exist, import the new CA into the existing trust store. Using
the JDK keytool utility, type:

keytool -importcert -alias RCFCA -file ca.pem -trustcacerts -storetype jks -
keystore /home/rsasoc/rsa/soc/reporting-engine/keystores/re-truststore.jks

Create SSL Certificates
After you create a root certificate and trust stores, you can create SSL certificates
for both your RCF and RSA Security Analytics systems.

Note: If you are only setting up the Enterprise Management plug-in, you can skip
step 2. If you are only setting up the SecOps plug-in, you can skip step 3 to 6.

Procedure

1. Create an SSL certificate for your RCF system as follows.

a. Using OpenSSL, type:
openssl req -newkey rsa:nbits -keyout rcfkey.pem -out rcfreq.pem
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where nbits is number of bits to generate for an RSA key.

rcfkey.pem is the private key and rcfreq.pem is the certificate signing
request. You can use other names for these files.

b. Sign the certificate request using the root certificate. Type:
openssl x509 -req -in rcfreq.pem -CA ca.pem -CAkey
ca_pvt.pem -CAcreateserial -out rcfcert.pem

rcfcert.pem is the signed certificate name. You can use another name for
this file.

c. Convert the signed certificate and private key from PEM to an intermediate
PKCS#12 format. Type:

openssl pkcs12 -export -in rcfcert.pem -inkey rcfkey.pem
-out rcfkeystore.p12 –CAfile ca.pem

d. Convert the certificate from PKCS #12 to JKS format. Using the JDK
keytool utility, type:

keytool -importkeystore -destkeystore rcfkeystore.jks
-srcstoretype PKCS12 -srckeystore rcfkeystore.p12

e. Copy rcfkeystore.jks to your RCF system.

When you create the certificate for the RCF, ensure that the Common Name
value that you enter matches the hostname in the URL that you use to connect to
the RCF.

2. Create another client certificate for your RSA Security Analytics system, as
follows:

a. Using OpenSSL, type:
openssl req -newkey rsa:nbits -keyout sakey.pem -out sareq.pem

where nbits is number of bits to generate for an RSA key.

sakey.pem is the private key and sareq.pem is the certificate signing
request. You can use other names for these files.

b. Sign the certificate request using the root certificate. Type:
openssl x509 -req -in sareq.pem -CA ca.pem -CAkey
ca_pvt.pem -out sacert.pem

sacert.pem is the signed certificate name. You can use another name for this
file.

c. Convert the signed certificate and private key from PEM to an intermediate
PKCS#12 format. Type:

openssl pkcs12 -export -in sacert.pem -inkey sakey.pem
-out re-keystore.p12 –CAfile ca.pem
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d. Convert the certificate from PKCS #12 to JKS format. Using the JDK
keytool utility, type:

keytool -importkeystore -destkeystore /home/rsasoc/rsa/soc/reporting-
engine/keystores/re_keystore.jks -srcstoretype PKCS12 -srckeystore re-
keystore.p12

mv re_keystore.jks re-keystore.jks

e. If you copied the file as root, change the owner to rsasoc. Type:
chown rsasoc.rsasoc re-keystore.jks re-truststore.jks

3. On your RCF system, export the RCF SSL certificate.

a. In the Security tab, click View Certificate.

b. Click the Details tab.

c. Click Export.

d. Name the file.

e. Click Save.

4. Copy the RCF SSL certificate to the RSA Security Analytics machine.

a. Open a WinSCP client on your RCF machine.

b. Log on to your RSA Security Analytics machine through WinSCP.

c. Copy the RCF SSL certificate to your RSA Security Analytics machine's
root directory.

5. Import the RCF into the RSA Security Analytics key store. On your RSA
Security Analytics machine, using the JDK utility, type:

JDK=/usr/java/default

keytool -import -v -trustcacerts -alias alias_name -file rcf.crt -keystore
$JDK/lib/security/cacerts

where rcf.crt is the name of the RCF SSL certificate that you exported.

6. Restart RSA Security Analytics. In your command prompt, type:

stop jettysrv

start jettysrv
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Chapter 4: Configuring the SecOps Plug-in for
Collecting and Aggregating Alerts

SecOps Plug-in for Alert Collection and Aggregation
RSA Security Analytics provides full network and log-based visibility to rapidly
detect advanced threats. Once a threat is detected, the SecOps plug-in in the RCF
takes the alert from your RSA Security Analytics system and creates an incident in
your Security Incidents application, within the RSA Archer
Security Operations Management solution. The RCF can also aggregate multiple
alerts into a single incident, based on criteria that you define—such as source IP,
destination IP, or both.

Configure the SecOps Plug-in
To enable the full end-to-end functionality of the SecOps plug-in, you must
configure your RSA Security Analytics and RSA Archer systems in addition to
configuring the actual plug-in in the RCF.

Procedure

1. Configure RSA Security Analytics

2. Configure the RSA Archer GRC Platform

3. Configure the RCF

Configure RSA Security Analytics

Procedure

1. Configure Syslog Output Action

2. Configure Rules

3. Add Alert Templates

4. Configure Alerts

Configure Syslog Output Action for Your Reporting Engine

Procedure

1. In the Security Analytics menu, click Administration > Devices.

2. Select your Reporting Engine, and in the Device Grid toolbar, select View >
Config.
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3. Click the Output Actions tab.

4. In the SA Configuration section, in the Host Name field, enter the host name or
IP address of your Reporting Engine server.

Important: If you do not enter a value in this field, the link in the RSA Archer
Security Alerts application back to Security Analytics will not work.

5. In the Syslog section, enter data in the fields as follows. Do not fill out any
fields that are not listed below.

Field Description

Transport
Type

Select either TCP or SECURE_TCP.

Delimiter If you are using Security Analytics 10.3 or 10.3 SP1, select
LF. Otherwise, do not enter a value for this field.

Key Store
Password

Enter the password for the key store that you created for the
RCF in Create SSL Certificates.

This field is only required if you selected SECURE_TCP for
the transport type.

Trust Store
Password

Enter the password for the trust store that you created in
Export the Root Certificate Public Key to Trust
Stores.

This field is only required if you selected SECURE_TCP for
the transport type.

Include
Local
Timestamp

Check this box to include the local timestamp in all Syslog
alert messages.

Max
Length

Increase this value if the syslog message being generated is
larger than 2048 bytes. RSA recommends that you set this
value to a large enough number to cover any potential syslog
message, for example, 10,000 bytes.

Server
Name

Specify the hostname or IP Address of the system on which
you installed the RCF.

Server Port Specify the port number on which you want the RCF to listen
for Syslog alert messages.

6. Click Apply.
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Configure Rules
In RSA Security Analytics, rules are filters that you create for specific meta data,
which result in defined actions when matches are found. For the SecOps plug-in,
you must create rules to define the conditions that trigger an alert to be escalated to
your RSA Archer GRC Platform. You can create network and application rules.
For more information about rules, see the RSA Security Analytics User Guide.

Procedure

l If you are using Security Analytics 10.2 SP2, follow these steps:

1. Click the Rule tab.

2. In the Rule Library Panel, click Add (+) > Group.

3. Enter a name for the new group, and click OK.

4. In the Rule Library Panel, select the group that you created, and click Add
(+) > Rule.

5. Enter a name for the rule.

6. In the Rule Definition Panel, do the following:

a. In the Rule Type field, select Netwitness DB.

b. Enter values in the Select and Where fields based on the rule that you
want to create.

c. Click Save.

7. In the Rule Definition Panel Toolbar, click Create Alert.

l If you are using Security Analytics 10.3 or 10.3 SP1, follow these steps:

1. Do one of the following:

l On 10.3, click Reporting > Rules.

l On 10.3 SP1, click Reporting > Manage.

2. In the Groups panel, click > Add.

3. Enter a name for the new group.

4. Select the group you created, and in the Rule toolbar, click Add (+).

5. In the Rule Type field, select NetWitness DB.

6. Enter a name for the rule.

7. Enter values in the Select and Where fields based on the rule that you want to
create.

8. Click Save.
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Add Alert Templates
The SecOps plug-in comes with out of the box alert templates that you can use
when you create an alert with a syslog output action. These templates define the
criteria used to aggregate alerts into incidents in your RSA Archer GRC Platform.
The names and message text to use for the default alert templates are provided in
the SecOps_templates.txt file (located in \Install_Dir\EMC\RSA Connector
Framework\plugins\secops). For instructions on creating your own custom alert
template, see Customizing and Modifying the SecOps Plug-in. Whether you use
the default alert templates or create your own, you must add them into your RSA
Security Analytics system.

Procedure

1. Do one of the following:

l If you are using Security Analytics 10.2 SP2, click Alerter > Define.

l If you are using Security Analytics 10.3, click Reporting > Alerts.

l If you are using Security Analytics 10.3 SP1, click Reporting > Manage, and
click the Alert tab.

2. Click the Template tab.

3. Click Add (+).

4. In the Name field, enter a name for the alert template.

5. In the Message field, enter the alert message.

6. Click Create.

Note: If you are using Security Analytics 10.3 SP1, you may receive an error
message that reads "Given Template Name Already Exists". This message can
be ignored.

7. Repeat steps 3 to 6 for each alert template that you want to add.

Configure Alerts
In RSA Security Analytics, an alert is a rule that you can schedule to run on a
continuous basis and log its findings to several different alerting outputs. The
SecOps plug-in uses the syslog output action to send alerts to the RCF.

Procedure

l If you are using Security Analytics 10.2 SP2, follow these steps:

1. Open the rule that you created.

2. Click Create Alert, and when prompted, click Yes.

3. In the Security Analytics menu, select Alerter > Define.
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4. Select the alert and click Edit.

5. In the Create/Modify Alert dialog, do the following:

a. Select Enable.

b. Select Push to Decoders.

Important: If you do not enter a value in this field, the link in the RSA
Archer Security Alerts application back to Security Analytics will not
work.

c. From the Data Sources list, select your data source.

d. Click Add (+) and select Syslog.

e. Select values in the Severity and Facility fields.

Important: You need to enter the same value for Facility when you
configure the RSA Connector Framework. Note this value, if necessary.

f. From the Use Template field, select the template that you want to use for
this syslog alert.

g. Click Save.

l If you are using Security Analytics 10.3 or 10.3 SP1, follow these steps:

1. Do one of the following:

l On 10.3, click Reporting > Rules.

l On 10.3 SP1, click Reporting >Manage.

2. Select the rule you created, and in the Rule toolbar, click > Create >
Alert.

3. Select the alert, and click Edit.

a. Select Push to Decoders.

Important: If you do not enter a value in this field, the link in the RSA
Archer Security Alerts application back to Security Analytics will not work.

b. From the Data Sources list, select your data source.

c. Click Add (+) and select Syslog.

d. Select values in the Severity and Facility fields.

Important: You need to enter the same value for Facility when you
configure the RSA Connector Framework. Note this value, if necessary.

e. From the Use Template field, select the template that you want to use for this
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syslog alert.

f. Click Save.

Configure the RSA Archer GRC Platform

Procedure

1. Create a User Account for the WebServices Client

2. Modify Archer Single Sign-On Mode

3. Collect Archer Details

Create a User Account for the SecOps Plug-in
You must create a user account that the RCF can use to write data into the RSA
Archer GRC Platform for the SecOps plug-in. The RCF uses the web service client
to transfer data.

Procedure

1. Click Administration > Access Control > Manage Users > Add New.

2. In the First Name field, enter SecOps Plug-in.

3. In the Last Name field, enter RCF.

4. (Optional) Enter a user name for this new user account.

Note: If you do not specify a user name, the RSA Archer Platform creates the
user name from the first and last name entered when you save the new user
account.

5. In the Contact Information section, in the Email field, enter an email address to
be associated with this new user account.

6. In the Account Maintenance section, click Change Password.

7. Enter a new password for the new user account, confirm the new password, and
click OK.
When prompted, click OK.

Important: Note the user name shown for the new user account that you just
created. Also, remember the password that you just created. You need to enter
these credentials when you set up the RCF to communicate with the
RSA Archer Platform through the web service client.

8. Clear Force Password Change On Next Sign-In.

9. In the Security Parameter field, select the security parameter that you want to
use for this user.
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Note: This user account is automatically assigned the General User Security
Parameter, which requires you to change the password every 120 days, only
allows three grace logons, and does not notify you when it is about to expire.
RSA recommends assigning a security parameter that notifies you that the
password is going to expire and that allows more than three grace logons. For
instructions on changing the password after it expires, see Component
Troubleshooting.

10. Click the Groups tab, and click Lookup.

11. Expand the Groups list, and select SOC: Solution Administrator and EM: Read
Only.

12. Click the Roles tab, and click Lookup.

13. Expand the Roles list, and select SOC: Solution Administrator and EM: Read
Only.

14. Click Save.

15. If the machine language and regional settings of your RSA Archer system are
set to anything other than English-US, also do the following:

a. Open the user account you just created, and in the Localization section, in
the Locale field, select English (United States), and click Save.

b. On the Windows system hosting your RSA Archer Platform, open Internet
Information Services (IIS) Manager, and do one of the following:

l If you are running IIS 6, right-click your RSA Archer site, select
Properties, click the ASP.Net tab, click Edit Configuration, click the
Application tab, in both the Culture and UI Culture fields, select en-US,
and click Apply.

l If you are running IIS 7, expand your RSA Archer site, click .Net
Globalization, in both the Culture and UI Culture fields, select English
(United States), and click Apply.

c. Restart your RSA Archer site.

Modify Archer Single Sign-On Mode
If you are running the RSA Archer GRC Platform with single sign-on enabled, you
must make a modification so that the RCF can communicate with your RSA Archer
Platform.

Procedure

1. On the Windows system hosting the RSA Archer Platform, click Start >
Programs > Administrative Tools > Internet Information Services (IIS)
Manager.

2. Expand the local computer.
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3. Expand Web Sites > Default Web Site > Archer.

4. Enable anonymous access. Do one of the following:

l For IIS 6.0:

a. Right-click the ws folder, and select Properties.

b. Click the Directory Security tab.

c. In the Authentication and access control section, click Edit.

d. Check Enable anonymous access and ensure that the default IIS account
is selected. (By default, the account is named IUSR_computername.)

e. Click OK twice.

l For IIS 7.0:

a. Select the ws folder.

b. In the IIS section, double-click Authentication.

c. Right-click Anonymous Authentication, and click Edit.

d. Select Specific user, and click Set.

e. Enter the credentials for the default IIS account. (By default, the account
is named IUSR.)

f. Click OK twice.

5. (Optional) Verify that single sign-on is running correctly:

a. Log on to the system on which you installed the RCF.

b. Open a browser and enter the following URL:
http(s)://yourArcherAddress/ws/module.asmx?wsdl

where http(s)://yourArcherAddress is the address that you use to log on to
the RSA Archer Platform. For example:

l For the RSA Archer Platform in simple mode, type:
http://10.10.10.10/archer

l For the RSA Archer Platform in SSL/TLS mode with no context, type:
https://10.10.10.10

Collect RSA Archer GRC Platform Details
You must collect some specific RSA Archer GRC Platform details for configuring
the RCF. This information tells the RCF where to collect data from.

Note: You should already have noted a user name and a password in Create a
User Account for the SecOps Plug-in.
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Procedure

1. Click Start > Programs > Archer Technologies > Archer Control Panel.

2. Click Computer Name > Instances > Instance Name
where

l Computer Name is the name of your computer.

l Instance Name is the name configured for the default instance.

3. Note the instance name that is listed.

4. Log on to the RSA Archer Platform user interface.

5. From the URL, note the hostname, port, and context base, as indicated below:
http://hostname:port/context_base/default.aspx

Note: If you enabled SSL communication between the RCF and the RSA
Archer Platform, this value must match the Issued to value in the RSA Archer
Platform HTTPS certificate.

Note: If the port number does not appear, by default, HTTP uses port 80 and
HTTPS uses port 443.

6. Before moving on, ensure that you have the following details ready.

Archer Detail Your Value

User Name of the user account that you
created for the RCF to use to transfer data into
the RSA Archer Platform in Create a User
Account for the RSA Archer
GRC Platform Web Service Client.

Hostname found in the RSA Archer Platform
URL.

Port number found in the RSA Archer Platform
URL.

Context Base found in the RSA Archer
Platform URL.

Instance Name found in the RSA Archer
Platform Control Panel.

Note: You must also remember the password that you created for the
WebServices client user account.
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Configure the RCF
For the SecOps plug-in, the RCF transports alerts from your Security Analytics
system and creates incidents and incident events in your RSA Archer Platform.

Procedure

1. Open the secops_config_wizard.vbs file located in the \Install_Dir\EMC\RSA
Connector Framework\plugins\secops\auto-config directory.

2. If prompted to allow the program to run, click Yes.

3. When prompted, add the about:blank page as a trusted site. If you are not
prompted, add the page as follows:

a. In Internet Explorer, from the Tools menu, select Internet Options.

b. Click the Security tab.

c. Click Trusted Sites.

d. Click Sites.

e. In the Add this website to the zone field, enter about:blank, and click Add.

4. From the Introduction page, click Next.

Note: If you installed the RCF in a non-default location, the Next button may
not work. If it does not work, try the following: repeat steps 3a to 3b, then click
Custom Level, and under Scripting > Active scripting, ensure that Enable is
selected. You may have to repeat step 3a to 3c and change the security level for
trusted sites from high to medium. Close and reopen the configuration wizard
after making these changes.

5. Enter the data in the following fields.
If you are upgrading from the RCF 2.5, you can refer to your backup of the
endpoint.properties file for the values you should enter.

Field Description

Host Name/IP
Address of
Archer Web
Server

The host name or IP address that you use to connect to the RSA
Archer Platform web console. If SSL is enabled, make sure that the
value specified here is the same as the web server name the Archer
SSL server certificate has used in the 'Issued to' field.

Port Number of
Archer Web
Server

The port number that you use to connect to the RSA Archer
Platform web console (by default, use 80 for HTTP and 443 for
HTTPS).
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Field Description

Instance Name
of Archer Web
Server

The name of the RSA Archer Platform instance to which you are
connecting.

Context Base
of Archer Web
Server

The RSA Archer Platform URL context base that you use.
(Optional)

Communication
Protocol

Select either HTTPS or HTTP. If you select HTTPS, ensure that
both your RSA Archer and RCF systems have HTTPS enabled and
that you have completed the steps in Configure the for TLS or
SSL Communication with the RSA Archer GRC
Platform.

User Name of
RCF Account
in Archer

The user name of the user account created for the RCF to transfer
data into the RSA Archer Platform. This information must be for
the user account that you created for the SecOps plug-in. If you
have also configured other plug-ins, you may also have other user
accounts.

Password of
RCF Account
in Archer

The password for the user account created for the RCF to transfer
data into the RSA Archer Platform.

6. To test the RSA Archer Platform connection using the information that you
provided, click Test Archer Connection.
If the connection to the RSA Archer Platform is not successful, verify the above
data and try again. If you receive an error while testing the connection to your
SSL-enabled RSA Archer Platform, test your connection as follows: open a
browser on the system on which you installed the RCF, and log on to your
RSA Archer Platform using the user account that you created in Create a User
Account for the RSA Archer GRC Platform Web Service Client.

7. Click Next.

8. Enter the data in the following fields, and click Next.
If you are upgrading from the RCF 2.5, you can refer to your backup of the
felix.properties file for the values you should enter.
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Field Description

Syslog Server
Port

The port number that you use to listen for syslog messages from the
RSA Security Analytics syslog server. 514 is the default value.

Note: RSA recommends that you review the allowed port numbers
for TCP.

Syslog Server
Facility

The facility for the syslog server. This must be the same value that
you selected in Configure Alerts.

Syslog
Transport
Mode

Select the communication protocol that you want to use for your
syslog server: TCP or SECURE_TCP.

Java Keystore
File Path

Enter the path of the Java KeyStore file that you are using to store
the SSL certificate for the RCF.

Java Keystore
Alias

Enter the alias of the Java KeyStore file that you are using to store
the SSL certificate for the RCF.

Java Keystore
Passphrase

Enter the passphrase protecting the Java KeyStore that is used to
store the SSL certificate for the RCF.

Syslog Server
SSL Mututal
Authentication

Select Enabled if you want to require mututal authentication
between the RCF and your Security Analytics system. Select
Disabled if you only want to require that the RCF be
authenticated.

Java Trust
Store File Path

Enter the path of the Java Trust Store file that you created to store
the certificates that the RCF should trust.

Java Trust
Store Password

Enter the passphrase protecting the Java Trust Store that you cre-
ated.

9. In the User Name and Password fields, enter the credentials you entered when
you installed the RCF, and click Next.

10. On the Summary page, verify that the information is correct, and click Start
Configuration.
The VB script performs the configurations based on the data given and requests
that you to enter a run-script command.

The RSA Connector Shell uses PuTTY as its SSH client. The first time that you
open PuTTY, a security alert appears and informs you that the server host key is
not cached in the registry. Select Yes to proceed.

11. Click Run Script. (If Run Script does not work the first time, try clicking the
button again.)
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When the script finishes successfully, the secops application has been created
from the secops plug-in and is in the Running state.

12. Restart the RCF.

a. Click Control Panel > Administrative Tools > Services.

b. Select RSA Connector Framework Service, and click Restart.

Customizing the SecOps Plug-in
The SecOps plug-in comes with default alert message templates and a mapping file
that define how meta data values from RSA Security Analytics are mapped to RSA
Archer fields and the criteria by which alerts are aggregated into incidents. If these
default options do not meet your needs, you can create your own custom alert
template and modify the mapping file to define your own mapping and aggregation
criteria.

The names and message text of the default alert templates are provided in the
SecOps_Templates.txt file.

Alert Templates
An alert template defines the format of the alert message, including which meta
data field names are included in the message. For the SecOps plug-in, the alert
messages are then sent via syslog to the RCF. The default alert templates provided
use the CEF format, and any custom templates that you create must also be CEF-
compliant. Consult CEF documentation for more details.

Alert Template Components
The following example alert template aggregates alerts based on the value of
Source IP meta data.

CEF:0|RSA|Security Analytics|1.1|20|This incident is based on the rule
"${meta.alert}" and based on the aggregation criteria "source IP" where the source
IP is: "${meta.ip.src}"|3|externalId=${meta.sessionid} src=${meta.ip.src}
dst=${meta.ip.dst} rt=${meta.time} sourceServiceName=${meta.service}
requestClientApplication=${meta.client}
destinationDnsDomain=${meta.domain.dst} username=${meta.username}
shost=${meta.alias.host} act=${meta.action} smac=${meta.eth.src}
dmac=${meta.eth.dst} cs1=${meta.city.dst} cs1Label=destinationcity
cs2=${meta.country.dst} cs2Label=destinationcountry cs3=ip.src-${meta.ip.src}
cs3Label=aggregationcriteria cs4=${meta.did} cs4Label=decoderid
cs5=${meta.cid} cs5Label=concentratorid cs6=${meta.threat.source}
cs6Label=threatsource cs7=${meta.referer} cs7Label=referer cs8=secops
cs8Label=RCFApplicationName spt=${meta.tcp.srcport} dpt=${meta.tcp.dstport}
cs9=${meta.udp.srcport} cs9Label=udpsourceport cs10=${meta.udp.dstport}
cs10Label=udptargetport cs11=${meta.latdec.dst} cs11Label=destinationlattitude
cs12=${meta.latdec.src} cs12Label=sourcelattitude cs13=${meta.longdec.dst}
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cs13Label=destinationlongitude cs14=${meta.longdec.src}
cs14Label=sourcelongitude cs15=${meta.filename} cs15Label=filename
cs16=${meta.alert.id} cs16Label=alertid cs17=${meta.domain.src}
cs17Label=sourcedomain cs18=${meta.domain.dst} cs18Label=destinationdomain
cs19=${meta.alert} cs19Label=alert cs20=${meta.country.src}
cs20Label=sourcecountry cs21=${meta.city.src} cs21Label=sourcecity
cs22=${device.id} cs22Label=deviceid cs23=${meta.medium} cs23Label=medium
msg=${meta.alert} grouped by source IP:${meta.ip.src} cs25=${sa.host}
cs25Label=sahost cs26=${meta.risk.info} cs26Label=riskinfo
cs27=${meta.risk.warning} cs27Label=riskwarn cs28=${meta.risk.suspicious}
cs28Label=risksusp cs29=${meta.threat.category} cs29Label=threatcategory
cs30=${meta.threat.desc} cs30Label=threatdesc

The following sections comprise the alert template:

Prefix. These fields identify the mandatory CEF prefix, the device vendor,
product, and version of the message sender, and the signature ID of the event
type. These fields are required in your template and should not be modified.

CEF:0|RSA|Security Analytics|1.1|20|

Name. This field describes the event. This field is required, but you may enter
whatever you want to name the template.

Important:Whatever you enter for this field displays in the Incident
Summary field in the RSA Archer Security Incidents application.

This incident is based on the rule "${meta.alert}" and based on the aggregation
criteria "source IP" where the source IP is: "${meta.ip.src}"

Severity. This field identifies the severity of the message. This field is
required in your template. The default value is 3, but you may select a
different value. Only numbers from 0-10 are allowed.

3

Extension. This section is made up of key-value pairs that follow the format
key=${meta.meta.data} where key is a predefined CEF key value and
meta.data is the Security Analytics meta data that you want to include in the
alert. For example, in the key-value pair dst=${meta.ip.dst}, dst is the
predefined CEF key value and meta.ip.dst is the Security Analytics meta data.

The CEF standard provides a number of predefined keys such as dst, but also
allows you to define keys for custom fields, csn, where n is a number. For any
custom fields, you must also define a label for the key, csnLabel. In the
following example, cs1 is the custom field key and cs1Label is the custom
field name.

cs1=${meta.city.dst} cs1Label=destinationcity

Note: Key-value pairs must be separated with a single space.
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You can include any number of key-value pairs in your alert template, but you
must include the following two pairs.

csn=secops csnLabel=RCFApplicationName

csn=fieldname-${meta.fieldname} csnLabel=aggregationcriteria

Note: These key-value pairs can be any custom string number.

Here, the key is a custom string and the meta data that you define is the value
by which the RCF aggregates alerts into incidents. For example:

cs3=ip.src-${meta.ip.src} cs3Label=aggregationcriteria

You can also aggregate alerts into incidents based on multiple aggregation
criteria by defining multiple values for the key, using the following syntax:

csn=${meta.fieldname1},${meta.fieldname2} csnLabel=aggregationcriteria

In the following example, alerts are aggregated based on both source and
destination IP:

cs3=${meta.ip.src},${meta.ip.dst} cs3Label=aggregationcriteria

Note: Ensure that the meta data that you select for your aggregation criteria
contains actual values in RSA Security Analytics.

Create Custom Alert Templates
To define your own mapping and aggregation criteria, you must create and add a
custom alert template to RSA Security Analytics, ensure that you have all the
necessary fields to map to in your RSA Archer system, and modify the mapping file
that the RCF uses to map the data.

Procedure

1. Write a custom alert template.

2. Add the alert template to RSA Security Analytics. For instructions, see Add
Alert Templates.

3. Modify the mapping file. For each RSA Security Analytics meta data that you
define with a key-value pair in an alert template, you must decide to which RSA
Archer field you want to map the meta data.

a. Open secops_archer.xml, located in the \Install_Dir\EMC\RSA Connector
Framework\plugins\secops directory.

b. Modify or add field mapping as needed, based on the example below.
The following mapping file entry defines the mapping of a single RSA
Security Analytics meta data type to a single RSA Archer field.

Chapter 4: Configuring the SecOps Plug-in for Collecting and Aggregating Alerts 46



Installation Guide

You can either modify the existing entries or add new entries as needed.

Note: The above example is located under the Security Alerts application
section. Ensure that any entries that you add or modify are located under the
application to which the RSA Archer field that you are mapping to belongs.

The keyName value is the key name that you defined in the alert template.
For example, if you defined dst=${meta.ip.dst} in your alert template, you
would enter dst for the keyName in the mapping file.

The field name value is the RSA Archer field to which you want to map
Security Analytics meta data.

Note: If your UUID value and field type are different from the default, or if
you are adding an entirely new field, you also need to enter values for those
two fields in the mapping file.

c. Save and close the mapping file.

4. In the RSA Connector Shell, type:
refresh-app secops
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Chapter 5: Configuring the Enterprise
Management Plug-in for Business Context

Enterprise Management Plug-in for Business Context
The RCF Enterprise Management plug-in provides context around the assets that
are most critical to your organization by automatically feeding critical asset
information from your RSA Archer Enterprise Management solution through the
RCF into RSA Security Analytics as meta data. In Security Analytics, security
analysts can prioritize an investigation based on the assets most critical to the
organization, using the asset criticality and other meta data fed from your RSA
Archer system. Security analysts can also use the meta data to create rules and
alerts to identify network and log events happening on critical assets.

Configure the Enterprise Management Plug-in
To enable the full end-to-end functionality of the Enterprise Management plug-in,
you must configure your RSA Security Analytics and RSA Archer systems in
addition to configuring the actual plug-in in the RCF.

Procedure

1. Configure the RSA Archer GRC Platform

2. Configure the RCF

3. Configure RSA Security Analytics

Configure the RSA Archer GRC Platform

Procedure

1. Create a User Account for the RSA Archer GRC Platform Web
Service Client

2. Modify Archer Single Sign-On Mode

3. Collect RSA Archer GRC Platform Details

Create a User Account for the Enterprise Management Plug-in
You must create a user account that the RCF can use to gather data from the RSA
Archer GRC Platform for the Enterprise Management Plug-in. The RCF uses the
web service client to transfer data.
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Procedure

1. Click Administration > Access Control > Manage Users > Add New.

2. In the First Name field, enter EM Plug-in.

3. In the Last Name field, enter RCF.

4. (Optional) Enter a user name for this new user account.

Note: If you do not specify a user name, the RSA Archer Platform creates the
user name from the first and last name entered when you save the new user
account.

5. In the Contact Information section, in the Email field, enter an email address to
be associated with this new user account.

6. In the Account Maintenance section, enter a new password for the new user
account and confirm the new password.

Important: Note the user name shown for the new user account that you just
created. Also, remember the password that you just created. You need to enter
these credentials when you set up the RCF to communicate with the
RSA Archer Platform through the web service client.

7. Clear Force Password Change On Next Sign-In.

8. In the Security Parameter field, select the security parameter that you want to
use for this user.

Note: This user account is automatically assigned the General User Security
Parameter, which requires you to change the password every 120 days, only
allows three grace logons, and does not notify you when it is about to expire.
RSA recommends assigning a security parameter that notifies you that the
password is going to expire and that allows more than three grace logons. For
instructions on changing the password after it expires, see Component
Troubleshooting.

9. Click the Groups tab, and click Lookup.

10. Expand the Groups list, and select SOC: Solution Administrator and EM: Read
Only.

11. Click the Roles tab, and click Lookup.

12. Expand the Roles list, and select SOC: Solution Administrator and EM: Read
Only.

13. Click Save.

14. If the machine language and regional settings of your RSA Archer system are
set to anything other than English-US, complete the following:
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a. Open the user account you just created, and in the Localization section, in
the Locale field, select English (United States), and click Save.

b. On the Windows system hosting your RSA Archer Platform, open Internet
Information Services (IIS) Manager, and do one of the following:

l If you are running IIS 6, right-click your RSA Archer site, select
Properties, click the ASP.Net tab, click Edit Configuration, click the
Application tab, in both the Culture and UI Culture fields, select en-US,
and click Apply.

l If you are running IIS 7, expand your RSA Archer site, click .Net
Globalization, in both the Culture and UI Culture fields, select English
(United States), and click Apply.

c. Restart your RSA Archer site.

Modify Archer Single Sign-On Mode
If you are running the RSA Archer GRC Platform with single sign-on enabled, you
must make a modification so that the RCF can communicate with your RSA Archer
Platform.

Procedure

1. On the Windows system hosting the RSA Archer Platform, click Start >
Programs > Administrative Tools > Internet Information Services (IIS)
Manager.

2. Expand the local computer.

3. Expand Web Sites > Default Web Site > Archer.

4. Enable anonymous access. Do one of the following:

l For IIS 6.0:

a. Right-click the ws folder, and select Properties.

b. Click the Directory Security tab.

c. In the Authentication and access control section, click Edit.

d. Check Enable anonymous access and ensure that the default IIS account
is selected. (By default, the account is named IUSR_computername.)

e. Click OK twice.

l For IIS 7.0:

a. Select the ws folder.

b. In the IIS section, double-click Authentication.

c. Right-click Anonymous Authentication, and click Edit.

d. Select Specific user, and click Set.
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e. Enter the credentials for the default IIS account. (By default, the account
is named IUSR.)

f. Click OK twice.

5. (Optional) Verify that single sign-on is running correctly:

a. Log on to the system on which you installed the RCF.

b. Open a browser and enter the following URL:
http(s)://yourArcherAddress/ws/module.asmx?wsdl

where http(s)://yourArcherAddress is the address that you use to log on to
the RSA Archer Platform. For example:

l For the RSA Archer Platform in simple mode, type:
http://10.10.10.10/archer

l For the RSA Archer Platform in SSL/TLS mode with no context, type:
https://10.10.10.10

Collect RSA Archer GRC Platform Details
You must collect some specific RSA Archer GRC Platform details for configuring
the RCF. This information tells the RCF where to collect data from.

Note: You should already have noted a user name and a password in Create a
User Account for the Enterprise Management Plug-in.

Procedure

1. Click Start > Programs > Archer Technologies > Archer Control Panel.

2. Click Computer Name > Instances > Instance Name
where

l Computer Name is the name of your computer.

l Instance Name is the name configured for the default instance.

3. Note the instance name that is listed.

4. Log on to the RSA Archer Platform user interface.

5. From the URL, note the hostname, port, and context base, as indicated below:
http://hostname:port/context_base/default.aspx

Note: If you enabled SSL communication between the RCF and the RSA
Archer Platform, this value must match the Issued to value in the RSA Archer
Platform HTTPS certificate.

Note: If the port number does not appear, by default, HTTP uses port 80 and
HTTPS uses port 443.

6. Before moving on, ensure that you have the following details ready.
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Archer Detail Your Value

User Name of the user account that you
created for the RCF to use to transfer data into
the RSA Archer Platform in Create a User
Account for the RSA Archer
GRC Platform Web Service Client.

Hostname found in the RSA Archer Platform
URL.

Port number found in the RSA Archer Platform
URL.

Context Base found in the RSA Archer
Platform URL.

Instance Name found in the RSA Archer
Platform Control Panel.

Note: You must also remember the password that you created for the
WebServices client user account.

Configure the RCF
For the Enterprise Management plug-in, the RCF pulls asset information from your
RSA Archer Platform, creates the csv file for a custom feed, and places this file in
a local folder for RSA Security Analytics Live to download.

Procedure

1. Open the em_config_wizard.vbs file located in the \Install_Dir\EMC\RSA
Connector Framework\plugins\em\auto-config directory.

2. If prompted to allow the program to run, click Yes.

3. When prompted, add the about:blank page as a trusted site. If you are not
prompted, add the page as follows:

a. In Internet Explorer, from the Tools menu, select Internet Options.

b. Click the Security tab.

c. Click Trusted Sites.

d. Click Sites.

e. In the Add this website to the zone field, enter about:blank, and click Add.

4. From the Introduction page, click Next.
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Note: If you installed the RCF in a non-default location, the Next button may
not work. If the Next button does not work, try the following: repeat steps 3a to
3b, then click Custom Level, and under Scripting > Active scripting, ensure that
Enable is selected. If necessary, repeat step 3a to 3c and change the security
level for trusted sites from high to medium. Close and reopen the configuration
wizard after making these changes.

5. Enter the data in the following fields.
If you are upgrading from the RCF 2.5, you can refer to your backup of the
endpoint.properties file for the values you should enter.

Field Description

Host Name/IP
Address of
Archer Web
Server

The host name or IP address that you use to connect to the RSA
Archer Platform web console.

Port Number of
Archer Web
Server

The port number that you use to connect to the RSA Archer
Platform web console (by default, use 80 for HTTP and 443 for
HTTPS).

Instance Name
of Archer Web
Server

The name of the RSA Archer Platform instance to which you are
connecting.

Context Base
of Archer Web
Server

The RSA Archer Platform URL context base that you use.
(Optional)

Communication
Protocol

Select either HTTPS or HTTP. If you select HTTPS, ensure that
both your RSA Archer and RCF systems have HTTPS enabled and
that you have completed the steps in Configure the for TLS or
SSL Communication with the RSA Archer GRC
Platform.

User Name of
RCF Account
in Archer

The user name of the user account created for the RCF to transfer
data into the RSA Archer Platform. This must be the user account
that you created for the Enterprise Management plug-in. If you
have also configured other plug-ins, you may also have other user
accounts.

Password of
RCF Account
in Archer

The password for the user account created for the RCF to transfer
data into the RSA Archer Platform.

53 Chapter 5: Configuring the Enterprise Management Plug-in for Business Context



Installation Guide

6. To test the RSA Archer Platform connection using the information that you
provided, click Test Archer Connection.

Note: If the connection to the RSA Archer Platform is not successful, verify
the above data and try again. If you receive an error while testing the
connection to your SSL-enabled RSA Archer Platform, you can test your
connection as follows: open a browser on your RSA Security Analytics system
on which you installed the RCF, and log on to your RSA Archer Platform using
the user account that you created in Create a User Account for the RSA
Archer GRC Platform Web Service Client.

7. Click Next.

8. Enter data in the following fields.
If you are upgrading from the RCF 2.5, you can refer to your backup of the
plugin.properties file for the values you should enter.

Field Description

Feed
Frequency

The frequency with which you want to collect device criticality
data from your RSA Archer Platform.

Start Date The date when you want the feed to start.

Start Time The time when you want the feed to start.

Feed
Folder
Path

The existing folder on your RCF system in which you want feed
files to be saved for retrieval by Live.

Device
Criticality
Filter

Select which device criticalities you want to include in the feed.

Create
Initial
Feed

Select whether you want the initial feed to be created immediately
upon completion of the configuration wizard or as scheduled by
the feed frequency. This setting does not affect the regular feed
schedule.

User
Name of
Security
Analytics
account
in RCF

Enter a name for a new RCF user account that RSA Security
Analytics will use to retrieve data feeds.
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Field Description

Password
of
Security
Analytics
account
in RCF

Enter a password for the new RCF user account.

Web
Server
Mode

Select the transport mode that you want to use for your web server:
TCP or SECURE_TCP.

Web
Server
Port

The port number for the web server. The default port number is
9090 for TCP and 8443 for secure TCP.

Java
Keystore
File Path

The path of the Java Keystore file you created to store the SSL
certificate for RCF.

Java
Keystore
Password

The password protecting the Java Keystore file that will be used to
store the trusted SSL Web server certificate.

Java
Keystore
Private
Key
Password

The password protecting the private key for the Java Keystore file
that you created to store the SSL certificate for the RCF.

9. Click Next.

10. In the User Name and Password fields, enter the credentials you entered when
you installed the RSA Connector Framework, and click Next.

11. On the Summary page, verify that the information is correct, and click Start
Configuration.
The VB script performs the configurations based on the data given and displays
a note asking you to enter a run-script command.

The RSA Connector Shell uses PuTTY as its SSH client. The first time that you
open PuTTY, a security alert appears and informs you that the server host key is
not cached in the registry. Select Yes to proceed.

12. Click Run Script. (If Run Script does not work the first time, try clicking the
button again.)
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When the script finishes successfully, the em application has been created from
the em plug-in and is in the Running state.

13. Restart the RSA Connector Framework.

a. Click Control Panel > Administrative Tools > Services.

b. Select RSA Connector Framework Service, and click Restart.

Configure RSA Security Analytics
To configure RSA Security Analytics for the Enterprise Management plug-in, you
must add new meta data keys so that RSA Archer asset criticality data is visible as
a new meta data element in RSA Security Analytics. Next you must also create a
recurring feed task to define the feed that RSA Security Analytics must download
from the RCF and push to Decoders.

Procedure

1. Create Criticality Category

2. Create Recurring Feed Task

Create Criticality Category
The RCF manages the files for a custom feed and deposits these files in a local
folder that you specify when you configure the RCF. The Live module of RSA
Security Analytics retrieves the feed files from this folder. Live then pushes the
feed to the Decoders, which start creating meta data based on captured network
traffic and the feed definition. To make each Concentrator aware of the new meta
data created by the Decoders, you must edit the index-concentrator-custom.xml file.

Note: If you also plan to feed Business Unit and Facility information from your
RSA Archer GRC Platform into Live, you must also add keys for these fields to the
index-concentrator-custom.xml file.

Procedure

1. In the Security Analytics Menu, click Administration > Devices.

2. Select your Concentrator, and in the Device Grid toolbar, select View > Config.

3. Click the Files tab.

4. From the drop-down list, select index-concentrator-custom.xml.

5. In the file, add a key for the new meta data element as follows:
<key description="Criticality" format="Text" level="IndexValues"
name="criticality" defaultAction="Open"/>

6. Click Apply.
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7. Click Push. Select the devices to which you want to push this file. Click OK.

8. Stop and start the Concentrator and Decoder services.

Create a Recurring Feed Task
In order for RSA Security Analytics to download feed files from your RCF machine
and push the feeds to Decoders, you must create a recurring feed task and define
the feed settings.

Procedure

1. In the Security Analytics Menu, click Live > Feeds.

2. Click [+].

3. Select Custom Feed, and click Next.

4. Select Recurring.

5. Enter a name for the feed.

6. In the URL field, enter http(s)://rcf_hostname_or_ip:port/archer/sa/feed
where http(s)://rcf_hostname_or_ip:port is the address of your RCF system. Use
https if you have enabled SSL communication with RSA Security Analytics. For
example: http://10.10.10.10:9090 or https://10.10.10.10:8443.

7. Select Authenticated, and in the User Name and Password fields, enter the
credentials of the user account you created for RSA Security Analytics to use to
access files on the RCF system in Configure the RSA Connector
Framework.

8. Define the recurrence interval for the feed.

9. In the Date Range section, define a start and end date for the feed.

10. Click Next.

11. Select each Decoder to which you want to push this feed.

12. Click Next.

13. In the Type field, ensure that IP is selected.

14. In the Index Column field, select 1.
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15. In the second column, set the Key value to criticality.

16. Click Next.

17. Review your feed configuration details, and click Finish.

Customizing and Modifying the Enterprise Management Plug-in
l Include Optional Archer Fields

l Create a New Context Menu Action

l Change Feed Settings

l Change Feed File Name

Include Optional RSA Archer Fields
By default, only the IP Address and Criticality Rating fields in the RSA Archer
Devices application are fed into RSA Security Analytics by the RCF. You can
customize the Enterprise Management plug-in to include the Business Unit and
Facility fields that are cross-referenced in the Devices application in the feed.

Procedure

1. From the \Install_Dir\EMC\RSA Connector Framework\plugins\em directory,
open em_archer5.xml for editing.
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2. Uncomment the businessunit and facility lines by removing <!-- and --> from the
ends of the line.

3. Save and close the file.

4. In the RSA Connector Shell, type:
refresh-app em

5. In the Security Analytics menu, click Administration > Devices.

6. Select your Concentrator, and in the Device Grid toolbar, select View > Config.

7. Click the Files tab.

8. From the drop-down list, select index-concentrator-custom.xml.

9. To include Business Unit meta data, add the following:
<key description="Business Unit" format="Text" level="IndexValues"
name="businessunit" defaultAction="Open"/>

10. To include Facilities meta data, add the following:
<key description="Facility" format="Text" level="IndexValues" name="facility"
defaultAction="Open"/>

11. Click Apply.

12. Click Push, select the devices to which you want to push this file, and click OK.

13. Stop and start the Concentrator and Decoder services.

14. Open the task that you created in Create a Recurring Feed Task.

15. Add two additional Key values as follows.

Column Key

3 businessunit

4 facility

16. Click Save.

17. Restart each Decoder to which you pushed these feeds and each Concentrator
to which one of these Decoders is assigned.

Create a New Context Menu Action
If you want security analysts to have the option of opening an RSA Archer session
to create a blank incident directly from the RSA Security Analytics interface, you
can create a new context menu action to perform this action.

Procedure

1. In the Security Analytics Menu, click Administration > System.

2. In the left navigation panel, click Plugins.

59 Chapter 5: Configuring the Enterprise Management Plug-in for Business Context



Installation Guide

3. Click Add (+).

4. In the Configuration field, copy and paste the following:

{     
"groupName": "externalLookupGroup",
"openInNewTab": "true",
"urlFormat": "http://yourarcherhostname/context_
base/GenericContent/Record.aspx?id=0&moduleID=75",
"moduleClasses": [
"UAP.investigation.InvestigationValuesApplication"
],
"type":"UAP.common.contextmenu.actions.URLContextAction",
"version": "1",
"id": "archerIncidentAction",
"order": "5",
"description": "",
"local": "false",
"displayName": "CreateArcherIncident",
"modules": [
"investigation"
],
"disabled": "",
"cssClasses": [
"meta-value-name-link"
]

}

where yourarcherhostname/context_base is the hostname and context base of
your RSA Archer system.

5. Click OK.

Change Feed Settings
After you have set up the Enterprise Management plug-in, if you find that you are
creating too much meta data or decide to include optional fields, you may need to
modify your feed settings.

Procedure

1. Open the plugin.properties file, located in the \Install_Dir\EMC\RSA Connector
Framework\plugins\em directory.

Note: This file contains some properties that do not apply to the Enterprise
Management plug-in and can be ignored. Only the properties listed below are
relevant to the Enterprise Management plug-in.

2. To change the feed frequency, enter a new value for the
all.import.scheduler.frequency property.
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Note: Valid values for this property are daily, weekly, and monthly.

3. To change the start date and time of the feed, enter new values for the
all.import.scheduler.start_date and all.import.scheduler.start_time properties.

Note: Values for the start date property must follow a MM/DD/YYYY format.
Values for the start time property must follow a HH:MM AM(/PM) format.

4. To change the criticality filter, enter any of the following:

a. To include devices with a "High" criticality rating in the feed, enter High for
the all.import.filter.high_criticality property.

b. To include devices with a "Medium" criticality rating in the feed, enter
Medium for the all.import.filter.medium_criticality property.

c. To include devices with a "Low" criticality rating in the feed, enter Low for
the all.import.filter.low_criticality property.

5. To change the folder location on your RCF system where feed files are stored,
enter a value or comma-separated values for the all.import.folder property.
For example, to store the feed in your C:\Program Files (x86)\EMC\RSA
Connector Framework\feeds\ folder, set the property as follows:

all.import.folder=C:\\Program Files (x86)\\EMC\\RSA Connector
Framework\\feeds

6. Save and close the file.

7. In the RSA Connector Shell, type:
refresh-app em

Change Feed File Name
By default, the feed file that the RCF produces is named assets.csv. If you want,
you can change the assets prefix to a different name.

Procedure

1. Open the plugin.properties file, located in the \Install_Dir\EMC\RSA Connector
Framework\plugins\em directory.

2. Enter a name in the all.import_file_prefix property.

3. Save and close the file.

4. Rename the assets.xml file, located in the \Install_Dir\EMC\RSA Connector
Framework\plugins\em directory, to match the new name you entered in step 2.

5. In the RSA Connector Shell, type:
refresh-app em

6. In the Security Analytics menu, click Live > Feeds.

7. Click the Recurring tab.

61 Chapter 5: Configuring the Enterprise Management Plug-in for Business Context



Installation Guide

8. Select the task that you created in Create a Recurring Feed Task, and click
Edit.

9. In the Name field, enter the new name for your feed.

10. Click Save.

11. Restart each Decoder to which you pushed this feed and each Concentrator to
which one of the Decoders is assigned.
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Appendix A: RSA Connector Framework (RCF)
Administration

This appendix provides information about the RCF and instructions on how to
manage the RSA Connector Framework Service and how to use each of the
commands available in the RSA Connector Shell.

l RCF Tasks

l Plug-In Commands

l Application Commands

l Endpoint Commands

l Help Commands

RSA Connector Framework
The RCF is a plug-and-play structure that runs as a Windows system service and
integrates RSA products together by transporting and managing product data.

RSA Connector Framework Key Components
The RCF uses the following key components:

l A plug-in associated with the specific RSA Integration. A plug-in is a component
that you can manage during runtime to create an instance of an RSA Connector
application.

l An application that you create using the plug-in. An RSA Connector application
is a program that handles the business logic and imported data from one system
and outputs that data to another system.

l An endpoint configured for the RSA Connector application. An endpoint is an
external system with which the RCF needs to communicate. An endpoint can be
either a data source or data destination.

l A data mapping file that corresponds with the RSA Connector application. A
data mapping file is an XML document that instructs the corresponding
RSA Connector application on how to interpret the data received from the source
and how to map and transport that data to its destination.

l A command shell that you use to interact with the RCF.

l A configuration wizard for the plug-in that automates the configuration of
endpoint details and creation of the application from that plug-in.

The commands that you can use for a plug-in depend on the state of the plug-in.
Plug-ins have three possible states:
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Installed. The plug-in is installed but all dependencies are not resolved.

Resolved. The plug-in is installed and all dependencies are resolved.

Active. The plug-in is installed and activated, and you can create new
applications.

Like plug-ins, the commands that you can use for an application depend on the state
of the application. Applications have three possible states:

Unconfigured. The application is created, but the validation has either failed or
has not been completed.

Stopped. The application is created and the validation is successful, or a running
application has been stopped.

Running. The application is created, configured, validated, and running.

The following figure shows the relationship between the plug-in and application
states.

Note:When you install the RSA Connector Framework, you can select which
plug-ins you want to install. When the RSA Connector Framework installation is
complete, the plug-in is in the Resolved state.

RSA Connector Framework Tasks
The RCF runs as a Windows system service. The following tasks describe how to
start and stop the service, update user credentials, and launch the command shell
through which you interact with the RCF.
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Start RSA Connector Framework
The RCF is automatically started as a Windows system service upon installation.
You can manually start the RCF if it has been stopped manually or unexpectedly.

Procedure

1. Click Control Panel > Administrative Tools > Services.

2. Select RSA Connector Framework Service, and click Start.

Start RSA Connector Shell
The RSA Connector Shell is the text-based user interface that you use to interact
with the RCF. After you install the RCF, you must start the Connector Shell to
begin interacting with the RCF.

In either of the procedures, you may be prompted for the SSH server host key.

l If you click Yes, the host key is stored in the client cache and you are not
prompted again.

l If you click No, the host key is not stored in the client cache, and you are
prompted the next time that you log on.

l If you click Cancel, you abort the connection.

Procedure

Do either of the following:

l From a new command prompt, follow these steps:

1. Change directories to \Install_Dir\EMC\RSA Connector Framework\tools.

2. Type:
"putty.exe -ssh localhost -P port -l username -pw password"

where:

l port is the port number that you specified for the RCF user interface.

l username is your RCF user name.

l password is your RCF password.

l From the Start menu, follow these steps:

1. Click All Programs > EMC > RSA Connector Framework > RSA Connector
Shell.

2. Enter your user name and password.

Change RSA Connector Framework User Credentials
Use the change credentials command to update the user name and password that
you use to connect to the RCF.
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Procedure

In the RSA Connector Shell, type:

change-ui-cred old-username old-password new-username new-password

where:

l old-username is the current user name whose credentials you would like to
change.

l old-password is current password of the user.

l new-username is the new user name of the user.

l new-password is the new password for the user.

Note: The command arguments are optional. If you do not include them, the
Connector Shell prompts you for each individual value and also prompts you to
confirm your password.

List Bundles
A bundle is an installed component of the RCF. You cannot take any actions on
bundles, but knowing what state they are in may be useful for troubleshooting. Use
the list bundles command to display all installed bundles for the RCF, and to view
the name and state of each bundle.

Procedure

In the RSA Connector Shell, type:

list-bundles

Display RSA Connector Framework Version Information

Procedure

In the RSA Connector Shell, type:

version

Stop RSA Connector Framework

Procedure

1. Click Control Panel > Administrative Tools > Services.

2. Select RSA Connector Framework Service, and click Stop.
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Restart RSA Connector Framework

Procedure

1. Click Control Panel > Administrative Tools > Services.

2. Select RSA Connector Framework Service, and click Restart.

Define Queue Settings
Each plug-in has an associated plugin.properties file, which allows you to define
settings for how the RCF handles data requests for any applications created from
that plug-in. Each property in the file begins with appname.request, where appname
is the name of the application created from the plug-in. If you want to configure a
property for every application created from the plug-in, use all as the application
name.

Procedure

1. Open the plugin.properties file, located in the \Install_Dir\EMC\RSA Connector
Framework\plugins\plugin-name directory.

2. Modify any of the settings, as follows:

l To set the queue size for incoming requests, enter a value for the
request.queue.size property.

Note: Valid values for this property are numbers between 1 and 2147483647.
The default value is 2147483647.

l To set the time interval between the processing each queued request, enter a
value for the request.queue.worker.sleep.interval property.

Note: Valid values for this property are numbers in milliseconds between 1
and n. The default value is 0, which means no delay between requests.

l To set the time interval between retry attempts for failed requests, enter a
value for the request.queue.retry.sleep.interval property.

Note: Valid values for this property are numbers in milliseconds between 1
and n. The default value is 10.

l To set the maximum number of retry attempts for failed requests, enter a
value for the request.queue.max.retry property.

Note: Valid values for this property are numbers between 1 and 2147483647.
The default value is 2147483647.

l To set whether or not the RCF loads the persisted incoming requests when
the service is started, enter a value for the
request.queue.reload.persisted.entries property.
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Note: Valid values for this property are true and false. The default value is
true.

3. Save and close the file.

Activate Silent Mode
Normally, there are certain RSA Connector Shell commands that require user
confirmation to run. You can use the silent mode on command to remove that
confirmation requirement and help with automation.

Procedure

In the RSA Connector Shell, type:

silent-mode on

The Connector Shell now no longer asks for confirmation for the following
commands:

l change-endpoint-cred

l add-endpoint-cred

l delete-endpoint-cred

l change-ui-cred

l create-app

l delete-app

l deactivate-plugin

l stop-app

l refresh-app

Deactivate Silent Mode
Normally, there are certain RSA Connector Shell commands that require user
confirmation to run. If you have previously used the silent mode on command and
wish to reinstate the command confirmation, you can use the silent mode off
command to turn off silent mode.

Procedure

In the RSA Connector Shell, type:

silent-mode off

The Connector Shell now asks for command confirmations.

Run Script
This command allows the administrator to run a batch file from the RSA Connector
Shell to perform multiple commands.
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Procedure

In the RSA Connector Shell, type:

run-script filename

where filename is the name of your script file.

If you do not specify a path, the RCF assumes that the script file is located under
\Install_Dir\EMC\RSA Connector Framework\scripts.

Note: For each command listed in the script file, the Connector Shell echoes the
command and displays the messages generated from the command.

Schedule Job to Run Immediately
Some RCF applications run jobs at a scheduled frequency. This command allows
the administrator to schedule a job to run immediately, even if the job is already
scheduled to run at a specific time. Running this command does not affect the
configured run schedule.

Procedure

In the RSA Connector Shell, type:

run-job-now app_id

where app_ID is the application ID of the application for which you want to
schedule a job.

Uninstall RSA Connector Framework
You can uninstall the RCF if necessary. When you uninstall the RCF, all of the
Framework components are uninstalled.

Note: Uninstalling the RCF does not remove the RSA Connector Framework
folder, the logs subdirectory, or any files in the logs subdirectory. To remove these
files, manually delete them.

Procedure

1. Click Start > Programs > EMC > RSA Connector Framework > Uninstall.

2. When prompted to uninstall, click Yes.

3. Click Finish.

Plug-In Commands
The following sections describe how to use each of the plug-in commands available
for RCF. For more information about plug-ins and plug-in states, see
RSA Connector Framework Key Components.
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Install a Plug-In
If you chose not to install a plug-in when you installed the RCF, you can install the
plug-in later.

Note: Only plug-ins that are located in the same folder as the RSA_Connector_
Framework_Plugin_n.nbnnn.exe file can be installed. Before you begin, ensure that
the plug-in file that you want to install is located in this folder.

Procedure

1. Double-click RSA_Connector_Framework_Plugin_n.nbnnn.exe.

2. Click Next.

3. Read and accept the license agreement, and click Next.

4. On the Select Plug-ins page, select the plug-in that you want to install, and click
Next.

5. On the Begin Install page, click Install.

6. On the Finished page, click Finish.

Activate a Plug-In
Use the activate plug-in command to activate plug-ins that are currently in the
Resolved state. After you activate a plug-in, the state changes to Active and you
can now create applications from the plug-in.

Procedure

In the RSA Connector Shell, type:

activate-plugin plugin_name

where plugin_name is the name of the plug-in that you want to activate.

Note: You can also enter the plug-in ID instead of the plug-in name.

List Plug-Ins
Use the list plug-ins command to display all installed plug-ins for the RCF and to
view the ID, current state, name, and description of each plug-in.

Procedure

In the RSA Connector Shell, type:

list-plugins
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Deactivate a Plug-In
Use the deactivate plug-in command to deactivate a plug-in that is in the Active
state. You can only deactivate a plug-in that has no existing applications created
from it. After you deactivate a plug-in, the state changes to Resolved and you may
no longer create applications from that plug-in.

Procedure

In the RSA Connector Shell, type:

deactivate-plugin plugin_name

where plugin_name is the name of the plug-in that you want to deactivate.

Note: You can also enter the plug-in ID instead of the plug-in name.

Uninstall a Plug-In
If you have previously installed a plug-in that you no longer require, you can
uninstall the plug-in.

To uninstall a plug-in:

1. Double-click RSA_Connector_Framework_Plugin_2.6bnnn.exe.

2. Click Next.

3. Read and accept the license agreement, and click Next.

4. On the Select Plug-Ins page, deselect the plug-in that you want to uninstall, and
click Next.

5. On the Begin Install page, click Install.

6. On the Finished page, click Finish.

Application Commands
The following tasks describe how you can use each of the application commands
available. For more information about applications and application states, see
RSA Connector Framework Key Components.

Create an Application
Use the create application command to create a new application from a plug-in that
is in the Active state.

Procedure

In the RSA Connector Shell, type:

create-app plugin_name app_ID mapping_file.xml

where:
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l plugin_name is the plug-in name of the Active plug-in from which you want to
create an application.

Note: You can also enter the plug-in ID instead of the plug-in name.

l app_ID is the application ID of the application that you are creating.

l mapping_file.xml is the data mapping file that you want to use.

Note: The application ID cannot be longer than 32 characters and cannot contain
spaces. The mapping file that you want to use must be located in the Install_
Dir\EMC\RSA Connector\plugins\plugin_name directory.

Validate an Application
Use the validate application command to validate the configuration of an application
if you have updated either the endpoint details or the data mapping file.

Procedure

In the RSA Connector Shell, type:

validate-app app_ID

where app_ID is the application ID of the application that you want to validate.

Start an Application
Use the start application command to start an application that is currently in the
Stopped state. An application must be started to begin transferring data.

Procedure

In the RSA Connector Shell, type:

start-app app_ID

where app_ID is the application ID of the application that you want to start.

Refresh an Application
Use the refresh application command to refresh the configuration of an application
that is in the Running state if you have updated the endpoint details or the
application data mapping file.

Note: Use the validate application command to verify your new configuration
before you refresh the application.

Procedure

In the RSA Connector Shell, type:

refresh-app app_ID

where app_ID is the application ID of the application that you want to refresh.
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List Applications
Use the list applications command to display all of the currently installed
applications for the RCF and to view the application ID, service name, and state of
each application.

Procedure

In the RSA Connector Shell, type:

list-apps

Stop an Application
Use the stop application command to stop an application that is currently in the
Running state.

Procedure

In the RSA Connector Shell, type:

stop-app app_ID

where app_ID is the application ID of the application that you want to stop.

Delete an Application
Use the delete application command to remove an application that you no longer
need from the RCF. You can only delete applications that are in the Stopped state.

Procedure

In the RSA Connector Shell, type:

delete-app app_ID

where app_ID is the application ID of the application that you want to delete.

Note:When you delete an application, the user name and password endpoint
credentials are also deleted, but the other endpoint details are not. The associated
mapping file is also not deleted. You must delete these items manually.

Endpoint Commands
When you set up endpoint details for an RSA Connector application so that the RCF
can communicate with the RSA Archer GRC Platform, you enter user credentials
through the RSA Connector Shell and enter other details directly into the
endpoint.properties file. The following tasks describe how you can use each of the
endpoint commands available.

Add Endpoint Credentials
Use the add endpoint command to enter user credentials for a new endpoint.
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Note: You must also specify the hostname, port, and instance for the RSA Archer
session with which you want to communicate. This process is done outside of the
RSA Connector Shell.

Procedure

In the RSA Connector Shell, type:

add-endpoint-cred appID endpointName username password

where

l appID is the application ID that you created in the RSA Connector Framework.

l endpointName is the name of your new endpoint.

l username is the user name that you created for this endpoint.

l password is the password that you created for this endpoint.

Note: The command arguments are optional. If you do not include them, the
Connector Shell prompts you for each individual value and also prompts you to
confirm your password.

Change Endpoint Credentials
Use the change endpoint command to update the user credentials of an existing
endpoint.

Procedure

In the RSA Connector Shell, type:

change-endpoint-cred appID endpointName username password

where

l appID is the application ID that you created in the RCF.

l endpointName is the name of your endpoint.

l username is the user name that you created for this endpoint.

l password is the password that you created for this endpoint.
The command arguments are optional. If you do not include them, the Connector
Shell prompts you for each individual value and also prompts you to confirm your
password.

List Endpoints
Use the list endpoints command to display all endpoints found in the
endpoint.properties file.

Procedure

In the RSA Connector Shell, type:
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list-endpoints appID

where appID is the application ID that you created in the RCF.

Delete Endpoint Credentials
Use the delete endpoint command to remove the user credentials for an endpoint
that you no longer need.

Procedure

In the RSA Connector Shell, type:

delete-endpoint-cred appID endpointName

where

l appID is the application ID that you created in the RCF.

l endpointName is the name of your new endpoint.

The appID argument is optional. If you do not include the argument, the Connector
Shell prompts you for it.

Important:When you delete an endpoint, the user name and password endpoint
credentials are deleted, but the RSA Archer Platform hostname, port, and instance
name are not. You must delete these items from the endpoint.properties file
manually.

Help Commands
The RSA Connector Shell features built-in help commands that allow you to view a
complete list of commands and to display more detailed information about a specific
command. The following tasks describe how to use each of the help commands.

Display All Commands
Use the help command to list all commands that are supported by the RSA
Connector Shell.

To display commands:

In the RSA Connector Shell, type:

help

The system displays a list of all available commands.

Display Specific Command
Use this procedure to display more detailed information about a particular
command. The system displays the name of the command, the correct syntax for
entering the command, and a description of what the command does.
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Procedure

In the RSA Connector Shell, type:

help command_name

where command_name is the name of the command for which you want to display
more information.
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Appendix B: Troubleshooting
This appendix provides resolutions to common problems that you may encounter
while configuring the solution.

Package Installation Log Message Examples
For more information on the Package Installation Log messages, see "Package
Installation Log Messages" in the Packaging section of the RSA Archer
GRC Platform Administrator Guide portfolio.

For information on the dependencies for each solution, see the Data Dictionary.

Warning
Message Explanation Remediation

<Object Name>
Alias was
changed from
<Original Alias>
to <New Alias>

This message is an
informational warning
indicating that the Alias was
updated on the object. There
are two reasons for an alias in
the Target Instance to have
been updated:

l Update was in the Source
Package.

l Alias has to be unique in
the Target Instance. If the
alias already exists in
Target, packaging adds a
unique identifier to the end.

This message is only potentially an issue if the
change occurs on a field that is utilized in a Mail
Merge Template or Data Publication Service. In that
scenario, update the DPS or the mail merge template
with the new alias.

<Field Name> in
the application
<Application
Name> cannot
be changed from
a private field to
a public field.

This message is an
informational warning
notifying you that packaging
does not change a private field
in the target instance to a
public field.

Change the field to public manually (optional).
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Warning
Message Explanation Remediation

Field <Field
Name> could
not be saved due
to inability to
identify the
related module.

This message is seen when a
cross-reference or related record
field could not be created
because the related application
does not exist in the target
instance. This message usually
occurs because the field is part
of a related core solution that
has not been updated in the
target instance.

1. Install the package for the solution containing
the related application. You must have a license
for the related application.

2. Reapply the original package to resolve the
warning.

See the Data Dictionary.

The calculated
field <Field
Name> in the
application
<Application
Name> cannot
be verified.

The formula in the calculated
field is incorrect. Most often,
this message occurs when the
formula references a field in a
related application and either
the field or the application
does not exist in the target
instance. This may be because
the application is in a related
core solution that has not been
updated.

1. Install the package for the solution containing
the related application. You must have a license
for the related application.

2. Reapply the original package to resolve the
warning.

See the Data Dictionary.

Field <Field
Name> was not
found and
removed from a
collection.

This warning may be seen on
Inherited Record Permission
fields, cross-reference/related
record fields (record lookup
and grid display), or as a dis-
play field in a report. The warn-
ing means that the field could
not be found in the target
instance and was not included
in the package. This is usually
because the field is part of an
application in a related core
solution that has not been
updated in the target instance.

1. Install the package for the solution containing
the related application (to obtain the missing
field). You must have a license for the related
application.

2. Reapply the original package to resolve the
warning.

See the Data Dictionary.

Note: If you do not have a license for the related
application, you may ignore this message, and the
field remains omitted from the object.

The following
access role
referenced on the
Access tab could
not be resolved:
<Role Name>

This message occurs because
access roles are not included in
the package and you must cre-
ate them manually. Packaging
cannot reference the system
IDs of the new access roles
that you created.

Add the access roles to the referenced items
manually.

See the Data Dictionary.
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SecOps Plug-in Setup Troubleshooting
If you finish configuring the SecOps plug-in, but RSA Security Analytics alerts are
not appearing as incidents in your RSA Archer GRC Platform, use the following
table to help identify the source of the issue and resolve the problem. The left-hand
column lists specific items to check, the middle column tells you how to determine
if this item is your issue, and the right-hand column gives potential resolutions for
each issue. If any of the resolutions do not solve the problem, contact RSA
Customer Support.
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Checklist Item How to Determine Resolution

Are alerts being
generated in RSA
Security Analytics?

l On Security Analytics 10.2 SP2, select Alerter >
Schedule, and note whether the alert count has
increased.

l On Security Analytics 10.3 or 10.3 SP1, select
Alerting > Summary, and in the Alerts section note
whether the alert count has increased.

l On Security
Analytics 10.2
SP2, do the
following:

1. In the Security
Analytics
menu, select
Alerter >
Define.

2. Select the alert,
and click Edit.

3. Ensure that
Push to
Decoders is
selected.

ll On Security
Analytics 10.3, do
the following:

1. Click
Reporting >
Alerts.

2. Select the alert,
and ensure that
it is enabled
and pushed to
decoders.

l  On Security
Analytics 10.3
SP1, do the
following:

1. Click
Reporting >
Manage.

2. Click the Alert
tab.

3. Select the alert,
and ensure that
it is enabled
and pushed to
decoders.

80 Appendix B: Troubleshooting



Installation Guide

Checklist Item How to Determine Resolution

Is your RSA Security
Analytics system
reachable from your
RCF system?

Log on to your RCF machine, open a command prompt,
and ping your RSA Security Analytics system.

Try to log on to your
RSA Security
Analytics system. If
you are not
successful, contact
your administrator.

Are alerts leaving
your RSA Security
Analytics system
through syslog?

On your Security Analytics system, run a tcpdump
command.

Double check the
values that you
entered in Configure
the Syslog Output
Action.

Is your RSA Archer
system reachable from
your RCF system?

Log on to your RCF machine, and do the following:

1. Open a command prompt and ping your RSA Archer
system.

2. Open a web browser and log on to your RSA Archer
system using the WebServices user account that you
created for the RCF in Create a User Accountfor
the RSA Archer GRC Platform Web
Service Client.

If you are not
successful at step 1,
contact your network
administrator.

If the RSA Archer
Platform logon page
does not render in
step 2, reset Internet
Information Services
(IIS) on the RSA
Archer web server, as
follows:

1. Log on to the
Windows system
hosting the RSA
Archer Platform.

2. Open a command
prompt. Type:

iisreset
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Checklist Item How to Determine Resolution

Does the WebServices
user account created
for the RCF have the
correct credentials and
access rights?

Log on to your RCF system, open a web browser, and
log on to your RSA Archer system using the
WebServices user account that you created for the RCF
in Create a User Account for the RSA Archer
GRC Platform Web Service Client.

Do the following:

l Review the logon
credentials and
access rights for
the WebServices
user account that
you created in
Create a User
Account for the
RSA Archer
GRC Platform
Web
Service Client.

l Verify that the
user credentials
selected in
the RSA Archer
system match what
you entered in the
RCF Configuration
Wizard. If you
need to change the
credentials, see
Change
Endpoint
Credentials.

Are there TLS or SSL
errors found within
the RCF logs?

1. Open \Install_Dir\EMC\RSA Connector
Framework\logs to view the logs.

2. Check to see if there is an error message as seen in
the example below:

SEVERE: app_ID - Error occured while storing data
into archer.... Caused by: org.apache.felix.log.
LogException: javax.wsdl. WSDLException:
WSDLException: faultCode=PARSER_ERROR:
Problem parsing '_
https://10.100.0.1:443/archer/ws/general.asmx?wsdl'.:
java.io.IOException: HTTPS hostname wrong:
should be <10.100.0.1>

Ensure that the RSA
Archer TLS or SSL
certificate hostname
or IP address matches
the hostname or IP
address that you
entered in step 3 of
Configure the for
TLS or SSL
Communication
with the RSA
Archer GRC
Platform.
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Checklist Item How to Determine Resolution

Is the RCF configured
properly?

l Are the bundles
installed properly?

Use the list bundles command to verify the status of each
bundle.

Restart the RSA
Connector Framework
Service, and recheck
the bundles.

l Is the RSA
Connector
Framework Service
running?

Click Start > Administrative Tools > Services, and see if
the RSA Connector Framework Service is running.

Start the RSA
Connector Framework
Service. See Start
RSA Connector
Framework.

l Is the plug-in in
the Active state?

Use the list-plugins command to ensure that the plug-in
is in the Active state.

Activate the plug-in.

l Is the application
in the Running
state?

Use the list-apps command to ensure that the application
that you created is in the Running state.

Start the application.

l Is the syslog server
installed properly?

On your RCF system, run the following command, and
see if the syslog server port is in the listening state.
Type:

netstat -a | find "port_number"

where port_number is the port number that you
configured in Configure the Syslog Output Action.

Restart the RSA
Connector Framework
Service.

l Are the
endpoint.properties
details entered
properly?

Open \Install_Dir\EMC\RSA Connector
Framework\plugins\secops\endpoint.properties

If you need to make
any changes, follow
the instructions for
changing the
configuration of an
application in the
Running state in
Component
Troubleshooting.
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Checklist Item How to Determine Resolution

l Are the
plugin.properties
details entered
properly?

Open \Install_Dir\EMC\RSA Connector
Framework\plugins\secops\plugin.properties.

If you need to make
any changes, follow
the instructions for
changing the
configuration of an
application in the
Running state in
Component
Troubleshooting.

l Do the log files
indicate errors or
exceptions?

Open \Install_Dir\EMC\RSA Connector Framework\logs
to view the logs.

Contact Customer
Support.

Enterprise Management Plug-In Setup Troubleshooting
If you finish configuring the Enterprise Management plug-in, but RSA Archer asset
criticality information is not showing up in RSA Security Analytics, use the
following table to help identify the source of the issue and resolve the problem. The
left-hand column lists specific items to check, the middle column tells you how to
determine if this item is your issue, and the right-hand column gives potential
resolutions for each issue. If any of the resolutions do not solve the problem, contact
RSA Customer Support.

Checklist Item How to Determine Resolution

Is your Archer
Devices application
populated with
device and criticality
information?

1. On the RSA Archer Platform, expand the Enterprise
Management solution in the Navigation Menu.

2. Expand the Devices application, and click Display
All.

3. Open a device record and note whether the
Criticality Rating field is populated.

Contact RSA
Professional Services
for assistance.

Is the asset criticality
.csv feed file located
in the file you
specified?

On your RCF system, open the folder that you specified
for the feed file location in Configure the RSA
Connector Framework and note whether the feed file
is present.

Review the following
items.
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Checklist Item How to Determine Resolution

l Is your RSA
Archer system
reachable from
your RCF system?

Log on to your RCF machine, and do the following:

1. Open a command prompt and ping your RSA Archer
system.

2. Open a web browser and log on to your RSA Archer
system using the WebServices user account that you
created for the RSA Connector Framework in
Create a User Account for the RSA Archer
GRC Platform Web Service Client.

If you are not
successful at step 1,
contact your network
administrator.

If the RSA Archer
Platform logon page
does not render in step
2, reset Internet
Information Services
(IIS) on the RSA
Archer web server, as
follows:

1. Log on to the
Windows system
hosting the RSA
Archer Platform.

2. Open a command
prompt. Type:

iisreset

Appendix B: Troubleshooting 85



Installation Guide

Checklist Item How to Determine Resolution

l Does the
WebServices user
account created for
the RCF have the
correct credentials
and access rights?

Log on to the system on which you installed the RCF,
open a web browser and log on to your RSA Archer
system using the WebServices user account that you
created for the RCF in Create a User Account for
the RSA Archer GRC Platform Web
Service Client.

Do the following:

l Review the logon
credentials and
access rights for the
WebServices user
account that you
created in Create
a User Account
for the RSA
Archer
GRC Platform
Web
Service Client.

l Verify that the user
credentials selected
in the RSA Archer
system match what
you entered in the
RCF Configuration
Wizard. If you need
to change the
credentials, see
Change Endpoint
Credentials.

Are there TLS or SSL
errors found within
the RCF logs?

1. Open \Install_Dir\EMC\RSA Connector
Framework\logs to view the logs.

2. Check to see if there is an error message as seen in
the example below:
SEVERE: app_ID - Error occured while storing data
into archer.... Caused by: org.apache.felix.log.
LogException: javax.wsdl. WSDLException:
WSDLException: faultCode=PARSER_ERROR:
Problem parsing '_
https://10.100.0.1:443/archer/ws/general.asmx?wsdl'.:
java.io.IOException: HTTPS hostname wrong:
should be <10.100.0.1>

Ensure that the RSA
Archer TLS or SSL
certificate hostname or
IP address matches the
hostname or IP address
that you entered in
step 3 of Configure
the for TLS or SSL
Communication
with the RSA
Archer GRC
Platform.

Is the RCF configured
properly?
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Checklist Item How to Determine Resolution

l Are the bundles
installed properly?

Use the list bundles command to verify the status of
each bundle.

Restart the RSA
Connector Framework
Service, and recheck
the bundles.

l Is the RCF Service
running?

Click Start > Administrative Tools > Services, and see if
the RCF Service is running.

Start the RCF Service.
See Start RSA
Connector
Framework.

l Is the plug-in in
the Active state?

Use the list-plugins command to ensure that the plug-in
is in the Active state.

Activate the plug-in.

l Is the application
in the Running
state?

Use the list-apps command to ensure that the application
that you created is in the Running state.

Start the application.

l Are the
endpoint.properties
details entered
properly?

Open \Install_Dir\EMC\RSA Connector
Framework\plugins\em\endpoint.properties

If you need to make
any changes, follow
the instructions for
changing the
configuration of an
application in the
Running state in
Component
Troubleshooting.

l Are the
plugin.properties
details entered
properly?

Open \Install_Dir\EMC\RSA Connector
Framework\plugins\em\plugin.properties.

If you need to make
any changes, follow
the instructions for
changing the
configuration of an
application in the
Running state in
Component
Troubleshooting.

l Do the log files
indicate errors or
exceptions?

Open \Install_Dir\EMC\RSA Connector Framework\logs
to view the logs.

Contact Customer
Support.

Did the recurring task
run correctly?

1. In the Security Analytics menu, click Live > Feeds.

2. Note the task you created, when it last ran, and what
the last run result was.

Review the following
items.
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Checklist Item How to Determine Resolution

l Is your RSA
Security Analytics
system reachable
from your RCF
system?

Log on to your RCF system, open a command prompt,
and ping your RSA Security Analytics system.

Try to log on to your
RSA Security
Analytics system. If
you are not successful,
contact your
administrator.

l Does the RCF user
account created for
Security Analytics
to use have the
right credentials?

Review the logon credentials and access rights that you
entered for Security Analytics to access the RCF in
Create a Recurring Feed Task match the values
that you entered in Configure the RSA Connector
Framework.

l Enter the correct
credentials in the
recurring feed task,
save the task, and
restart any
Decoders to which
the feed is pushed.

Does the new meta
data category appear
in the Investigation
Module?

In the Security Analytics menu, click Investigation >
Navigate, and select a device to investigate, and see
whether the Criticality report is visible.

Note: If you do not see the report, check to see if the
report contains any results for the active query. The list
of reports that contain no results is at the bottom of the
collection screen.

Do the following:

l Review Create
Criticality
Category.

Note: Double
check that you
have restarted the
Concentrator after
editing the index
file.

Does the Criticality
report contain results?

In the Investigation Module, locate the Criticality report
and see if it lists report values and associated session
counts.

Do the following:

l Verify that the
name attribute of
the key that you
entered in the
index-concentrator-
custom.xml file
matches the name
of the key value
you entered in
Create a
Recurring Feed
Task.
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Component Troubleshooting
The following table lists common component problems and their resolutions. If any
of the resolutions do not solve the problem, contact RSA Customer Support.

Component Problem Resolution

RSA Archer
GRC
Platform

Password for an RSA Archer WebServices
user account is about to expire.

To change the password for the RSA
Archer WebServices user account, follow
these steps:

1. On your RSA Archer system, do the
following:

a. Click Administration > Access
Control > Manage Users.

b. Select the WebServices user
account.

c. In the Account Maintenance
section, click Change Password.

d. Enter a new password, confirm the
password, and click OK.

e. Click Save.

2. In the RSA Connector Framework
Shell, do the following:

a. Stop the application. See Stop an
Application.

b. Change the endpoint credentials
using the new password. See
Change Endpoint Credentials.

c. Validate the application. See
Validate an Application.

d. If the validation is successful,
refresh the application. See
Refresh an Application.

e. Start the application. See Start an
Application.
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Component Problem Resolution

During the package import process, the
following warning messages may appear.

"Field {0} was not found and removed from
a collection."

These errors are benign and can be ignored.

The Incident Status dashboard still appears
in your workspace after upgrading from RSA
Advanced Incident Management for Security
1.1. This dashboard is not required for RSA
Security Operations Management.

Remove the dashboard from your
workspace, as follows:

1. Click Administrations > Workspaces
and Dashboards > Manage Workspaces.

2. Open the Security Operations
Management workspace.

3. Click the Dashboards tab.

4. For the Incident Status dashboard, click
Remove in the Actions column.

5. Click Save.

RSA
Connector
Framework

Cannot log on to RSA Connector Shell. Confirm that you do not have another
instance of the RSA Connector Shell
already running.
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Component Problem Resolution

Need to change configuration of an
application that is currently in the Running
state.

If you need to update any of the existing
configuration files, follow these steps:

1. Stop the application. See Stop an
Application.

2. Change the configuration files (data
mapping file, endpoint properties, or
plugin properties).

3. Validate the application. See Validate
an Application.

4. Start the application. See Start an
Application.

If you want to use a different mapping file,
follow these steps:

1. Stop the application. See Stop an
Application.

2. Delete the application. See Delete an
Application.

3. Create the application again and
specify the new mapping file. See
Create an Application.

4. Create the endpoint again. See Create
an Endpoint.

5. Validate the application. Validate an
Application.

6. Start the application. Start an
Application.
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RSA Connector Framework does not support
internationalization of RSA Archer content.

1. Stop the RSA Connector Framework
Service. See Stop the RSA
Connector Framework.

2. In the Install_Dir\EMC\RSA Connector
Framework\system\felix\wrapper\conf\
directory, open wrapper.conf for
editing.

Note: You must have administrative
privileges to edit this file.

3. Add the following additional
parameter:

wrapper.java.additional.8=-
Dfile.encoding=UTF-8

4. Save and close the file.

5. Start the RSA Connector Framework
Service. See Start the RSA
Connector Framework

The Configuration Wizard displays the
following error message:

Line 2251
Char 6
Error Permission denied
Code 800A0046
Source Microsoft VBScript runtime error

Close the Configuration Wizard, wait a
minute, and restart the wizard.

The Configuration Wizard displays the
following error message:

Line 453
Char 5
Error the object invoked has disconnected
from its clients
Code 80010108
Source (null)

Close the Configuration Wizard, wait a
minute, and restart the wizard.
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Component Problem Resolution

You accidentally deleted the felix.properties
file in the Install_Dir\EMC\RSA Connector
Framework\config folder or it has become
corrupted.

Run the RSA Connector Framework
installer, as follows:

1. Double-click RSA_Connector_
Framework_2.6bnnn.exe.

2. When prompted to update your current
installation, click Yes.

3. Click Finish.

You accidentally deleted the rsa_connector_
shell.bat file in the Install_Dir\EMC\RSA
Connector Framework\bin directory or it
became corrupted, and after you run the
repair installer for the RSA Connector
Framework, the RSA Connector Shell
displays the following message, "Network
error: Connection refused." The repair
installer cannot recreate the rsa_connector_
shell.bat file. You must do so manually.

1. In the Install_Dir\EMC\RSA Connector
Framework\bin directory, create a new
file called rsa_connector_shell.bat.

2. In the file, enter the following:
REM Replace Install_Dir and Port_
Num with values selected by the
user during installation.

Install_Dir\EMC\RSA Connector
Framework\tools\putty.exe" -ssh
localhost -P Port_Num

3. Replace Install_Dir with the directory
where you installed the RSA Connector
Framework.

4. Replace Port_Num with the user
interface port number that you entered
when you first installed the RSA
Connector Framework.

5. Save and close the file.
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Component Problem Resolution

The following warning messages may appear
in the RSA Connector Framework logs after
installation.

WARNING: Exception occurred while
fetching binary value from vault for key
app_ID.endpointname.username: Error: -31
LockBox::retrieveBinaryItemSize : The
requested lockbox entry could not be found.

WARNING: Error occurred while loading
Plugin Folder's Install_Dir\EMC\RSA
Connector Framework\plugins\plugin-name
plugin.properies file. File may not be
required.

WARNING: No items found in persisted
cache queue app_ID_request_queue_cache.

These messages do not affect any
functionality and can be ignored.

The following message may appear in the
RSA Connector Framework logs.

SEVERE: Crossed referenced tracking id not
found for field name Field Name for
application Name.

This message indicates that there is a value
in the Security Analytics alert for which
there is no record in your RSA Archer
Devices application. You may see this mes-
sage for the source IP, destination IP, or
device IP fields. To resolve the issue, you
can add a record for the missing value in
your Devices application.

You are unable to edit RSA Connector
Framework configuration files, such as
plugin.properties or endpoint.properties.

1. Open a text editor with escalated
administrative privileges. For example,
right-click notepad.exe, and select run
as administrator.

2. Use this instance of the text editor to
open, modify, and save the
configuration files.
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Component Problem Resolution

The following error messages appear in the
RSA Connector Framework logs.

SEVERE: app_ID - Error occured while
handling incoming data

Causedby:org.apache.felix.log.LogExceptio
n: java.net.SocketTimeoutException

The connection between the RSA
Connector Framework and the RSA Archer
Web Services may time out if Archer is
busy. You can modify the amount of time
that the RSA Connector Framework waits
for a response from the RSA Archer Web
Services before timing out.

1. Open the plugin.properties file, located
in the \Install_Dir\EMC\RSA
Connector Framework\plugins\plugin_
name directory.

2. Modify either of the following:

l To set how quickly the connection
with the RSA Archer Web Services
times out if there is no response from
the RSA Archer Platform when the
application tries to send requests,
enter a value for the
archer.ws.client.request.send.timeout
property.

Note: Valid values for this property
are numbers in milliseconds between
1 and n. The default value is 30000.

l To set how quickly the connection
with the RSA Archer Web Services
times out if there is no response from
the RSA Archer Platform when the
application tries to read responses,
enter a value for the
archer.ws.client.response.read.timeou
t property.

Note: Valid values for this property
are numbers in milliseconds between
1 and n. The default value is 60000.

Default logging level does not provide
enough information.

1. Open the logging.properties file,
located in the \Install_Dir\EMC\RSA
Connector Framework\config directory.

2. Change the
java.util.logging.FileHandler.level
property to ALL.
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