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Preface

About This Guide
This guide is for RSA® Archer® GRC administrators who need to install the RSA
Archer Security Operations Management 1.2 solution. For more information, see
the RSA Archer Online Documentation.

This guide assumes that the reader is knowledgeable about the GRC industry and
RSA Archer GRC.

RSA Archer Documentation
You can access the RSA Archer documentation from the RSA Archer Exchange
and RSA Archer Community.

Documentation Location

Platform On the RSA Archer Community at:
https://community.emc.com/community/connect/grc_
ecosystem/rsa_archer

Solutions, Applications,
and Content

On Content tab on the RSA Archer Exchange at:
https://community.emc.com/community/connect/grc_
ecosystem/rsa_archer_exchange

RSA continues to assess and improve the documentation. Check the RSA Archer
Community and RSA Archer Exchange for the latest documentation.

RSA Security Analytics Documentation
For information about RSA Security Analytics, see the following documentation:

Guide Description

RSA Security Analytics Help The RSA Security Analytics Help provides
information needed to understand and use RSA
Security Analytics features. It contains topics and
tutorials to help you learn the basics of the user
interface, system configuration, and analysis
concepts. In addition, troubleshooting information
for common situations is added on a continuous
basis.
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You can access this reference material from the RSA Security Analytics Unified
Dashboard.

RSA Archer Security Operations Management Data Dictionary
The RSA Archer Security Operations Management Data Dictionary contains
configuration information for the solution.

You can obtain the Data Dictionary for the solution by contacting your RSA Archer
Account Representative or calling 1-888-539-EGRC.

Support and Service

Customer Support
Information

www.emc.com/support/rsa/index.htm

Customer Support
E-mail

archersupport@rsa.com

Other Resources
RSA Archer Community enables collaboration among GRC clients, partners, and
product experts. Members actively share ideas, vote for product enhancements, and
discuss trends that help guide the RSA Archer product roadmap.
https://community.emc.com/community/connect/grc_ecosystem/rsa_archer

RSA Archer Exchange is an online marketplace dedicated to supporting GRC
initiatives that delivers on-demand applications with service, content, and
integration providers to drive the success of RSA Archer clients.
https://community.emc.com/community/connect/grc_ecosystem/rsa_archer_
exchange

RSA Solution Gallery provides information about third-party hardware and software
products that have been certified to work with RSA products. The gallery includes
Secured by RSA Implementation Guides with instructions and other information
about interoperation of RSA products with these third-party products.
https://gallery.emc.com/community/marketplace/

RSA SecurCare Online (SCOL) provides unlimited access to a wealth of resources
on the Web, 24 hours a day. The secure system provides members access to a
support knowledgebase, to download current platform patches and bug fixes, to sign
up for notifications, to manage your support cases and more.
https://knowledge.rsasecurity.com/
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Chapter 1: RSA Archer Security Operations
Management

l RSA Archer Security Operations Management

l RSA Archer Security Operations Management Architecture

l RSA Archer Security Operations Management Files

l RSA Archer Security Operations Management Requirements

l Prepare to Install and Configure RSA Archer Security Operations
Management

RSA Archer Security Operations Management
The RSA Archer Security Operations Management solution enables you to
aggregate all actionable security alerts, allowing you to become more effective,
proactive, and targeted in your incident response and SOC management.

RSA Archer Security Operations Management helps you do the following:

l Prioritize and respond faster to security incidents by leveraging business context
and actionable threat intelligence.

l Engage key business and IT stakeholders in the incident management process.

l Simplify incident investigation and breach response procedures through industry
best practice methodologies and response procedures.

l Optimize SOC investments through SOC KPI (key performance indicators)
monitoring and staff time management tracking.

RSA Archer Security Operations Management Components
RSA Archer Security Operations Management is composed of the following:

l RSA Archer Security Operations Management solution
o Incident Response subsolution
o Data Breach Response subsolution
o SOC Program Management subsolution
o Issue Management subsolution

l Integrations with a SIEM tool:
o RSA Security Analytics. For more information, see Integrations with RSA

Security Analytics.

Chapter 1: RSA Archer Security Operations Management 10
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o Other supported third-party SIEM tools. For more information, see the RSA
Archer Exchange.

Important: The RSA Archer Enterprise Management solution is also required for
RSA Archer Security Operations Management to be fully functional.

RSA Archer Security Operations Management Architecture
The following figure shows the architecture of the integrations between RSA
Archer Security Operations Management and RSA Security Analytics and the flow
of data.

Note: RSA Archer Security Operations Management can also integrate with other
SIEM tools to feed alerts into the solution. For information on supported third-party
integrations, see the RSA Archer Exchange.

Integrations with RSA Security Analytics
RSA Archer Security Operations Management can integrate with RSA Security
Analytics using two different pieces of middleware:

l SA IM Integration Service

l RSA Connector Framework

Chapter 1: RSA Archer Security Operations Management 11
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SA IM Integration Service

The SA IM Integration Service integrates the RSA Archer Security Operations
Management solution with the RSA Security Analytics Incident Management
module. You can choose one of the following integration options: 
o Manage the full incident workflow in RSA Archer Security Operations

Management. If you select this option, the SA IM Integration Service transports
incidents from the Security Analytics Incident Management module into the
solution.

o Manage the incident workflow in the Security Analytics Incident Management
module and allow analysts the option to escalate remediation tasks and open data
breaches for management and remediation in the RSA Archer Security
Operations Management solution. If you select this option, the SA IM Integration
Service transports remediation tasks (created as Findings), data breaches, or
both.

Note: You must configure the same option in both RSA Security Analytics and
the SA IM Integration Service.

RSA Connector Framework

The RSA Connector Framework (RCF), using the Enterprise Management plug-in,
provides context around the assets that are most critical to your organization by
automatically feeding critical asset information from your RSA Archer Enterprise
Management solution through the RCF into RSA Security Analytics as meta data.
In Security Analytics, security analysts can prioritize an investigation based on the
assets most critical to the organization, using the asset criticality and other meta
data fed from your RSA Archer system. Security analysts can also use the meta
data to create rules and alerts to identify network and log events happening on
critical assets.

RSA Archer Security Operations Management Files
The RSA Archer Security Operations Management file RSA_Archer_Security_
Operations_Management_1.2.zip includes the following files:

l Solution install package, RSA_Archer_Security_Operations_Management_1.2_
Install_Package.zip

l RSA_Archer_Security_Operations_Management_1.1_Data_Feeds.zip

l Security_Operations_-_Generate_Breach_Tasks.dfx5

l Security_Operations_-_Generate_Incident_Response_Procedures_and_
Tasks.dfx5

Chapter 1: RSA Archer Security Operations Management 12
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l Security_Operations_-_Not_Applicable_Breach_Tasks.dfx5

l Security_Operations_-_Not_Applicable_Incident_Response_Tasks.dfx5

To set up the integration between your RSA Archer and RSA Security Analytics
systems, you also need RSA_Unified_Collector_Framework.zip. The master
installer bundles all the files needed to install both the RSA Connector Framework
(RCF) and SA IM Integration Service.

Note: The solution also provides ACD CSV Files.zip, RSA Advanced Cyber
Defense (ACD) incident response procedures and tasks that you can import and
use.

RSA Archer Security Operations Management Requirements
Before installing the RSA Archer Security Operations Management 1.2 solution,
you must meet the requirements for the following components:

l RSA Archer GRC

l RSA Security Analytics

l Middleware System

RSA Archer GRC Requirements

Requirement Details

RSA Archer GRC Platform 5.4 SP1 P1, 5.5, or
5.5 SP1

The RSA Archer Security Operations
Management solution is designed to
work with specific versions of the
Platform.

A user account on the RSA Archer GRC
Exchange

You must have a user account to the
Exchange to download the solution
files.

An RSA Archer license that gives you access
to the most current version of RSA Archer
Security Operations Management

RSA Archer Security Operations
Management 1.2

RSA Archer Enterprise Management 4 This guide assumes that you have
installed the RSA Archer Enterprise
Management 4 solution. For
installation instructions, see RSA
Archer Enterprise Management 4
Installation Guidehaha,.

Chapter 1: RSA Archer Security Operations Management 13
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Requirement Details

A valid license for Microsoft Bing Maps You must have an active license to
Microsoft Bing Maps to use the Bing
maps iView in the Incident
Coordinator dashboard.

For the Enterprise Management plug-in, your
RSA Archer Devices application is populated
with the IP addresses, criticality rating
information, and the business unit and facilities
cross-references that you want to transfer to
your RSA Security Analytics system.

The Enterprise Management plug-in
pulls data from your Devices
application.

If you need assistance populating your
RSA Archer system with data, RSA
strongly recommends that you engage
the Professional Services group.
Contact your RSA Sales
Representative to arrange an
engagement.

RSA Security Analytics Requirements

Requirement Details

RSA Security
Analytics
10.4

To fully enable the RSA Archer Security Operations Management
solution, a specific version of RSA Security Analytics must be installed
and running, with the Security Analytics Incident Management module
configured.

Chapter 1: RSA Archer Security Operations Management 14
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Middleware System Requirements

Requirement Details

An independent system running either
of the following:

l Microsoft Windows Server 2008
R2 DataCenter edition or higher

l Microsoft Windows Server 2012

RSA also recommends that this
system has 8 GB RAM with a dual
core processor and minimum of
1.5GB of available hard drive space.

Important: If you have previously
installed the RCF on a 32-bit system,
you can upgrade your installation of
the RCF on that system, but you must
install the SA IM Integration Service
on a separate 64-bit system.

The system needs to reach both your RSA
Security Analytics system and your RSA Archer
Platform, and is where you can install the the
SA IM Integration Service and the RSA
Connector Framework. You can install both on
the same system or on separate systems.

Make sure that the time on your middleware
system and the RSA Archer Platform are
synchronized or with a difference of no more
than a minute.

Java Runtime Environment (JRE) 7 The SA IM Integration Service requires the use
of this software.

Windows security updates Ensure that all Windows security updates are
applied to your system prior to installing the
middleware.

Prepare to Install and Configure RSA Archer Security Operations
Management

Procedure

1. Ensure that you have access to the following:

l RSA Archer GRC Platform Help

l RSA Archer GRC Platform Control Panel Help

2. Read and understand the "Managing Packages" section of the RSA Archer
GRC Platform Help.

3. Obtain the Data Dictionary for the solution by contacting your RSA Archer
Account Representative or calling 1-888-539-EGRC. The Data Dictionary
contains the configuration information for the solution.

Chapter 1: RSA Archer Security Operations Management 15
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4. Determine what components you want to set up:

a. For all scenarios, install the solution. See Installing RSA Archer Security
Operations Management.

b. If you plan to configure an alert source, install middleware. See Setting Up
the Integration Middleware.

c. If you want to use RSA Security Analytics as an alert source, see Setting
up the Integration with RSA Security Analytics Incident Management.

d. If you want to send business context from your RSA Archer system to RSA
Security Analytics, configure the Enterprise Management plug-in. See
Configuring the Enterprise Management Plug-in and Customizing the
Enterprise Management Plug-in.

e. If you want to integrate a third-party SIEM tool as an alert source, see the
RSA Archer Exchange for installation and configuration details.

Chapter 1: RSA Archer Security Operations Management 16
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Chapter 2: Installing the RSA Archer Security
Operations Management Solution

l Upgrading from RSA Advanced Incident Management for Security 1.1

l Upgrading from RSA Archer Security Operations Management 1.0 or 1.1

l Install and Configure RSA Archer Security Operations Management

Upgrading from RSA Advanced Incident Management for Security 1.1
If you are upgrading from RSA Advanced Incident Management for Security 1.1,
follow the process to install the RSA Archer Security Operations Management
solution in this chapter. There are extra steps that you must perform noted in the
individual sections. RSA also recommends that prior to upgrading you ensure that
all your existing security incidents are closed (have a status of Resolved or Invalid).
If you upgrade open incidents, some fields that are not required become set to
required and users are prompted to fill them out when they edit the record. If you
want to upgrade but have open incidents that are not ready to be closed, contact
RSA Archer Professional Services for additional assistance.

Upgrading from RSA Archer Security Operations Management 1.0 or
1.1

If you are upgrading from RSA Archer Security Operations Management 1.0 or 1.1,
follow the process to install the RSA Archer Security Operations Management
solution in this chapter. RSA strongly recommends contacting Professional Services
for assistance upgrading and migrating your data.

Please note the following important items before beginning the upgrade:

l Custom modifications made to the solution are not automatically preserved
during the upgrade process. For example, if you modified a packaged field to
make it required in RSA Archer Security Operations Management 1.0 or 1.1,
your changes may be overwritten when you upgrade to version 1.2 if you select
Create New and Update during the installation. If you have made extensive
modifications to your existing solution, RSA recommends contacting Professional
Services prior to upgrading.

l If you are upgrading from RSA Security Operations Management 1.0, consider
the following:

o In RSA Archer Security Operations Management 1.1, the SOC Procedure
Library was divided into the Breach Response Procedure Library and the
Incident Response Procedure Library. During the upgrade process, all

Chapter 2: Installing the RSA Archer Security Operations Management Solution 17
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procedures that were stored in the original SOC Procedure Library
application, including both breach and incident procedures, reside in the
Breach Response Procedure Library until incident response procedure data is
migrated.

o The Incident Response Procedure Library and Incident Response Procedures
applications were leveled in 1.1. Data from the 1.0 SOC Procedure Library
and Incident Response Tasks applications should now reside at the lower
level of these applications. Any existing data that you have stored in the 1.0
SOC Procedure Library and Incident Response Tasks applications should be
exported prior to upgrade and re-imported into the lower level afterward. You
may also need to create new procedures to group your tasks.

Upgrade from RSA Archer Security Operations Management 1.0

Procedure

1. Export Incident Response Procedures from the SOC Procedure Library
Application

2. Export Incident Response Tasks from the Incident Response Tasks
Application

3. Install and Configure RSA Archer Security Operations Management 1.2

4. Import Migrated Data into the Incident Response Procedure Library
Application

5. Import Migrated Data into the Incident Response Procedures Application

Install and Configure RSA Archer Security Operations Management

Procedure

1. Download the Solution File from the RSA Archer Exchange

2. Back Up the Database

3. Import the Solution Install Package

4. Update the License Key

5. Perform Advanced Package Mapping

6. Install the Solution Install Package

7. Review the Package Installation Log

8. Create the Security Operations Management Group

9. Create a New Crisis Event Status

10. Configure Bing Maps

11. Create a User Account for the RSA Archer Web Service Client

Chapter 2: Installing the RSA Archer Security Operations Management Solution 18
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12. RSA Archer Security Operations Data Feeds

13. Importing ACD Content

14. Perform Post-Install Activities

15. Test the Solution

Export Incident Response Procedures from the SOC Procedure
Library Application

Complete this topic only if you are upgrading from RSA Archer Security Operations
Management 1.0.

In version 1.1, the SOC Procedure Library was renamed to Breach Response
Procedure Library. You must export and delete your incident response procedures
prior to upgrading to ensure that the Breach Response Procedure Library contains
only breach response procedures.

Procedure

1. From the Navigation Menu, expand the SOC Procedure Library application and
click Search Records.

2. In the Fields to Display section, from the Available menu, select the following
required fields:

l Name

l Description

l Incident Categories

l Priority

l Required/Optional

l Target

3. In the Filters section, enter the specific value for each respective filter to search
for only the incident response procedures.

Filter Value to Enter

Field to Evaluate Type

Operator Equals

Values Incident

4. Click Search.

5. Click Export.

6. In the Export Options dialog, select CSV.

Chapter 2: Installing the RSA Archer Security Operations Management Solution 19
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7. In the Warning pop-up, select Exclude all HTML formatting tags. Click OK.

8. Save your file to a location on your hard drive.

9. Delete the incident response procedures from the SOC Procedure Library.

10. Separate Incident Response Procedures and Tasks.

Export Incident Response Tasks from the Incident Response Tasks
Application

Complete this topic only if you are upgrading from RSA Archer Security Operations
Management 1.0.

In version 1.1, the Incident Response Tasks application was changed to a leveled
application. By default when a flat application changes to a leveled application, any
previously existing data is stored at the parent level and data that belongs in the
child level must be manually imported into the correct level. You must complete
some additional steps to ensure that your data is migrated correctly.

Procedure

1. From the Navigation Menu, select Incident Response > Incident Response
Tasks > Display All.

2. Ensure that the following required fields are displayed:

l Name

l Analyst Name

l Analyst Notes

l Description

l Implementation Status

l Order

l Related Investigation

l Related Security Incident

l Required/Optional

l Target Analyst

l Threat Category

3. Click Export.

4. In the Export Options dialog, select CSV.

5. In the Warning pop-up, select Exclude all HTML formatting tags. Click OK.

6. Save the CSV file to a location on your hard drive.

Chapter 2: Installing the RSA Archer Security Operations Management Solution 20
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Separate Incident Response Procedures and Tasks
Complete this topic only if you are upgrading from RSA Archer Security Operations
Management 1.0.

After exporting your existing incident response procedure data, you must separate
the incident response procedures from the incident response tasks. RSA strongly
recommends contacting Professional Services for assistance.

Before You Begin

l Export Incident Response Procedures from the SOC Procedure Library
Application

l Export Incident Response Tasks from the Incident Response Tasks
Application

Procedure

1. Open the CSV file.

2. Copy and paste the procedure information into a separate CSV file. The
following fields apply to procedures only:

l Threat Category

l Target

l Related Security Incidents/Investigations

3. Copy and paste the task information into a separate CSV file. The following
fields apply to tasks only.

l Name

l Analyst Name

l Analyst Notes

l Description

l Order

l Required/Optional

l Target Analyst

4. Save each CSV file.
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Download the Solution File from the RSA Archer Exchange

Procedure

Download the RSA_Archer_Security_Operations_Management_1.2_Install_
Package.zip file for RSA Archer Security Operations Management 1.2 from the
Applications Exchange page on the RSA Archer Exchange at
https://community.emc.com/community/connect/grc_ecosystem/rsa_archer_
exchange.

Back Up the Database
After a solution package has been installed, the installation cannot be rolled back
(reversed). RSA recommends that you create a backup of your database before
installing the new package in case you need to return to a pre-install state.

Important: You must be a database administrator to perform this task.

Procedure

Back up the database according to the standards and procedures of your company.

Import the Install Package

Procedure

1. From the Navigation Menu, click Administration > Application Builder > Install
Packages.

2. In the Available Packages section, click Import to open the Select Import File
dialog box.

3. Click Add New, then locate and select the package file that you want to import.

4. Click OK.

Update the License Key

Note: You must update the license key if you are installing a new application or
questionnaire. If you are updating existing applications or questionnaires, you do not
need to update the license key.

The administrator (a web or database administrator) on the server on which the
Archer Control Panel resides must update the license key in the Archer Control
Panel before the application package is imported in order for the new applications
and questionnaires to be available for use.
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Procedure

Update the license key. For instructions, see "Update a License Key" in the RSA
Archer Control Panel Help.

Important: If you do not update the license key prior to installing the solution
package, you may receive package failures.

Performing Advanced Package Mapping
To perform this task, you must be a user with an access role that has rights to install
a package. When you install the latest solution package, you must perform
Advanced Package Mapping to avoid creating duplicate objects.

Important: Advanced Package Mapping does not update data feeds and Web
APIs. If you modify the system ID of an object used by a data feed or Web API, the
data feed or Web Service API will not function properly. You must update the data
feed and Web Service API to reference the new system ID of the object. Changing
the system ID of a field can adversely affect data feeds or calculations that use the
field. Before you execute the mapping process, RSA recommends that you back up
your database.

As part of Advanced Package Mapping, you can do the following:

l Map objects

l Review the Package Mapping Log

l Export Mapping Settings

l Import Mapping Settings

l Undo Package Mapping Changes

Advanced Package Mapping requires a considerable amount of memory, which can
result in loss of data input and IE errors when working with large applications.
System performance may vary based on the size of a package file.

Note: To optimize your system for packaging, RSA recommends using Silverlight
5.1.3 or later.

For information about advanced package mapping and its components, see
"Advanced Package Mapping" in the RSA Archer Online Documentation.

Install the Solution Package

Important:When you install a package that updates a subform, the updates affect
all applications, questionnaires, workspaces, and dashboards that use the subform.
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Procedure

1. From the Navigation Menu, click Administration > Application Builder > Install
Packages.

2. In the Available Packages section, locate the package file that you want to
install, and click Install.

3. To modify the components of the installation package, follow these steps:

a. In the Configuration section, select the components of the package that you
want to install.

Note: By default, RSA Archer only selects new applications, so you must
select all other applications and questionnaires as needed. If you are
installing the solution for the first time, ensure that you select all
applications.

b. In the Install Method section, for each component, select one of the
following options.

Option Description

Create New Only Creates new objects that do not currently exist in the
instance. Does not update existing objects.

During a solution upgrade, this option preserves any
customization made to the objects in a previous
version.

Important: You must manually update any existing
items that you want to change. See the Data
Dictionary for field information.

Create New and
Update

Creates new objects and updates existing objects that
match objects in the package.

Note: If you are installing the solution for the first
time, ensure that you select Create New and Update.

c. In the Layout section, for each component, select one of the following
options.
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Option Description

Override Layout Replaces the existing layout with the layout in the
package. Moves fields that were previously on the
layout that are not on the package layout to the
Available Fields list.

Important: If you select this option, you will lose any
customization that you have made to your existing
layout.

Note: If you are installing the solution for the first
time, ensure that you select Override Layout.

Do Not Override
Layout

No changes are made to the existing layout, but you
may have to modify the layout after installing the new
package.

4. Click Install, and click OK.
For sample installation log messages, see Package Installation Log Message
Examples.

Review the Package Installation Log

Procedure

Review the Package Installation Log to determine if you need to take specific
action to resolve issues. For more information on the log messages, see "Package
Installation Log Messages" in the RSA Archer Online Documentation.

For example, you may need to install specific dependent solutions or applications.
For information on the dependencies for each solution, see the Data Dictionary.

For additional examples and remediation information for common Package
Installation Log messages, see Package Installation Log Message Examples.

Create the Security Operations Management Group
Once you have installed the RSA Archer Security Operations Management
package, you must create a Security Operations Management group to make it the
parent group of all the other SOC subgroups that were added during installation.

Procedure

1. Click Navigation > Administration > Access Control > Manage Groups.

2. Click Add New.
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3. In the Name field, enter Security Operations Management.

4. In the Members section, locate and select the following groups from the
Available list:

l SOC : Business Manager

l SOC : CISO/CSO

l SOC : Compliance/Privacy Officer

l SOC : HR

l SOC : Incident Coordinator

l SOC : IT Helpdesk

l SOC : L1 Incident Handler

l SOC : L2 Incident Handler

l SOC : Legal

l SOC : SOC Manager

l SOC : Solution Administrator

5. Click Save.

Create a New Crisis Event Status
This procedure is only required if you have licensed the RSA Archer Business
Continuity Management solution.

The RSA Archer Security Operations Management solution allows users to create a
new Crisis Event record from either an incident, investigation, or a data breach
record. You must create a new Status field value named Under Review for new
Crisis Events created from RSA Archer Security Operations Management, so that
when a RSA Archer Security Operations Management user creates a new crisis
event, the crisis response team can determine whether to approve or reject the
record.

Procedure

1. Click Administration > Application Builder > Manage Applications.

2. Click Crisis Events.

3. Click the Fields tab.

4. Click the Status field.

5. Click the Values tab.

6. Click Add New.

7. In the Text Value field, enter Under Review.

8. Save the field and the application.
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Configure Bing Maps
The Incident Coordinator dashboard provides a Bing maps iView, however you
must have a Bing maps license and configure the mapping connection for this iView
to work. The administrator (a web or database administrator) on the server on
which the Archer Control Panel resides must configure the mapping connection in
the Archer Control Panel.

Procedure

Configure the mapping connection. For instructions, see "Configure the Mapping
Connection" in the RSA Archer GRC Platform Control Panel Help.

Create a User Account for the RSA Archer Web Service Client
You must create a user account for the web service client to use to transfer data
into the RSA Archer Platform.

Note: If you are upgrading from RSA Advanced Incident Management for Security
1.1, you can use the same user account that you already created.

Procedure

1. Click Administration > Access Control > Manage Users.

2. In the Manage Users section, click Add New.

3. In the General Information section, enter a first name, last name, and user
name.

4. In the Localization section, set the time zone to (UTC) Dublin, Edinburgh,
Lisbon, London.

5. In the Localization section, set the locale to English (United States).

6. Click the Groups tab, and do the following:

a. In the Groups section, click Lookup.

b. In the Available Groups window, expand Groups.

c. Scroll down and select SOC: Solution Administrator and EM: Read Only.

d. Click OK.

7. Click the Roles tab, and do the following:

a. In the Roles section, click Lookup.

b. In the Available Roles window, expand Roles.

c. Scroll down and select SOC: Solution Administrator and EM: Read Only.

d. Click OK.

Chapter 2: Installing the RSA Archer Security Operations Management Solution 27



Installation and Configuration Guide

8. Click Save, then click Apply.

RSA Archer Security Operations Management Data Feeds
RSA Archer Security Operations Management includes the following data feed
files:

l Security_Operations_-_Generate_Breach_Tasks.dfx5

l Security_Operations_-_Generate_Incident_Response_Procedures_and_
Tasks.dfx5

l Security_Operations_-_Not_Applicable_Breach_Tasks.dfx5

l Security_Operations_-_Not_Applicable_Incident_Response_Tasks.dfx5

The Generate Breach Tasks and Generate Incident Response Procedure and Tasks
data feeds automatically create tasks based on the response templates associated
with a record. For example, when an Incident Handler selects a category for an
incident, the Generate Incident Response Procedures and Tasks data feed copies all
incident response procedures that match that category and associates them with the
incident. If a task becomes unnecessary due to a change in the related impacted
regulation, the Not Applicable data feeds make a copy of that task and list it in the
Not Applicable section of a Breach Task record or an Incident Response Task
record.

You must import each data feed and schedule it to run as frequently as you need.
By default, the feeds are scheduled to run every minute. If you encounter any
performance impacts, please contact RSA Archer Professional Services for
assistance.
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Import a Data Feed

Procedure

1. In the Control Panel, ensure that the Relative Path checkbox is not selected.

a. Open the RSA Archer Control Panel, and go to Installation Settings.

b. On the General tab, in the Data Feed Manager section, ensure that the
Relative Path checkbox is not selected.

2. In your RSA Archer Security Operations Management system, from the
Navigation Menu, click Administration > Integration > Manage Data Feeds.

3. In the Manage Data Feeds section, click Import.

4. Locate and select the .dfx5 file for the data feed.

5. From the General tab in the General Information section, in the Status field,
select Active.

6. Click the Transport tab. Complete the fields in the Transport Configuration
section as follows:

a. In the URL field, type:
YourServerName/VirtualDirectoryName/ws/search.asmx

b. In the User Name and Password fields, type the username and password of
a Platform user that has API access and access to all of the records on the
Platform instance (from which the data feed is coming). For instructions on
creating a user account, see Create a User Account for the RSA Archer
Web Service Client.

c. In the Instance field, type the name of the Platform instance from which the
data feed is coming (this is the instance name as you enter it on the Login
window).

7. For the Security_Operations_-_Generate_Incident_Response_Procedures_and_
Tasks.dfx5 data feed only, do the following:

a. Click the Navigation tab.

b. In the XML File Definition section, locate the File tag under the Task_
Attachment element and replace C:\ArcherFiles\Repository\ with your file
repository location. Ensure that your location ends with a backslash.

8. For the Security_Operations_-_Generate_Breach_Tasks.dfx5 feed only, do the
following:

a. Click the Source Definition tab.

b. In the File field, edit the calculation and replace C:\ArcherFiles\Repository\
with your file repository location. Ensure that your location ends with a
backslash.

9. Verify that key field values are not missing from the data feed setup window.
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10. Click Save.

Note: After clicking save, you may see one or more warning messages. Click
Ignore and continue installing the solution.

Schedule a Data Feed

Important: A data feed must be active and valid to successfully run.

As you schedule your data feed, the Data Feed Manager validates the information.
If any information is invalid, an error message is displayed. You can save the data
feed and correct the errors later; but the data feed does not process until you make
corrections.

Procedure

1. Click Administration > Integration > Manage Data Feeds.

2. In the Name column, click the data feed that you want to edit.

3. Click the Schedule tab.

Note: The Schedule tab is available for both Standard and Transport-Only data
feed types.

4. In the Frequency drop-down list, set the frequency for the data feed. For
example, if you select Minutely and specify 3 in the Every field, the data feed
runs every 3 minutes.

5. (Optional) To configure a data feed to run immediately after another data feed,
follow these steps:

a. In the Frequency drop-down list, select Reference.

b. In the Reference Feed drop-down list, select the first data feed. Your
current data feed would run after this selected one.

6. (Optional) To override the data feed schedule and immediately run your data
feed, in the Run Data Feed Now section, click Start.

7. Click Save.

Importing ACD Content
The RSA Archer Security Operations Management 1.2 solution allows you to
import RSA Advanced Cyber Defense (ACD) content into each level of the
Incident Response Procedure Library application. You can:

l Import ACD Incident Response Procedure content into the Incident Response
Procedures level.
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l Import ACD Incident Response Task content into the Incident Response Task
level.

Note: You can download the Incident_Response_Procedures_OOTB_RSA_
ACD.zip from the RSA Archer Exchange at
https://community.emc.com/community/connect/grc_ecosystem/rsa_archer_
exchange.

Prepare to Import ACD Data
You must update two fields in the Incident Response Procedure Library application.

Procedure

1. At the Incident Response Procedure level, change the key field to Procedure
Name, as follows:

a. Click Administration > Application Builder > Manage Applications.

b. In the Manage Applications section, select the Incident Response Procedure
Library application.

c. Click the Fields tab, and in the Incident Response Procedures level, select
the Procedure Name field.

d. Click the Options tab.

e. In the Options section, in the Key Field field, select the checkbox.

f. Click Save.

2. At the Incident Response Task level, change the minimum value of the Step
Number field.

a. In the Incident Response Task level, select the Step Number field.

b. Click the Options tab.

c. In the Minimum Value field, change the minimum value to 0.

d. Click Save.

3. Click Save.

Import ACD Data into Incident Response Procedure Library
If you are importing data into a leveled application, you must import data into the
parent level before importing data into the child level. Do the following procedure
to import data specific to the Incident Response Procedures level, and then repeat
the steps to import data specific to the Incident Response Tasks level.

Procedure

1. Click Administration > Integration > Manage Data Imports.

2. In the Manage Data Imports section, from the Incident Response Procedure
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Library application, select one of the following levels:

l To import incident response procedures, select the Incident Response
Procedures level.

Important: You must import incident response procedures before importing
incident response tasks.

l To import incident response tasks, select the Incident Response Tasks level.

3. In the General Information section, click Browse.

4. From the File Upload window, click Add New. Select the one of the following:

l If you are importing incident response procedures, select the OOTB ACD
Procedures.csv file, and click Open.

l If you are importing incident response tasks, select the OOTB ACD
Tasks.csv file, and click Open.

5. Click OK.

6. In the Format Options section, leave all the fields as default, and click Next.

7. From the General Information section, in the Import Type drop-down list, select
Create New Records.

8. In the Import Field Mapping section, ensure that all the values in the
Application Fields row match the column headers. If a value does not match,
click the drop-down list for the item, and select the appropriate value.

Important:When you import the incident response tasks, map Procedure
Name to Incident Response Procedure (Procedure Name).

9. Click Next.

10. Ensure that the summary information from the Data Import Wizard is correct,
and click Import.

11. Repeat steps 1 – 10 to import data into the Incident Response Tasks application.

For more information about data imports, see "Data Imports" in the RSA Archer
GRC Help.

Perform ACD Data Post Import Activities
After completing the data import, you must update the Incident Response Procedure
Library key field and add additional values to the Response Phase values list.

1. Change the key field of the Incident Response Procedure Library application to
Incident Response Procedure ID, as follows:

a. Click Administration > Application Builder > Manage Applications.

b. In the Manage Applications section, select the Incident Response Procedure
Library application.
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c. Click the Fields tab, and in the Incident Response Procedures level, select
the Incident Response Procedure ID field.

d. Click the Options tab.

e. In the Options section, in the Key Field field, select the checkbox.

f. Click Save.

2. Add the following values to the Response Phase values list field.

l Discovery

l Identification

l Remediation

3. Click Save.

Import Migrated Data into the Incident Response Procedure Library
Application

Complete this task only if you are upgrading from RSA Archer Security Operations
Management 1.0.

Before You Begin

l Locate the CSV files that you saved in Separate Incident Response
Procedures and Tasks.

l Ensure that each procedure and task file includes the required fields outlined in
Export SOC Procedure Library Data.

Procedure

1. Click Administration > Integration > Manage Data Imports.

2. In the Manage Data Imports section, under the Incident Response Procedure
Library do one of the following:

l If you are importing your incident response procedures, select the Incident
Response Procedure level.

l If you are importing your incident response tasks, select the Incident
Response Tasks level.

3. In the Data Import Wizard, in the General Information section, select Browse.

4. From the File Upload window, click Add New, and select the file that you want
to import.

5. In the Format Options section, leave all the fields as default, and click Next.

6. From the General Information section, in the Import Type drop-down list, select
Create New Records.
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7.  In the Import Field Mapping section, with the exception of Procedure Name,
ensure that all the values in the Application Fields row match the column
headers. If a value does not match, click the drop-down list for the item, and
select the appropriate value.

Important:When you import the incident response tasks, map Procedure
Name to Incident Response Procedure (Procedure Name).

8. Click Next.

9. Ensure that the summary information from the Data Import Wizard is correct,
and click Import.

10. Complete steps 1 to 9 to import your incident response tasks.

Import Migrated Data into the Incident Response Procedures
Application

Complete this topic only if you are upgrading from RSA Archer Security Operations
Management 1.0.

Before You Begin

l Locate the CSV files that you exported in Export Incident Response Tasks.

l Verify that your files include the required fields outlined in Export Incident
Response Tasks.

l In the Incident Response Procedure application, delete all previously existing
records.

Procedure

1. Click Administration > Integration > Manage Data Imports.

2. In the Manage Data Imports section, under the Incident Response Procedures
application, do one of the following:

l If you are importing your incident response procedures, select the Incident
Response Procedure level.

l If you are importing your incident response tasks, select the Incident
Response Tasks level.

3. In the Data Import Wizard, in the General Information section, select Browse.

4. From the File Upload window, click Add New, and select the file that you want
to import.

5. In the Format Options section, leave all the fields as default, and click Next.

6. From the General Information section,, in the Import Type drop-down list, select
Create New Records.
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7.  In the Import Field Mapping section, ensure that all the values in the
Application Fields row match the column headers. If a value does not match,
click the drop-down list for the item, and select the appropriate value.

Important:When you import the incident response tasks, map Procedure
Name to Incident Response Procedure (Procedure Name).

8. Click Next.

9. Ensure that the summary information from the Data Import Wizard is correct,
and click Import.

10. Complete steps 1 to 10 to import your incident response tasks.

Post-Install Activities
The package installation does not update some attributes of objects, or delete
obsolete objects that are not included in the current solution. RSA recommends that
you compare the objects in your database with the information in the Data
Dictionary to determine which objects are obsolete or have been updated.

Deleting Obsolete Objects
Packaging does not delete obsolete objects. RSA recommends that you delete these
objects because they may affect how the applications function. Follow these
guidelines on deleting obsolete objects:

l If you select Override Layout when you install the solution install package, the
Packager does not remove old fields from the layout. You must delete the old
fields.

l Evaluate your need for certain data driven events (DDE), pre-existing rules, and
actions that were not updated through Packaging. Delete any obsolete rules and
actions.

l Verify the DDE order and update it if necessary.

l Evaluate pre-existing notifications and reports that Packaging did not update.
Delete obsolete notifications and reports.

For more information about objects, see the "Managing Packages" section of the
RSA Archer GRC Platform Help.

Validating Formulas and Calculation Orders
Follow these guidelines on validating formulas and calculation orders:

l The packaging process logs an error if a formula does not validate. This error
may be caused by a formula that references applications or fields that do not
exist in the instance and were not part of the package (for example, fields in
applications that are part of a different core solution). Review those fields to
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determine if they are needed.
o If a field is needed, modify the formula to remove references to applications

or fields that do not existing in your instance. Fields that do not exist in your
instance are identified with an exclamation mark.

o If a field is not needed, delete the field or remove it from the layout. If the
field is not deleted, removing the formula prevents errors from being written
in the log files when records are saved.

l Verify the order of calculations for each application and sub-form in the solution.
See the Data Dictionary for calculation orders for each individual application or
sub-form.

l Update the order of calculations as needed for each application and subform in
the solution.

For more information about deleting objects, see the "Managing Calculations"
section of the RSA Archer GRC Platform Help.

Verifying Key Fields
Packaging does not change key fields. To verify the key fields in each application,
see the RSA Archer Security Operations Management Data Dictionary.

Updating Record Permissions Fields to Allow Access to Other Solution
Records

The access roles in the RSA Archer Security Operations Management package
provide read-access rights to records in the Crisis Events application (in the RSA
Archer Business Continuity Management solution) and the Risk Register
application (in the RSA Archer Risk Management solution), if you have licensed
these solutions.

However, the package does not update any Record Permissions fields in those
applications, so users must still be selected in a Record Permissions field in a
record in order to view that record.

RSA recommends that you work with your Business Continuity Management and
Risk Management solution administrators to determine which RSA Archer Security
Operations Management users require access to Crisis Events or Risk Register
records and to update any Record Permissions fields necessary to provide default
access.

Verifying the Upgrade from RSA Advanced Incident Management for Security
1.1

If you have upgraded from RSA Advanced Incident Management for Security 1.1,
you should see the following changes:
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l In the Security Incidents application, you have two new tabs: Forensic Analysis
and Remediation. The Results tab also has new sections and the Overview tab
has a couple new fields.

l In the Incident Response subsolution, you have two new applications: Forensic
Analysis and Incident Investigations.

l You have three new subsolutions: Data Breach Response, SOC Program
Management, and Issue Management.

l You have six new dashboards for each primary solution user role.

l The Incident Coordinator dashboard provides a Bing maps iView.

Note: You must have a Bing maps license installed for this iView to work.

l Incident Response Procedures and Tasks can now be created from the Incident
Response Procedure Library records that match the selected category.

Test the Solution

Procedure

Test the RSA Archer Security Operations Management 1.2 solution according to
your company standards and procedures, to ensure that the solution works with your
existing processes. Some of the items that you may want to include in your testing
are:

l Customized objects and fields

l Notifications - ensure that notifications are firing

l Calculations - ensure that calculations are functioning

l Workflows - ensure that workflows are correct
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Chapter 3: Setting Up the Integration Middleware
l SA IM Integration Service

l RSA Connector Framework (RCF)

l Set Up the RCF and the SA IM Integration Service

SA IM Integration Service
The SA IM Integration Service allows you to integrate your RSA Archer Security
Operations Management system with the RSA Security Analytics Incident
Management module.

RSA Connector Framework (RCF)
The RCF is a plug-and-play structure that runs as a Windows system service and
integrates your RSA Archer system with RSA Security Analytics.

Set Up the RCF and the SA IM Integration Service

Procedure

1. Install the RCF and SA IM Integration Service.

2. Set Up SSL Communication Between the SA IM Integration Service and
RSA Security Analytics.

3. Set Up TLS/SSL Communication between the RSA Archer Platform and
the RCF.

4. Set Up TLS/SSL Communication between RSA Security Analytics and the
RCF.

5. (RCF Only) Configure the RCF for Hosted RSA Archer GRC.
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Install the RCF and the SA IM Integration Service

Before You Begin

l Review the Solution Requirements.

Note: You must install the RCF and SA IM Integration Service on a Microsoft
Windows 2008 R2 Server 64-bit system that can reach both your RSA Security
Analytics system and your RSA Archer Platform.You can install the RCF and
SA IM Integration Service on the same system or on separate systems. If you
have previously installed the RCF on a 32-bit system, you can update your RCF
installation on that system, but you must install the SA IM Integration Service on
a separate 64-bit system.

l If you are upgrading from the RCF 2.6, stop the RCF Service. For instructions,
see Stop the RCF.

Procedure

1. Double-click RSA_Unified_Collector_Framework.exe.

2. Read and accept the license agreement, and click Next.

3. Choose one or both:

l RSA Connector Framework - necessary to integrate with all third-party
SIEM tools and to send business context data from your RSA Archer system
to RSA Security Analytics.

l SA IM Integration Service - necessary to integrate with RSA Security
Analytics Incident Management.

4. If you are installing or updating the RSA Connector Framework, do one of the
following:

l If you are updating the RCF 2.7, follow these steps:

a. When prompted to update your installation, click Yes.

b. Verify the plug-ins that you want to install, and click Next.

Note: The SecOps plug-in is used for integrating with third-party SIEM
tools. The EM plug-in is used to feed business context from the RSA
Archer Enterprise Management solution into RSA Security Analytics.

c. Click Next.

d. Click Finish.
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l If you are installing the RCF 2.7 for the first time, click Next.

a. (Optional) If you want to change the destination path:

a. Click Change.

b. Select your destination, and click OK.

b. Click Next.

c. On the Select Plug-ins page, select the plug-ins that you want to install,
and click Next.

Note: The SecOps plug-in is used for integrating with third-party SIEM
tools. The EM plug-in is used to feed business context from the RSA
Archer Enterprise Management solution into RSA Security Analytics.

d. On the Create User Credentials page, complete the following fields, and
click Next.

Field Description

User Name User name for the RSA Connector Shell. This user name is
used exclusively for the RCF.

RCF user names:

l Must be at least 8 characters in length

l Must be at most 32 characters in length

l Are not case sensitive

l Cannot include the following special characters: " / \ [ ] : ;
| = , + * ? < >

Enter
Password

Password for the user name.

RCF passwords:

l Must be between 8 and 32 characters in length

l Must contain at least one upper case letter

l Must contain at least one numeral

l Must contain at least one special character

l Cannot include the following special characters: " \

Confirm
Password

Confirmation of the password.

Connector
Shell Port

Port used by the RSA Connector Shell (default 8001, which
is an SSH port).
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e. On the Ready to Install the Program page, click Install.

f. Click Finish

5. If you are installing the SA IM Integration Service, do the following:

a. Click Next on the InstallShield Wizard.

b. Read and accept the license agreement, and click Next.

c. (Optional) If you want to change the destination path:

a. Click Change.

b. Select your destination, and click OK.

d. Click Next.

e. Click Install.

f. Click Finish.

Both the RSA Connector Framework Service and SA IM Integration Service start
automatically, without requiring a restart of your system.

Set Up SSL Communication Between the SA IM Integration Service and RSA
Security Analytics

Note: The steps in these procedures are only one method of setting up SSL
communication between your two systems. You can use another method if desired.

Procedure

1. Create SSL Certificates

2. Install Certificates

Create SSL Certificates

Procedure

1. Create a Root CA for the SA IM Integration Service.

a. On your RSA Security Analytics system or SA IM Integration Service,
using OpenSSL, type:
openssl req –x509 –newkey rsa:2048 –days n –out ca.pem

–keyout ca_pvt.pem

where n is the number of days for which to certify the certificate.
ca.pem is the public key and ca_pvt.pem is the private key. You can use
other names for these files.

Note: Ensure that you store ca_pvt.pem in a secure location on this
machine.

b. When prompted, enter a password for the private key for this certificate.

Chapter 3: Setting Up the Integration Middleware 41



Installation and Configuration Guide

c. When prompted, enter a name for the Common Name value. For the rest of
the prompted information, enter information as desired.

Note: Do not use "Archer" for the Common Name value.

2. Create an SSL certificate for your SA IM Integration Service system.

a. On your RSA Security Analytics system or SA IM Integration Service
system, using OpenSSL, type:
openssl req -newkey rsa:2048 -keyout key.pem -out req.pem

key.pem is the private key and req.pem is the certificate signing request.
You can use other names for these files.

b. When prompted for the Common Name value, enter archer.

3. Sign the certificate request using the root certificate. Type:
openssl x509 -req -in req.pem -CA ca.pem -CAkey ca_pvt.pem

-CAcreateserial -out server.pem

req.pem is the signed certificate you created in step 2. ca.pem and ca_pvt.pem
are the public and private keys you created in step 1. server.pem is the signed
certificate. You can use another name for this file.

4. Import the SA IM Integration Service CA into the RSA Security Analytics
truststore. This step must be done on the RSA Security Analytics server.

a. If you completed step 1 on the SA IM Integration Service server, copy
ca.pem to a location on your RSA Security Analytics server, for example,
/tmp.

b. Using a text editor, open ca.pem and the Security Analytics truststore.pem
file, located in /etc/puppet/modules/rabbitmq/files/.

c. Append the contents of ca.pem to the bottom of truststore.pem.

5. Publish the updated RSA Security Analytics truststore to all other machines in
the network. Type:
puppet agent -t

6. Convert the signed certificate and private key from PEM to PKCS#12 format.
On the same system that you created the SSL certificate, using OpenSSL, type:
openssl pkcs12 -export -in server.pem -inkey key.pem -out

keystore.p12 –CAfile ca.pem

server.pem is the signed certificate you created in step 3. key.pem is the private
key you created in step 1. keystore.p12 is the converted certificate. You can use
another name for this file.

7. If you completed steps 1 to 3 and 6 on the RSA Security Analytics server, copy
keystore.p12 to any location on your SA IM Integration Service system, such as
c:\certs\keystore.p12.
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Install Certificates

Procedure

1. On your SA IM Integration Service system, open the Connection Manager.

a. Open a command prompt.

b. Change directories to saim_install_dir/data-collector.

c. Type runConnectionManager.bat

2. Install the keystore.

a. Enter 7 for Install SA IM Integration Service Certificate.

b. Enter full filepath of the keystore.p12 file you created.
For example: C:/certs/keystore.p12

c. Enter the password that was used to create keystore.p12.

Set Up TLS/SSL Communication Between the RCF and the RSA Archer GRC
Platform

This procedure is optional.

Before You Begin

Ensure that the following requirements have been met:

l The RSA Archer Platform has been installed and is running.

l The RSA Archer Platform is configured to support (or require) TLS or SSL
communication.

l The RCF has been installed.

Procedure

1. On the system on which you installed the RSA Connector Framework, open a
DOS command prompt.

2. Change directories to Install_Dir\EMC\RSA\RSA Connector Framework\tools

3. Type:
install_cert_admin.bat Archer Host URL:Port

where:

l Archer Host URL is the hostname or IP address of your RSA Archer system.
Your hostname or IP address must match the value that you specified in the
RSA Archer Platform TLS or SSL certificate. If you have specified a
hostname, you must use that hostname for importing certificates and
configuring the RSA Archer Platform endpoint properties. The Port argument
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is optional if you are using the standard SSL port 443.

l Port is the TLS or SSL port used.

Set Up TLS/SSL Communication Between the RCF and RSA Security
Analytics

These procedures are required only if you want to configure the RCF to
communicate with your RSA Security Analytics system using TLS/SSL. This
process only applies to the EM plug-in.

Note: The steps in these procedures are only one method of setting up SSL
communication between your two systems. You can use another method if desired.

Procedure

1. Create a Self-Signed Root Certificate

2. Export the Root Certificate Public Key to a Trust Store

3. Create SSL Certificates

Create a Self-Signed Root Certificate
You must create a self-signed root certificate, used to sign the client certificates for
your RSA Security Analytics and RCF systems.

Procedure

1. On your RSA Security Analytics system, using OpenSSL, type:
openssl req –x509 –newkey rsa:2048 –days n –out ca.pem

–keyout ca_pvt.pem

where n is the number of days for which to certify the certificate.

ca.pem is the public key and ca_pvt.pem is the private key. You can use other
names for these files.

2. When prompted, enter a password for the private key for this certificate.

3. When prompted, enter RSA for the Common Name value, and for the rest of the
prompted information, enter information as desired.

Export the Root Certificate Public Key to Trust Stores
After you have created a root certificate, you must export the public key to a trust
store on both your RSA Security Analytics and RCF systems.

Procedure

1. On your RSA Security Analytics system, using the JDK keytool utility, type:
keytool -importcert -alias alias_name -file ca.pem -

trustcacerts -storetype jks -keystore ssltruststore.jks
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where

l alias_name is the name that you want to use to distinguish this certificate if
multiple certificates are present in a key store.

l ssltruststore.jks is the trust store file that you want to create. You can use
other names for this file.

l ca.pem is the public key that you created in Create a Self-Signed Root
Certificate. If you named the file something different, use that name here.

2. When prompted, enter Yes to trust this certificate.

3. Move a copy of ssltruststore.jks to your RCF system.

Create SSL Certificates
After you create a root certificate and trust stores, you can create SSL certificates
for both your RCF and RSA Security Analytics systems.

Important: The Enterprise Management Plug-in must be configured before
completing steps 2-6. See Configure the Enterprise Management Plug-in.

Procedure

Note:When you create the certificate for the RCF, ensure the Common Name
value matches the hostname of your RCF system.

1. Create an SSL certificate for your RCF system as follows.

a. Using OpenSSL, type:
openssl req -newkey rsa:nbits -keyout rcfkey.pem -out

rcfreq.pem

where nbits is number of bits to generate for an RSA key.

rcfkey.pem is the private key and rcfreq.pem is the certificate signing
request. You can use other names for these files.

b. Sign the certificate request using the root certificate. Type:
openssl x509 -req -in rcfreq.pem -CA ca.pem -CAkey

ca_pvt.pem -CAcreateserial -out rcfcert.pem

rcfcert.pem is the signed certificate name. You can use another name for
this file.

c. Convert the signed certificate and private key from PEM to an intermediate
PKCS#12 format. Type:
openssl pkcs12 -export -in rcfcert.pem -inkey rcfkey.pem

-out rcfkeystore.p12 –CAfile ca.pem

d. Convert the certificate from PKCS #12 to JKS format. Using the JDK
keytool utility, type:
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keytool -importkeystore -destkeystore rcfkeystore.jks

-srcstoretype PKCS12 -srckeystore rcfkeystore.p12

e. Copy rcfkeystore.jks to your RCF system.

2. Export the RCF SSL certificate with the Mozilla Firefox browser by accessing
the following URL:

https://rcf_hostname_or_ip:port/archer/sa/feed

where https://rcf_hostname_or_ip:port is the address of your RCF system.

a. In the Security tab, click View Certificate.

b. Click the Details tab.

c. Click Export.

d. Name the file.

e. Click Save.

3. Copy the RCF SSL certificate to the RSA Security Analytics machine.

a. Open a WinSCP client on your RCF machine.

b. Log on to your RSA Security Analytics machine through WinSCP.

c. Copy the RCF SSL certificate of the root directory on your RSA Security
Analytics machine.

4. Import the RCF into the RSA Security Analytics key store. On your RSA
Security Analytics machine, using the JDK utility, type:
JDK=/usr/lib/jvm/<current_JAVA>/jre

Ex: JDK = /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.65.x86_

64/jre

keytool -import -v -trustcacerts -alias alias_name -file

rcf.crt -keystore $JDK/lib/security/cacerts

where rcf.crt is the name of the RCF SSL certificate that you exported. alias_
name can be anything.

5. When prompted, enter the password for the RSA Security Analytics keystore
file.

6. Restart RSA Security Analytics. In your command prompt, type:
stop jettysrv

start jettysrv

Configure the RCF for Hosted RSA Archer GRC

Important: This procedure is required only if you plan to use the RCF with a
hosted version of the RSA Archer GRC Platform
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Procedure

1. Stop the RCF service:

a. Click Control Panel > Administrative Tools > Services.

b. Select RSA Connector Framework Service, and click Stop.

2. Open wrapper.conf, located in the Install_Dir\EMC\RSA Connector
Framework\system\felix\wrapper\conf folder.

3. Set the following property to true:
wrapper.java.additional.9=-Darcher.isSaas=true

4. Save and close the file.

5. Start the RCF service:

a. Click Control Panel > Administrative Tools > Services.

b. Select RSA Connector Framework Service, and click Start.

Chapter 3: Setting Up the Integration Middleware 47



Installation and Configuration Guide

Chapter 4: Setting up the Integration with
RSA Security Analytics Incident Management

l Integration Options

l Set Up the Integration

Integration Options
RSA Security Analytics integrates with RSA Archer Security Operations
Management solution with a different levels of access. You must select the same
options in both RSA Security Analytics and the SA IM Integration Service.

The following table describes the different integration options and what data is
transported for each option.

Integration option Data transported into Archer

Manage incidents workflow exclusively
in the RSA Archer Security Operations
Management solution

Incidents

Note: Once incidents are transported into
RSA Archer Security Operations
Management, incidents and remediation
tasks are no longer visible in RSA Security
Analytics.

Manage incidents workflow in the RSA
Security Analytics Incident Management
module

Data breaches

Remediation tasks (as Findings), which can
be assigned to either the GRC or Operations
queues for remediation:

Note:When updates are made in RSA
Archer Security Operations Management,
the remediation status is automatically
synchronized across the two systems.

Incidents (records are read only)

Set Up the Integration

Procedure

1. Configure RSA Security Analytics Incident Management

2. Configure RSA Archer Security Operations Management
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3. Configure the SA IM Integration Service

Configure RSA Security Analytics Incident Management

Procedure

1. In the Security Analytics menu, click Incidents > Configure.

2. Click the Integration tab.

3. Select from the given options.

l Manage incident workflow in RSA Security Analytics.
o Allow analysts to escalate remediation tasks for the Operations target

queue as tickets.
o Allow analysts to escalate remediation tasks for the GRC target queue as

Findings.
o Allow analysts to report data breaches and trigger the breach response

process in the RSA Archer Security Operations Management solution.

l Manage incident workflow exclusively in RSA Archer Security Operations
Management.

4. Click Apply.

Configure RSA Archer Security Operations Management

Procedure

1. (Optional) Create SA IM Integration Service User Security Parameter

2. Create SA IM Integration Service User Accounts

(Optional) Create SA IM Integration Service User Security Parameter
The SA IM Integration Service uses an Archer user account to transfer data into
your system. If you assign this account a default security parameter with a
password change interval of 90 days, you will also have to update the user account
password stored in the SA IM Integration Service every 90 days. To avoid this, you
can optionally create a new security parameter for the SA IM Integration Service
user accounts and set the password change interval to the maximum value allowed
by your corporate standards.

Important: If the SA IM Integration Service user account password expires, all
communication between the SA IM Integration Service and RSA Archer Security
Operations Management will stop.
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Procedure

1. Click Administration > Access Control > Manage Security Parameters.

2. Click Add New.

3. Do one of the following:

l To select new settings for the security parameter, select Create a new
Security Parameter from scratch, and click OK.

l To use the settings of an existing security parameter as a starting point for
the new security parameter, select Copy an existing Security Parameter.
Select an existing security parameter from the Security Parameter list, and
click OK.

4. In the General Information section, in the Name field, type SA IM Integration
Service User Security Parameter.

5. In the Password properties section, change the Password Change Interval.

6. If you created a new security parameter from scratch, fill in the additional
properties settings.

7. Click Save.

Create User Accounts for the SA IM Integration Service
Two RSA Archer user accounts are required to avoid conflicts while sending and
receiving data from RSA Security Analytics.

Procedure

1. Click Administration > Access Control > Manage Users > Add New.

2. In the First and Last Name fields, enter a name that indicates that this account
will be used by the SA IM Integration Service to push data into Archer, for
example, SA IM Integration User, Push.

3. (Optional) Enter a user name for this new user account.

Note: If you do not specify a user name, the RSA Archer Platform creates the
user name from the first and last name entered when you save the new user
account.

4. In the Contact Information section, in the Email field, enter an email address to
be associated with this new user account.

5. In the Localization section, change the time zone to (UTC) Dublin, Edinburgh,
Lisbon, London.

6. In the Account Maintenance section, enter a new password for the new user
account and confirm the new password.
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Important: Note the user name shown for the new user account that you just
created. Also, remember the password that you just created. You need to enter
these credentials when you set up the SA IM Integration Service to
communicate with the RSA Archer Platform through the web service client.

7. Clear Force Password Change On Next Sign-In.

8. In the Security Parameter field, select the security parameter that you want to
use for this user.

9. Click the Groups tab, and do the following:

a. In the Groups section, click Lookup.

b. In the Available Groups window, expand Groups.

c. Scroll down and select SOC: Solution Administrator and EM: Read Only.

d. Click OK.

10. Click the Roles tab, and do the following:

a. In the Roles section, click Lookup.

b. In the Available Roles window, expand Roles.

c. Scroll down and select SOC: Solution Administrator and EM: Read Only.

d. Click OK.

11. Click Save, then click Apply.

12. If the machine language and regional settings of your RSA Archer system are
set to anything other than English-US, complete the following:

a. Open the user account you just created, and in the Localization section, in
the Locale field, select English (United States), and click Save.

b. On the Windows system hosting your RSA Archer Platform, open Internet
Information Services (IIS) Manager, and do one of the following:

l If you are running IIS 6, right-click your RSA Archer site, select
Properties, click the ASP.Net tab, click Edit Configuration, click the
Application tab, in both the Culture and UI Culture fields, select en-US,
and click Apply.

l If you are running IIS 7, expand your RSA Archer site, click .Net
Globalization, in both the Culture and UI Culture fields, select English
(United States), and click Apply.

c. Restart your RSA Archer site.

13. Repeat steps 1 – 11 to create a second user account for the SA IM Integration
Service to use to pull data from Archer. In step 2, enter a name that indicates
that this account will be used by the SA IM Integration Service to pull data from
Archer, for example, SA IM Integration Service User, Pull.
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Configure the SA IM Integration Service
1. Configure Endpoints

2. Select Integration Mode

3. Set the Maximum Number of Alerts or Events Sent Through the SA IM
Integration Service

Configure Endpoints
Endpoints provide the connection details required for the SA IM Integration Service
to reach both your RSA Security Analytics and RSA Archer systems.

Procedure

1. On your SA IM Integration Service system, open the Command Manager:

a. Open a command prompt.

b. Change directories to saim_install_dir/data-collector.

c. Type:

runConnectionManager.bat

2. In the Connection Manager, enter 1 for Add Endpoint.

3. Add an endpoint for RSA Security Analytics Incident Management:

a. Enter 1 for Security Analytics IM.

b. Enter a name for the endpoint.

c. Enter the SA Host IP address.

d. Enter the SA Port.

e. Enter the target queue for remediation tasks (either Operations or GRC) that
you selected in Configure RSA Security Analytics Incident
Management. If you selected both, enter All.

4. Add an endpoint for pushing data to RSA Archer Security Operations
Management:

a. Enter 2 for Archer.

b. For the endpoint name, type push.

c. Enter the URL of your RSA Archer system.

d. Enter the instance name of your RSA Archer system.

e. Enter the user name of the user account you created to push data into your
RSA Archer system.

f. Enter the password for the user account you created to push data into your
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RSA Archer system, and confirm the password.

g. When asked whether this account is used for pulling data, enter False.

5. Add an endpoint for pulling data from RSA Archer Security Operations
Management:

a. Enter 2 for Archer.

b. For the endpoint name, type pull.

c. Enter the URL of your RSA Archer system.

d. Enter the instance name of your Archer system.

e. Enter the user name of the user account you created to pull data from your
RSA Archer system.

f. Enter the password for the user account you created to pull data from your
RSA Archer system, and confirm the password.

g. When asked whether this account is used for pulling data, enter True.

6. In the Connection Manager, enter 5 to test each endpoint.

Select Integration Mode

Procedure

1. Open the Command Manager:

a. Open a command prompt.

b. Change directories to saim_install_dir/data-collector.

c. Type:

runConnectionManager.bat

2. In the Connection Manager, enter 4 for Mode Selection.

3. Do one of the following.

l Enter 1 for Manage the incident workflow in RSA Security Analytics.

l Enter 2 for Manage the incident workflow in RSA Archer Security
Operations Management.

Note: You must select the same integration option that you selected in
Configure RSA Security Analytics Incident Management. For more
information which data is transported for each option, see Integration
Options.

4. Confirm the mode to enable by typing TRUE.
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(Optional) Set the Maximum Number of Alerts or Events Sent Through the SA
IM Integration Service

By default, the SA IM Integration Service sends all the alerts associated with an
incident and all the events associated with an alert into the RSA Archer Security
Operations Management solution. If this is more data than you need, you can set
limits on the number of alerts or events sent.

Procedure

1. Stop the SA IM Integration Service:

a. Click Control Panel > Administrative Tools > Services.

b. Select RSA SA IM - Data Collector, and click Stop.

2. Open the saim_intall_dir/config/collector-config.properties file.

3. Do one or both of the following:

l In the sa.alertsInIncident property, enter a valid integer. To allow all alerts,
enter a value of 0.

l In the sa.eventsInAlert property, enter a valid integer. To allow all events,
enter a value of 0.

4. Save the saim_intall_dir/config/collector-config.properties file.

5. Start the SA IM Integration Service:

a. Click Control Panel > Administrative Tools > Services.

b. Select RSA SA IM - Data Collector, and click Start.
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Chapter 5: Configuring the Integration with RSA
Security Analytics for Business Context

l Enterprise Management Plug-in for Business Context

l Configure the Enterprise Management Plug-in

Enterprise Management Plug-in for Business Context
The RCF Enterprise Management plug-in provides context around the assets that
are most critical to your organization by automatically feeding critical asset
information from your RSA Archer Enterprise Management solution through the
RCF into RSA Security Analytics as meta data. In Security Analytics, security
analysts can prioritize an investigation based on the assets most critical to the
organization, using the asset criticality and other meta data fed from your RSA
Archer system. Security analysts can also use the meta data to create rules and
alerts to identify network and log events happening on critical assets.

Important: You must populate the RSA Archer Devices application with the IP
addresses, criticality rating information, and the business unit and facilities cross-
references that you want to transfer to your RSA Security Analytics system. RSA
recommends contacting Professional Services if you need assistance populating
your data.

Configure the Enterprise Management Plug-in
To enable the full end-to-end functionality of the Enterprise Management plug-in,
you must configure your RSA Security Analytics and RSA Archer systems in
addition to configuring the actual plug-in in the RCF.

Procedure

1. Configure the RSA Archer GRC Platform

2. Configure the RCF

3. Configure RSA Security Analytics

Configure the RSA Archer GRC Platform

Procedure

1. (Optional) Create RCF User Security Parameter

2. Create RCF User Account
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3. Modify Archer Single Sign-On Mode

4. Collect RSA Archer GRC Platform Details

(Optional) Create RCF User Security Parameter
The RCF uses an Archer user account to transfer data into your system. If you
assign this account a default security parameter with a password change interval of
90 days, you will also have to update the user account password stored in the RCF
every 90 days. To avoid this, you can optionally create a new security parameter for
the RCF user account and set the password change interval to the maximum value
allowed by your corporate standards.

Important: If the RCF user account password expires, all communication between
the RCF and RSA Archer Security Operations Management will stop.

Procedure

1. Click Administration > Access Control > Manage Security Parameters.

2. Click Add New.

3. Do one of the following:

l To select new settings for the security parameter, select Create a new
Security Parameter from scratch, and click OK.

l To use the settings of an existing security parameter as a starting point for
the new security parameter, select Copy an existing Security Parameter.
Select an existing security parameter from the Security Parameter list, and
click OK.

4. In the General Information section, in the Name field, type RCF User Security
Parameter.

5. In the Password properties section, change the Password Change Interval.

6. If you created a new security parameter from scratch, fill in the additional
properties settings.

7. Click Save.

Create a User Account for the Enterprise Management Plug-in
You must create a user account that the RCF can use to gather data from the RSA
Archer GRC Platform for the Enterprise Management Plug-in. The RCF uses the
web service client to transfer data.

Procedure

1. Click Administration > Access Control > Manage Users > Add New.

2. In the First Name field, enter EM Plug-in.

3. In the Last Name field, enter RCF.
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4. (Optional) Enter a user name for this new user account.

Note: If you do not specify a user name, the RSA Archer Platform creates the
user name from the first and last name entered when you save the new user
account.

5. In the Contact Information section, in the Email field, enter an email address to
be associated with this new user account.

6. In the Localization section, change the time zone to (UTC) Dublin, Edinburgh,
Lisbon, London.

7. In the Account Maintenance section, enter a new password for the new user
account and confirm the new password.

Important: Note the user name shown for the new user account that you just
created. Also, remember the password that you just created. You need to enter
these credentials when you set up the RCF to communicate with the
RSA Archer Platform through the web service client.

8. Clear Force Password Change On Next Sign-In.

9. In the Security Parameter field, select the security parameter that you want to
use for this user.

10. Click the Groups tab, and click Lookup.

11. Expand the Groups list, select EM: Read Only, and click OK.

12. Click the Roles tab, and click Lookup.

13. Expand the Roles list, select EM: Read Only, remove General User, and click
OK.

14. Click Save.

15. If the machine language and regional settings of your RSA Archer system are
set to anything other than English-US, do the following:

a. Open the user account you just created, and in the Localization section, in
the Locale field, select English (United States), and click Save.

b. On the Windows system hosting your RSA Archer Platform, open Internet
Information Services (IIS) Manager, and do one of the following:

l If you are running IIS 6, right-click your RSA Archer site, select
Properties, click the ASP.Net tab, click Edit Configuration, click the
Application tab, in both the Culture and UI Culture fields, select en-US,
and click Apply.

l If you are running IIS 7, expand your RSA Archer site, click .Net
Globalization, in both the Culture and UI Culture fields, select English
(United States), and click Apply.

c. Restart your RSA Archer site.
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Modify Archer Single Sign-On Mode
If you are running the RSA Archer GRC Platform with single sign-on enabled, you
must make a modification so that the RCF can communicate with your RSA Archer
Platform.

Procedure

1. On the Windows system hosting the RSA Archer Platform, click Start >
Programs > Administrative Tools > Internet Information Services (IIS)
Manager.

2. Expand the local computer.

3. Expand Web Sites > Default Web Site > Archer.

4. Enable anonymous access. Do one of the following:

l For IIS 6.0:

a. Right-click the ws folder, and select Properties.

b. Click the Directory Security tab.

c. In the Authentication and access control section, click Edit.

d. Check Enable anonymous access and ensure that the default IIS account
is selected. (By default, the account is named IUSR_computername.)

e. Click OK twice.

l For IIS 7.0:

a. Select the ws folder.

b. In the IIS section, double-click Authentication.

c. Right-click Anonymous Authentication, and click Edit.

d. Select Specific user, and click Set.

e. Enter the credentials for the default IIS account. (By default, the account
is named IUSR.)

f. Click OK twice.

5. (Optional) Verify that single sign-on is disabled on the /ws folder:

a. Log on to the system on which you installed the RCF.

b. Open a browser and enter the following URL:
http(s)://yourArcherAddress/ws/module.asmx?wsdl

where http(s)://yourArcherAddress is the address that you use to log on to
the RSA Archer Platform. For example:

l For the RSA Archer Platform in simple mode, type:
http://10.10.10.10/archer
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l For the RSA Archer Platform in SSL/TLS mode with no context, type:
https://10.10.10.10

When you open the URL, you should not be prompted with a login screen if
single sign-on is properly disabled.

Collect RSA Archer GRC Platform Details
You must collect some specific RSA Archer GRC Platform details for configuring
the RCF. This information tells the RCF where to collect data from.

Note: You should already have noted a user name and a password in Create a
User Account for the Enterprise Management Plug-in.

Procedure

1. Click Start > Programs > Archer Technologies > Archer Control Panel.

2. Click Computer Name > Instances > Instance Name
where

l Computer Name is the name of your computer.

l Instance Name is the name configured for the default instance.

3. Note the instance name that is listed.

4. Log on to the RSA Archer Platform user interface.

5. From the URL, note the hostname, port, and context base, as indicated below:
http://hostname:port/context_base/default.aspx

Note: If you enabled SSL communication between the RCF and the RSA
Archer Platform, this value must match the Issued to value in the RSA Archer
Platform HTTPS certificate.

Note: If the port number does not appear, by default, HTTP uses port 80 and
HTTPS uses port 443.

6. Before moving on, ensure that you have the following details ready.

Archer Detail Your Value

User Name of the user account that you created
for the RCF to use to transfer data into the
RSA Archer Platform in Create a User
Account for the RSA Archer
GRC Platform Web Service Client.
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Archer Detail Your Value

Hostname found in the RSA Archer Platform
URL.

Port number found in the RSA Archer Platform
URL.

Context Base found in the RSA Archer
Platform URL.

Instance Name found in the RSA Archer
Platform Control Panel.

Note: You must also remember the password that you created for the
WebServices client user account.

Configure the RCF
For the Enterprise Management plug-in, the RCF pulls asset information from your
RSA Archer Platform, creates the csv file for a custom feed, and places this file in
a local folder for RSA Security Analytics Live to download.

Procedure

1. Open the em_config_wizard.vbs file located in the \Install_Dir\EMC\RSA
Connector Framework\plugins\em\auto-config directory.

2. If prompted to allow the program to run, click Yes.

3. When prompted, add the about:blank page as a trusted site. If you are not
prompted, add the page as follows:

a. In Internet Explorer, from the Tools menu, select Internet Options.

b. Click the Security tab.

c. Click Trusted Sites.

d. Click Sites.

e. In the Add this website to the zone field, enter about:blank, and click Add.

4. From the Introduction page, click Next.
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Note: If you installed the RCF in a non-default location, the Next button may
not work. If the Next button does not work, try the following: repeat steps 3a –
3b, then click Custom Level, and under Scripting > Active scripting, ensure that
Enable is selected. If necessary, repeat step 3a to 3c and change the security
level for trusted sites from high to medium. Close and reopen the configuration
wizard after making these changes.

5. Enter the data in the following fields.

Field Description

Host Name/IP
Address of
Archer Web
Server

The host name or IP address that you use to connect to the RSA
Archer Platform web console.

Port Number of
Archer Web
Server

The port number that you use to connect to the RSA Archer
Platform web console (by default, use 80 for HTTP and 443 for
HTTPS).

Instance Name
of Archer Web
Server

The name of the RSA Archer Platform instance to which you are
connecting.

Context Base
of Archer Web
Server

The RSA Archer Platform URL context base that you use.
(Optional)

Communication
Protocol

Select either HTTPS or HTTP. If you select HTTPS, ensure that
both your RSA Archer and RCF systems have HTTPS enabled and
that you have completed the steps in Configure the for TLS or
SSL Communication with the RSA Archer GRC
Platform.

User Name of
RCF Account
in Archer

The user name of the user account created for the RCF to transfer
data into the RSA Archer Platform. This must be the user account
that you created for the Enterprise Management plug-in. If you
have also configured other plug-ins, you may also have other user
accounts.

Password of
RCF Account
in Archer

The password for the user account created for the RCF to transfer
data into the RSA Archer Platform.

6. To test the RSA Archer Platform connection using the information that you
provided, click Test Archer Connection.
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Note: If the connection to the RSA Archer Platform is not successful, verify
the above data and try again. If you receive an error while testing the
connection to your SSL-enabled RSA Archer Platform, you can test your
connection as follows: open a browser on your RCF system, and log on to your
RSA Archer Platform using the user account that you created in Create a User
Account for the RSA Archer GRC Platform Web Service Client.

7. Click Next.

8. Enter data in the following fields.

Field Description

Feed
Frequency

The frequency with which you want to collect device criticality
data from your RSA Archer Platform.

Start Date The date when you want the feed to start.

Start Time The time when you want the feed to start.

Feed
Folder
Path

The existing folder on your RCF system in which you want feed
files to be saved for retrieval by Live.

Device
Criticality
Filter

Select which device criticalities you want to include in the feed.

Create
Initial
Feed

Select whether you want the initial feed to be created immediately
upon completion of the configuration wizard or as scheduled by
the feed frequency. This setting does not affect the regular feed
schedule.

User
Name of
Security
Analytics
account
in RCF

Enter a name for a new RCF user account that RSA Security
Analytics will use to retrieve data feeds.

Password
of
Security
Analytics
account
in RCF

Enter a password for the new RCF user account.
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Field Description

Web
Server
Mode

If you select SECURE_TCP, ensure SSL communication is enabled
between Security Analytics and the RCF system and that you have
created an SSL certificate for the RCF. See Create SSL
Certificates.

Web
Server
Port

The port number for the web server. The default port number is
9090 for TCP and 8443 for secure TCP.

Java
Keystore
File Path

The path of the Java Keystore file you created to store the SSL
certificate for RCF.

Java
Keystore
Password

The password protecting the Java Keystore file that will be used to
store the trusted SSL Web server certificate.

Java
Keystore
Private
Key
Password

The password protecting the private key for the Java Keystore file
that you created to store the SSL certificate for the RCF.

9. Click Next.

10. In the User Name and Password fields, enter the credentials you entered when
you installed the RSA Connector Framework, and click Next.

11. On the Summary page, verify that the information is correct, and click Start
Configuration.
The VB script performs the configurations based on the data given and displays
a note asking you to enter a run-script command.

The RSA Connector Shell uses PuTTY as its SSH client. The first time that you
open PuTTY, a security alert appears and informs you that the server host key is
not cached in the registry. Select Yes to proceed.

12. Click Run Script. (If Run Script does not work the first time, try clicking the
button again.)
When the script finishes successfully, the em application has been created from
the em plug-in and is in the Running state.

13. Restart the RSA Connector Framework.

a. Click Control Panel > Administrative Tools > Services.

b. Select RSA Connector Framework Service, and click Restart.

Chapter 5: Configuring the Integration with RSA Security Analytics for Business Context 63

weaglk
Highlight



Installation and Configuration Guide

Note: If you were creating SSL certificates before configuring the Enterprise
Management plug-in, finish the task. See Create SSL Certificates.

Configure RSA Security Analytics
To configure RSA Security Analytics for the Enterprise Management plug-in, you
must add new meta data keys so that RSA Archer asset criticality data is visible as
a new meta data element in RSA Security Analytics. Next you must also create a
recurring feed task to define the feed that RSA Security Analytics must download
from the RCF and push to Decoders.

Procedure

1. Create Criticality Category

2. Create Recurring Feed Task

Create Criticality Category
The RCF manages the files for a custom feed and deposits these files in a local
folder that you specify when you configure the RCF. The Live module of RSA
Security Analytics retrieves the feed files from this folder. Live then pushes the
feed to the Decoders, which start creating meta data based on captured network
traffic and the feed definition. To make each Concentrator aware of the new meta
data created by the Decoders, you must edit the index-concentrator-custom.xml file.

Note: If you also plan to feed Business Unit and Facility information from your
RSA Archer GRC Platform into Live, you must also add keys for these fields to the
index-concentrator-custom.xml file.

Procedure

1. In the Security Analytics Menu, click Administration > Services.

2. Select your Concentrator, and in the Device Grid toolbar, select View > Config.

3. Click the Files tab.

4. From the drop-down list, select index-concentrator-custom.xml.

l Do one of the following:

l If content already exists in the file, add a key for the new meta data
element as follows:
<key description="Criticality" format="Text" level="IndexValues"
name="criticality" defaultAction="Open"/>

Note: If you copy and paste this text, ensure that it is formatted on a
single line.
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l If the file is blank, add the following content:
<?xml version="1.0" encoding="utf-8"?>
<language level="IndexNone" defaultAction="Auto">
<key description="Criticality" format="Text" level="IndexValues"
name="criticality" defaultAction="Open"/>
</language>

5. Click Apply.

6. Click Push. Select the devices to which you want to push this file. Click OK.

7. Stop and start the Concentrator and Decoder services.

Create a Recurring Feed Task
In order for RSA Security Analytics to download feed files from your RCF machine
and push the feeds to Decoders, you must create a recurring feed task and define
the feed settings.

Procedure

1. In the Security Analytics Menu, click Live > Feeds.

2. Click +.
3. Select Custom Feed, and click Next.

4. Select Recurring.

5. Enter a name for the feed.

6. In the URL field, enter http(s)://rcf_hostname_or_ip:port/archer/sa/feed
where http(s)://rcf_hostname_or_ip:port is the address of your RCF system. Use
https if you have enabled SSL communication with RSA Security Analytics. For
example: http://10.10.10.10:9090 or https://10.10.10.10:8443.

7. Select Authenticated, and in the User Name and Password fields, enter the
credentials of the user account you created for RSA Security Analytics to use to
access files on the RCF system in Configure the RSA Connector
Framework.

8. Define the recurrence interval for the feed.

9. In the Date Range section, define a start and end date for the feed.

10. Click Next.

11. Select each Decoder to which you want to push this feed.

12. Click Next.

13. In the Type field, ensure that IP is selected.

14. In the Index Column field, select 1.
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15. In the second column, set the Key value to criticality.

16. Click Next.

17. Review your feed configuration details, and click Finish.
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Chapter 6: Customizing and Modifying the
Integration with RSA Security Analytics for
Business Context

l Include Optional Archer Fields

l Create a New Context Menu Action

l Change Feed Settings

l Change Feed File Name

Include Optional RSA Archer Fields
By default, only the IP Address and Criticality Rating fields in the RSA Archer
Devices application are fed into RSA Security Analytics by the RCF. You can
customize the Enterprise Management plug-in to include the Business Unit and
Facility fields that are cross-referenced in the Devices application in the feed.

Procedure

1. From the \Install_Dir\EMC\RSA Connector Framework\plugins\em directory,
open em_archer5.xml for editing.

2. Uncomment the businessunit and facility lines by removing <!-- and --> from the
ends of the line.

3. Save and close the file.

4. In the RSA Connector Shell, type:
refresh-app em

5. In the Security Analytics menu, click Administration > Devices.

6. Select your Concentrator, and in the Device Grid toolbar, select View > Config.

7. Click the Files tab.

8. From the drop-down list, select index-concentrator-custom.xml.

9. To include Business Unit meta data, add the following:
<key description="Business Unit" format="Text"

level="IndexValues" name="businessunit"

defaultAction="Open"/>

Note: If you copy and paste this text, ensure that it is formatted on a single line.

10. To include Facilities meta data, add the following:
<key description="Facility" format="Text"

level="IndexValues" name="facility" defaultAction="Open"/>
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Note: If you copy and paste this text, ensure that it is formatted on a single line.

11. Click Apply.

12. Click Push, select the devices to which you want to push this file, and click OK.

13. Stop and start the Concentrator and Decoder services.

14. Open the task that you created in Create a Recurring Feed Task.

15. Add two additional Key values as follows.

Column Key

3 businessunit

4 facility

16. Click Save.

17. Restart each Decoder to which you pushed these feeds and each Concentrator
to which one of these Decoders is assigned.

Create a New Context Menu Action
If you want security analysts to have the option of opening an RSA Archer session
to create a blank incident directly from the RSA Security Analytics interface, you
can create a new context menu action to perform this action.

Procedure

1. In the Security Analytics Menu, click Administration > System.

2. In the left navigation panel, click Plugins.

3. Click Add (+).

4. In the Configuration field, copy and paste the following:
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{     

"groupName": "externalLookupGroup",

"openInNewTab": "true",

"urlFormat": "http://yourarcherhostname/context_

base/GenericContent/Record.aspx?id=0&moduleID=75",

"moduleClasses": [

"UAP.investigation.InvestigationValuesApplication"

],

"type":"UAP.common.contextmenu.actions.URLContextAction",

"version": "1",

"id": "archerIncidentAction",

"order": "5",

"description": "",

"local": "false",

"displayName": "CreateArcherIncident",

"modules": [

"investigation"

],

"disabled": "",

"cssClasses": [

"meta-value-name-link"

]

}

where yourarcherhostname/context_base is the hostname and context base of
your RSA Archer system.

5. Click OK.

Change Feed Settings
After you have set up the Enterprise Management plug-in, if you find that you are
creating too much meta data or decide to include optional fields, you may need to
modify your feed settings.

Procedure

1. Open the plugin.properties file, located in the \Install_Dir\EMC\RSA Connector
Framework\plugins\em directory.

Note: This file contains some properties that do not apply to the Enterprise
Management plug-in and can be ignored. Only the properties listed below are
relevant to the Enterprise Management plug-in.

2. To change the feed frequency, enter a new value for the
all.import.scheduler.frequency property.

Note: Valid values for this property are daily, weekly, and monthly.
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3. To change the start date and time of the feed, enter new values for the
all.import.scheduler.start_date and all.import.scheduler.start_time properties.

Note: Values for the start date property must follow a MM/DD/YYYY format.
Values for the start time property must follow a HH:MM AM(/PM) format.

4. To change the criticality filter, enter any of the following:

a. To include devices with a "High" criticality rating in the feed, enter High for
the all.import.filter.high_criticality property.

b. To include devices with a "Medium" criticality rating in the feed, enter
Medium for the all.import.filter.medium_criticality property.

c. To include devices with a "Low" criticality rating in the feed, enter Low for
the all.import.filter.low_criticality property.

5. To change the folder location on your RCF system where feed files are stored,
enter a value or comma-separated values for the all.import.folder property.
For example, to store the feed in your C:\Program Files (x86)\EMC\RSA
Connector Framework\feeds\ folder, set the property as follows:

all.import.folder=C:\\Program Files (x86)\\EMC\\RSA

Connector Framework\\feeds

6. Save and close the file.

7. In the RSA Connector Shell, type:
refresh-app em

Change Feed File Name
By default, the feed file that the RCF produces is named assets.csv. If you want,
you can change the assets prefix to a different name.

Procedure

1. Open the plugin.properties file, located in the \Install_Dir\EMC\RSA Connector
Framework\plugins\em directory.

2. Enter a name in the all.import_file_prefix property.

3. Save and close the file.

4. Rename the assets.xml file, located in the \Install_Dir\EMC\RSA Connector
Framework\plugins\em directory, to match the new name you entered in step 2.

5. In the RSA Connector Shell, type:
refresh-app em

6. In the Security Analytics menu, click Live > Feeds.

7. Click the Recurring tab.
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8. Select the task that you created in Create a Recurring Feed Task, and click
Edit.

9. In the Name field, enter the new name for your feed.

10. Click Save.

11. Restart each Decoder to which you pushed this feed and each Concentrator to
which one of the Decoders is assigned.
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Appendix A: RSA Connector Framework (RCF)
Administration

This appendix provides information about the RCF and instructions on how to
manage the RSA Connector Framework Service and how to use each of the
commands available in the RSA Connector Shell.

RSA Connector Framework
The RCF is a plug-and-play structure that runs as a Windows system service and
integrates RSA products together by transporting and managing product data.

RSA Connector Framework Key Components
The RCF uses the following key components:

l A plug-in associated with the specific RSA Integration. A plug-in is a component
that you can manage during runtime to create an instance of an RSA Connector
application.

l An application that you create using the plug-in. An RSA Connector application
is a program that handles the business logic and imported data from one system
and outputs that data to another system.

l An endpoint configured for the RSA Connector application. An endpoint is an
external system with which the RCF needs to communicate. An endpoint can be
either a data source or data destination.

l A data mapping file that corresponds with the RSA Connector application. A
data mapping file is an XML document that instructs the corresponding
RSA Connector application on how to interpret the data received from the source
and how to map and transport that data to its destination.

l A command shell that you use to interact with the RCF.

l A configuration wizard for the plug-in that automates the configuration of
endpoint details and creation of the application from that plug-in.

The commands that you can use for a plug-in depend on the state of the plug-in.
Plug-ins have three possible states:

Installed. The plug-in is installed but all dependencies are not resolved.

Resolved. The plug-in is installed and all dependencies are resolved.

Active. The plug-in is installed and activated, and you can create new
applications.
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Like plug-ins, the commands that you can use for an application depend on the state
of the application. Applications have three possible states:

Unconfigured. The application is created, but the validation has either failed or
has not been completed.

Stopped. The application is created and the validation is successful, or a running
application has been stopped.

Running. The application is created, configured, validated, and running.

The following figure shows the relationship between the plug-in and application
states.

Note:When you install the RSA Connector Framework, you can select which
plug-ins you want to install. When the RSA Connector Framework installation is
complete, the plug-in is in the Resolved state.

RSA Connector Framework Tasks
The RCF runs as a Windows system service. The following tasks describe how to
start and stop the service, update user credentials, and launch the command shell
through which you interact with the RCF.

Start RSA Connector Framework
The RCF is automatically started as a Windows system service upon installation.
You can manually start the RCF if it has been stopped manually or unexpectedly.
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Procedure

1. Click Control Panel > Administrative Tools > Services.

2. Select RSA Connector Framework Service, and click Start.

Start RSA Connector Shell
The RSA Connector Shell is the text-based user interface that you use to interact
with the RCF. After you install the RCF, you must start the Connector Shell to
begin interacting with the RCF.

In either of the procedures, you may be prompted for the SSH server host key.

l If you click Yes, the host key is stored in the client cache and you are not
prompted again.

l If you click No, the host key is not stored in the client cache, and you are
prompted the next time that you log on.

l If you click Cancel, you abort the connection.

Procedure

Do either of the following:

l From a new command prompt, follow these steps:

1. Change directories to \Install_Dir\EMC\RSA Connector Framework\tools.

2. Type:
"putty.exe -ssh localhost -P port -l username -pw

password"

where:

l port is the port number that you specified for the RCF user interface.

l username is your RCF user name.

l password is your RCF password.

l From the Start menu, follow these steps:

1. Click All Programs > EMC > RSA Connector Framework > RSA Connector
Shell.

2. Enter your user name and password.

Change RSA Connector Framework User Credentials
Use the change credentials command to update the user name and password that
you use to connect to the RCF.

Procedure

In the RSA Connector Shell, type:
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change-ui-cred old-username old-password new-username new-

password

where:

l old-username is the current user name whose credentials you would like to
change.

l old-password is current password of the user.

l new-username is the new user name of the user.

l new-password is the new password for the user.

Note: The command arguments are optional. If you do not include them, the
Connector Shell prompts you for each individual value and also prompts you to
confirm your password.

List Bundles
A bundle is an installed component of the RCF. You cannot take any actions on
bundles, but knowing what state they are in may be useful for troubleshooting. Use
the list bundles command to display all installed bundles for the RCF, and to view
the name and state of each bundle.

Procedure

In the RSA Connector Shell, type:
list-bundles

Display RSA Connector Framework Version Information

Procedure

In the RSA Connector Shell, type:
version

Stop RSA Connector Framework

Procedure

1. Click Control Panel > Administrative Tools > Services.

2. Select RSA Connector Framework Service, and click Stop.

Restart RSA Connector Framework

Procedure

1. Click Control Panel > Administrative Tools > Services.

2. Select RSA Connector Framework Service, and click Restart.
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Define Queue Settings
Each plug-in has an associated plugin.properties file, which allows you to define
settings for how the RCF handles data requests for any applications created from
that plug-in. Each property in the file begins with appname.request, where appname
is the name of the application created from the plug-in. If you want to configure a
property for every application created from the plug-in, use all as the application
name.

Procedure

1. Open the plugin.properties file, located in the \Install_Dir\EMC\RSA Connector
Framework\plugins\plugin-name directory.

2. Modify any of the settings, as follows:

l To set the queue size for incoming requests, enter a value for the
request.queue.size property.

Note: Valid values for this property are numbers between 1 and 2147483647.
The default value is 2147483647.

l To set the time interval between the processing each queued request, enter a
value for the request.queue.worker.sleep.interval property.

Note: Valid values for this property are numbers in milliseconds between 1
and n. The default value is 0, which means no delay between requests.

l To set the time interval between retry attempts for failed requests, enter a
value for the request.queue.retry.sleep.interval property.

Note: Valid values for this property are numbers in milliseconds between 1
and n. The default value is 10.

l To set the maximum number of retry attempts for failed requests, enter a
value for the request.queue.max.retry property.

Note: Valid values for this property are numbers between 1 and 2147483647.
The default value is 2147483647.

l To set whether or not the RCF loads the persisted incoming requests when
the service is started, enter a value for the
request.queue.reload.persisted.entries property.

Note: Valid values for this property are true and false. The default value is
true.

3. Save and close the file.
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Activate Silent Mode
Normally, there are certain RSA Connector Shell commands that require user
confirmation to run. You can use the silent mode on command to remove that
confirmation requirement and help with automation.

Procedure

In the RSA Connector Shell, type:
silent-mode on

The Connector Shell now no longer asks for confirmation for the following
commands:

l change-endpoint-cred

l add-endpoint-cred

l delete-endpoint-cred

l change-ui-cred

l create-app

l delete-app

l deactivate-plugin

l stop-app

l refresh-app

Deactivate Silent Mode
Normally, there are certain RSA Connector Shell commands that require user
confirmation to run. If you have previously used the silent mode on command and
wish to reinstate the command confirmation, you can use the silent mode off
command to turn off silent mode.

Procedure

In the RSA Connector Shell, type:
silent-mode off

The Connector Shell now asks for command confirmations.

Run Script
This command allows the administrator to run a batch file from the RSA Connector
Shell to perform multiple commands.

Procedure

In the RSA Connector Shell, type:

run-script filename
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where filename is the name of your script file.

If you do not specify a path, the RCF assumes that the script file is located under
\Install_Dir\EMC\RSA Connector Framework\scripts.

Note: For each command listed in the script file, the Connector Shell echoes the
command and displays the messages generated from the command.

Schedule Job to Run Immediately
Some RCF applications run jobs at a scheduled frequency. This command allows
the administrator to schedule a job to run immediately, even if the job is already
scheduled to run at a specific time. Running this command does not affect the
configured run schedule.

Procedure

In the RSA Connector Shell, type:
run-job-now app_id

where app_ID is the application ID of the application for which you want to
schedule a job.

Uninstall RSA Connector Framework
You can uninstall the RCF if necessary. When you uninstall the RCF, all of the
Framework components are uninstalled.

Note: Uninstalling the RCF does not remove the RSA Connector Framework
folder, the logs subdirectory, or any files in the logs subdirectory. To remove these
files, manually delete them.

Procedure

1. Click Start > Programs > EMC > RSA Connector Framework > Uninstall.

2. When prompted to uninstall, click Yes.

3. Click Finish.

Plug-In Commands
The following sections describe how to use each of the plug-in commands available
for RCF. For more information about plug-ins and plug-in states, see
RSA Connector Framework Key Components.

Install a Plug-In
If you chose not to install a plug-in when you installed the RCF, you can install the
plug-in later.
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Note: Only plug-ins that are located in the same folder as the RSA_Connector_
Framework_Plugin_n.nbnnn.exe file can be installed. Before you begin, ensure that
the plug-in file that you want to install is located in this folder.

Procedure

1. Double-click RSA_Connector_Framework_Plugin_n.nbnnn.exe.

2. Click Next.

3. Read and accept the license agreement, and click Next.

4. On the Select Plug-ins page, select the plug-in that you want to install, and click
Next.

5. On the Begin Install page, click Install.

6. On the Finished page, click Finish.

Activate a Plug-In
Use the activate plug-in command to activate plug-ins that are currently in the
Resolved state. After you activate a plug-in, the state changes to Active and you
can now create applications from the plug-in.

Procedure

In the RSA Connector Shell, type:
activate-plugin plugin_name

where plugin_name is the name of the plug-in that you want to activate.

Note: You can also enter the plug-in ID instead of the plug-in name.

List Plug-Ins
Use the list plug-ins command to display all installed plug-ins for the RCF and to
view the ID, current state, name, and description of each plug-in.

Procedure

In the RSA Connector Shell, type:
list-plugins

Deactivate a Plug-In
Use the deactivate plug-in command to deactivate a plug-in that is in the Active
state. You can only deactivate a plug-in that has no existing applications created
from it. After you deactivate a plug-in, the state changes to Resolved and you may
no longer create applications from that plug-in.

Procedure

In the RSA Connector Shell, type:
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deactivate-plugin plugin_name

where plugin_name is the name of the plug-in that you want to deactivate.

Note: You can also enter the plug-in ID instead of the plug-in name.

Uninstall a Plug-In
If you have previously installed a plug-in that you no longer require, you can
uninstall the plug-in.

To uninstall a plug-in:

1. Double-click RSA_Connector_Framework_Plugin_2.7bnnn.exe.

2. Click Next.

3. Read and accept the license agreement, and click Next.

4. On the Select Plug-Ins page, deselect the plug-in that you want to uninstall, and
click Next.

5. On the Begin Install page, click Install.

6. On the Finished page, click Finish.

Application Commands
The following tasks describe how you can use each of the application commands
available. For more information about applications and application states, see
RSA Connector Framework Key Components.

Create an Application
Use the create application command to create a new application from a plug-in that
is in the Active state.

Procedure

In the RSA Connector Shell, type:
create-app plugin_name app_ID mapping_file.xml

where:

l plugin_name is the plug-in name of the Active plug-in from which you want to
create an application.

Note: You can also enter the plug-in ID instead of the plug-in name.

l app_ID is the application ID of the application that you are creating.

l mapping_file.xml is the data mapping file that you want to use.
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Note: The application ID cannot be longer than 32 characters and cannot contain
spaces. The mapping file that you want to use must be located in the Install_
Dir\EMC\RSA Connector\plugins\plugin_name directory.

Validate an Application
Use the validate application command to validate the configuration of an application
if you have updated either the endpoint details or the data mapping file.

Procedure

In the RSA Connector Shell, type:
validate-app app_ID

where app_ID is the application ID of the application that you want to validate.

Start an Application
Use the start application command to start an application that is currently in the
Stopped state. An application must be started to begin transferring data.

Procedure

In the RSA Connector Shell, type:
start-app app_ID

where app_ID is the application ID of the application that you want to start.

Refresh an Application
Use the refresh application command to refresh the configuration of an application
that is in the Running state if you have updated the endpoint details or the
application data mapping file.

Note: Use the validate application command to verify your new configuration
before you refresh the application.

Procedure

In the RSA Connector Shell, type:
refresh-app app_ID

where app_ID is the application ID of the application that you want to refresh.

List Applications
Use the list applications command to display all of the currently installed
applications for the RCF and to view the application ID, service name, and state of
each application.
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Procedure

In the RSA Connector Shell, type:
list-apps

Stop an Application
Use the stop application command to stop an application that is currently in the
Running state.

Procedure

In the RSA Connector Shell, type:
stop-app app_ID

where app_ID is the application ID of the application that you want to stop.

Delete an Application
Use the delete application command to remove an application that you no longer
need from the RCF. You can only delete applications that are in the Stopped state.

Procedure

In the RSA Connector Shell, type:
delete-app app_ID

where app_ID is the application ID of the application that you want to delete.

Note:When you delete an application, the user name and password endpoint
credentials are also deleted, but the other endpoint details are not. The associated
mapping file is also not deleted. You must delete these items manually.

Endpoint Commands
When you set up endpoint details for an RSA Connector application so that the RCF
can communicate with the RSA Archer GRC Platform, you enter user credentials
through the RSA Connector Shell and enter other details directly into the
endpoint.properties file. The following tasks describe how you can use each of the
endpoint commands available.

Add Endpoint Credentials
Use the add endpoint command to enter user credentials for a new endpoint.

Note: You must also specify the hostname, port, and instance for the RSA Archer
session with which you want to communicate. This process is done outside of the
RSA Connector Shell.
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Procedure

In the RSA Connector Shell, type:
add-endpoint-cred appID endpointName username password

where

l appID is the application ID that you created in the RSA Connector Framework.

l endpointName is the name of your new endpoint.

l username is the user name that you created for this endpoint.

l password is the password that you created for this endpoint.

Note: The command arguments are optional. If you do not include them, the
Connector Shell prompts you for each individual value and also prompts you to
confirm your password.

Change Endpoint Credentials
Use the change endpoint command to update the user credentials of an existing
endpoint.

Procedure

In the RSA Connector Shell, type:
change-endpoint-cred appID endpointName username password

where

l appID is the application ID that you created in the RCF.

l endpointName is the name of your endpoint.

l username is the user name that you created for this endpoint.

l password is the password that you created for this endpoint.
The command arguments are optional. If you do not include them, the Connector
Shell prompts you for each individual value and also prompts you to confirm your
password.

List Endpoints
Use the list endpoints command to display all endpoints found in the
endpoint.properties file.

Procedure

In the RSA Connector Shell, type:
list-endpoints appID

where appID is the application ID that you created in the RCF.
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Delete Endpoint Credentials
Use the delete endpoint command to remove the user credentials for an endpoint
that you no longer need.

Procedure

In the RSA Connector Shell, type:
delete-endpoint-cred appID endpointName

where

l appID is the application ID that you created in the RCF.

l endpointName is the name of your new endpoint.

The appID argument is optional. If you do not include the argument, the Connector
Shell prompts you for it.

Important:When you delete an endpoint, the user name and password endpoint
credentials are deleted, but the RSA Archer Platform hostname, port, and instance
name are not. You must delete these items from the endpoint.properties file
manually.

Help Commands
The RSA Connector Shell features built-in help commands that allow you to view a
complete list of commands and to display more detailed information about a specific
command. The following tasks describe how to use each of the help commands.

Display All Commands
Use the help command to list all commands that are supported by the RSA
Connector Shell.

To display commands:

In the RSA Connector Shell, type:
help

The system displays a list of all available commands.

Display Specific Command
Use this procedure to display more detailed information about a particular
command. The system displays the name of the command, the correct syntax for
entering the command, and a description of what the command does.

Procedure

In the RSA Connector Shell, type:
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help command_name

where command_name is the name of the command for which you want to display
more information.
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Appendix B: SA IM Integration Service
Administration

This appendix provides additional tasks for using and managing the
SA IM Integration Service.

Start the SA IM Integration Service

Procedure

1. On your SA IM Integration Service system, click Control Panel >
Administrative Tools > Services.

2. Select RSA SA IM - Data Collector, and click Start.

Stop the Collector Service

Procedure

1. Click Control Panel > Administrative Tools > Services.

2. Select RSA SA IM - Data Collector, and click Stop.

Note: If the service takes too long to shutdown, use the Task Manager to end the
RSASAIMCollector process.

Uninstall the SA IM Integration Service

Procedure

1. Click Control Panel > Programs and Features

2. Select RSA_Unified_Collector_Framework.

3. Click Uninstall.
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Appendix C: Troubleshooting
This appendix provides resolutions to common problems that you may encounter
while configuring the solution.

Package Installation Log Message Examples
For more information on the Package Installation Log messages, see "Package
Installation Log Messages" in the RSA Archer Online Documentation.

For information on the dependencies for each solution, see the Data Dictionary.

Warning
Message Explanation Remediation

<Object Name>
Alias was
changed from
<Original Alias>
to <New Alias>

This message is an
informational warning
indicating that the Alias was
updated on the object. There
are two reasons for an alias in
the Target Instance to have
been updated:

l Update was in the Source
Package.

l Alias has to be unique in
the Target Instance. If the
alias already exists in
Target, packaging adds a
unique identifier to the end.

This message is only potentially an issue if the
change occurs on a field that is utilized in a Mail
Merge Template or Data Publication Service. In
that scenario, update the DPS or the mail merge
template with the new alias.

<Field Name> in
the application
<Application
Name> cannot be
changed from a
private field to a
public field.

This message is an
informational warning
notifying you that packaging
does not change a private field
in the target instance to a
public field.

Change the field to public manually (optional).
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Warning
Message Explanation Remediation

Field <Field
Name> could not
be saved due to
inability to
identify the
related module.

This message is seen when a
cross-reference or related record
field could not be created
because the related application
does not exist in the target
instance. This message usually
occurs because the field is part
of a related core solution that
has not been updated in the
target instance.

1. Install the package for the solution containing
the related application. You must have a
license for the related application.

2. Reapply the original package to resolve the
warning.

See the Data Dictionary.

The calculated
field <Field
Name> in the
application
<Application
Name> cannot be
verified.

The formula in the calculated
field is incorrect. Most often,
this message occurs when the
formula references a field in a
related application and either
the field or the application does
not exist in the target instance.
This may be because the applic-
ation is in a related core solu-
tion that has not been updated.

1. Install the package for the solution containing
the related application. You must have a
license for the related application.

2. Reapply the original package to resolve the
warning.

See the Data Dictionary.

Field <Field
Name> was not
found and
removed from a
collection.

This warning may be seen on
Inherited Record Permission
fields, cross-reference/related
record fields (record lookup and
grid display), or as a display
field in a report. The warning
means that the field could not
be found in the target instance
and was not included in the
package. This is usually
because the field is part of an
application in a related core
solution that has not been
updated in the target instance.

1. Install the package for the solution containing
the related application (to obtain the missing
field). You must have a license for the related
application.

2. Reapply the original package to resolve the
warning.

See the Data Dictionary.

Note: If you do not have a license for the related
application, you may ignore this message, and the
field remains omitted from the object.
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Security Analytics Incident Management Integration Troubleshooting

Problem Resolution

After stopping the
RSASAIMDC service
from Windows Service
Control Manager, the
service does not stop.

1. On your SA IM Integration Service system, open Task
Manager.

2. End the RSASAIMDC process.

After installing the SA
IM Integration Service,
the RSASAIMDC
service does not start
automatically.

Open the saim_install\logs\collector.log file and check for
errors.

Findings and Security
Incidents do not appear
in RSA Archer
Security Operations
Management solution.

1. Confirm that the time on your middleware system and the
RSA Archer Platform are synchronized or with a difference
of no more than a minute.

2. Confirm that the SA IM Integration Service is set to the
appropriate mode.

l For Findings, you should select to manage the incident
workflow in RSA Security Analytics.

l For Security Incidents, you should select to manage the
incident workflow in RSA Archer Security Operations
Management.

3. In Rabbit MQ, confirm the existence of im.archer_
incident_queue and im.archer_tickets_queue.

4. Confirm the above queues are populated with messages
from the SA IM Integration Service.

Remediation Tasks
being pushed to the
Operations queue
through the SA IM
Integration Service are
not appearing in
RSA Archer Security
Operations
Management as
Findings.

1. Open the Command Manager:

a. Open a command prompt

b. Change directories to saim_install_dir/data-collector.

c. Type: runConnectionManager.bat

2. Enter 2 for Edit Endpoint.

3. Enter 3 for Security Analytics IM.

4. Ensure the Target Queue is set to All or Operations.
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Problem Resolution

Default log files do not
provide RSA Archer
Webservice API calls.

Open saim_install\config\collector-log4j.xml, and change the
log level for CXF to warn from info:

<logger name="org.apache.cxf">
<level value="info" />
</logger>

In the saim_
install\logs\collector.lo
g, there are SSL errors
between RSA Security
Analytics and
SA IM Integration
Service.

Verify that the SSL certificates are valid.

In the saim_
install\logs\collector.lo
g, there are a series of
connection
timeout/reset issues.

This is a known issue when using an operating system less
than Window Service 2008 R2 DataCenter. Please wait 4 to 5
minutes after the service starts for the SA IM Integration
Service to establish a connection.

In RSA Archer
Security Operations
Management, there are
more events per alert or
alerts per incident
displayed than desired.

By default, RSA Archer will send and receive all events and
alerts. To adjust your settings, Set the Maximum Number
of Alerts or Events Sent Through the SA IM
Integration Service.

RSA Archer is pulling
data from SA IM at an
undesirable rate.

The default interval
between incident
updates is 1 minute.

The default interval
between findings
updates is 5 minutes.

1. Stop the SA IM Integration Service.
2. Open the saim_install\config\collector-config.properties

file, and edit the applicable property.

l To update the interval for incident updates, change the
cron expression of archer.pull.getIncidents.schedule.

l To update the interval for findings updates, change the
cron expression of archer.pull.getFindings.schedule.

Where:

pull is the endpoint name for the account used to pull data
from RSA Archer.

3. Start the SA IM Integration Service.
For more information on cron expressions, see the Quartz Job
Scheduler tutorial on CronTrigger.
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Problem Resolution

Adding an RSA Archer
endpoint in the
Connection Manager
fails.

In the saim_install\logs\connectionManager.log log file, verify
the following

l RSA Archer is in SSL Mode.

l The Common Name present in the RSA Archer
SSL Certificate matches the host name of the RSA Archer
machine.

l The password for the user is valid.

Adding an
SA IM Endpoint in the
Connection Manager
fails.

Retry adding the endpoint.

Insufficient security
SSL errors occur in the
saim_
install\install\logs\colle
ctor.log.

1. Stop the SA IM Integration Service.
2. Download the Java Cryptography Extension (JCE)

Unlimited Strength Jurisdiction Policy Files from
http://www.oracle.com/technetwork/java/javase/do
wnloads/index.html

3. Extract the downloaded zip file.

4. Move the extracted US_export_policy.jar and local_
policy.jar files to the following JRE install directory:
JRE_Install_Dir/lib/security (Overwrite the existing files)

5. Start the SA IM Integration Service.

Enterprise Management Plug-In Setup Troubleshooting
If you finish configuring the Enterprise Management plug-in, but RSA Archer asset
criticality information is not showing up in RSA Security Analytics, use the
following table to help identify the source of the issue and resolve the problem. The
left-hand column lists specific items to check, the middle column tells you how to
determine if this item is your issue, and the right-hand column gives potential
resolutions for each issue. If any of the resolutions do not solve the problem, contact
RSA Customer Support.
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Checklist Item How to Determine Resolution

Is your Archer
Devices application
populated with
device and criticality
information?

1. On the RSA Archer Platform, expand the Enterprise
Management solution in the Navigation Menu.

2. Expand the Devices application, and click Display
All.

3. Open a device record and note whether the
Criticality Rating field is populated.

Contact RSA
Professional Services
for assistance.

Is the asset criticality
.csv feed file located
in the file you
specified?

On your RCF system, open the folder that you specified
for the feed file location in Configure the RSA
Connector Framework and note whether the feed file
is present.

Review the following
items.

l Is your RSA
Archer system
reachable from
your RCF system?

Log on to your RCF machine, and do the following:

1. Open a command prompt and ping your RSA Archer
system.

2. Open a web browser and log on to your RSA Archer
system using the WebServices user account that you
created for the RSA Connector Framework in
Create a User Account for the RSA Archer
GRC Platform Web Service Client.

If you are not
successful at step 1,
contact your network
administrator.

If the RSA Archer
Platform logon page
does not render in step
2, reset Internet
Information Services
(IIS) on the RSA
Archer web server, as
follows:

1. Log on to the
Windows system
hosting the RSA
Archer Platform.

2. Open a command
prompt. Type:

iisreset
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Checklist Item How to Determine Resolution

l Does the
WebServices user
account created for
the RCF have the
correct credentials
and access rights?

Log on to the system on which you installed the RCF,
open a web browser and log on to your RSA Archer
system using the WebServices user account that you
created for the RCF in Create a User Account for
the RSA Archer GRC Platform Web
Service Client.

Do the following:

l Review the logon
credentials and
access rights for the
WebServices user
account that you
created in Create
a User Account
for the RSA
Archer
GRC Platform
Web
Service Client.

l Verify that the user
credentials selected
in the RSA Archer
system match what
you entered in the
RCF Configuration
Wizard. If you need
to change the
credentials, see
Change Endpoint
Credentials.

Are there TLS or SSL
errors found within
the RCF logs?

1. Open \Install_Dir\EMC\RSA Connector
Framework\logs to view the logs.

2. Check to see if there is an error message as seen in
the example below:
SEVERE: app_ID - Error occured while storing data
into archer.... Caused by: org.apache.felix.log.
LogException: javax.wsdl. WSDLException:
WSDLException: faultCode=PARSER_ERROR:
Problem parsing '_
https://10.100.0.1:443/archer/ws/general.asmx?wsdl'.:
java.io.IOException: HTTPS hostname wrong:
should be <10.100.0.1>

Ensure that the RSA
Archer TLS or SSL
certificate hostname or
IP address matches the
hostname or IP address
that you entered in
step 3 of Configure
the for TLS or SSL
Communication
with the RSA
Archer GRC
Platform.

Is the RCF configured
properly?
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Checklist Item How to Determine Resolution

l Are the bundles
installed properly?

Use the list bundles command to verify the status of
each bundle.

Restart the RSA
Connector Framework
Service, and recheck
the bundles.

l Is the RCF Service
running?

Click Start > Administrative Tools > Services, and see if
the RCF Service is running.

Start the RCF Service.
See Start RSA
Connector
Framework.

l Is the plug-in in
the Active state?

Use the list-plugins command to ensure that the plug-in
is in the Active state.

Activate the plug-in.

l Is the application
in the Running
state?

Use the list-apps command to ensure that the application
that you created is in the Running state.

Start the application.

l Are the
endpoint.properties
details entered
properly?

Open \Install_Dir\EMC\RSA Connector
Framework\plugins\em\endpoint.properties

If you need to make
any changes, follow
the instructions for
changing the
configuration of an
application in the
Running state in
Component
Troubleshooting.

l Are the
plugin.properties
details entered
properly?

Open \Install_Dir\EMC\RSA Connector
Framework\plugins\em\plugin.properties.

If you need to make
any changes, follow
the instructions for
changing the
configuration of an
application in the
Running state in
Component
Troubleshooting.

l Do the log files
indicate errors or
exceptions?

Open \Install_Dir\EMC\RSA Connector Framework\logs
to view the logs.

Contact Customer
Support.

Did the recurring task
run correctly?

1. In the Security Analytics menu, click Live > Feeds.

2. Note the task you created, when it last ran, and what
the last run result was.

Review the following
items.

Appendix C: Troubleshooting 94



Installation and Configuration Guide

Checklist Item How to Determine Resolution

l Is your RSA
Security Analytics
system reachable
from your RCF
system?

Log on to your RCF system, open a command prompt,
and ping your RSA Security Analytics system.

Try to log on to your
RSA Security
Analytics system. If
you are not successful,
contact your
administrator.

l Does the RCF user
account created for
Security Analytics
to use have the
right credentials?

Review the logon credentials and access rights that you
entered for Security Analytics to access the RCF in
Create a Recurring Feed Task match the values
that you entered in Configure the RSA Connector
Framework.

l Enter the correct
credentials in the
recurring feed task,
save the task, and
restart any
Decoders to which
the feed is pushed.

Does the new meta
data category appear
in the Investigation
Module?

In the Security Analytics menu, click Investigation >
Navigate, and select a device to investigate, and see
whether the Criticality report is visible.

Note: If you do not see the report, check to see if the
report contains any results for the active query. The list
of reports that contain no results is at the bottom of the
collection screen.

Do the following:

l Review Create
Criticality
Category.

Note: Double
check that you
have restarted the
Concentrator after
editing the index
file.

Does the Criticality
report contain results?

In the Investigation Module, locate the Criticality report
and see if it lists report values and associated session
counts.

Do the following:

l Verify that the
name attribute of
the key that you
entered in the
index-concentrator-
custom.xml file
matches the name
of the key value
you entered in
Create a
Recurring Feed
Task.
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Component Troubleshooting
The following table lists common component problems and their resolutions. If any
of the resolutions do not solve the problem, contact RSA Customer Support.

Compon
ent Problem Resolution

RSA
Archer
GRC
Platform
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Compon
ent Problem Resolution

Password for an RSA Archer
WebServices user account is about to
expire.

To change the password for the
RSA Archer WebServices user
account, follow these steps:

1. On your RSA Archer system,
do the following:

a. Click Administration >
Access Control >
Manage Users.

b. Select the WebServices
user account.

c. In the Account
Maintenance section,
click Change Password.

d. Enter a new password,
confirm the password,
and click OK.

e. Click Save.

2. In the RSA Connector
Framework Shell, do the
following:

a. Stop the application. See
Stop an Application.

b. Change the endpoint
credentials using the new
password. See Change
Endpoint Credentials.

c. Validate the application.
See Validate an
Application.

d. If the validation is
successful, refresh the
application. See Refresh
an Application.

e. Start the application. See
Start an Application.
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Compon
ent Problem Resolution

During the package import process, the
following warning messages may appear.

"Field {0} was not found and removed
from a collection."

These errors are benign and can
be ignored.

The Incident Status dashboard still
appears in your workspace after
upgrading from RSA Advanced Incident
Management for Security 1.1. This
dashboard is not required for RSA
Security Operations Management.

Remove the dashboard from your
workspace, as follows:

1. Click Administrations >
Workspaces and Dashboards
> Manage Workspaces.

2. Open the Security Operations
Management workspace.

3. Click the Dashboards tab.

4. For the Incident Status
dashboard, click Remove in
the Actions column.

5. Click Save.

RSA
Connecto
r
Framewor
k

Cannot log on to RSA Connector Shell. Confirm that you do not have
another instance of the RSA
Connector Shell already running.
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Compon
ent Problem Resolution

Need to change configuration of an
application that is currently in the
Running state.

If you need to update any of the
existing configuration files,
follow these steps:

1. Stop the application. See
Stop an Application.

2. Change the configuration
files (data mapping file,
endpoint properties, or plugin
properties).

3. Validate the application. See
Validate an Application.

4. Start the application. See
Start an Application.

If you want to use a different
mapping file, follow these steps:

1. Stop the application. See
Stop an Application.

2. Delete the application. See
Delete an Application.

3. Create the application again
and specify the new mapping
file. See Create an
Application.

4. Create the endpoint again.
See Create an Endpoint.

5. Validate the application.
Validate an Application.

6. Start the application. Start
an Application.
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Compon
ent Problem Resolution

The Configuration Wizard displays the
following error message:

Line 2251
Char 6
Error Permission denied
Code 800A0046
Source Microsoft VBScript runtime error

Close the Configuration Wizard,
wait a minute, and restart the
wizard.

The Configuration Wizard displays the
following error message:

Line 453
Char 5
Error the object invoked has
disconnected from its clients
Code 80010108
Source (null)

Close the Configuration Wizard,
wait a minute, and restart the
wizard.

You accidentally deleted the
felix.properties file in the Install_
Dir\EMC\RSA Connector
Framework\config folder or it has
become corrupted.

Run the RSA Connector
Framework installer, as follows:

1. Double-click RSA_
Connector_Framework_
2.7bnnn.exe.

2. When prompted to update
your current installation,
click Yes.

3. Click Finish.
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Compon
ent Problem Resolution

You accidentally deleted the rsa_
connector_shell.bat file in the Install_
Dir\EMC\RSA Connector
Framework\bin directory or it became
corrupted, and after you run the repair
installer for the RSA Connector
Framework, the RSA Connector Shell
displays the following message,
"Network error: Connection refused."
The repair installer cannot recreate the
rsa_connector_shell.bat file. You must
do so manually.

1. In the Install_Dir\EMC\RSA
Connector Framework\bin
directory, create a new file
called rsa_connector_
shell.bat.

2. In the file, enter the
following:

REM Replace Install_Dir and
Port_Num with values
selected by the user during
installation.

Install_Dir\EMC\RSA
Connector
Framework\tools\putty.exe" -
ssh localhost -P Port_Num

3. Replace Install_Dir with the
directory where you installed
the RSA Connector
Framework.

4. Replace Port_Num with the
user interface port number
that you entered when you
first installed the RSA
Connector Framework.

5. Save and close the file.
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Compon
ent Problem Resolution

The following warning messages may
appear in the RSA Connector Framework
logs after installation.

WARNING: Exception occurred while
fetching binary value from vault for key
app_ID.endpointname.username: Error: -
31 LockBox::retrieveBinaryItemSize :
The requested lockbox entry could not
be found.

WARNING: Error occurred while
loading Plugin Folder Install_
Dir\EMC\RSA Connector
Framework\plugins\plugin-name
plugin.properies file. File may not be
required.

WARNING: No items found in persisted
cache queue app_ID_request_queue_
cache.

These messages do not affect any
functionality and can be ignored.

The following message may appear in
the RSA Connector Framework logs.

SEVERE: Crossed referenced tracking id
not found for field name Field Name for
application Name.

This message indicates that there
is a value in the Security
Analytics alert for which there is
no record in your RSA Archer
Devices application. You may
see this message for the source IP,
destination IP, or device IP fields.
To resolve the issue, you can add
a record for the missing value in
your Devices application.

You are unable to edit RSA Connector
Framework configuration files, such as
plugin.properties or endpoint.properties.

1. Open a text editor with
escalated administrative
privileges. For example,
right-click notepad.exe, and
select run as administrator.

2. Use this instance of the text
editor to open, modify, and
save the configuration files.
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Compon
ent Problem Resolution

The following error messages appear in
the RSA Connector Framework logs.

SEVERE: app_ID - Error occured while
handling incoming data

Causedby:org.apache.felix.log.LogExcep
tion: java.net.SocketTimeoutException

The connection between the RSA
Connector Framework and the
RSA Archer Web Services may
time out if Archer is busy. You
can modify the amount of time
that the RSA Connector
Framework waits for a response
from the RSA Archer Web
Services before timing out.

1. Open the plugin.properties
file, located in the \Install_
Dir\EMC\RSA Connector
Framework\plugins\plugin_
name directory.

2. Modify either of the
following:

l To set how quickly the
connection with the RSA
Archer Web Services
times out if there is no
response from the RSA
Archer Platform when the
application tries to send
requests, enter a value for
the
archer.ws.client.request.sen
d.timeout property.

Note: Valid values for
this property are numbers
in milliseconds between 1
and n. The default value is
30000.

l To set how quickly the
connection with the RSA
Archer Web Services
times out if there is no
response from the RSA
Archer Platform when the
application tries to read
responses, enter a value
for the

Appendix C: Troubleshooting 103



Installation and Configuration Guide

Compon
ent Problem Resolution

archer.ws.client.response.re
ad.timeout property.

Note: Valid values for
this property are numbers
in milliseconds between 1
and n. The default value is
60000.

Default logging level does not provide
enough information.

1. Open the logging.properties
file, located in the \Install_
Dir\EMC\RSA Connector
Framework\config directory.

2. Change the
java.util.logging.FileHandler.
level property to ALL.
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The following error messages appear in
the RSA Connector Framework logs.

SEVERE: Job
(enterpriseManagementGroup.emJob
threw an exception.

org.quartz.SchedulerException: Job
threw an unhandled exception. [See
nested exception:
java.lang.OutOfMemoryError: Java heap
space]

at org.quartz.core.JobRunShell.run
(JobRunShell.java:217)

at
org.quartz.simpl.SimpleThreadPool$Wor
kerThread.run
(SimpleThreadPool.java:548)

Caused by:
java.lang.OutOfMemoryError: Java heap
space

1. Stop the RCF service:

a. Click Control Panel >
Administrative Tools >
Services.

b. Select RSA Connector
Framework Service, and
click Stop.

2. Open wrapper.conf, located
in the Install_Dir\EMC\RSA
Connector
Framework\system\felix\wrap
per\conf folder.

3. Change the
wrapper.java.initmemory
property to 512, and ensure
that the property is
uncommented.

4. Change the
wrapper.java.maxmemory
property to 1024, and ensure
that the property is
uncommented.

5. Save and close the file.

6. Start the RCF service:

a. Click Control Panel >
Administrative Tools >
Services.

b. Select RSA Connector
Framework Service, and
click Start.
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