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System Security and User Management Overview
This guide provides information about setting up security and controlling user access. The
System Administrator needs to understand system-wide settings, user accounts, system roles,
permissions, and access to services.

Topics

l How Role-Based Access Control Works

l Set Up System Security

l Manage Users with Roles and Permissions

l Set Up Public Key Infrastructure (PKI) Authentication

l System Security and User Management: Additional Procedures

l System Security and User Management: References

l System Security and User Management: Troubleshooting
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How Role-Based Access Control Works
This topic explains role-based access control (RBAC) when there is a trusted connection
between Security Analytics Server and a core service.

In Security Analytics, roles determine what users can do. A role has permissions assigned to it
and you must assign a role to each user. The user then has permission to do what the role allows.

Pre-Configured Roles
To simplify the process of creating roles and assigning permissions, there are pre-configured
roles in Security Analytics. You can also add roles customized for your organization. 

The following table lists each pre-configured role and the permissions assigned to it. All
permissions are assigned to the Administrators role. A subset of permissions is assigned to each
of the other roles.

Role Permission

Administrators Full system access.The System Administrators persona is granted all per-

missions by default.

Operators Access to configurations but not to meta and session content. The System

Operators persona is focused on system configuration, but not Investigation,

ESA, Alerting, Reporting, and Incident Management.

Analysts Access to meta and session content but not to configurations. The Security

Operation Center (SOC) Analysts persona is centered around Investigation,

ESA Alerting, Reporting, and Incident Management, but not system con-

figuration.

SOC_Man-

agers

Same access as Analysts plus additional permission to handle incidents. The

SOC Managers persona is identical to Analysts, but with permissions neces-

sary to configure Incident Management.

Malware_Ana-

lysts

Access to investigations and malware events. The only access granted to the

Malware Analysts persona is the  Malware Analysis module.

How Role-B ased A ccess C ontrol W orks 8
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Role Permission

Data_Privacy_

Officers

The Data Privacy Officer (DPO) persona is similar to Administrators with

additional focus on configuration options that manage obfuscation and view-

ing of sensitive data within the system (see Data Privacy Management).

Users with the DPO role can see which meta keys are flagged for obfus-

cation, and they also see obfuscated meta keys and values created for the

flagged meta keys.

Trusted Connections Between Server and Service
In a trusted connection, a service explicitly trusts Security Analytics Server to manage and
authenticate users. This reduces administration on each service because authenticated users do
not have to be defined locally in each Security Analytics Core service.

As the following table shows, you perform all user management tasks on the server:

Task Location

Add a user Server

Maintain usernames Server

Maintain passwords Server

Authenticate internal Security Analytics users Server

(Optional) Authenticate external users with:

- Active Directory

- PAM

Server

Server

Install and configure PAM Server

The benefits of a trusted connection and centralized user management are that:

l You perform all user administration tasks once, on Security Analytics Server only.

l You control access to services but do not have to set up and authenticate users on the
services.
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l Users enter passwords once at Security Analytics Log On and are authenticated by the
server.

l Users, already authenticated by the server, access every core service in Administration >
Services without entering a password.

How Trusted Connections Are Established

When you install or upgrade to 10.6, trusted connections are established by default with two
settings:

1. SSL is enabled.

2. The core service is connected to an encrypted SSL port.

To establish a trusted connection, each Security Analytics Core service must be upgraded to
10.4 or later. Trusted connections are not backwards compatible with Security Analytics Core
10.3.x or earlier.

Common Role Names on the Server and Services

Trusted connections rely on common role names on the server and service. On a fresh
installation, Security Analytics installs the five pre-configured roles on the server and each core
service. If you upgrade to 10.6 from 10.3x or earlier, Security Analytics does not install the
new SOC_Managers and Malware_Anlaysts roles. You must add these roles to each core
service.

If you add a custom role, such as JuniorAnalysts, you must add the role to each service, such
as ArchiverA and BrokerB. Role names are case-senstive, cannot contain spaces and must be
identical. For example, JuniorAnalyst (singular) and JuniorAnalysts (plural) do not meet the
requirements for common role names.

How Role-B ased A ccess C ontrol W orks 10
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End-to-End Workflow for User Setup and Service Access 
This workflow shows how role-based access control works when there is a trusted connection
between Security Analytics Server and the service BrokerB.

1. On Security Analytics Server, create an account for a new user:
Name: Chris Jones
Username: CAJ
Password: practice123

2. Determine if you want to assign a pre-configured or custom role to Chris Jones:

l Pre-Configured role

a. Keep or modify the default permissions assigned to the Analysts role, which
include permissions such as access to the Alerting, Investigation and Malware
modules,  

b. Assign the Analysts role to Chris Jones.

l Custom role

a. Create the custom role, such as JuniorAnalysts.

b. Assign permissions to the JuniorAnalysts role.
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c. Assign the JuniorAnalysts role to Chris Jones.

d. Add the JuniorAnalysts role to the service, such as BrokerB.

3. The user, Chris Jones, logs on to Security Analytics Server:
Username: CAJ
Password: practice123

4. The server authenticates Chris. 

5. The trusted connection allows the authenticated user, Chris, to access BrokerB without
entering another password.

For more detailed descriptions and procedures, see Manage Users with Roles and Permissions.

Related Topic

l Role Permissions
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Role Permissions
This topic describes access to the user interface that users assigned to the built-in Security
Analytics roles have by default. 

Within Security Analytics, user access to each module, dashlet, and view is restricted based on
the assigned permissions described in this topic. The tables have a row for each permission with
columns to indicate if it is a default permission for each user role:

l Administrators

l Operators

l Analysts

l SOC Managers (SOC Mgrs)

l Malware Analysts (MAs)

l Data Privacy Officers (DPOs)

Administration

The following table lists the permissions in the Administration tab:

Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Access Admin-

istration Module

Yes Yes Yes Yes Yes Yes

Access Health &

Wellness

Yes Yes Yes Yes Yes Yes

Apply System

Updates

Yes Yes

Can Opt In to

Live Intelligence

Sharing

Yes Yes

Manage Global

Auditing

Yes Yes Yes
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Manage Health &

Wellness Policy

Yes Yes

Manage

SA Advanced Set-

tings

Yes Yes

Manage

SA Auditing

Yes Yes Yes

Manage

SA Email

Yes Yes

Manage SA LLS Yes Yes

Manage SA Logs Yes Yes Yes

Manage SA Noti-

fications

Yes Yes

Manage

SA Plugins

Yes Yes

Manage

SA Predicates

Yes Yes

Manage SA

Reconstruction

Yes Yes

Manage

SA Security

Yes Yes Yes

Manage Services Yes Yes Yes

Manage System

Settings

Yes Yes
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Modify ESA Set-

tings

Yes Yes

Modify Event

Sources

Yes Yes

Modify Hosts Yes Yes

Modify Services Yes Yes Yes

View Event

Sources

Yes Yes Yes

View Health &

Wellness Policy

Yes Yes Yes Yes

View Health &

Wellness Stats

Browser

Yes Yes Yes Yes Yes

View Hosts Yes Yes Yes

View Services Yes Yes Yes

Alerting

The following table lists the permissions in the Alerting tab:

Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Access Alerting

Module

Yes Yes Yes Yes Yes

Manage Rules Yes Yes Yes Yes

View Alerts Yes Yes Yes Yes
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

View Rules Yes Yes Yes Yes

Incidents

The following table lists the permissions in the Incidents tab:

Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Access Incident

Module

Yes Yes Yes Yes Yes

Configure Incid-

ent Management

Integration

Yes Yes Yes

Delete Alerts and

incidents

Yes Yes

Manage Alert

Handling Rules

Yes Yes Yes

View and Man-

age Incidents

Yes Yes Yes Yes Yes

Investigation

The following table lists the permissions in the Investigation tab:

Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Access Invest-

igation Module

Yes Yes Yes Yes Yes

Context Lookup Yes Yes Yes Yes
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Create Incidents

from Invest-

igation

Yes Yes Yes Yes

Manage List

from Invest-

igation

Yes Yes Yes Yes

Navigate Events Yes Yes Yes Yes Yes

Navigate Values Yes Yes Yes Yes Yes

Live

The following table lists the permissions in the Live tab:

Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Live

Access Live

Module

Yes Yes Yes Yes Yes

Manage Live

System Settings

Yes Yes

Resources

Deploy Live

Resources

Yes Yes Yes

Manage Live

Feeds

Yes Yes Yes
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Manage Live

Resources

Yes Yes Yes

Search Live

Resources

Yes Yes Yes Yes Yes

View Live

Resource

Details

Yes Yes Yes Yes Yes

Malware

The following table lists the permissions in the Malware tab:

Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Download Mal-

ware File(s)

Yes Yes Yes Yes Yes

Initiate Malware

Analysis Scan

Yes Yes Yes Yes Yes

View Malware

Analysis Events

Yes Yes Yes Yes Yes

Reports

The following table lists the permissions in the Reports tab:

Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Alert

Define RE Alert Yes Yes Yes Yes
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Export RE Alert

Definition

Yes Yes Yes Yes

Manage RE

Alerts

Yes Yes Yes Yes

View RE Alerts Yes Yes Yes Yes

View Scheduled

RE Alerts

Yes Yes Yes Yes

Chart 

Define Chart Yes Yes Yes Yes

Delete Chart Yes Yes Yes Yes

Export Chart

Definition

Yes Yes Yes Yes

Manage Charts Yes Yes Yes Yes

View Charts Yes Yes Yes Yes

List 

Define Lists Yes Yes Yes Yes

Delete List Yes Yes Yes Yes

Export List Yes Yes Yes Yes

Manage Lists Yes Yes Yes Yes

Report

Define Report Yes Yes Yes Yes
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Delete Report Yes Yes Yes Yes

Export Report Yes Yes Yes Yes

Manage Reports Yes Yes Yes Yes

View Reports Yes Yes Yes Yes

Reports

Access Configure Yes Yes Yes Yes

Access Reporter

Module

Yes Yes Yes Yes

Access Reporter

search

Yes Yes Yes Yes

Access View Yes Yes Yes Yes

Rule

Add RE Alert

Definition from

Rule

Yes Yes Yes Yes

Define Rule Yes Yes Yes Yes

Delete Rule Yes Yes Yes Yes

Export Rule Yes Yes Yes Yes

Manage Rules Yes Yes Yes Yes

View Rule Usage Yes Yes Yes Yes

Schedules
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Define Schedule Yes Yes Yes Yes

Delete Schedule Yes Yes Yes Yes

View Schedules Yes Yes Yes Yes

Warehouse Ana-

lytics

Define Jobs Yes Yes Yes Yes

Delete Jobs Yes Yes Yes Yes

Manage Jobs Yes Yes Yes Yes

View Jobs Yes Yes Yes Yes

Dashboard

The following table lists the permissions in the Dashboard tab:

Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Dashlet Access -

Admin Device

List Dashlet

Yes Yes Yes Yes Yes

Dashlet Access -

Admin Device

Monitor Dashlet

Yes Yes Yes

Dashlet Access -

Admin

News Dashlet

Yes Yes Yes Yes Yes
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Dashlet Access -

Alert

Variance Dashlet

Yes Yes Yes Yes

Dashlet Access -

Alerting Recent

Alerts Dashlet

Yes Yes Yes Yes

Dashlet Access -

Investigation Jobs

Dashlet

Yes Yes Yes Yes

Dashlet Access -

Investigation Top

Values Dashlet

Yes Yes Yes Yes

Dashlet Access -

Live Featured

Resources Dashlet

Yes Yes Yes Yes Yes

Dashlet Access -

Live New

Resources Dashlet

Yes Yes Yes Yes Yes

Dashlet Access -

Live Subscriptions

Dashlet

Yes Yes Yes Yes Yes

Dashlet Access -

Live Updated

Resources Dashlet

Yes Yes Yes Yes Yes
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Permission Administrators Operators Analysts
SOC
Mgrs

MAs DPOs

Dashlet Access -

Malware

Jobs Dashlet

Yes Yes Yes Yes

Dashlet  Access -

Reporting Recent

Report Dashlet

Yes Yes Yes Yes

Dashlet  Access -

Reporting

Charts Dashlet

Yes Yes Yes Yes

Dashlet  Access -

Top Alerts Dashlet

Yes Yes Yes Yes

Dashlet Access ‐

Unified RSA First

Watch Dashlet

Yes Yes Yes Yes Yes

Dashlet Access ‐

Unified Shortcuts

Dashlet

Yes Yes Yes Yes Yes
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Set Up System Security
This topic introduces a set of end-to-end procedures for implementing system security. Each step
in the following topics explains a system-wide setting. Follow the steps in order to set up
security in Security Analytics.

Topics

l Step 1. Configure Password Complexity

l Step 2. Change the Default admin Passwords

l Step 3. Configure System-Level Security Settings

l Step 4. (Optional) Configure External Authentication

l Step 6. (Optional) Configure PKI Authentication

l Step 7. (Optional) Create a Customized Login Banner
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Step 1. Configure Password Complexity
This topic provides instructions to set system-wide Security Analytics password complexity
requirements.

Passwords are an important part of your network security strategy. They provide critical front-
line protection for your computer systems and help prevent attacks and unauthorized access to
private information. 

Password policies, designed to enhance the security of corporate networks, vary depending on
the industry, corporate requirements, and regulations. Because of these password policy
variations, Security Analytics software allows you to configure the password complexity
requirements for internal Security Analytics users to conform to your corporate password policy
guidelines.

Password complexity requirements apply only to internal users and are not enforced for external
users. External users rely on their own methods and systems to enforce password complexity.  

Password Strength

Strong passwords make it more difficult for attackers to guess user passwords and help prevent
unauthorized access to your organization's network. You can define the appropriate level of
password strength for your Security Analytics users. When you configure the password
strength settings, they apply to internal Security Analytics users, including the admin user.

You can choose to enforce any combination of the following password strength requirements
when a Security Analytics user creates or changes their password:

l Minimum password length

l Minimum number of uppercase characters

l Minimum number of lowercase characters

l Minimum number of decimals (0 through 9)

l Minimum number of special characters

l Minimum number of non-Latin alphabetic characters (includes Unicode characters from
Asian languages)

l Whether or not the password can contain the username

For example, you can create a strong password requirement that has a minimum of 8 characters,
cannot contain the username of the user, and contains a mix of uppercase and lowercase letters,
numbers, and special characters.

If you choose to enforce a minimum number of non-Latin alphabetic characters, ensure that your
users have these characters available to them when setting their passwords.
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STIG Compliant Passwords in the System Maintenance Guide provides an example of a strong
password policy. 

Configure Password Strength

1. In the Security Analytics menu, select Administration > Security.

The Security view is displayed with the Users tab open.

2. Click the Settings tab.

3. In the Password Strength section, select the password complexity requirements to enforce
when Security Analytics users set their passwords and specify the minimum characters
required, if applicable. Clear the checkbox for the requirements that you do not want to
enforce.

Requirement Description

Minimum
Password Length

Specifies a minimum password length. A minimum password length
prevents users from using short passwords that are easy to guess.

Uppercase
Characters

Specifies a minimum number of uppercase characters for the password.
This includes European language characters A through Z, with diacritic
marks, Greek characters, and Cyrillic characters. For example:

l Cyrillic uppercase: Д Ц

l Greek uppercase: Π Λ
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Requirement Description

Lowercase
Characters

Specifies a minimum number of lowercase characters for the password.
This includes European language characters a through z, sharp-s, with
diacritic marks, Greek characters, and Cyrillic characters. For
example:

l Cyrillic lowercase: д ц

l Greek lowercase: π λ

Base 10 Digits Specifies a minimum number of decimal characters (0 through 9) for
the password.

Special
Characters
(~!@#$%^&*_-
+=`|(){}
[]:;"'<>,.?/)

Specifies a minimum number of special characters for the password:

~!@#$%^&*_-+=`|(){}[]:;"'<>,.?/

Non-Latin
Alphabetic
Characters

Specifies a minimum number of Unicode alphabetic characters that are
not uppercase or lowercase. This includes Unicode characters from
Asian languages. For example:

l Kanji (Japanese): 頁 (leaf) 枒 (tree) 

Password May
Not Contain
Username

Specifies that a password cannot contain the case-insensitive username
of the user.

4. Click Apply.

5. In the confirmation dialog, select an answer to the following question: Do you want to force
all internal users to change their passwords on the next login?

l Yes: Forces all internal users to change their passwords the next time they log on to
Security Analytics. This overrides any individual user account settings.

l No: Forces only those internal users with the Force password change at next login
option enabled in their individual user account settings to change their password the next
time they log on to Security Analytics.

The password strength settings take effect when Security Analytics users create or change their
passwords. 
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Step 2. Change the Default admin Passwords
This topic provides instructions for changing the admin password for the Security Analytics
service and for the Security Analytics Core services.

The system administrator's user account is installed with Security Analytics. The username is
admin and the default password is netwitness. The Administrators role is assigned to admin.
This role has full system privileges to control what a user can do and which services a user can
access. The only modification you can make to this account is to change the password. Unlike
other Security Analytics users, changes to the admin user password do not automatically
propagate to downstream services. When you configure the password strength settings, they
apply to all Security Analytics users, including the admin user.

Passwords, an important aspect of computer security, are the front line of protection for your
system. The admin user is pre-installed in Security Analytics and on each Security Analytics
Core service. For security, you create the Users and Roles for your organization in Security
Analytics, and on each Security Analytics Core service.

Best Practices

RSA recommends the following best practices:

l Change the admin password of each service from the default.

l Create a different password for the admin account on each service.

Change the admin Password for the Security Analytics Service

Change the admin password for the Security Analytics service in the Profile view. See
Change Password in the Security Analytics Getting Started Guide. The password of the admin
user does not propagate to Core services.

Note: After you change the admin password, you must remove and re-add a Data Source on
the Reporting Engine. For more information, see the Remove and re-add a Data Source on
the Reporting Engine section below.

Change the admin Password for Security Analytics Core Services

To change the admin password for a Core service:

1. In the Security Analytics menu, select Administration > Services.

2. Select a service, and then select  > View > Security.

3. On the Users tab, select the admin user.
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4. In the Password field, type a new admin password for the selected service.

Note: The Password field cannot be empty.

5. In the Confirm Password field, retype the new password.

6. Click Apply.

Note: After you change the admin password, you must remove and re-add a Data Source on
the Reporting Engine. For more information, see Remove and re-add a Data Source on the
Reporting Engine below.

Remove and re-add a Data Source on the Reporting Engine

Reporting Engine validates a Data Source using the Data Source username and password. If you
change the username or password of a Data Source, you must remove and re-add the Data
Source.

To remove and re-add a data source on the Reporting Engine:

1. In the Security Analytics menu, select Administration > Services.

2. In the Services view, select Reporting Engine and  View > Config.

3. Click the Sources tab.

4. Select a service to remove and click

5. Click  and select Available Services.

6. Select the service you removed in step 4 and click OK.

7. When prompted, enter the new username and password for the service.
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Change the admin Password for a Service Using the REST API

In rare circumstances, you may need to change the admin password for a Core service outside of
the Security Analytics user interface. This is simply another way to perform the Security
Analytics Core password change, and is not the preferred method.

To change the admin password for the service using the REST User Interface:

1. Open a web browser, and go to the following URL:

<hostname>:<port>

where the hostname is the name of a Security Analytics Core service and port is the port
used for REST communication. Here is an example for a Security Analytics Decoder:
http://10.20.30.40:50104

The authentication dialog is displayed.

2. In the dialog enter the user name and password used for authentication as admin on the
service, and click OK. The default user name is admin and the default password is
netwitness.

The REST window for the service is displayed.

3. Navigate through the node structure to users/accounts/admin/config.

The user configuration fields for admin are displayed in the browser window.

4. In the Password field, type a new admin password and click Set.
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Step 3. Configure System-Level Security Settings
This topic explains how to set system-wide security parameters.

Most global security settings, such as the maximum number of failed login attempts to allow,
apply to all Security Analytics users and sessions.  Settings related to password expiration, such
as password expiration period and the default number of days before user passwords expire,
apply to internal Security Analytics users, but not external users.

In addition to specifying the global default user expiration period, you can specify if and when
internal Security Analytics users receive notification that their passwords are about to
expire. The password expiration notification consists of a one-time email and password
expiration messages when they log on to Security Analytics.

Configure Security Settings

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Settings tab.

3. In the Security Settings section, specify values for the fields as described in the following
table.

Field Description

Lockout
Period

Number of minutes to lock a user out of Security Analytics after the
configured number of failed logins is exceeded. The default value
is 20 minutes.
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Field Description

Idle Period Number of minutes of inactivity before a session times out. The default value
is 60. If the value is 0, the session will not timeout.

Session
Timeout

The maximum duration of a user session before timing out  The default value
is 600. If the value is 0, there is no maximum time for a session. If the value
is a positive integer, the session times out when the configured time has
elapsed. The user must log in again.

Case
Insensitive
User Name

Select this option if you want the RSA Security Analytics Username field on
the login screen to be case insensitive. For example, you could use Admin or
admin to log on to Security Analytics.

Max Login
Failures

The maximum number of unsuccessful login attempts before a user is locked
out. The default value is 5

Global
Default
User
Password
Expiration
Period

The default number of days before a password expires for all internal
Security Analytics users. A value of zero (0) disables password expiration. 
For upgrades and new installations, the default value is zero (0).

Notify
User <n>
Days Prior
to
Password
Expiry

The number of days before the password expiration date, to notify a user that
their password is about to expire. Users receive a one-time email on the
specified date before their passwords expire. They also see a Password
Expiration Message dialog when they log on to Security Analytics.
A value of zero (0) disables automatic password expiration notification. If
you set the Global Default User Password Expiration Period to zero (0),
users do not receive automatic password expiration notifications. 

4. Click Apply. The Security Settings take effect immediately. If a password expires, the user
receives a prompt to change the password when they log on to Security Analytics.
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Step 4. (Optional) Configure External Authentication
This topic introduces the external authentication methods that Security Analytics supports.

External authentication allows users who do not have an internal Security Analytics user account
to log on to Security Analytics and receive role-based permissions.

Security Analytics supports two methods of external authentication, Active Directory
and Pluggable Authentication Modules (PAM). Topics in this section describe how to configure
and test each method.

Topics

l Configure Active Directory

l Configure PAM Login Capability

l Test External Authentication
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Configure Active Directory

This topic explains how to configure Security Analytics to use Active Directory to authenticate
external user logins.

When a user logs in, Security Analytics first attempts to authenticate locally. If no local user is
found, and Active Directory configuration is enabled, an attempt is made to authenticate with
Active Directory Service. You can configure Active Directory settings to enable authentication
of external groups in the Administration > Security > Settings tab.

In an environment with multiple authentication servers, LDAP forwarding allows LDAP referral
following for AD group lookups. LDAP forwarding can increase the time required to log on
because AD group lookups are extended to connected authentication servers. When your AD
instance attempts to contact domain controllers that are blocked by your firewall, users can
experience a delay of several minutes in logging on to Security Analytics. Security Analytics has
a configuration option that specifies whether LDAP forwarding occurs; by default, LDAP
referrals are disabled. When disabled, your AD instance does not attempt to contact referred
domain controllers.

Procedures

Configure Active Directory Authentication

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Settings tab.
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3. In the External Authentication section, select Active Directory.
The Active Directory Configurations list is displayed in the panel so that you can add or edit
a configuration.

4. When all configurations are added click Apply.
The domains added to this list and enabled are automatically populated in the External Group
Mapping tab so that you can map security roles to each group.

Note: To configure security roles used for Active Directory access, see Step 5. (Optional) Map
User Roles to External Groups.

Add a New Active Directory Configuration

To add a new active directory configuration in the Active Directory Configurations list:

1. Under Active Directory Configurations, click .

The Add New Configuration dialog is displayed.

2. Click the Enabled checkbox.

3. Enter Domain, Host and Port information for the Active Directory Service.

4. (Optional) To select SSL for this configuration, check the Use SSL checkbox.

5. In the Username Mapping field, select the Active Directory search field to use for
username mapping. You can select userPrincipalName (UPN) or sAMAccountName.
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6. In the User Lookup Filter field, (if PKI is enabled) to find a user in the Active Directory
using AD Attributes other than 'sAMAccountName' or 'userPrincipalName' you must
configure the custom LDAP filter.
For example, (&(objectClass=user)(objectClass=top)(samAccountName={username})). The
{username} in the filter is replaced with the value extracted from the user certificate.

7. For sites that have multiple authentication servers, click Follow Referrals to enable or
disable LDAP referral following for AD group lookups.

8. To provide credentials to bind to the Active Directory Service while searching Active
Directory group, enter the credentials in the Username and Password fields.

9. In the Number of Login Attempts field, select the number of login attempts performed by
Security Analytics when the AD service is unavailable.

10. Click Save.
The new configuration is listed in the Active Directory Configurations list.

Edit an Active Directory Configuration

To edit an active directory configuration in the Active Directory Configurations list:

1. Under Active Directory Configurations, click .

The Edit Configuration dialog is displayed.

37 Set U p System Secur i ty



System Security and U ser M anagem ent

2. (Optional) Enter the Domain, Host and Port information for the Active Directory Service.

3. (Optional) To select SSL for this configuration, check the Use SSL checkbox.

4. (Optional) In the Username Mapping field, select the the Active Directory search field to
use for username mapping. 

5. (Optional) In the User Lookup Filter field, (if PKI is enabled) to find a user in the Active
Directory using AD Attributes other than 'sAMAccountName' or 'userPrincipalName' you
must configure the custom LDAP filter.

6. To specify the Follow LDAP referrals behavior in environments with multiple authentication
servers, click the Follow Referrals checkbox.

a. If you want to disable LDAP forwarding, uncheck the box.

b. If you want to enable LDAP forwarding, check the box.

7. To provide credentials to bind to the Active Directory Service while searching Active
Directory group, enter the credentials in the Username and Password fields.

8. In the Number of Login Attempts field, select the number of login attempts performed by
Security Analytics when the AD service is unavailable.

9. Click Save.
The configuration is listed in the Active Directory Configurations list.
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Test an Active Directory Configuration

To test an active directory configuration:

1. Select the configuration to be tested from the Active Directory Configurations list.

2. In the toolbar, click  .

A message that the test is successful is displayed.

Test an Active Directory User Lookup

To verify that the active directory user lookup method is configured correctly:

1. Under Active Directory Configurations, click Test User Lookup.
The Test User Lookup dialog is displayed.

2. Enter the user name that you want to test for authentication using the current Active
Directory.

3. Click Test.
If the test succeeds, you can access the active directory service else you must review and
edit the configuration.

Delete an Active Directory Configuration 

To delete an active directory configuration:

1. Under Active Directory Configurations, select the configuration to be deleted from the
Active Directory Configurations list.

2. In the toolbar, click .
A message indicates that the selected configuration is deleted from the list.
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Configure PAM Login Capability

This topic explains how to configure Security Analytics to use Pluggable Authentication
Modules (PAM) to authenticate external user logins.

PAM login capability involves two separate components:

l PAM for user authentication

l NSS for group authorization

Together they provide external users the capability to log on to Security Analytics without having
an internal Security Analytics account, and to receive permissions or roles determined by
mapping the external group to a Security Analytics security role. Both components are required
for a login to succeed.

External authentication is a system-level setting. Before configuring PAM, carefully review all
of the information here.

Pluggable Authentication Modules

PAM is a Linux-provided library responsible for authenticating users against authentication
providers such as are Active Directory, RADIUS, or LDAP. For implementation, each
authentication provider uses its own module, which is in the form of an operating system (OS)
package such as pam_ldap. Security Analytics uses the OS-provided PAM library, and the
module that the PAM library is configured to use, to authenticate users.

Note: The PAM provides only the ability to authenticate.

Name Service Switch

NSS is a Linux feature that provides databases that the operating system (OS) and applications
use to discover information like hostnames; user attributes like home directory, primary group,
and login shell; and to list users that belong to a given group. Similar to PAM, NSS is
configurable and uses modules to interact with different types of providers. Security Analytics
uses OS-provided NSS capabilities to authorize external PAM users by looking up whether a
user is known to NSS and then requesting from NSS the groups of which that user is a member.
Security Analytics  compares the results of the request to the Security Analytics External Group
Mapping and if a matching group is found, the user is granted access to log on to SA with the
level of security defined in the External Group Mapping.

Note: NSS does not provide authentication.
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PAM and NSS Combination

Both PAM (authentication) and NSS (authorization) must succeed in order for an external user
to be allowed to log on to Security Analytics. The procedure for configuring and troubleshooting
PAM is different than the procedure for configuring and troubleshooting NSS. The PAM
examples in this guide include Kerberos, LDAP, and RADIUS. The NSS examples include
Samba, LDAP, and UNIX. The PAM and NSS module combination used is determined by site
needs.

Note: For pre-10.4 services that use untrusted connections, all PAM users must also be
configured in all Security Analytics Core services, and PAM needs to be configured on every
EL6 Core host.  While this document does not address configuring PAM Authentication and
Users for Core services, such as Decoder and Concentrator, the steps for configuring the
PAM module are the same, except that the Security Analytics Core services use a different
PAM configuration file, /etc/pam.d/netwitness.

Process Overview

To configure PAM login capability, follow the instructions in this document to complete each
step:

1. Configure and test the PAM module.

2. Configure and test the NSS service.

3. Enable PAM in Security Analytics Server.

4. Create group mappings in Security Analytics Server.

Prerequisites

This feature is only available for EL6 based Security Analytics Version 10.4 or later.

Before beginning the setup of PAM, review the procedure and gather the external authentication
server details depending on the PAM module you want to implement.

Before beginning the setup of NSS, review the procedure, identify the group names that you will
use in the External Group mapping, and gather the external authentication server details,
depending on the NSS service being used.

If you purchased a new host with Security Analytics 10.4 or later installed, the required rpm
packages for Kerberos, LDAP, RADIUS, and Samba are installed by default.

Before beginning setup of PAM in Security Analytics, identify the group names that you will use
in the External Group mapping. When mapping roles, the role in Security Analytics must match
a group name that exists in the external authentication server.

Configure and Test the PAM Module

Choose one of the following sections to set up and configure the PAM component:
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l PAM Kerberos

l PAM LDAP

l PAM RADIUS

l SecurID

PAM Kerberos

Kerberos Communication Ports – TCP 88

Note: If Security Analytics Server and Security Analytics Malware Analysis share the same
server, once you setup the PAM Kerberos, the Malware Analysis Samba (SMB) configuration
will be disabled.
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To configure PAM authentication using Kerberos:

1. If you upgraded to Security Analytics 10.6, execute the following command, otherwise skip
this step:
yum --enablerepo=nwupdates install krb5-workstation pam_krb5  

2. Edit the following lines in the Kerberos configuration file /etc/krb5.conf. Replace
variables, which are delimited by <angle brackets>, with your values and omitting the angle
brackets. Capitalization is required where shown.

[libdefaults]

default_realm = <DOMAIN.COM>

dns_lookup_realm = true

dns_lookup_kdc = true

ticket_lifetime = 24h

renew_lifetime = 7d

forwardable = true

[realms]

<DOMAIN.COM> = {

kdc = <SERVER.DOMAIN.COM>

admin_server = <SERVER.DOMAIN.COM>

}

[domain_realm]

<domain.com> = <DOMAIN.COM>

<.domain.com> = <DOMAIN.COM>

[appdefaults]

pam = {

debug = true ticket_lifetime = 36000

renew_lifetime = 36000

forwardable = true

krb4_convert = false

}

3. Test the Kerberos configuration with the command: 
kinit <user>@<DOMAIN.COM>

No output after entering the password indicates success.
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4. Edit the Security Analytics Server PAM configuration file 
/etc/pam.d/securityanalytics to add the following line. If the file does not exist,
create it and add the following line:
auth sufficient pam_krb5.so no_user_check

This completes the configuration for PAM Kerberos. Now, proceed to the next section,
Configure and Test the NSS Service.

PAM LDAP

LDAP Communication Ports - TCP 389 or TCP 636 

TCP 389 can be used for both unencrypted and in most cases encrypted traffic and is usually
sufficient. Most modern LDAP implementations support the start_tls command once
connected to port 389, which upgrades the connection from an unencrypted to an encrypted state.
In this instance, LDAP URIs still begin with ldap:// even when using start_tls.

TCP 636 is used only in instances where the LDAP server does not support the start_tls
command. In this case, LDAP URIs begin with ldaps:// and the start_tls command is not
used.

To configure PAM authentication using LDAP:

1. If you upgraded to Security Analytics 10.6, execute the following command, otherwise skip
this step:
yum --enablerepo=nwupdates install openldap-clients

2. Edit the LDAP configuration files, /etc/pam_ldap.conf and
/etc/openldap/ldap.conf as shown in the following examples

Note: The two LDAP configuration files serve different purposes. The pam_ldap.conf file is
used by the PAM Module only. The openldap/ldap.conf file is used by the openldap
client tools, such as ldapsearch, which is used for troubleshooting the basic LDAP
communications. Replace variables, which are delimited by <angle brackets>, with your
values and omitting the angle brackets. Capitalization is required where shown.

Sample /etc/pam_ldap.conf file entries

base <dc=domain,dc=com>
uri ldap://<server.domain.com>

binddn <binduser@domain.com>
bindpw <secret>
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nss_map_objectclass posixAccount user
nss_map_objectclass shadowAccount user
nss_map_attribute uid sAMAccountName
nss_map_attribute homeDirectory unixHomeDirectory
nss_map_attribute shadowLastChange pwdLastSet
nss_map_objectclass posixGroup group
nss_map_attribute uniqueMember member
pam_login_attribute sAMAccountName
pam_filter objectclass=User

Sample /etc/openldap/ldap.conf file entries

URI ldap://<server.domain.com>
BASE <DC=domain,DC=com>
TLS_CACERTDIR /etc/openldap/certs

3. (Optional) To enable secure transport for LDAP communication with peer certificate
verification (more secure), add the lines shown below to /etc/pam_ldap.conf and
/etc/openldap/ldap.conf:
Lines to add to /etc/pam_ldap.conf:
ssl start_tls

tls_cacertfile /etc/openldap/certs/myca.pem

Lines to add to /etc/openldap/ldap.conf:
ssl start_tls

tls_cacert /etc/openldap/certs/myca.pem

myca.pem is a file that contains a base64-encoded PEM-format x.509 certificate for the
root CA (not the issuing CA) of the certificate chain that issued the domain controller’s
secure LDAP certificate. Contact your Active Directory administrator to obtain this root CA
certificate. The certificate file must be in PEM format.

Note:Windows domain controllers do not by default enable secure LDAP transport.
They require the installation of a server certificate for Server Authentication. Obtaining
and installing this certificate onto the DC is outside the scope of this document. Some
guidance on this is available
at https://social.technet.microsoft.com/wiki/contents/articles/2980.ldap-over-ssl-ldaps-
certificate.aspx.

4. (Optional) To enable secure transport for LDAP communication without peer certificate add
the lines shown below to /etc/pam_ldap.conf and /etc/openldap/ldap.conf:
Lines to add to /etc/pam_ldap.conf
ssl start_tls
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tls_reqcert never

Lines to add to /etc/openldap/ldap.conf
ssl start_tls

tls_checkpeer no

5. To test the LDAP configuration, enter the following command:
ldapsearch -x -D <user>@<domain.com> -W

6. To perform an advanced test or to troubleshoot your bind user, connect as your Bind User
(example Mike Cool) and search for the user, see what the user's distinguished name (DN)
is and use that value as the binddn in pam_ldap.conf, for example:

a. ldapsearch -b "dc=domain,dc=com" -D mcool@domain.com -h

server.domain.com -W "(cn=Cool*)" |grep Cool

The grep will hide the password prompt (-W)

b. Type the password and press ENTER.

7. Edit the Security Analytics server PAM configuration file 
/etc/pam.d/securityanalytics to add the following line. If the file does not exist,
create it and add the following line:
auth sufficient pam_ldap.so

This completes the configuration for PAM LDAP. Now, proceed to the next section, Configure
and Test the NSS Service.

PAM RADIUS

RADIUS Communication Ports - UDP 1812 or UDP 1813

To configure PAM authentication using RADIUS you must add the Security Analytics Server to
your RADIUS Server’s Client list and configure a shared secret. For instructions, see Add a
RADIUS Client and Associated Agent.

To configure PAM authentication using RADIUS:

1. If you upgraded to Security Analytics 10.6, execute the following command, otherwise skip
this step:
yum --enablerepo=nwupdates install pam_radius_auth

2. Edit the RADIUS configuration file, /etc/raddb/server as follows:
# server[:port] shared_secret  timeout (s)

server   secret    3

3. Edit the Security Analytics server PAM configuration file 
/etc/pam.d/securityanalytics to add the following line. If the file does not exist,
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create it and add the following line:
auth sufficient pam_radius_auth.so

The PAM Modules and associated services output information to /var/log/messages and
/var/log/secure. These outputs can be used to assist in troubleshooting configuration
problems.

The following is an example of the steps to configure PAM authentication for RADIUS
using SecurID:

Note: The examples in these tasks use RSA Authentication Manager as the RADIUS server.

1. If you upgraded to Security Analytics 10.6, execute the following command to check if the
PAM RADIUS package is installed:

rpm -qa | grep pam_radius_auth

Example: [root@ ~]# rpm -qa | grep pam_radius_auth

pam_radius_auth-1.3.17-1.x86_64

[root@ ~]#

If the pam_radius_auth package is not available then use the following command to
install the required PAM RADIUS package:

yum --enablerepo=nwupdates install pam_radius_auth

2. Edit the RADIUS configuration file, /etc/raddb/server and update it with the
authentication manager instance hostname, shared secret and timeout value:

# server[:port] shared_secret timeout (s)

111.222.33.44 secret 1

#other-server other-secret 3

192.168.12.200:6369 securid 10

Note: You must comment out 127.0.0.1 & other-server lines and add the IP
address of the authentication manager primary instance with RADIUS port number (for
example, 192.168.12.200:1812), RADIUS shared secret and a timeout value of 10.

3. Edit the Security Analytics server PAM configuration file
/etc/pam.d/securityanalytics to add the following line. If the file does not exist,
create it and add the following line:

auth sufficient pam_radius_auth.so

Note: You can add debug to the end of the above line in the
/etc/pam.d/securityanalytics file to enables PAM debugging (for example,
auth sufficient pam_radius_auth.so debug)
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The PAM Modules and associated services output information to /var/log/messages and
/var/log/secure.These outputs can be used to assist in troubleshooting configuration
problems.

Add a RADIUS Client and Associated Agent

Note: The examples in these tasks use RSA Authentication Manager as the RADIUS server.
You must use administrative account credentials to log on RSA Authentication Manager
Security Console.

To add a RADIUS Client and Associated Agent:

1. Log on to RSA Authentication Manager.

The Security Console is displayed.

2. In the Security Console, Click RADIUS > RADIUS Client > Add New.
The Add RADIUS Client page is displayed.

3. In RADIUS Client Settings, provide the following information:

a. In the Client Name field, enter the name of the client, for example, SECURITY
ANALYTICS.
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b. In the IPv4 Address field, enter the IPv4 address of the RADIUS client, for example,
192.168.12.108.

c. In the Make/Model drop-down list, select the type of RADIUS client, for example,
Fortinet.

d. In the Shared Secret field, enter the authentication shared secret.

4. Click Save & Create Associated RSA Agent.

5. Click Save.

If Authentication Manager Instance is unable to find the authentication agent on the network, A
warning page is displayed. Click Yes, Save Agent.

For more information, see Add a RADIUS Client topic in RSA Authentication Manager 8.2
Administrator’s Guide.

This completes the configuration for PAM RADIUS. Now, proceed to the next section,
Configure and Test the NSS Service.
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PAM Agent for SecurID

PAM Communication Port - UDP 5500

Prerequisites
The RSA SecurID PAM module is supported only under the following conditions:

1. All Security Analytics core services in the deployment must be running at a minimum
version 10.4.0. Security Analytics 10.3.x or earlier is not supported.

2. Trusted connections must be enabled and functioning between Security Analytics and
Security Analytics core services.

Process Overview 

The high-level steps to configure the SecurID PAM module are:

1. Configure Authentication Manager:
a. Add Authentication Agent.
b. Download configuration file.

2. Configure Security Analytics server:
a. Copy configuration file from Authentication Manager and customize it.
b. Install the PAM SecurID Module.

3. Test connectivity and authentication.

Then follow the remaining procedures in the sections that follow:

l Configure NSS.

l Enable PAM in Security Analytics.

l Configure group mappings in Security Analytics server.

To configure Authentication Manager:

1. Log on to RSA Authentication Manager.
The Security Console is displayed.
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2. In the Security Console, add a new authentication agent.
Click Access > Authentication Agents > Add New.
The Add New Authentication Agent page is displayed.

3. In the Hostname field, type the hostname of the Security Analytics server.

4. Click Resolve IP.
The IP address of the Security Analytics server is automatically displayed in the IP Address
field.

5. Keep the default settings and click Save.

6. Generate a configuration file.
Click Access > Authentication Agents > Generate Configuration File.
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The Generate Configuration File page is displayed.

7. Keep the defaults and click Generate Config File.
This creates AM_Config.zip, which contains two files.

8. Click Download Now.

To install and configure the PAM SecurID module:

Note: In version 10.4 or later, OVAs and installation ISOs pre-install the SecurID package. If
this applies to your environment, skip step 5 in the below procedure.

1. On the Security Analytics server, make a directory:
mkdir /var/ace

2. On the Security Analytics server, copy sdconf.rec from the .zip file to /var/ace.

3. Create a text file sdopts.rec in the /var/ace directory.

4. Insert the following line:
CLIENT_IP=<IP address of Security Analytics server>

5. Install the SecurID Authorization Agent for PAM, which is available in the yum repository:
yum install sid-pam-installer

6. Run the install script:
/opt/rsa/pam-agent-installer/install_pam.sh

7. Follow the prompts to accept or change the defaults. 

8. Edit the Security Analytics server PAM configuration file, /etc/pam.d/securityanalytics by
adding this line:
auth required pam_securid.so
If the file does not exist, create it and add this line:
auth sufficient pam_securid.so
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This completes the installation of the SecurID PAM module. Next, test the connectivity and
authentication. Then, follow the procedures in Configure and Test the NSS Service.

Note: After installation, verify that VAR_ACE in the /etc/sd_pam.conf file points to the
correct location of the sdconf.rec file. This is the path to the configuration files. The whole
path must have -rw------- root root permission.

Note: If the PAM SecurID setup is not complete, it may crash the Jetty server and Security
Analytics UI will not be displayed. You must wait till the PAM authentication configuration is
complete and then restart the Jetty server.

To test connectivity and authentication:

1. Run /opt/pam/bin/64bit/acetest, enter username and passcode. 

2. (Optional) If acetest fails, turn on debugging:
vi/etc/sd_pam.conf

RSATRACELEVEL=15

3. Run /opt/pam/bin/63bit/acestatus. Output below

RSA ACE/Server Limits
---------------------
Configuration Version : 15 Client Retries : 5 
Client Timeout : 5 DES Enabled : Yes 

RSA ACE/Static Information
--------------------------
Service : securid Protocol : udp Port Number : 5500 

RSA ACE/Dynamic Information
---------------------------
Server Release : 8.1.0.0 Communication : 5

RSA ACE/Server List
-------------------
Server Name : auth81.netwitness.local
Server Address : 192.168.100.10
Server Active Address : 192.168.100.10
Master : Yes Slave : No Primary : Yes 
Usage : Available for Authentications

4. (Optional) To troubleshoot the Authentication Manager server,
Click Reporting > Real-time Activity Monitors > Authentication Activity Monitor. 
Then, click Start Monitor.

5. If you changed the setting, reset RSATRACELEVEL to 0:
vi/etc/sd_pam.conf

RSATRACELEVEL=0
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This completes the configuration for PAM Agent for SecurID. Now, proceed to the next section,
Configure and Test the NSS Service.

Configure and Test the NSS Service

Choose an NSS Service

There are three NSS service options: Samba, LDAP, and UNIX.  There are advantages and
disadvantages to all three.

NSS Samba Pros NSS Samba Cons

Purpose built for Active Directory Cannot be used with non-AD back-ends

Minimal to no configuration must

be performed in Active Directory

Potentially more difficult to configure and troubleshoot

No special user accounts needed Requires the SA Server machine be joined to the Active

Directory Domain

Uses many ports to communicate with Active Directory;

more difficult to implement across firewalls and proxies

NSS LDAP Pros NSS LDAP Cons

Basic configuration is simpler May require additional configuration and roles

inside of Active Directory

Can communicate with any LDAP imple-

mentation

Requires configuration of an LDAP bind

account

Uses a single TCP port for communication -

easier to work with firewalls and proxies

More difficult to enable secure transport unless

configured to not validate server certificates

Does not require joining SA host to AD

domain
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NSS UNIX

No configuration is necessary to enable the NSS UNIX module; it is enabled in the host
operating system by default. To authorize a user for a specific group, simply add that user to the
operating system and add them to a group:

1. Create an OS group to use add your external user to with this command:
groupadd <groupname>

2. Add the external user to the OS with this command:
adduser -G <groupname> -M -N <externalusername>

Note: Note that this does NOT permit or allow access to the SA Server console.

This completes the configuration for NSS UNIX. Next, go to Test NSS Functionality.

NSS Samba

Note: If Security Analytics Server and Security Analytics Malware Analysis share the same
service, once you setup NSS Samba, the Malware Analysis Samba (SMB) configuration will
be disabled.

AD Winbind Communication Ports

The following ports are the minimum ports internal testing indicates should be open to permit
NSS Samba functionality.  These are provided only as a reference.

TCP 88 - Kerberos
TCP 139 - Netbios
TCP 389 - LDAP
UDP 53 - DNS
UDP 88 - Kerberos
UDP 389 - LDAP

Additional ports may be needed, depending on site-specific requirements of implementation. See
the following article for information on all ports Active Directory communication may require:
http://technet.microsoft.com/en-us/library/dd772723%28ws.10%29.aspx
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To configure NSS Samba:

1. Edit the Samba configuration file, /etc/samba/smb.conf, as follows. Replace variables,
which are delimited by <angle brackets>, with your values and omitting the angle brackets.
Capitalization is required where shown.
[global]

workgroup = domain

netbios name = <SA_APPLIANCE_HOSTNAME>

password server = <ADSERVER.DOMAIN.COM>

realm = <DOMAIN.COM>

local master = no

security = ads

syslog only = yes

log file = /var/log/samba/log.%m

max log size = 5120

idmap config * : range = 16777216-33554431

template shell = /bin/bash

winbind use default domain = true

winbind offline logon = false

winbind enum groups = yes

2. To enable and start the Windows binding service, winbind, enter the following commands:
chkconfig winbind on

service winbind start

3. Edit the NSS configuration file, /etc/nsswitch.conf. Update only the below 2 entries
and leave the rest all default:
passwd:     files winbind

group:      files winbind

4. To join the Domain, enter the following command:
net ads join -U <DomainAdminUser>

5. To store the Domain Controller SID, enter the following command:
net rpc getsid -S <SERVER.DOMAIN.COM>

6. Test NSS functionality as described in the Test NSS Functionality section.

7. When you have confirmed that NSS is working properly from the command line, to reboot
the host for the NSS changes to take effect, enter the following command.
reboot
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To troubleshoot NSS Samba:

To confirm whether NSS Winbind is able to communicate successfully with Active Directory:

1. Enter the following commands:
wbinfo -u to return a list of AD users
wbinfo -g to return a list of AD groups

2. If neither command succeeds, run winbind in console debug mode by entering the following
commands:
service winbind stop

winbindd -S -F -d <optional debugleve 0-10>

3. From a separate ssh session, repeat step 1 and watch the winbindd output for any indication
of the problem.
Increase winbindd debugging verbosity as needed.

4. Make any necessary adjustments to /etc/samba/smb.conf.

5. In the winbindd debug window from step 2, stop winbindd by typing CTRL-C. 
Repeat steps 1 and 2 and continue troubleshooting until the wbinfo commands succeed.

6. Once the wbinfo commands succeed, use the getent commands from the Testing NSS
Functionality section of this guide to test NSS.
getent passwd <pamUser>

getent group <groupOfPamUser>

7. When getent succeeds, stop the command line winbindd by typing CTRL-C and enter the
following command to start the service daemon:
service winbind start

If wbinfo -g succeeds from the command line but search for external group mapping does not
display any Active Directory groups:

1. Add the following line to to /etc/samba/smb.conf:

allow trusted domains = no

2. Type service winbind restart.

This completes the configuration for NSS Samba. Next, go to Test NSS Functionality.
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NSS LDAP

Note: These instructions require all Active Directory PAM user and NSS group objects to
have their uidNumber and gidNumber attributes set to UNIX-style UID and GID numbers in
order to be used by NSS LDAP. Older Active Directory schemas may not have these
attributes by default. Newer AD schemas may have these attributes but they may not be
defined in each object. Correctly configuring these attributes is beyond the scope of this
document. Contact your Active Directory administrator to have these attributes defined for
your PAM users and NSS groups.

An LDAP bind user must be created in Active Directory in order for NSS to be used. This user
should be configured to not have its password expire. Because these credentials must be
specified to the NSS LDAP service in plaintext, the permissions of /etc/nslcd.conf should
be left at their default of 600 so the file cannot be read by system users other than root.

LDAP Communication Ports - TCP 389 or TCP 636

TCP 389 can be used for both unencrypted and in most cases encrypted traffic and is usually
sufficient. Most modern LDAP implementations support the start_tls command once
connected to port 389, which upgrades the connection from an unencrypted to an encrypted state.
In this instance, LDAP URIs still begin with ldap:// even when using start_tls.

TCP 636 is only used in instances where the LDAP server does not support the start_tls
command.  In this instance, LDAP URIs begin with ldaps:// and the start_tls command
is not used.
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To configure the NSS module for LDAP with Active Directory:

1. Obtain the nss-pam-ldapd package from the SMCUPDATE repository or from the
Security Analytics Server Updates Repository if the server is synchronized with
SMCUPDATE. This requires a configured Live Account in Security Analytics.

2. To install the package, do one of the following:

a. To install directly from SMCUPDATE, enter the following command:
yum --enablerepo=sa install nss-pam-ldapd

b. To install from the Security Analytics Updates Repository, enter the following command:
yum --enablerepo=nwupdates install nss-pam-ldapd

3. Edit /etc/nslcd.conf to include the lines below, ensuring that all existing lines in the file
are first commented out using a hash mark # at the beginning of the line:
#see note in NSS LDAP Communication Ports section for guidance on

using ldap:// or ldaps://

uri ldap://<ldapServerHost>/ 

base dc=<yourDomain>,dc=<com>

binddn <ldapBindUser@yourdomain.com>

bindpw <bindPassword>

bind_timelimit 30

timelimit 30

idle_timelimit 3600

pagesize 1000

referrals off

filter passwd (&(objectClass=user)(!(objectClass=computer))

(uidNumber=*)(unixHomeDirectory=*))

map    passwd uid              sAMAccountName

map    passwd homeDirectory    unixHomeDirectory

map    passwd gecos            displayName

filter shadow (&(objectClass=user)(!(objectClass=computer))

(uidNumber=*)(unixHomeDirectory=*))

map    shadow uid              sAMAccountName

map    shadow shadowLastChange pwdLastSet

filter group  (objectClass=group)

map    group  uniqueMember     member

uid nslcd

gid ldap

4. (Optional) To enable secure transport for LDAP communication with peer certificate
verification (more secure), add these lines to /etc/nslcd.conf:
ssl start_tls
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tls_cacert /etc/openldap/certs/myca.pem

myca.pem is a file that contains a base64-encoded PEM-format x.509 certificate for the root
CA (not the issuing CA) of the certificate chain that issued the domain controller’s secure
LDAP certificate. Contact your Active Directory administrator to obtain this root CA
certificate.  The certificate file must be in PEM format.

Note:Windows Domain Controllers do not by default enable secure LDAP transport. They
require the installation of a server certificate for Server Authentication. Obtaining and
installing this certificate onto the DC is outside the scope of this document. Some guidance on
this is available from this URL:
https://social.technet.microsoft.com/wiki/contents/articles/2980.ldap-over-ssl-ldaps-
certificate.aspx

5. (Optional) To enable secure transport for LDAP communication without peer certificate add
these lines to /etc/nslcd.conf:
ssl start_tls

tls_reqcert never

6. Edit the NSS configuration file /etc/nsswitch.conf. Update only the below two entries
and leave the rest at their default values:
passwd:files ldap

group:files ldap

7. To enable and start the NSLCD service, enter these commands:
chkconfig nslcd on

service nslcd start

8. Test NSS functionality using guidance in the Test NSS Functionality section. If NSS tests
fail, troubleshoot NSS LDAP as described in Troubleshoot NSS LDAP.

9. When you have confirmed that NSS is working properly from the command line, reboot the
host for the NSS changes to take effect.
reboot

To troubleshoot NSS LDAP:

1. To troubleshoot NSS LDAP, first stop the nslcd service by entering the following command:
service nslcd stop

2. To output troubleshooting and status information from the service to the console, run the
nslcd service in debug mode from the command line.
nslcd -d

Set U p System Secur i ty 60

https://social.technet.microsoft.com/wiki/contents/articles/2980.ldap-over-ssl-ldaps-certificate.aspx
https://social.technet.microsoft.com/wiki/contents/articles/2980.ldap-over-ssl-ldaps-certificate.aspx


System Security and U ser M anagem ent

3. (Optional) To increase debug verbosity, add an additional d multiple times to the end of nslcd
-d, for example, enter the following command:
nslcd -ddd

4. From a separate ssh session, use the getent commands from the Testing NSS Functionality
section of this guide to test NSS. Watch the debug output from nslcd for any indications of
where the failure is occurring.  Increase nslcd debugging verbosity as needed.
getent passwd <pamUser>

getent group <groupOfPamUser>

5. Make any necessary adjustments to /etc/nslcd.conf based on the output of step 2 or 3.

6. In the nslcd debug window from step 2 or 3, stop nslcd with CTRL-C.  Repeat step 2 or 3
and continue troubleshooting until the getent command succeeds.

7. When getent succeeds, stop the command line nslcd and start the service daemon:
service nslcd start

Common problems may include:

l LDAP secure transport SSL certificate not installed on LDAP/AD server.

l CA certificate verification failed – comment out the tls_cacert line in /etc/nslcd.conf
and instead try tls_reqcert never.  If it succeeds, you know that certificate verification
that is failing.

l Root CA certificate is not in PEM format.

l Using issuing CA certificate rather than root CA certificate.

l LDAP server’s SSL certificate name does not match its hostname.

l Incorrect base DN.

l LDAP bind user or password is not specified correctly.

l Incorrectly specifying ldaps:// instead of ldap:// in uri line of /etc/nslcd.conf. 
ldaps:// should only be used when using LDAPS but not using the start_tls command.

l Active Directory users and groups do not have uidNumber or gidNumber attributes set.

l Network firewall is blocking communications.

l LDAP server hostname specified cannot be resolved.

l Incorrect DNS settings in /etc/resolv.conf.

l Bad hostname specified in uri line of /etc/nslcd.conf.

This completes the configuration for NSS LDAP. Next, go to Test NSS Functionality.
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Test NSS Functionality

To test whether NSS is working with any of the previous NSS services, use the following
commands:
getent passwd <pamUser>
getent group <groupOfPamUser>

Output should be similar to:
[root@~]# getent passwd myuser
myuser:*:10000:10000::/home/myuser:/bin/sh

[root@~]# getent group mygroup
mygroup:*:10000:myuser3

l If neither command produces output, NSS is not working properly for external authorization.
Refer to the troubleshooting guidance for your NSS module provided in this document.

l If getent commands succeed and authentication success is confirmed in
/var/log/secure but Security Analytics still fails to allow External users to login:

l Was the correct group name specified for the NSS group in SA External Group Mapping? 
See Enable PAM and Create Group Mappings below.

l It is possible that the NSS configuration has changed and Security Analytics has not picked
up the change.  A reboot of the Security Analytics host will cause Security Analytics to
pick up NSS configuration changes.  A restart of jettysrv is not sufficient.

Proceed to the next section, Enable PAM in Security Analytics server.

Enable PAM in Security Analytics Server

1. Log on to Security Analytics and in the Security Analytics menu, select Administration >
Security.
The Administration Security view is displayed with the Users tab open.

2. Click the Settings tab.
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3. Under External Authentication, select PAM and click Apply.

PAM is enabled, and Active Directory is automatically disabled. The Active Directory
configuration settings are stored and hidden. Perform a test authentication with the PAM
configuration, For instructions, see Test External Authentication.

Proceed to the final section, Create Group Mappings in Security Analytics server.

Create Group Mappings in Security Analytics Server

1. In the Security view, click the External Group Mapping tab.

2. Click to Add a Role Mapping.

The Add Role Mapping page is displayed.
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3. Map the external group names to the appropriate Security Analytics roles as described in
Step 5. (Optional) Map User Roles to External Groups.
The external group name and the Security Analytics role name must match.
For example, Analysts and Analysts but not Analysts and Analyst. 
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Test External Authentication

This topic explains how to test the currently enabled External Authentication method in Security
Analytics.

When a user logs in, Security Analytics first attempts to authenticate locally. If no local user is
found, and External Authentication configuration using Active Directory or PAM  is enabled, an
attempt is made to authenticate externally. You can test the currently enabled external
authentication method in the Administration > Security > Settings tab.

Procedure

To test external authentication:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Settings tab.

3. Under External Authentication, select Active Directory or PAM.

4. Under External Authentication options, click Test.
The External Authentication Test dialog is displayed.
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5. Enter the user name and password that you want to test for authentication using the current
Active Directory or PAM configuration.

Note: If you are using RSA Authentication Manager as your external authentication
component, you must enter the Passcode in the Password field.

6. Click Test.
The external authentication method is tested to ensure connectivity.

7. If the test does not succeed, review and edit the configuration (see Configure Active Directory
or Configure PAM Login Capability.

Step 5. (Optional) Use Custom Server Certificate
By default Security Analytics server uses a web server certificate generated by Security
Analytics for HTTPS connection. Security Analytics also allows you to configure custom web
server certificate to be used as Security Analytics server certificate. You can configure custom
web server certificate even if PKI is not enabled.

Supported Certificate Formats

The following certificate formats are supported. You must select the format that meets your
requirement:

l For server certificate with its private key:

l pkcs12 or .p12 

l jks

l pfx 

l For trusted CA certificate:

l pkcs12 or .p12 

l jks 

l pfx

l pem

l crt

l der

l cer
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Note: The .pfx, .p12, .jks are containers that can contain one or more private keys and its
chains or certificates. PEM is a BASE64 encoded certificate that can contain multiple
certificates.

Note: The alias name for a Security Analytics server certificate cannot contain the following
Brace Characters: [ ] { } ( ) < > or the characters & (ampersand) ! (exclamation point) or |
(pipe).

Procedures

(Optional) Create a Certificate Signing Request (CSR) and Certificate Store for Jetty Cer-

tificate

The CSR can be submitted to the Certificate Authority (CA) Server to get the Server Certificate
based on the CSR created. Once the certificate is created, these steps will help you to package
the Private Key and the Signed Certificate that can be uploaded to Security Analytics Server to
be used as a Server Certificate. If a Server Certificate has already been created (along with its
private key), you can skip these steps and upload the certificate to the Security Analytics Server.

Perform the following steps to create a CSR for Jetty Certificate:

1. Change the directory to /root:
cd /root

2. Create a new directory:
mkdir sa_pki_server_cert

3. Change the directory to the newly created directory:
cd sa_pki_server_cert

4. Create a Private Key of 2048 Bits:
openssl genrsa -out sa_server_pki_private_key.key 2048

5. Create a CSR:
openssl req -new -nodes -out server_cert_request.csr -newkey rsa:4096

-keyout sa_server_pki_private_key.key -config <ssl_conf_file>

And, the ssl_conf_file (for example, openssl.cnf), contains:
subjectAltName = @alt_names

In the alt_names section, provide the domain names that you want to use with SSL.
For example,
DNS.1 = <domain1>

DNS.2 = <domain2> and so on.

6. Check that the CSR and Private Key match.
openssl req -noout -modulus -in server_cert_request.csr | openssl md5

openssl rsa -noout -modulus -in sa_server_pki_private_key.key |
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openssl md5

An example output is:
[root@ABCD open_ssl_test]# openssl rsa -noout -modulus -in server_

private.key | openssl md5

(stdin)= 88df3d1ea5b2f411712b96d2ed4a72f5

[root@ABCD open_ssl_test]# openssl req -noout -modulus -in server_

cert_request.csr | openssl md5

(stdin)= 88df3d1ea5b2f411712b96d2ed4a72f5

Note: Ensure you make a note of both the stdin's.

7. Submit the CSR to a CA and get a signed certificate.

8. Copy the Certificate in PEM format to the newly created directory:
/root/sa_pki_server_cert/signed_certificate.pem

9. Check that the certificate that you receive from CA has the correct public key and it matches
the above two outputs. If they do not match, you might have omitted the previous steps.
openssl x509 -noout -modulus -in certificate.crt | openssl md5

Note: You can use the xca tool to complete these steps.

For example:
[root@ABCD open_ssl_test]# mv test.crt certificate.crt

[root@ABCD open_ssl_test]# openssl x509 -noout -modulus -in

certificate.crt | openssl md5

(stdin)= 3e2f4bbd1f32ae097902afcc1893089e

[root@ABCD open_ssl_test]# openssl rsa -noout -modulus -in sa_

server_pki_private_key.key | openssl md5

(stdin)= 3e2f4bbd1f32ae097902afcc1893089e

[root@ABCD open_ssl_test]# openssl req -noout -modulus -in

server_cert_request.csr | openssl md5

(stdin)= 3e2f4bbd1f32ae097902afcc1893089e

10. Copy the Private Key and Certificate to a Key Store.
openssl pkcs12 -export -descert -name <myservercert> -in signed_

certificate.pem -inkey sa_server_pki_private_key.key -out

keystore.p12

11. Provide a password, for example sa, to the Key Store.
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Import Trusted CAs

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the PKI Settings tab.

3. In the Trusted CAs section, click  .

The Import Certificate Authority dialog is displayed.

4. In the CA Store File field, click Browse and select the certificate or certificate store.

5. In the Password field, enter the password of the certificate or certificate store.

Note: The password is applicable only for .pkcs12 or .p12, .pfx, and .jks certificate store
formats.

6. If you already have an existing CA file with the same name as the one that you are
importing, and you want to overwrite it and take the new CA file, select the Overwrite
Existing Entries checkbox.

7. Click Save.
The CA certificate is successfully added to the Security Analytics Trusted CAs store.

Import SA Server Certificate with its Private Key

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Settings tab.
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3. In the Server Certificates section, click .

The Import Server Certificates dialog is displayed.

4. In the Keystore/Certificate File field, click Browse and select the certificate store.

5. In the Password field, enter the password of the certificate store.

6. (Optional) If the user certificate and Security Analytics server certificate are issued by the
same CA, select the Import CAs checkox.

7. Click Save.
The Security Analytics server certificate with its private key is successfully added to
Security Analytics.

Note: You can import multiple server certificates with its private keys.

Note: The Import Server Certificates dialog may not close on some browsers, however, the
import will be  successful. To view the imported certificate, refresh the page.

8. To specify a default server certificate, select a certificate and click Use as Server
Certificate.
The selected server certificate is highlighted in red.

9. You must SSH the Security Analytics server and run the following command:

puppet agent -t

This will automatically update the jetty-ssl.xml file with the appropriate server certificate.

10. Restart the Jetty service for changes to take effect.
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Step 6. (Optional) Configure PKI Authentication
To configure PKI authentication, see Configure PKI Authentication.
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Step 7. (Optional) Create a Customized Login Banner
This topic provides instructions for creating a login banner that is displayed before users log on
to Security Analytics and the server title prefix that is displayed on the title bar when you log on
to Security Analytics.

You can create and enable a customized banner asking users to agree to conditions before
logging on. Users who do not agree are not able to log on. The server title prefix differentiates
the Security Analytics server of the current tab, when you have deployed multiple Security
Analytics in your system. This prefix will be prepended in the title on each page of Security
Analytics server .

Create and Enable a Customized Login Banner

To create and enable a login banner for your instance of Security Analytics:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Login Banner tab.

3. To differentiate the Security Analytics server of the current tab, in the Server Prefix Title
field, enter the value of a prefix.

4. Select the Enabled checkbox to toggle between enabling and disabling the banner.
When Enable is selected, the Login Banner Title and Login Banner fields become active
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with default content in place.

5. Use the default content or type the custom title and content for your banner and click Apply.
The banner is enabled and becomes active immediately.

6. To test the banner, log out. The banner is displayed in front of the fields for entering Security
Analytics credentials.

7. Click Agree. 
The banner closes and you can log on.
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Manage Users with Roles and Permissions
This topic introduces a set of end-to-end procedures for managing users in Security
Analytics. These steps explain how to add a user in Security Analytics and then how to control
what the user can do.

Topics

l Step 1. Review the Pre-Configured Security Analytics Roles

l Step 2. (Optional) Add a Role and Assign Permissions

l Step 3. V erify Q uery and Session Attributes per Role

l Step 4. Set Up a User

l Step 5. (Optional) Map User Roles to External Groups

75 M anage U sers w ith R oles and Perm issions



System Security and U ser M anagem ent

Step 1. Review the Pre-Configured Security Analytics Roles
To simplify the process of creating roles and assigning permissions, there are pre-configured
roles in Security Analytics.

Role Permission

Administrators Full system access

Operators Access to configurations but not to meta and session content

Analysts Access to meta and session content but not to configurations

SOC_Man-

agers

Same access as Analysts plus additional permission to handle incidents

Malware_Ana-

lysts

Access to malware events and to meta and session content

Data_Privacy_

Officers

Access to meta and session content as well as configuration options that man-

age obfuscation and viewing of sensitive data within the system (see Data Pri-

vacy Management).

The administrator can also add custom roles.
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Step 2. (Optional) Add a Role and Assign Permissions
Although Security Analytics has pre-configured roles, you can add custom roles. For example, in
addition to the pre-configured Analysts role you could add custom roles for AnalystsEurope and
AnalystsAsia. For a detailed list of permissions, see Role Permissions. 

Each of the following procedures starts on the Roles tab.

To navigate to the Roles tab:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Roles tab.
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Add a Role and Assign Permissions

1. In the Roles tab, click  in the toolbar.

2. The Add Role dialog is displayed.

3. In the Role Info section, type the following information for the role:

l Name

l (Optional) Description

4. In the Permissions section:

l Click   and   to scroll through the modules.

l Select a module the role will access.

l Select each permission the role will have.
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5. Repeat the previous step until you select all permissions to assign to the role.

6. Click Save to add the new role, which is effective immediately. You can now assign the new
role to users.

Duplicate a Role

An efficient way to add a new role is to duplicate a similar role, save it with a new name and
revise the permissions that are already assigned.

1. In the Roles tab, select the role you want to duplicate and click  .

2. Type a new role name and click Save. 

3. To change the permissions, follow the steps in the next procedure.

Change Permissions Assigned to a Role

1. In the Roles tab, select the role and click  .

The Edit Role dialog is displayed.

2. In the Permissions section:

l Click   and   to scroll through the modules.

l Select a module to revise permissions for it.

l Select or deselect each permission.

3. Repeat the previous step until the role has the required permissions.

4. Click Save. The revised permissions are effective immediately.

Delete a Role

You can delete a role if it is not assigned to any users.

1. In the Roles tab, select the role and click .

2. A dialog requests confirmation that you want to delete the role. Click Yes.
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Step 3. V erify Q uery and Session Attributes per Role
This topic explains the query and session attributes and provides instructions for setting these
attributes for user roles. This topic also describes how these role settings impact individual user
settings and what happens if a user is a member of multiple roles.

After you define your user roles, it is important to verify the query and session attributes that are
set for each role. You can adjust these settings according to your requirements. These attributes
can be set for user roles and for individual users. If you set these attributes for individual users,
the user settings override their assigned role settings.

Q uery and Session Attributes

Query and session attributes determine how to handle the queries that a user runs. These
attributes enable you to lock down the information that users can retrieve. These attributes apply
to all sessions of users assigned to a role unless these attributes are also set at the user level.

Depending on your requirements, you can specify the following query-handling attributes for a
user role or an individual user:

l Query Timeout is an optional setting that applies to Security Analytics 10.5 and later Core
services. It specifies the maximum number of minutes that a user can run a query. If this
value is set, it must be zero (0) or greater. A value of zero represents no timeout.

l Query Level is an optional setting that applies to Security Analytics 10.4 and earlier Core
services. It defines the maximum query running time for a user based on three query levels: 1,
2, and 3. The default query levels are Q uery Level 1 = 60 minutes, Q uery Level 2 = 40
minutes, and Query Level 3 = 20 minutes. Q uery Level is deprecated for Core services
starting with Security Analytics 10.5.

l Query Prefix is an optional filter applied to queries the user runs. The prefix restricts query
results that the user sees. For example, the 'service' = 80 query prefix prepends to any
queries run by the user and the user can only access meta of HTTP sessions.

l Session Threshold is a required setting. This value must be zero (0) or greater. If the
threshold is greater than zero, a query optimization will extrapolate the total session counts
that exceed the threshold. When the meta value returned by the query reaches the threshold,
the system will:

l Stop its determination of the session count

l Show the threshold and percentage of query time used to reach the threshold
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The query-handing attribute settings applied for a user depend on the role memberships of the
user and whether these attributes have been set for the roles and the user. It is important to
verify the query-handling attribute settings for your roles and users.

HowQ uery-Handling Attribute Settings Apply to Individual Users

Query-handling attributes set for individual users override assigned role settings. If a user is a
member of multiple roles, the following logic applies for the user:

l Query Timeout/Q uery Level: Individual user settings override all role settings. If
individual user settings are not set, the most permissive (highest) value of all assigned roles
applies to the user.

l Query Prefix: Individual user settings override all role settings. If individual user settings
are using defaults, which are shown in italics, the query prefixes of each of the user roles are
OR'd together. If the query prefix is blank for both user and roles, no query prefix applies to
the user.

l Session Threshold: Individual user settings override all role settings. The highest value of all
the assigned roles applies to the user.

Procedure

To set query handling attributes for a user role:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Roles tab. If you are adding a role, click  . If you are editing a role, select

the role and click  .
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The Add or Edit Role dialog is displayed.

3. To set the attributes for the role, in the Attributes section:

l (Optional) In the SA Core Query Timeout field, type the maximum number of minutes
that a user can run a query. The default value is 5 minutes. This timeout only applies to
queries performed from Investigation. Security Analytics 10.5 and later Core services use
this field.
When migrating to Security Analytics 10.5 and later, if there is no value set in the roles, 5
minutes is set by default.

l (Optional) In the SA Core Query Level field, select the query level for the user. The
default query levels are Q uery Level 1 = 60 minutes, Q uery Level 2 = 40 minutes, and
Query Level 3 = 20 minutes. Security Analytics 10.4 and earlier Core services use this
field. Q uery Level is deprecated for Core services starting with Security Analytics 10.5.

l (Optional) Type an SA Core Query Prefix to filter query results that the role members
see. By default, this is blank.

l Type an SA Core Session Threshold for the system to stop its determination of the
session count. The default is 100000 . The limit you specify here overrides the Max
Session Export value defined in Profile > Preferences > Investigation.

A value shown in italics indicates a default value, for example 5 . A value shown without
italics indicates a change from the default value, for example, 1200.
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4. Click Save.
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Step 4. Set Up a User
This topic introduces procedures to set up a new user.

Topics

l Add a User and Assign a Role

l V erify Q uery and Session Attributes per User

l Enable, Unlock, and Delete User Accounts
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Add a User and Assign a Role

This topic explains how to add a new user to each type of user account, local and external. It
also explains how to assign a role to a local user.

All Security Analytics users must have a local or external user account. 

The following considerations are important when managing local and external user accounts.

Local User Account External User Account

Managed within Security Ana-

lytics

Managed externally and outside the scope of this document

Roles assigned directly Roles assigned by external group mapping

Derives permissions from each

role assigned to the user, as

explained in this topic

Derives permissions from each role mapped to the account's

external user group, as explained in Step 5. (O ptional)

M ap U ser R oles to External G roups.

Security Analytics manages all

user information.

Security Analytics manages user identification only. This

includes Username, Full Name and Email.

Procedures

Each of the following procedures starts on the Users tab. To navigate to the Users tab, in the
Security Analytics menu, select Administration > Security. The Security view is displayed
with the Users tab open.

Add a User and Assign a Role

To add a local user account and assign a role to the user:

1. In the Users tab, click  in the toolbar.

The Add User dialog is displayed.

85 M anage U sers w ith R oles and Perm issions



System Security and U ser M anagem ent

2. Type the following account information for the new user:

l Username for logging on to Security Analytics

l Email address

l Password for logging on to Security Analytics, in the Password and Confirm Password
fields

l Full Name of the new user

l (Optional) Description of the user account

3. To require the user to create a new password when there are changes to the password
strength policy, select Force password change on Password Policy change. 

4. To expire the user password the next time the user logs on, select Force password change
on next login.

This does not affect any active user sessions. The   appears in the user row to show that
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the user password expired. After a password is expired, you cannot undo it. This checkbox is
cleared the next time you edit the user account.

5. To assign a role to the user, click  in the Roles tab.

The Add Role dialog shows the list of available roles.

6. Select each role to assign and click Add.
The Add User dialog shows each role to assign to the user.

7. (Optional) Select a role and click   to Show all permissions for the role.
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8. (Optional) To specify query handling settings in the Attributes tab, see V erify Q uery and

Session Attributes per User. 

9. Click Save.
The Users tab shows the new user and each role assigned to the user. The account is active
immediately.
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Add a User for External Authentication

Prerequisite: External authentication must be configured. Refer to Step 4. (Optional) Configure
External Authentication.

To add a user that is authenticated externally, outside of Security Analytics:

1. In the Users tab, click   in the toolbar.

The Add User dialog is displayed.

2. Select External to show only the fields required for external authentication.

3. Type the following information:

l Username for logging on to Security Analytics

l Email address

l Full Name of the new user

l (Optional) Description of the user account

4. (Optional) To specify query handling settings in the Attributes tab, see V erify Q uery and

Session Attributes per User. 

5. Click Save. The Users tab shows the new user account, which still needs a role and
permissions.

6. To map a role to the new user, see Step 5. (Optional) Map User Roles to External Groups.
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Change User Information or Roles

To change a user's account information or assigned roles:

1. In the Users tab, select a user and click  in the toolbar.

The Edit User dialog is displayed.

2. To edit user information, change any of the following fields:

l Password

l Email

l Full Name

l Description

3. To change the account type, select or deselect External.

Note: If you change the account from local to external or vice versa, you must also change
how the user receives permissions. For details, see the introduction to this topic.

4. To require an internal user to create a new password when there are changes to the
password strength policy, select Force password change on Password Policy change. 

5. To expire the internal user password the next time the user logs on, select Force password
change on next login.

This does not affect any active user sessions. The   appears in the user row to show that

the user password expired. After a password is expired, you cannot undo it. This checkbox is
cleared the next time you edit the user account.

6. In the Roles section:

l To assign another role, click , select a role and click Add.

l To remove an assigned role, select the role and click .

7. Click Save.

Delete a User

1. In the Users tab, select a user.

2. In the toolbar, click  .

3. Click Save.
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Note: To fully delete a user that is externally authenticated by Active Directory, you must
also delete the user from the AD Group.
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Verify Q uery and Session Attributes per User

This topic provides instructions for setting query-handling attributes for individual users if you
want to override the role settings.

Q uery-handling attributes determine how to handle the queries that a user runs. These attributes
enable you to lock down the information that users can retrieve. You can specify the following
query-handling attributes for a role or user:

l Query Timeout is an optional setting that applies to Security Analytics 10.5 and later Core
services. It specifies the maximum number of minutes that a user can run a query. If this
value is set, it must be zero (0) or greater. A value of zero represents no timeout.

l Query Level is an optional setting that applies to Security Analytics 10.4 and earlier Core
services. It defines the maximum query running time for a user based on three query levels: 1,
2, and 3. The default query levels are Q uery Level 1 = 60 minutes, Q uery Level 2 = 40
minutes, and Query Level 3 = 20 minutes. Q uery Level is deprecated for Core services
starting with Security Analytics 10.5.

l Query Prefix is an optional filter applied to queries the user runs. The prefix restricts query
results that the user sees. For example, the 'service' = 80 query prefix prepends to any
queries run by the user and the user can only access meta of HTTP sessions.

l Session Threshold is a required setting. This value must be zero (0) or greater. If the
threshold is greater than zero, a query optimization will extrapolate the total session counts
that exceed the threshold. When the meta value returned by the query reaches the threshold,
the system will:

l Stop its determination of the session count

l Show the threshold and percentage of query time used to reach the threshold

You should not set these query-handling attributes at the user level unless you want to override
the role settings. Q uery-handling attributes set for individual users override assigned role
settings. If you do not specify these settings for individual users, the settings are applied to users
based on their role memberships. Step 3. V erify Q uery and Session Attributes per Role provides
information on how the role settings impact individual user settings and what happens if a user is
a member of multiple roles.

It is important to verify the query-handling attributes that are set for each user.

Procedure

Note: You should not set these query-handling attributes at the user level unless you want to
override the role settings. 
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To set query-handling attributes for a user:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. If you are adding a user, click . If you are editing a user, select the user and click .

3. In the Add or Edit User dialog, select the Attributes tab.

4. To set an attribute for the user:

l (Optional) In the SA Core Query Timeout field, type the maximum number of minutes
that a user can run a query. This timeout only applies to queries performed from
Investigation. This field is blank by default. If you do not want to override the assigned
role settings, leave this field blank. Security Analytics 10.5 and later Core services use
this field.
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l (Optional) In the SA Core Query Level field, select the query level for the user. The
default query levels are Q uery Level 1 = 60 minutes, Q uery Level 2 = 40 minutes, and
Query Level 3 = 20 minutes. Security Analytics 10.4 and earlier Core services use this
field. Q uery Level is deprecated for Core services starting with Security Analytics 10.5.

l (Optional) Type an SA Core Q uery Prefix to filter query results the user sees. By
default, this is blank.

l Type an SA Core Session Threshold for the system to stop its determination of the
session count. The default is 100000. The limit you specify here overrides the Max
Session Export value defined in Profile > Preferences > Investigation.

A value shown in italics indicates a default value, for example, 100000 . A value shown
without italics indicates a change from the default value, for example, 40.

5. (Optional) If you want to revert to the existing values, click Reset Form.

6. Click Save.

To verify the attributes assigned for a user, you can turn DEBUG logging on the
com.netwitness.platform.server.common.auth package. When the user logs on to Security
Analytics, a Debug log message is generated that shows the attributes applied for that user.
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Enable, Unlock, and Delete User Accounts

This topic provides instructions for enabling, unlocking, and deleting user accounts.

All users of Security Analytics must either have a local user account with username and
password or have an external user account. Within Security Analytics, you can enable, disable,
and delete local user accounts.

The first time an external user logs into Security Analytics, a new user entry is automatically
created with Security Analytics. Security Analytics manages only user identification
information; for example, Full Name and Email.

You can unlock locked accounts for both local and external users.

Enable Disabled Security Analytics U ser Accounts

To enable Security Analytics user accounts that have been disabled:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. In the Users grid, select one or more accounts.

3. Click  . 

A dialog requests confirmation.

4. If you want to enable the accounts, click Yes.
The accounts are enabled, and the user can log in to Security Analytics.
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Disable Security Analytics U ser Accounts

You can block user access by disabling users. Disabling the user does not delete user
preferences. This action blocks user access without deleting user preferences so that upon re-
enabling users, user preferences are intact. You can re-enable users to restore user access.
Disabling users applies only to Local users and not External Users.

To disable Security Analytics user accounts:

1. In the Users grid, select one or more accounts.

2. Click  .

A dialog requests confirmation.

3. If you want to disable the accounts, click Yes.
The accounts are disabled, and the user can no longer log in to Security Analytics.

Unlock Locked Security Analytics U ser Accounts

A user is locked out for a period of time after a number of failed consecutive login attempts. To
unlock Security Analytics user accounts that are locked due to excessive failed login attempts:

1. In the Users grid, select one or more accounts.

2. Click .

A dialog requests confirmation.

3. If you want to unlock the accounts, click Yes.
The accounts are unlocked, and the user can log on to Security Analytics.

Delete Security Analytics U ser Accounts

If not using External Authentication, a user can log on to Security Analytics using a local
account. These local accounts are directly managed using Security Analytics. To revoke access
to a local user, either disable the account or delete the account completely from the system.

Note: This deletes all user preferences for the account from Security Analytics. If this is not
the intention, disable the user instead of deleting the user.

To delete Security Analytics user accounts:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. In the Users grid, select one or more accounts.

3. Click .
A warning dialog requests confirmation.

M anage U sers w ith R oles and Perm issions 96



System Security and U ser M anagem ent

4. If you want to delete the accounts, click Yes.
The accounts are removed from Security Analytics, and the users can no longer log in to
Security Analytics.
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Step 5. (Optional) M ap User Roles to External G roups
This topic describes the method for mapping Security Analytics user roles to external groups.

In Security Analytics, external groups derive permissions for various modules and views from
Security Analytics user roles, which have permissions assigned to them. To provide access to an
external group, map user roles to it. To modify an external group's access, edit the roles mapped
to it. Add and delete roles until the external group has the necessary access. Changes take effect
immediately.

Prerequisites

In the Settings tab, you must set up a method for external user authentication to make external
groups visible to Security Analytics.
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Add Role Mapping for an External G roup

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the External Group Mapping tab.

3. In the toolbar, click .

The Add Role Mapping dialog for the external authentication method you selected is
displayed.
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4. Click Search and search for an external group name in the Search External Groups Dialog,
then select an external group name.

5. To add roles to the group mapping, click  in the Mapped Roles section.

The Add Role dialog is displayed.

6. Click the checkbox in the title bar to select all roles, or select roles individually.

7. To add the roles to the Mapped Roles section in the Add Role Mapping dialog, click Add.
The dialog closes and the selected roles are displayed in the Mapped Roles section.

8. If you want to delete roles from the Mapped Roles section, select the roles and click .

9. When the Add Role Mapping dialog reflects the role mapping that you want to define for
the group, click Save.
The Add Role Mapping dialog closes, and the new role mapping is listed in the External
Group Mapping tab grid.

Edit Role Mapping for a G roup

1. In the External Group Mapping action bar, click Edit.
The Edit Role Mapping dialog is displayed with the group name in the External Group
Name field.

2. To add roles to the mapping, click in the Mapped Roles section.

The Add Role dialog is displayed.

3. Click the checkbox in the title bar to select all roles, or select roles individually.
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4. To add the roles to the Mapped Roles section in the Add Role Mapping dialog, click Add.
The dialog closes, and the selected roles are displayed in the Mapped Roles section.

5. If you want to delete roles from the Mapped Roles section, select the roles and click .

6. When the Edit Role Mapping dialog reflects the role mapping that you want to define for
the group, click Save.
The dialog closes, and the edited role mapping is listed in the External Group Mapping tab
grid.

Related Topic

l Search for External Groups
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Search for External G roups

This topic provides instructions for searching for external groups that have Security Analytics
user roles mapped to them.

Prerequisites

A method for external user authentication must be enabled.

Procedure

To search for an external group:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the External Group Mapping tab.

3. In the toolbar, click   or .

The Add Role Mapping dialog for the external authentication method you selected is
displayed.

4. The Group Mapping section is dependent on the selected external authentication method. 

l For Active Directory, select a Domain. Then click   next to External Group Name.

l For PAM, click Search next to PAM Group Name.
The Search External Groups dialog is displayed.

5. In Common Name, type a group name or part of a group name with the wild card character
(*).
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6. Click Search.
The results are displayed in the External Group Search Results section.

7. Select the group to which you want to assign roles and click OK.
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Set Up Pub lic K ey Infrastructure (PK I)
Authentication
This topic provides an overview of PKI authentication and detailed instructions to
configure PKI authentication in Security Analytics.

Topics

l Overview

l Configure PKI Authentication
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Overview
This topic provides an overview of PKI authentication and how it is used to access Security
Analytics User Interface (UI).

In 10.5.0.2 or later, PKI authentication can be used to access the Security Analytics UI. PKI
allows users to authenticate and access the Security Analytics UI using digital certificates.

Certificates are issued by a Third-Party Certificate Authority (CA) (external to Security
Analytics server). The following categories of certificates are required for PKI authentication:

l Security Analytics server certificate (private key and its chain)

l Trusted CA certificates

l User certificate (issued by CA)

Security Analytics Server Certificate

This certificate is used by Security Analytics server to present its identity. This certificate is
issued by a trusted CA. When a user accesses the Security Analytics UI using HTTPS, this
certificate is presented to the user in the web browser.

Trusted CA Certificates

These are collection of CA certificates. Security Analytics server uses these certificates as the
trusted authorities to validate the certificate provided by the user. If the user does not have a
certificate signed by one of these CA(s), the user is not allowed to access the Security Analytics
UI. 

User Certificate

This certificate is used by the Security Analytics user to present the user's identity. This
certificate is issued by a CA that is trusted by the users. The user certificates, by default, are
identified by most browsers. In case the certificates are not identified, the user must import the
certificates into browser certificates store.

Security Analytics PK I Authentication W orkflow

The following figure shows how the user can access Security Analytics using PKI
authentication.
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The following points explain the workflow of the above figure.

1. User tries to access the Security Analytics UI using the web browser. For
example, https://sa-host/login. 

2. The user is prompted to select the user certificate.

Note: The certificate prompt may appear differently depending on the browser.

3. User selects the certificate. The browser sends the selected certificate to the Security
Analytics server for authentication.

4. If the authentication is successful, the Security Analytics server authorizes the user based on
the user groups configured on the Active Directory Server(s). 

5. If the user authentication and authorization are successful, the Security Analytics dashboard
is displayed.

Note: If the certificate validation fails, the user cannot access the Security Analytics
Dashboard.
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Configure PKI Authentication
This topic provides the step-by-step procedure to configure PKI authentication on Security
Analytics. Follow the steps in order to configure PKI on Security Analytics.

Note: PKI authentication is supported from SA versions 10.5.0.2 or later.

Note: PAM is not supported for PKI authentication. 

Topics

l Step 1. Configure Active Directory

l Step 2. Map User Roles to External Groups

l Step 3. Import Server Certificate and Trusted CA Certificate

l Step 4. Configure User Principal Settings

l Step 5. Import Certificate Revocation L ist

l Step 6. Enable PKI
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Step 1 . Configure Active Directory

See Configure Active Directory for instructions on how to use Active Directory to authenticate
external user logins.

Next Step:

Step 2. Map User Roles to External Groups
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Step 2 . Map User Roles to External G roups

See Step 5. (Optional) Map User Roles to External Groups for instructions on how to map user roles
to external groups to provide necessary access.

Next Step:

Step 3. Import Server Certificate and Trusted CA Certificate
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Step 3 . Import Server Certificate and Trusted CA Certificate

This topic describes the procedure to import a Security Analytics server certificate with its key
and trusted Certificate Authority (CA) certificate required to enable Public Key Infrastructure 
(PKI) authentication.

Prerequisites

Make sure that you have:

l Configured Active Directory to enable authentication for external groups. For more
information, see Configure Active Directory.

l Mapped external groups to Security Analytics user roles. For more information, see Step 2.
Map User Roles to External Groups.

l The Security Analytics server certificate with its private key. For more information, see Step
5. (Optional) Use Custom Server Certificate.

l The trusted CA certificates. This can be the root CA's or Intermediate CA's certificate up to
root CA.

l The Security Analytics user certificate signed by one of the trusted CAs in the Security
Analytics server.

Next Step:

Step 4. Configure User Principal Settings
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Step 4 . Configure User Principal Settings

This topic describes how you can specify an attribute in a certificate to uniquely identify the
user for Public Key Infrastructure (PKI) authentication.

You must specify an attribute with user name or user id, in a certificate, to uniquely identify the
user. A certificate may contain user name or user id in Extension (Non standard custom
attributes) , Subject DN  or Subject Alternative N ame field and Security Analytics server
must be configured to read the value of this attribute. The Security Analytics server uses the
extracted value of this attribute for authorization and retrieves the user groups from an Active
Directory (AD) server. By default, Security Analytics server extracts the entire value of the
selected attribute, without filtering any characters. You can use regular expression (REGEX) to
refine the value extracted.

To configure user principal settings:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Settings tab.

3. In the User Principal settings, click Configure.
The User Principal Settings dialog is displayed.

4. In the Certificate field, paste the BASE64 encoded user certificate.

5. Click Next.
The Extensions, SubjectDN and Subject Alternative name fields are displayed.
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6. Select a unique field that reflects the user name or user id.

7. Click Test.
The user name or user principal name is extracted and displayed within square brackets.

l If the extracted user principal name does not match the AD user name, you can modify
the Regex to extract the exact user name and click Test.

If the extracted value does not contain the Active Directory user name as a unique value
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and if it contains a uniquely identifiable attribute of the user such as EmpNo or EmpID.
You must configure the custom LDAP filter in the Active Directory which uniquely
identifies the user object. For more information to configure custom LDAP filter, see Step
1. Configure Active Directory.

8. Click Save to update the Security Analytics server.

Note: If the User Principal Setting is incorrect, Security Analytics server will not allow you to
access Security Analytics UI. In this case, to access the Security Analytics UI you
must revert or disable PKI from the backend. For more information to disable PKI, see Disable
PKI.

Next Step:

Step 5. Import Certificate Revocation L ist
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Step 5 . Import Certificate Revocation List

This topic describes the procedure to import a Certificate Revocation List (CRL) to Security
Analytics server.

A CRL is a file that contains a list of revoked certificates with details such as the serial
number and revocation date of each certificate. Typically a certificate is revoked to avoid any
compromise of the certificate by unauthorized users. For example, if a Security Analytics user
resigns from an organization, then the user's certificate must be revoked by the issuing CA to
avoid any certificate compromise. 

You can import the CRL issued by your trusted CA, so that Security Analytics can use the CRL
to block unauthorized users from accessing Security Analytics. You can specify or import a
CRL to Security Analytics using the below options:

l HTTP server - This is the most common CRL Location where CA publishes the CRL to
external applications using a HTTP server. The Security Analytics server reads the CRL
using the HTTP URL.

l Local CRL - This allow you to manually download the CRL for a CA and upload it to the
Security Analytics server. For automation, you can write a Cron job to copy the CRL to the
/var/lib/netwitness/uax/pki/crldirectory in the Security Analytics server. The
Security Analytics server uses the updated CRL from the disk when the CRL is refreshed
(every 5 minutes).

l LDAP Resource - This is mostly used by Windows Systems. You must specify an LDAP
URL with the username and password to access the LDAP Object. The Security Analytics
server reads the CRL from the LDAP URL.

l OCSP Responder - To specify a OCSP Responder, you need to provide the HTTP URL and
OCSP Responder's Signing certificate. Make sure the OCSP Responder is online while
adding the entry. In case OCSP Responder Signing Certificate is updated, you need to
manually update the certificate in Security Analytics server.

Procedure

Specify CRL file on HTTP server

Note: Make sure that the CRL is available and HTTP server is accessible from Security
Analytics server.

To specify CRL file on HTTP server:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.
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2. Click the PKI Settings tab.

3. In the CRLs section, click .

4. In the CRL Type, select CRL is located on a HTTP Server from the drop-down list.

5. In the URL field, specify the HTTP URL to access the CRL.

6. Click Test.
The Security Analytics UI displays the extracted information from the CRL.

Note: If the HTTP URL is located on HTTPS location, the Security Analytics server do
not validate the Web Server certificate of the HTTP server on which the CRL is located.

7. Click Save.

The CRL file is successfully added to the Security Analytics server.

Import Local CRL file using Security Analytics UI

Note: Make sure that the CRL is downloaded from CDP location.

To import Local CRL file using Security Analytics UI:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the PKI Settings tab.

3. In the CRLs section, click .

The CRL Settings dialog is displayed.

4. In the CRL Type, select CRL is available as a F ile from the drop-down list.

5. In the CRL file, click Browse to upload the CRL file.

Note: The CRL file extension should be .crl.

6. Click Test.

The Security Analytics UI displays the extracted information from the CRL.

7. Click Save.
The CRL file is successfully added to the Security Analytics server.

Specify CRL as LDAP Resource using Security Analytics UI

Note: Make sure that the CRL is available and LDAP server is accessible from Security
Analytics server.
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1. In the Security Analytics menu, select Administration > Security.

The Security view is displayed with the Users tab open.

2. Click the PK I Settings tab.

3. In the CRLs section, click .

The CRL Settings dialog is displayed.

4. In the CRL Type, select CRL is published as LDAP Resource from the drop-down list.

5. In the URL field, specify the LDAP URL to access the CRL.

Note: If the LDAP URL contains white spaces, for example, CN=EMC Root CA it is
escaped as CN=EMC%20Root%20CA.

6. In the Username field, enter the username in the format of Domain/Username.

7. In the Password field, enter the password to access the CRL.

8. Click Test.

The Security Analytics UI displays the information extracted from the CRL.

9. Click Save.

The CRL is successfully added to the Security Analytics server.

Specify OCSP Responder using Security Analytics UI

Note: Make sure that the OCSP Responder is reachable from Security Analytics server.

To specify OCSP Responder using Security Analytics UI:

1. In the Security Analytics menu, select Administration > Security.

The Security view is displayed with the Users tab open.

2. Click the PKI Settings tab.

3. In the CRLs section, click .

The CRL Settings dialog is displayed.

4. In the CRL Type, select HTTP URL for OCSP Responder from the drop-down list.

5. In the URL field, specify the HTTP URL.

6. In the Certificate field, click Browse to upload the OCSP Responder Signing certificate.

7. Click Test.
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The Security Analytics UI displays the information extracted from the OCSP responder
signing certificate.

8. Click Save.
The OCSP responder is successfully added to the Security Analytics server.

Configure CRL Settings

You must configure CRL settings to validate the CRL for certificate revocation.

To configure CRL settings:

1. In the Security Analytics menu, select Administration > Security.

The Security view is displayed with the Users tab open.

2. Click the PKI Settings]tab.

3. In the CRL Settings section, select any one of the following Failure Mode option.

l Allow Users to login if Revocation check fails - This allows user to access the Security
Analytics server if:

o The CRL is not found for a user certificate issuer.

o The user certificate is not revoked but the CRL is expired.

o The OCSP server is not reachable.

l Block Users to login if Revocation Check fails - This allows user to login if :

o CRL is available for user certificate issuer.

o User certificate is revoked and CRL is valid.

o OCSP server is reachable and user certificate is valid.

4. In the Revocation Check Mode field, select the mode on how the user certificate should be
validated.

l If you select a CRL only mode, the CRL is considered valid if the following criteria are
met:

o There should exist a CRL which is issued by the same issuer of a user certificate.

o The CRL is not expired.

o The CRL is properly signed by the issuer.

l If you select a OCSP only mode, the OCSP is considered valid if the following criteria
are met:
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o There should exist OCSP Responder which is issued by the same issuer of a user
certificate.

o The OCSP Responder is not expired.

o The OCSP Responder is properly signed by the issuer.

l If you select a CRL then OCSP , the following criteria should be met:

o The user certificate should be valid.

o If the user certificate is valid in the above step then the user certificate is validated
using OCSP Responder.

o You will be consider valid only if it is not revoked in CRL and is valid using OCSP
Responder.

5. In the Multi CRL Mode field, select the CRL mode on how the CRL is to be processed
when a user has multiple CRLs from the same issuer.

l Check Revocation in Most Recently Issued CRL - The CRL that has the highest issue
date is considered as most recently used CRL.

l Check Revocation in Last Expiring CRL - The CRL that has the highest expiry date is
considered as last expiring CRL.

l Combine All CRLs for Revocation Check - All the revoked certificate in the CRLs is
considered revoked.

Note: If there are more than one CRL, a CRL is considered unique on the basis of:
- The date when a CRL is published.
- The date when a CRL expires.

Next Step:

Step 6. Enable PKI
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Step 6 . Enable PK I

This topic describes the procedure to enable Public Key Infrastructure (PKI) authentication on
Security Analytics.

Prerequisites

To enable PKI, make sure that:

l At least one Active Directory (AD) is configured and enabled on Security Analytics. This
AD must be reachable and the roles must be mapped. 

Note: PAM is not supported for PKI authentication. 

l One Server Certificate is configured and set as 'Use as Server Certificate'.

l One Trusted CA certificate is configured.

Procedure

Enable PKI Authentication

To enable PKI authentication:

1. In the Security Analytics menu, select Administration > Security. 
The Security view is displayed with the Users tab open.

2. Click the Settings tab.

3. In the Enable PKI section, select the Enable PKI checkbox.
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4. Click Apply.
The Pre-Requisite Checks dialog is displayed.

5. Click Enable PKI.

Note: If all the prerequisites are met, only then you click on Enable PKI.

6. Refresh the puppet agent on the Security Analytics host using the following command:
puppet agent -t

Note: After the puppet refresh, the default Administrator account is disabled and you will be
ONLY authenticated using the certificate.

After you enable PKI:

1. Make sure you do not delete the AD configuration and external group mapping that
corresponds to the user certificate's domain.

2. To log out from a PKI based session, you must close the browser used to access Security
Analytics.

3. If audit log is enabled, the user login and activity is logged using the user DN.
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System Security and User Management:
Additional P rocedures
Use this section when you are looking for instructions to perform a specific task after you enable
PKI authentication on Security Analytics (SA).

Topics

l Delete Certificate Revocation List

l Delete Server Certificate and Trusted CA Certificate

l Disable PKI
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Delete Certificate Revocation List
This topic describes the procedure to delete a Certificate Revocation List (CRL) file in the
Security Analytics.

Delete CRL

To delete a CRL file:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the PKI Settings tab.

3. In the CRLs section, select the CRL file to delete.

4. Click  .
The CRL file is successfully deleted.

5. Restart Security Analytics server for changes to take effect.
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Delete Server Certificate and Trusted CA Certificate
This topic describes the procedure to delete a Security Analytics server certificate with its
private key and trusted Certificate Authority (CA) certificate.

Procedures

Delete a Security Analytics Server Certificate with its Private Key

l For a server certificate currently used by Security Analytics:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Settings tab.

3. Replace the server certificate currently used by Security Analytics, perform the following
steps:

a. In the Server Certificates section, import a new server certificate with its private
key. For instructions, see Step 3. Import Server Certificate and Trusted CA Certificate.

b. Select the new server certificate. 

c. Click Use as Server Certificate.

d. Refresh puppet agent using the following command:
puppet agent -t

5. Delete the old server certificate, click  .

l For a server certificate not used by Security Analytics:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Settings tab.
In the Server Certificates section, select the certificate to delete.

3. Delete the server certificate, click  .

Delete a Trusted CA Certificate

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.
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2. Click the Settings tab.

3. In the CA Certificates section, select the certificate to delete.

4. Click .
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Disab le PKI
This topic describes the procedure to disable Public Key Infrastructure (PKI) authentication.

For some reason if you (Security Analytics user or Administrator) are unable to access the
Security Analytics UI and would like to revert to user name and password based authentication,
you must disable PKI using the command line.

Disable PK I

1. From the command line, stop the jetty server:
stop jettysrv

2. Stop the puppet agent:
service puppet stop

3. Edit the /etc/puppet/hieradata/common.yaml  file and set
jetty_pki_enabled: false.

4. Remove the security configuration file.
rm

/var/lib/

netwitness/uax/conf/securityConfiguration.cfg

However, this resets the Security Settings in the Settings tab to default values.

5. Restart the jetty server:
start jettysrv

6. Restart the puppet agent:
service puppet start 

7. Reconfigure the Security Settings in the Settings tab. For more information, see the Settings
Tab topic in the Hosts and Services Configuration G uides.
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System Security and User Management:
References
This topic is a collection of references for system security and user management in Security
Analytics.

Topics

l Administration Security V iew

l Certificate Attributes
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Administration Security V iew
This topic describes each user interface element in the Administration Security view and in all
related dialogs and tabs. The interface components are listed in alphabetical order.

The Administration Security view provides the capability to manage user accounts, manage user
roles, map external groups to Security Analytics roles, and modify other security-related system
parameters. These apply to the Security Analytics system and are used in conjunction with the
security settings for individual services.

To display this view, in the Security Analytics menu, select Administration > Security.

The Administration Security view has five tabs:

l The Users tab provides a way to manage user accounts.

l The Roles tab provides a way to define security roles and assign roles to user accounts.

l The External Group Mapping tab provides a way to manage access parameters for LDAP
groups.

l The Settings tab provides a way to configure password complexity and expiration for internal
Security Analytics users and to configure system behavior due to failed logins and inactivity.
It also provides a way to configure external authentication.

l The Login Banner tab provides a way to set conditions which must be agreed to before
gaining access to the login screen.

Topics
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l Add or Edit Role Dialog

l Add or Edit User Dialog

l Add Role Mapping Dialog

l External Group Mapping Tab

l Login Banner Tab

l Roles Tab

l Search External Groups Dialog

l Settings Tab

l Users Tab
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Add or Edit Role Dialog

This topic introduces the Add User and Edit User dialogs accessible from the Administration >
Security > Roles tab.

In the Add Role and Edit Role dialogs, you can add or edit a role and the permissions assigned
to it. You can also specify the query-handling attributes for role members to lock down the
information that they can retrieve. The structure of these dialogs is the same. The only
difference is that you either add a new role or modify an existing role.

When you change permissions for a role, the change is immediately applied to users who are
assigned the particular role after the role is saved.

To access this view:

1. In the Security Analytics menu, select Administration > Security.
The Security view opens to the Users tab by default.

2. Click the Roles tab.

3. Do one of the following:

l In the action bar, click .

The Add Role dialog is displayed.

l Select a role and in the action bar, click .

The Edit Role dialog is displayed.
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The Add Role and Edit Role dialogs include three sections: Role Info, Attributes, and
Permissions.

Role Info

This is the information in the Role Info section.

Feature Description

Nam e The name of the user role.

Description An optional description of the user role.

Attributes

This is the information in the Attributes section. A value shown in italics indicates a default
value, for example, 5 . A value shown without italics indicates a change from the default value,
for example, 1200. Step 3. V erify Q uery and Session Attributes per Role provides more
information.
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Feature Description

SA Core Query

T im eout

(Optional) Specifies the maximum number of minutes that a user can

run a query. The default value is 5 minutes. This timeout only applies

to queries performed from Investigation. If this value is set, it must be

zero (0) or greater. A value of zero represents no timeout.

When migrating to Security Analytics 10 .5 and later, if there is no

value set in the roles, 5 minutes is set by default.

Note: Security Analytics 10.5 and later Core services use this field.

SA Core Query

Level

(Optional) Specifies the maximum number of minutes that a user can

run a query. There are three query levels: 1 , 2 , and 3 . The default

query levels are Q uery Level 1 = 60 minutes, Q uery Level 2 = 40

minutes, and Query Level 3 = 20 minutes.

Note: Security Analytics 10.4 and earlier Core services use this
field. Q uery Level is deprecated for Core services starting with
Security Analytics 10.5.

Concurrent
Sessions Allowed

Specifies the maximum number of Concurrent Sessions Allowed for a

user. The default value is 100 . If this value is set, it must be 1 or

greater.

SA Core Query

Prefix

(Optional) Filters query results to restrict what the role members

see. By default, this is blank. For example, the 'service' =

80 query prefix prepends to any queries run by the user and the user

can only access meta of HTTP sessions.
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Feature Description

SA Core Session

Threshold

Controls how the service scans meta values to determine session

counts. This value must be zero (0) or greater. If this value is greater

than zero, a query optimization will extrapolate the total session counts

that exceed the threshold. When the meta value returned by the query

reaches the threshold, the system will:

l Stop its determination of the session count

l Show the threshold and percentage of query time used to reach the
threshold

The default value is 100000 . The limit you specify here overrides
the Max Session Export value defined in Profile > Preferences >
Investigation. 

Permissions

This is the information in the Permissions section. Role Permissions describes the permissions.

Feature Description

Module

tabs

There are eight tabs, one for each module: Administration, Alert-

ing, Incidents, Investigation, Live, Malware, Reports, and Dash-

board. Each tab lists the permissions for a module.

Description

column

List of all permissions for the module.

Assigned

column

Checkbox that indicates if a module permission is assigned to the

role.

Save Saves the role with the selected permissions assigned to it.

Cancel Cancels any work and closes the dialog.
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Add or Edit User Dialog

This topic introduces the Add User and Edit User dialogs accessible from the Administration >
Security > Users tab.

All users must either have a local user account with username and password or an external user
account that is mapped to Security Analytics.

To display the Add User or Edit User dialog:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Do one of the following:

l In the action bar, click .

The Add User dialog is displayed.

l Select a user and in the action bar, click  .

The Edit User dialog is displayed.
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The Add User dialog is identical to the Edit User dialog shown here.

The Add User and Edit User dialogs show:

l User information

l Roles to which the user belongs

l Security settings for queries

User Information

The following table provides descriptions of the user information.

Field Description

Usernam e Username for the Security Analytics user account.

Full N am e Name of the user.
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Field Description

Passw ord and

Confirm Passw ord

Password to log on to Security Analytics.

Em ail Address of the user.

Description (Optional) Description of the user.

External Indicates the user is authenticated externally by Active Directory

or PAM, rather than internally by Security Analytics. 

Force passw ord change

on Passw ord Policy

change

Requires the user to change their password (at the next log

on) when there are changes to the Security Analytics password

strength policy. This field applies only to internal users.

Force passw ord change

on next log in

Expires the user password the next time the user logs on to
Security Analytics. This field applies only to internal users. This

does not affect any active user sessions. The   appears in the
user row to show that the user password expired. After a
password is expired, you cannot undo it. This checkbox is cleared
the next time you edit the user account.

Reset Form Removes any changes in process.

Cancel Closes the dialog.

Save Saves changes.

Roles Tab

The following table provides descriptions of the Roles tab features.

Feature Description

Opens the Add Role dialog that lists roles you could assign to the user.

Removes the selected role from being assigned to the user.

Shows permissions for the selected role.

Nam e Lists each role assigned to the user.

System Secur i ty and U ser M anagem ent: R eferences 138



System Security and U ser M anagem ent

Attributes Tab

The following table describes fields on the Attributes tab. You should not set these query-
handling attributes at the user level unless you want to override assigned role settings. If you do
not specify these settings for individual users, the settings are applied to users based on their role
memberships. Step 3. V erify Q uery and Session Attributes per Role and V erify Q uery and Session
Attributes per User provide additional information.

A value shown in italics indicates a default value, for example, 100000 . A value shown
without italics indicates a change from the default value, for example, 40.

Field Description

SA Core

Query

T im eout

(Optional) Specifies the maximum number of minutes that a user can run a

query. This timeout only applies to queries performed from Investigation. By

default, this is blank. If you specify a value, it overrides the assigned role set-

tings. If this value is set, it must be zero (0) or greater. A value of zero rep-

resents no timeout.

Note: Security Analytics 10.5 and later Core services use this field.  

SA Core

Query Level

(Optional) Specifies the maximum number of minutes that a user can run a

query. There are three query levels: 1 , 2 , and 3 . The default query levels are

Q uery Level 1 = 60 minutes, Q uery Level 2 = 40 minutes, and Query

Level 3 = 20 minutes.

Note: Security Analytics 10.4 and earlier Core services use this field.
Q uery Level is deprecated for Core services starting with Security
Analytics 10.5. 

Concurren t

Sessions

A llow ed

Specifies the maximum number of Concurrent Sessions Allowed for a user.

The default value is 100 . If this value is set, it must be 1 or greater.

SA Core

Query Pre-

fix

(Optional) Filters query results to restrict what the user sees. By default, this

is blank. For example, the 'service' = 80 query prefix prepends to any

queries run by the user and the user can only access meta of HTTP sessions. 
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Field Description

SA Core Ses-

sion

Threshold

Controls how the service scans meta values to determine session counts. This

value must be zero (0) or greater. If this value is greater than zero, a query

optimization will extrapolate the total session counts that exceed the

threshold. When the meta value returned by the query reaches the threshold,

the system will:

l Stop its determination of the session count

l Show the threshold and percentage of query time used to reach the
threshold

The limit you specify here overrides the Max Session Export value defined

in Profile > Preferences > Investigation. The default value is 100000 .
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Add Role Mapping Dialog

This topic introduces the features of the Administration > Security view > External Group
Mapping tab > Add Role Mapping dialog.

In Security Analytics each user role has its own set of permissions. You can map one or
more Security Analytics roles to an external group, which grants the group the same set of
permissions that each role has.

1. In the Security Analytics menu, select Administration > Security.

2. Click the External Group Mapping tab.

3. In the toolbar, click .

The Add Role Mapping dialog for the external authentication method you set up is
displayed.
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The Add Role Mapping and the Edit Role Mapping dialogs are nearly identical. The only
difference is that you cannot search in the Edit Role Mapping dialog.

Group Mapping

The Group Mapping section has the following features.

Feature Description

Dom ain Displayed if you set up Active Directory for external user authentication.The

domain name of the external AD group to which roles are mapped.

External

G roup

Nam e

Displayed if you set up Active Directory for external user authentication.The

external group to which roles are mapped.

PAM

Group

Nam e

Displayed if you configured PAM for external user authentication. The name

of the external group to which roles are mapped.

Search Displays a search dialog in which you can search for external groups. Search

is not available in the Edit Role Mapping dialog.

Mapped Roles

The Mapped Roles section has the following features.

Feature Description

Opens the Add Role dialog, in which configured Security Analytics user roles

to add are listed.

Removes selected roles from the Mapped Roles grid. 

Nam e Displays the name of the Security Analytics user role.

Perm issions Displays the permissions associated with the Security Analytics user role.

Cancel Cancels the new group mapping or changed group mapping and closes the dia-

log.

Save Saves the new group mapping or changed group mapping and closes the dialog.
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External G roup Mapping Tab

If you set up external user authentication, you can map Security Analytics user roles to an
external group. The External Group Mapping tab provides information about each external group
to which you have mapped roles. 

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the External Group Mapping tab.

The External Group Mapping tab consists of a toolbar and grid. 

The grid has the following features.

Feature Description

Selection

box

In a row, toggles selection of a group name. In the title bar, toggles selection of

all group names.

Group

Nam e

Displays the name of the external group that has access to Security Analytics.

Mapped

Roles

Displays the Security Analytics roles mapped to the external group.

The toolbar has the following features.
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Feature Description

Displays the Add Role Mapping dialog in which you can select an external group

and map it to a Security Analytics role.

Displays a warning message and asks for confirmation to remove all Security Ana-

lytics roles mapped to the external group.

Displays the Edit Role Mapping dialog in which you can add or remove Security

Analytics roles from the external group.
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Login Banner Tab

The Login Banner tab provides a way to add a banner to the Security Analytics login screen,
which will prevent a user from logging on until they agree to the conditions. And, the server title
prefix to differentiate the Security Analytics server of the current tab, when you have deployed
multiple Security Analytics in your system. You can customize the default title and text of the
login banner. The banner is disabled by default.

To access the Login Banner tab:

1. In the Security Analytics menu, select Administration > Security.
The Security view opens to the Users tab by default.

2. Click the Login Banner tab.

When enabled, the banner appears on the Security Analytics login screen.
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The following table lists the features of the Login Banner tab.

Feature Description

Server Title
Prefix

Displays the prefix of the Security Analytics server on the title bar.

Enab led Checkbox that indicates whether or not the login banner is enabled. This box

is unchecked by default.

Login Banner

T itle

Shows the title of the dialog box that contains the login conditions.

Login Banner Shows the conditions the user must acknowledge.
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Roles Tab

This topic introduces the functions of the Administration > Security view > Roles tab.

Roles are assigned to all Security Analytics users. Users receive the permissions the roles
allow. In the Roles tab you can create, duplicate, edit and delete a role. You can also see a list
of all roles and their respective permissions.

To access this view:

1. In the Security Analytics menu, select Administration > Security.
The Security view opens to the Users tab by default.

2. Click the Roles tab.

The Roles tab consists of the Roles grid with a toolbar at the top.

The following table describes the toolbar features.

Feature Description

Displays the Add Role dialog.

Displays the Edit Role dialog.

Displays a warning message, and asks for confirmation that you want to delete a

role. 
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Feature Description

Duplicates a role to save with a different name.

The following table describes the grid features.

Column Description

Nam e Displays the name of a role that can be given to a user.

Description Displays a description of the role.

Perm issions Displays the permissions assigned to the role. 
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Search External G roups Dialog

This topic describes the features of the Administration > Security view > Search External
Groups dialog.

If you set up external user authentication, you can map Security Analytics user roles to external
groups. You search for external groups to select the groups to which you want to map Security
Analytics roles.

To access this dialog:

1. In the Security Analytics menu, select Administration > Security.

The Security view is displayed with the Users tab open.

2. Click the External Group Mapping tab.

3. In the toolbar, click .
The Add Role Mapping dialog for the external authentication method you set up is displayed.

4. In the Group Mapping section, select a domain.

5. In the Group Mapping section, click Search.

The Search External G roups dialog is displayed.

The following table describes the features of the Search External Groups dialog.
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Feature Description

Common Nam e Group name for which you are searching. Can

be the exact name or can contain the wild card

character (*) to match any character.

Group Nam e External group to which you could map roles.

Description Optional text about the group.

OK Displays the Add Role Mapping dialog, show-

ing the external group you selected.

Cancel Closes the dialog.
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Settings Tab

This topic explains the Administration Security view > Settings tab. In the Settings tab, you
configure password complexity for internal Security Analytics users and system-wide security
parameters.

For information on configuring these parameters, see Set Up System Security.

Password complexity requirements apply only to internal users and are not enforced for external
users. External users rely on their own methods and systems to enforce password complexity.  

To access the Settings tab:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the Settings tab.

The following figure shows the Password Strength of the Settings tab.

The following figure shows the Security Settings and External Authentication sections of the
Settings tab.

The following figure shows the Active Directory Configurations section of the Settings tab.
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Password Strength

The Password Strength section enables you to configure password complexity requirements for
internal Security Analytics users when they set their passwords.

Feature Description

M inim um Pass-

w ord Length

Specifies a minimum password length requirement for Security Ana-

lytics user passwords. A minimum password length prevents users from

using short passwords that are easy to guess.

Uppercase Char-

acters

Specifies a minimum number of uppercase characters for the password.

This includes European language characters A through Z , with diacritic

marks, Greek characters, and Cyrillic characters. For example:

l Cyrillic uppercase: Д Ц

l Greek uppercase: Π Λ

Low ercase Char-

acters

Specifies a minimum number of lowercase characters for the password.

This includes European language characters a through z, sharp-s, with

diacritic marks, Greek characters, and Cyrillic characters. For

example:

l Cyrillic lowercase: д ц

l Greek lowercase: π λ

Base 10 D ig its Specifies a minimum number of decimal characters (0 through 9) for

the password.
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Feature Description

Special Characters

(~ !@ #$% ^& *_

-+=`|(){}

[]:;" '<>,.? /)

Specifies a minimum number of special characters for the password:
~!@#$%^&*_-+=`|(){}[]:;"'<>,.?/

Non-Latin Alpha-

betic Characters

Specifies a minimum number of Unicode alphabetic characters that are

not uppercase or lowercase. This includes Unicode characters from

Asian languages. For example:

l Kanji (Japanese): 頁 (leaf) 枒 (tree)

Passw ord M ay

Not Contain U ser-

nam e

Specifies that a password cannot contain the case-insensitive username

of the user.

Apply Provides the option to force all internal users to change their passwords

the next time they log on to Security Analytics. 

The confirmation dialog shows the following question:

Do you want to force all internal users to change their passwords on the

next login?

l Selecting Yes forces all internal users to change their passwords the
next time they log on to Security Analytics and overrides any
individual user account settings.

l Selecting No forces only those internal users with the Force
password change at next login option enabled in their individual
user account settings to change their password the next time they log
on to Security Analytics.

Password strength settings take effect when Security Analytics users

create or change their passwords.

Security Settings

The Security Settings section enables you to configure global security settings for Security
Analytics users.
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Feature Description

Lockout

Period

Number of minutes to lock a user out of Security Analytics after the con-

figured number of failed logins is exceeded. The default value is 20  minutes.

Idle Period Number of minutes of inactivity before a session times out. The default value

is 60 . If the value is 0 , the session will not timeout.

Session

T im eout

The maximum duration of a user session before timing out  The default value

is 600 . If the value is 0 , there is no maximum time for a session. If the value

is a positive integer, the session times out when the configured time has

elapsed. The user must log in again.

Case Insens-

itive U ser

N am e

Specifies that the RSA Security Analytics Username field on the login screen

is case insensitive. For example, you could use Admin or admin to log on to

Security Analytics.

Max Login

Failures

The maximum number of unsuccessful login attempts before a user is locked

out. The default value is 5 .

G lobal

D efault

U ser Pass-

w ord Expir-

ation Period

The default number of days before a password expires for all internal Security

Analytics users. A value of zero (0) disables password expiration.  For

upgrades and new installations, the default value is zero (0).

Notify U ser

<n> Days

Prior to

Passw ord

Expiry

The number of days before the password expiration date, to notify a user that

their password is about to expire. Users receive a one-time email on the spe-

cified date before their passwords expire. They also see a Password Expir-

ation Message dialog when they log on to Security Analytics.

A value of zero (0) disables automatic password expiration notification. If you

set the Global Default User Password Expiration Period to zero (0), users do

not receive automatic password expiration notifications. 

Apply Makes the settings become effective immediately. 
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External Authentication

The External Authentication section enables you to configure Security Analytics to use Active
Directory or PAM to authenticate and test external user logins.

Feature Description

Active D ir-

ectory

Allows Security Analytics to use Active Directory to authenticate external user

logons.

PAM Allows Security Analytics to use Pluggable Authentication Modules (PAM) to

authenticate external user logons.

Apply Makes the settings become effective in the next logon. 

Test Prompts for a username and password, then tests the currently enabled external

authentication method.

Active Directory Configurations

The Active Directory Configuration section enables you to configure Security Analytics to use
Active Directory to authenticate external user logins.

Feature Description

Enab led Enables Active Directory authentication for Security Analytics users.

Dom ain Domain name where the Active Directory Service is located.

Host Host name or IP address where the Active Directory Service is located.

Port Port on the host that is used for Active Directory Service authentication.

SSL Indicates whether the Active Directory Service uses SSL.

Usernam e

M apping

Indicates the Active Directory search field to use for username mapping. You

can specify userPrincipalName (UPN) or sAMAccountName.

User

Lookup

F ilter

This is used to find a username in the Active Directory.
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Feature Description

Follow

Referrals

Indicates whether Security Analytics will follow LDAP referrals made by Act-

ive Directory.

Usernam e If Username is provided here, it binds to the Active Directory Service while

searching Active Directory groups. This credential is not used for any other pur-

pose.

Apply Makes settings become effective immediately.

PK I Settings Tab

This topic explains the Public Key Infrastructure (PKI) Settings tab that enables you to configure
PKI authentication for Security Analytics. In PKI Settings tab, you can perform the following
tasks:

l Import server certificate and trusted CA certifcate

l Import Certificate Revocation List (CRL)

l Configure CRL settings

l Configure user principal settings

l Enable PKI

To access the PKI Settings tab:

1. In the Security Analytics menu, select Administration > Security.
The Security view is displayed with the Users tab open.

2. Click the PKI Settings tab.
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Server Certificates

The Server Certificates section enables you to import a server certificate with its private key to
Security Analytics server. The following figure shows the Server Certificates of the PKI
Settings.

Feature Description

Alias A user-friendly name which is used to identify a certificate in a

store .

Subject DN The entity to which the certificate is issued.

Issuer DN The entity which issued the certificate.

CA Indicates whether the certificate is Certificate Authority (CA). 

Valid Form The start date for the certificate validity.

Valid T ill The end date till when a certificate is valid.

Use as Server Cer-

tificate

Uses a server certificate as a default server certificate.

Reset to D efau lt Restore the default server certificate.
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Trusted CAs

The Trusted CAs section enables you to import a Certificate Authority (CA) certificate to
Security Analytics server. The following figure shows the Trusted CAs sections of the PKI
Settings.

Feature Description

Alias A user-friendly name which is used to identify a certificate in a store .

Subject DN The entity to which the certificate is issued.

Issuer DN The entity which issued the certificate.

CA Indicates whether the certificate is Certificate Authority (CA).

Valid Form The start date for the certificate validity.

Valid T ill The end date till when a certificate is valid.

CRLs

The CRLs allows you to import Certificate Revocation List (CRL) to Security Analytics (SA)
server. The following figure shows the CRLs of the PKI Settings.

Feature Description
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Feature Description

Issuer DN The entity which issued the certificate.

Type The CRL type which can be a HTTP server, LDAP resource, LOCAL CRL,

OCSP Responder.

ID This is a unique id assigned to the CRLs which is useful in identifying a CRL

in the alerts and messages.

Count The total number of unique revoked certificates in the CRL.

Expiration Status of the CRL. The values can be Expired, Soon expiring, and Vaild.

l Expired - The CRL or OCSP Responder certificate is expired.

l Soon expiring - The CRL or OCSP Responder certificate will expire in
less than 24 hours.

l Vaild - The CRL or OCSP Responder certificate is valid atleast for 24
hours.

Next

Update on

The date on which CRL will be updated.

Update

C ache

Manually updates all the CRLs from the source location.

CRL Settings

This allows you to configure CRL settings to validate the CRL for certificate revocation. The
following figure shows the CRL Settings sections of the PKI Settings.
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Feature Description

Failure M ode Determines whether a user is allowed to login if the validation fails.

Revocation

check M ode

Validates the user certificate for revocation.

Multi CRL

M ode

Determines how to process multiple CRLs of the same issuer.

Test U ser C er-

tificate

This is used to check the certificate revocation based on the CRL and

settings applied for the CRL.

Save Click Save to apply the CRL settings.

User Principal Settings

The User Principal Settings section enables you to specify a field in a certificate to uniquely
identify the user for PKI authentication. The following figure shows the Notification Settings,
User Principal Settings of the PKI Settings.

Feature Description

Path The path to a field in a certificate which is used to extract a username or userid.

Regex A regular expression that is used to extract the final username or userid from the

value in a certificate at a given path.

Configure Allows you to configure the user principal settings to extract a username or

userid.
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Enable PKI

The Enable PKI section enables you to enable PKI authentication in Security Analytics. PKI
section enables you to enable PKI authentication in Security Analytics. The following figure
shows the Enable PKI sections of the PKI Settings.

Feature Description

Enab le PK I Select the option to enable PK I.

Apply Enables PK I authentication for Security Analytics users.
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Users Tab

This topic introduces the features and functions to set up a user account in the Administration
Security view > Users tab.

Each Security Analytics user must have a user account. In the Users tab, you can create, edit,
delete, enable/disable and unlock a user account. 

To access this view, in the Security Analytics menu, select Administration > Security. The
Security view opens to the Users tab by default.

The Users tab consists of the User grid with a toolbar at the top. These are the toolbar features.

Feature Description

Opens the Add User dialog.

Deletes the selected user.

Opens the Edit User dialog for the selected user.

Enables a disabled user account with all user preferences intact.

Blocks user access without deleting user preferences so that upon re-enabling

users, user preferences are intact.
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Feature Description

Unlock

Unlocks a user account that has been locked due to too many failed login

attempts.

The Users grid has these columns.

Column Description

If this icon appears in a user row, it indicates that the user pass-

word has expired.

Usernam e Username to log on to Security Analytics.

Nam e Name of the user to whom the account belongs.

Em ail Address Email address of the user.

Roles Role assigned to the user.

External Authentication method, which could be external by Active Dir-

ectory or PAM or internal by Security Analytics.

Description Description of the user account.

163 System Secur i ty and U ser M anagem ent: R eferences



System Security and U ser M anagem ent

Certificate Attributes
This topic describes the attributes of a certificate. A certificate contains the following attributes:

l Key Usage

l Enhanced Key Usage

The following table lists the attributes for the user and server certificates.

Certif ica te
Type

Key Usage Enhanced Key
Usage

User Certificate Digital Signature, Key
Encipherment 

Client Authentication

Server Certificate Digital Signature, Key
Encipherment 

Server Authentication

Note: If the user or server certificate does not contain any of the above mentioned
attribute values, RSA recommends that you obtain a new certificate with these attribute
values.
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System Security and User Management:
T roub leshooting
This topic provides information about possible issues that you may encounter when configuring
or using Public Key Infrastructure (PKI) authentication.

Possib le Issues
This table describes possible problems that you may encounter when you use PKI and solutions
to resolve the issues.

Problem Possible Causes Solutions

Unable to im port

.pfx file w hen

FIPS is enab led.

Some .pfx files may not

be built with FIPS com-

pliant algorithm.

Create a .pfx file that is built using

a FIPS compliant algorithm.

Certificate pop-up is

not displayed on

the IE brow ser.

The TLS protocol may not

be enabled in the Internet

Explorer.

To enable TLS, perform the following
steps:

1. In the Internet Explorer, Go to
Tools > Internet Options >
Advanced > Settings > Security.

2. Enable Use TLS 1.2 .
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Problem Possible Causes Solutions

Certificate pop-up is

not displayed on other

brow sers.

Certificate is not present in

the browser's certificate

store.

You must import a certificate to
browser's certificate store. 

For example:
To import a certificate on a Mozilla
Firefox browser, perform the following
steps:

1. Go toMenu > Options >
Advanced > Certificates tab.

2. Click View Certificates.

3. Click the Authorities tab.

4. Click Import.

5. Browse to select the certificate
and click Open.
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